
Logic Pro 6.4.2
This version simplifies the license management on the XSKey and fixes a few problems in the Mac OS X version.
In detail:

- OMF import and export is significantly improved.
- The Autoload song loads now as expected when its name contains the extension “.lso” or the launch of Logic Pro is

interrupted by a warning dialog (e.g. authorization request from an AU plug-in).
- Improved support for AU plug-in tempo synchronization.
- Crossfades which are created with the crossfade tool in the Arrange window are now using “equal power” as default

fade form.
- Unused controls on control surfaces no longer create unwanted MIDI events.
- Improved sample rate switching for certain audio drivers (e.g. for LynxTwo cards).
- Further improvements in different areas of the application.

Logic Pro 6.4.1
This versions fixes a few problems with HUI control surfaces on Dual CPU Macintoshs.

Logic 6.4
Renaming and Restructuring
Logic Platinum has been renamed to Logic Pro (containing the ES1, ES2, EVP88, EVB3, EVD6, EXS24mkII, EVOC20, Space
Designer, ESB TDM, PTHD Extension). Logic Audio has been renamed to Logic Express (containing the ES1, EVP73, EXSP24 and
the Extreme Analog sample library).  The printed and electronic documentation currently contains references to both old and
new product names –  we apologize for any inconvenience this may cause.

Space Designer Improvements

Sample Rate Conversion

When loading an Impulse Response, Space Designer automatically converts the sample rate of the IR to match the current
Logic song sample rate – if necessary. As an example, this allows you to load a 44.1kHz Impulse Response into a Logic song
running at 96kHz, and vice versa.

CPU power conservation hints
Operating Space Designer at higher sample rates will increase its CPU power requirements. If running Space Designer in a song
at 96 kHz (utilizing an Impulse Response originally recorded at 44.1 kHz), you may want to reduce the IR sample rate to ‘1/2’.
To do so, use the Sample Rate Slider in Space Designer. Make sure the Preserve Length function is enabled. This cuts CPU
power consumption by about 50%, without compromising reverb quality. There is no loss in reverb quality because the Impulse
Response - originally recorded at 44.1kHz - will not benefit from the higher song sample rate of 96kHz. Even reducing the
sample rate to 1/4 may produce good results, with even less strain on the CPU. Similar adjustments can be made while running
in Synthesized IR mode. Most typical reverb sounds don’t feature an excessive amount of high frequency content. If you were
running at 96kHz, you would need to make use of some deep low-pass filtering to obtain the mellow frequency response



characteristics of many reverb sounds.  As a different approach, you are better served to first reduce the high frequencies by
‘1/2’ or even ‘1/4’ using the sample rate slider in Space Designer, and than apply the low-pass filter. This conserves a
considerable amount of CPU power.

Separate Pre-Delay and IR Start parameters

Pre-Delay and IR Start (formerly negative Pre-Delay) are now separate parameters. The advantage of this concept is the
possibility to move the IR playback start point, while simultaneously applying Pre-Delay.
Note that the IR Start parameter is not available in Synthesized IR mode. In the Synthesized IR mode this parameter is not
required as, by design, the Length parameter provides identical functionality.

Grace Time

The grace time, indicated by the blue Grace Bar that appears during parameter changes, has been extended. This provides you
with more time for parameter changes, before IR processing starts.

Click points

Some key parameter positions are now clickable in the GUI – with the slider or dial “jumping” to that position immediately:
- The three base positions of the reverb input slider – Stereo, Mono, Xstereo.
- The zero mark of the Low Shelving EQ Gain control.
- The HP, BP, 12dB and 6dB filter modes.
- All up/down arrows alongside parameter values (a click increments/decrements the value by one step)

Filter cutoff values

The filter cutoff values are now expressed in Hz (Hertz).

Logic Platinum 6.3.3 – Mac OS X only
This is a release for TDM hardware users. It fixes a compatibility issue with DAE 6.2.2 (Panther release).

Logic Platinum 6.3.2 – Mac OS X only
Logic Platinum 6.3.2 for Mac OS X is a service release which also resolves Panther compatibility issues.

EXS24 with VSM on Dual G5

Logic 6.3.2 fixes a problem when using the EXS24MkII - with enabled Virtual Sample Memory - on Dual G5 Power Macs.

Recording Delay

Logic has always compensated for the latency of the Core Audio driver to ensure that recorded audio appears exactly at the
intended position in the Arrange window. Unfortunately, some drivers are incorrectly reporting their latency value – causing
Logic to fail in this task.
Should this issue affect your system, you can now manually set a value for driver latency compensation in Preferences >
Audio Drivers.
If you are using the built-in audio hardware, it is not necessary to change the Recording Delay default value of 0.



Improved Panther Compatibility

It is now possible to import Akai CD ROMs into the EXS24MkII, and to use the Deconvolution function of Space Designer - if
using Mac OS X 10.3 (Panther).

Other Improvements

- Recording is now possible on track numbers 128 or higher.
- I/O Labels provided by the driver are now visible in Logic (requires Mac OS X 10.2.8 or higher).
- When loading multiple samples into the EXS24MkII chromatically, they will also be re-sorted by file name.

Logic 6.3.1
Digidesign HD Accel Compatibility – Logic Platinum Mac OS X only

If you are using a Pro Tools HD system with the new Digidesign HD Accel card, please upgrade to Logic Platinum version 6.3.1
or higher. This version is required to take full advantage of the increased number of audio tracks afforded by an HD Accel card.

Smart Snap Option

The zoom-dependent drag grid (Smart Snap – introduced in version 6) is now available as an option - “Smart Snap when
dragging” in the Global Preferences page (Logic menu > Preferences > Global Preferences).
If this option is disabled, Logic behaves in a pre-version 6 fashion: You can move objects quantized to bars. With CTRL
depressed, moved objects will be quantized to the Format value. With CTRL and SHIFT depressed, you can move objects in
Ticks.

Improvements

In older 6.x versions, hanging MIDI notes were possible in certain situations. Logic Platinum users with TDM systems (on Mac
OS X) could encounter DAE error message –9060 when record-enabling tracks in “Punch on the fly” mode.
These problems have been fixed.

Logic 6.3
Version 6.3 or higher is required to run Space Designer, Emagic’s new premium reverb, which is based on convolution
technology. Space Designer is available as a separate product. You may, however, test Space Designer for the usual four week
demo period. You can find Space Designer in the “Reverb” section of the plug-in menu. The Logic 6.3 Updater/Installer installs
the Space Designer demo presets (including impulse response files) on your hard drive.

Space Designer
The real-time convolution process of Space Designer is CPU intensive. Should you encounter audio artifacts while using Space
Designer, try increasing your I/O Buffer size: Audio -> Audio Hardware & Drivers… -> I/O Buffer Size. You may also try to reduce
the CPU power used by the Space Designer (see below).

Reducing CPU power used by the Space Designer

The CPU power needed by Space Designer increases with the reverb length. We recommend removing silence at the end of an
impulse response (IR) recording.  In many cases it is also possible to shorten inaudible tails in the decay phase of IR files.
Note: The IR length of the Space Designer Sound Library has  already been optimized.



A large amount of CPU power is gained by reducing the sample rate in Space Designer. You may find that for many reverb
sounds, a rate of 1/2 of the original sample rate is adequate, thus reducing the CPU load by approximately 50%. To retain the
original reverb length, activate the ‘preserve length’ function.

Known issues

Due to technical reasons, the Space Designer IR files are currently not tracked by Logic’s Project Manager. As such, IR files are
not copied/moved when using the Logic ‘Save as Project’ function. Please copy any used IR files manually to your project
folder, if required. We apologize for this inconvenience.

ES2 Improvements

Pitch Bend Range

There are now separate settings for Bend Range up and down - with an optional "link" mode.

Modulation Matrix

There are two new parameters in each modulation router:
Bypass (“b/p”) disables the modulation routing, without the loss of settings. (If you’d like to exchange settings with Logic 5.x
users, set the target of all bypassed modulations to "off".)
Via invert (“inv”) inverts the effect of the Via modulation source.

Sidechain  Modulation

As per other plug-ins, you can select a sidechain source (tracks, inputs, busses) in the upper gray area of the window. This
source is fed to the internal envelope follower, which creates a modulation value based on the current incoming signal level. It
is available as modulation source/via source in every router (“SideCh”).

New Modulation Targets

Attack and Release times of Envelope 2 and 3 (Env2/3 Atck/Rel).
Lfo1Asym changes the waveform of LFO1:
rectangular wave - it changes its pulse width
triangular wave - it changes between triangle and sawtooth
sawtooth wave  - it shifts its zero crossing.
Lfo1Curve allows you to modulate the smoothing of rectangular and random waves. This changes the curves of triangular or
sawtooth waves between convex, linear and concave shapes.

Vector Envelope: Curve

The new "Curve" parameter sets the shape of the transition from point to point (which was always linear in older versions). You
can now also choose different convex/concave shapes, including their extreme values of “hold+step” and “step+hold”. These
values allow stepped modulation (jumping either at the start or end of the transition time). “hold+step” is particularly great for
stepped vector grooves with up to 15 steps.

General
The interface for the Vienna Symphonic Library – Performance Set is now also available in Logic Platinum for OS X.



Logic 6.2.1 – Mac OS X only
Improved Stability

Improved stability when using Channel EQ plug-ins in mono channels.

Adaptive Startup Screen

The startup screen shows the “Optimized for G4” logo if you’re using a G4 CPU. The G4 optimizations themselves are
unaffected.

Logic 6.2 – Mac OS X only
Logic Platinum 6.2 is the first version of Logic optimized for the Power Mac G5. Special care has also been taken to improve
performance on G5 Macs with two processors.

Running Logic on G5s requires version 6.2 or higher!

Multitrack Recording

Performance and stability were effectively improved when simultaneously recording multiple audio tracks on Mac OS X.

Waves Fix

Possible crashes when using the preset menu of Waves plug-ins were fixed. Please ensure that you are running the latest
versions of the Waves Audio Unit plug-ins.

General Improvements

Miscellaneous improvements were made in different areas of the application.

Logic 6.1.1 – Mac OS 9 only
EXS24MkII Improvements
EXS24 > Preferences > Ignore Release Velocity: When this setting is active (checked), the release velocity of a note is ignored.
This setting is useful for a number of sample libraries.

The EXS24MkII features an additional interface for the Vienna Symphonic Library – Performance Set. The VSL.LIB provided by
VSL must be installed in the System Extensions folder to allow access to this interface. Please refer to the VSL documentation
for details.

General Improvements

This version contains improvements in different areas of the application, e.g. the display of menus inside plug-in windows.

Logic 6.1
Logic 6.1 offers the following new features and improvements:



- TDM™ support in Mac OS X (Logic Platinum only)
- Improved MIDI I/O handling in Mac OS X
- Logic Setup Assistant enhancements (Mac OS X)
- Numerous improvements/refinements (Mac OS 9, Mac OS X)

TDM™ support in Mac OS X (Logic Platinum only)
TDM™ support in Logic Platinum 6.1 on Mac OS X is, for the most part, identical to running Logic Platinum on Mac OS 9. There are
a few issues to bear in mind:

Installation
It is important that all TDM™ components are in place, prior to the installation of Logic Platinum 6.1. Please ensure that Pro
Tools™ 6.0 (or higher) has already been completely installed, before running the Logic Platinum 6.1 (release) installer.  Should
you wish to add Pro Tools™ to an existing Logic system, you will need to reinstall Logic Platinum 6.1 after installing the Pro
Tools™ software.

Mac OS 9 TDM™ Software Components

Mac OS 9 TDM™ software components cannot be used in Mac OS X, i.e. Mac OS 9 TDM™ plug-ins. For more information on the
availability of Mac OS X compatible versions, please check with the respective manufacturers.

ESB
Digidesign’s DirectConnect™ technology is not available in Mac OS X. For ESB (Emagic System Bridge) users running Mac OS X:
rather than using an ESB plug-in to feed an ESB audio signal into a TDM Aux Channel, the ESB audio streams have been added
as audio inputs to the input menu of the TDM™ Aux channels – ESB 1-2, ESB 3-4, ESB 5-6, ESB 7-8.

To ensure compatibility of Logic songs using ESB running on Mac OS X and Mac OS 9, we recommended the use of Logic
Platinum version 6.1 in Mac OS 9 as well. In this scenario, when a Logic song that uses ESB (created on Mac OS 9) is loaded into
Logic Platinum 6.1 (running on Mac OS X), the DirectConnect™ ESB plug-ins are crossed-out. Logic Platinum 6.1 Mac OS X
automatically recognizes the original ESB plug-in settings, and selects the appropriate ESB inputs in the input menus of the
corresponding TDM™ Aux channels. Should you plan to continue working with Logic Platinum 6.1 in Mac OS 9, we recommend
that you simply leave the crossed-out ESB plug-ins where they are. This way, you can easily switch back and forth between
Mac OS X and Mac OS 9, running Logic Platinum 6.1.

Core Audio Driver
Currently, there is an incompatibility with Logic when using TDM™ and Digidesign’s Core Audio Driver (v.1.1) - posted on the
Digidesign website. When using Logic Platinum with TDM™ hardware, please do not install this Core Audio driver. Emagic and
Digidesign are working on a solution.

Improved MIDI I/O handling (Mac OS X)
Logic songs, once saved in Logic 6.1, automatically adjust their MIDI instrument port assignments if the Core MIDI setup
changes. This is true when loading a song which was saved with a different MIDI interface, or when MIDI interfaces are hot-
plugged/unplugged or powered on or off. Ports assignments are adjusted as described below:



If a once used MIDI port is not available but there is another port with the same port and interface name, Logic will use this
other port without notice (e.g. a USB interface is connected to a different USB connector).

If a once used MIDI port is not available but there is another port with the same port name but different interface name, a
message will appear suggesting to reassign the instrument to this other port (e.g. using a Unitor8 in the studio and an MT4 at
home. Tip: connect identical MIDI gear to the same port number in both setups).

If a once used MIDI port is not available and no other port with the same name exists, a message will appear suggesting to
reassign the port manually.
If a port is not reassigned, the missing port name will continue to be displayed. In this case, the port menu shows the port as
"unavailable" and grayed-out. When a “missing” port is found again, it is automatically reassigned to the instrument (e.g. a
MIDI interface is powered off and on again, while running Logic).

The automatic assignment of MIDI ports also applies to the in and out ports of control surface devices that have their own
driver.

Logic Setup Assistant v1.2.1 (Mac OS X)

TDM™ support
The Logic Setup Assistant (LSA) is able to create a TDM™ software mixer as part of the Logic Platinum default song, provided
that a compatible TDM™ hardware device (Digidesign Pro Tools™ 24/MIX/HD) is available.

Device name support
The device names of Apple's Audio MIDI Setup (AMS) are now supported. Earlier LSA versions simply supported the
manufacturer and model names. We recommend using device names in cases where you have multiple identical devices
(same model/manufacturer).

Improved multi monitor support
Screenset (window setup) behavior has improved when multiple physical monitors are used. Now, up to two monitors (among
a potential of four) can be selected for use with Logic.



Logic 6.0.1
Logic 6.0.1 offers you a highly improved and faster Project Manager, EXS24 import of Akai formatted CD-ROMs in Mac OS X,
improved localization (Japanese, German), better integration of the Logic Setup Assistant and many improvements leading to
increased stability, higher performance and enhanced ergonomics.

Global Functions

Clear Recent Songs Menu

You can now clear the list of recently opened Songs: Choose File > Recent Songs > Clear Menu.

Control Surface Support

Zoom-dependent Jog Resolution

There is a new option in the Preferences > Control Surface > Preferences page: Jog resolution depends on horizontal zoom. If
enabled, and the topped window contains a time ruler, the jog wheel resolution corresponds to the clock (with a difference of
+/- 10 pixels), if appropriate, rounded to bar, beat or format. This new feature affects the jog wheels of all suitable, supported
devices, i.e. Logic Control, SAC-2k, SI-24, all HUI compatible devices.

Changed Defaults

Channel EQs

The FFT Analyzer’s default signal flow position was changed to "Post EQ“.

Plug-In Windows

The default of the link button was changed to "off“. This allows you to open multiple plug-in windows, without first changing
the link state.

Project Manager (Logic Platinum only)
In order to take advantage of the improved, faster loading Project Manager of Logic Platinum 6.0.1, we recommend to re-scan
the database. To do so, simply choose Scan in the Functions menu. BTW: loading the database is, as mentioned, faster now,
and takes place in the background!

Function > Add selected audio files to arrange

This function allows you to move one or multiple audio files from your database directly into the Arrange window. All audio files
will be placed at the SPL position.
A dialog allows you to either:

- use existing audio tracks — in this mode, the first audio file will be placed on the currently selected track (and
further files on following tracks) or

- create new audio tracks for each file.



A second dialog offers the option to use the audio file(s) name(s) as track name(s).

Scan Folders per Drag & Drop

If Browse mode is active, dragging a folder from the Finder into the Project Manager window will start the Scan process for this
folder.

Add Scan Paths per Drag & Drop

The Scan Paths view now allows the addition of paths via drag & drop of folders from the Finder into the Project Manager
window. A new flip menu allows you to decide if the next dragged folder should be an include or an exclude path.

Search Folders per Drag & Drop

If in Find mode, dragging a folder from the Finder into the Project Manager window adds its path to the Only show files in the
following folders list.

Show/Hide Modification Date

The file list on the right-hand side in Browse view can now show a column with the modification date. You can show/hide this
column via the View menu.

Find Mode – Update File List

Please use the new "Update file list“ button after changing search conditions (or after you have updated the Project Manager
database). The slower automatic update of earlier versions has been removed.

Extended Find conditions
In Find Mode, there are new conditions, as follows:

Used by Song

Shows only audio files, EXS Instruments or Movies that are used by a Song.

Used by EXS Instrument

Shows only audio files that are used by an EXS Instrument.

Unresolved references / all references resolved

These two exclusive options allow you to search for Songs or EXS Instruments which have / have no unresolved references
(audio files with an unknown location).

Search for Modification Date

You can search for files that were modified before and/or after a certain date. Use the appropriate fields in Find mode.

Regular Expressions (Mac OS X only)

These checkboxes alongside the "file name" and "comments" text entry boxes allow you to use “Regular Expressions” — a Unix
standard for wildcard characters in your search string. Please read the Appendix of this document for details.

File Maps
A file map is a relatively small hidden file that contains the PM database of an external volume. It will be saved to that external
volume whenever the PM database is saved, e.g. directly after the scan process.



The advantage of a file map on your mobile drive is obvious: moving it to another studio doesn’t require a time-consuming re-
scan: its PM database is available immediately.
When connecting such an external drive to your computer, choose Edit > Import file maps in order to see the drive's contents
in your Project Manager window, without the need for scanning.
You can delete all file maps by choosing Edit > Delete all exported file maps.

EXS24 with AKAI Support in Mac OS X
In Mac OS X the AKAI Sample Format is now available to the EXS24. As usual the AKAI Convert function can be selected via the
EXS24 Option menu.



Appendix (6.0.1)
Regular Expressions (Mac OS X only)
You can now use replacement characters („wild cards“) in the search strings for file names or comments in the Project
Manager (see above) using common UNIX rules (Regular Expressions). The following are the most important rules. You can
view a complete description of Regular Expressions by entering „man re_format“ in your Terminal application.

Atoms

So called "atoms“ are the most fundamental elements of Regular Expressions:
. — matches any character
[a-b] — matches any character in the range from a to b

For example [0-9] matches any digit
[^a-b] — matches any character NOT in the range from a to b
^ — represents the beginning of a string

For example ^A matches all strings beginning with an A
$ — represents the end of a string
\  followed by any of the characters ^ . [ $ ( ) | * + ? { \  matches the character after \
any other character — matches the character itself

Repetitions

The character used after an atom can be used to indicate the number of times it appears (if nothing follows the atom, a match
requires the atom to appear exactly once):
* — 0 or more
+ — 1 or more
? — 0 or 1
{x} — exactly x (max. 255)
{x,y} — from x to y (inclusive)

A match occurs when the Regular Expression appears at least once in the name string. The Project Manager is not case-
sensitive (like the Finder), which means that a file called "hello.aif" will be viewed in the same way as a file called "Hello.AIF".

Examples

All names beginning with A: ^A
(= beginning of the Name, then an A)

All names ending with .AIF: \.AIF$
(= a dot, then „aif“, then the end of the name)

All .wav files beginning with B: ^B.*\.WAV$
(= beginning of the name, then „B“, then any number
of any character, then a dot, then „WAV“)

All Auto Backup Song files: \.[0-9][0-9]$
(= a dot, then two digits, then the end of the name)



Logic 6.0
This ReadMe file covers all information that didn’t make it into the printed addendum for version 6. We apologize for any
inconvenience.

Arrange Window

Improved Loop handling
Logic 6 improves the way you work with looped Sequences or Regions.

Cuts and Breaks

It’s now possible to cut a loop using the scissor tool. Logic 6 automatically creates a copy at this position and performs the
cut. If necessary, Logic also creates another looped copy at the following position, so that the resulting arrangement in the
rest of your composition is identical. The end part of the cut object is selected, and is immediately available for Mute or other
operations. You can also use the Split Objects... Key Commands in place of the Scissor tool.

Should you prefer your loops to continue past these Cut operations, you can switch back to the old behavior via the: Logic
Menu > Preferences > Global > Smart Loop handling of Scissor and “Split by SPL“ option.

Endings and Variations

Instead of using empty “Stop Sequences“, you can now easily create a copy of the original loop object by Option + clicking on it
with the Pencil. The content of this „real copy“ is immediately available for editing.

Track Instrument Colors
The new high-resolution icons are colored, and can no longer show the color of the Track Instrument. For this reason, there is a
new: View > Track Instrument Colors option. Once enabled, the color for every Track Instrument is shown as colored stripes on
the right edge of the Track List.

Time Compression/Expansion Algorithms
You can choose from several algorithms when time stretching audio regions using the Time and Pitch Machine in the Sample
Editor (Sample Editor > Factory > Time and Pitch Machine > Algorithm) or when time stretching in the Arrange window (Local
menu: Functions > Object > Time Machine Algorithm). Start with the algorithm that best describes the audio material you want
to process. Your choices are as follows:

Version 5

This is, obviously, the well-known algorithm of Logic 5 and earlier versions.

Any material

This is the most universal algorithm. It should be able to handle most kinds of material. The following algorithms can deliver
better results in cases where the material exactly matches these specifications:

Monophonic

This is a specialized algorithm for monophonic material, e.g. an individual voice, brass or woodwind instrument.



Pads

Use this algorithm on polyphonic material with harmonic content, e.g. choirs or string sections.

Rhythmic material

This algorithm perfectly maintains the timing of percussive material. It should be your first choice for all kinds of drum or
percussion loops, and is also useful on timing-sensitive material, such as rap style vocals.

Beats only

This algorithm works well with drum or rhythmic material consisting of clearly defined and distinguishable transients (beats),
e.g. a single bass drum pattern.

DV Playback via Firewire (Logic Platinum only)
If you’d like to/need to playback DV movies via a Firewire device, we recommend upgrading to QuickTime 6 (or higher).

Video Settings
There are some additional video settings for the Video Thumbnail Track and DV playback via Firewire. You will find all relevant
parameters in: File > Song Settings > Video.

Video to Song adjust (external devices)

This parameter works similarly to the one for internal video hardware, and allows you to correct the inherent system latency of
a connected external Firewire video hardware device. As you would expect, this is a global setting (set and forget).

Thumbnail Cache Resolution

Resolution of the thumbnails kept in the temporary internal memory (Cache). Higher resolutions display more detail, but take
up more space in the cache.

Max. Thumbnail Cache Size (in MB)

Amount of memory reserved for the thumbnail cache. 40 MB is recommend for medium resolution. For higher resolutions, use
a higher value. The memory cache will only be used when actual movie data is displayed.

Space between thumbnails (in pixels)

This is the amount of space between two thumbnails - as displayed on the thumbnail track. The setting has an impact on the
“drawing” speed  of the thumbnails.

Extracting the movie and displaying the thumbnails might take a while - dependent on the video codec being used. A larger
space between thumbnails will increase the drawing speed of thumbnails.

Rewire 2
Logic Platinum 6 now supports Rewire™ version 2 (from Propellerhead Software™). In comparison to Rewire 1, Rewire 2 allows
you to use Logic’s MIDI sequencing possibilities as well – not just Sync and Mixing. In order to send MIDI data to the software
instruments of a Rewire2 compatible application, you need to create Rewire-Instruments in Logic’s Environment window:
Environment > New > Internal > Rewire.

Starting a Rewire session
To connect to a Rewire compatible software instrument, first launch Logic and then the Rewire application. When shutting



down, first quit the Rewire application, then Logic.

Settings
Rewire objects offer two parameters in their object parameter box:

Bus

Bus - lets you choose the Rewire (MIDI) Bus. Should a Rewire2 compatible application provide bus names, they will be
displayed, rather than mere numbers. In Reason’s™ case, the names of the instruments available in the Reason Rack will be
shown (starting from Bus 6 upwards, see below).

Cha

Cha sets the MIDI channel of the Rewire object. For multitimbral Rewire sound sources, you will want to connect a Multi
Instrument to the Rewire object. In this scenario, the Cha parameter of the Rewire object should be set to All.

Reason Settings

When using Reason, the Bus numbers translate as follows:
- Bus 1 addresses the instrument chosen as the Live Track in Reason.
- Busses 2-5 address Busses A-D of the Reason MIDI In Device.
- Busses 6 and higher connect to the instruments of the Reason Rack.

Audio Driver Optimization for Rewire
In Logic Menu > Preferences > Audio Hardware & Driver > Core Audio you will find a parameter called Rewire behavior. When
sending MIDI data to a Rewire compatible software instrument, you can choose between these modes:

Live mode

Use this mode whenever you want to play a Rewire instrument live. This setting requires more CPU power.

Playback mode

Use this mode when all Rewire instruments are just playing back MIDI tracks (no live playing). This setting requires less CPU
power.

BTW: Yes, you can use Rewire tracks in offline bounce processes.

For further details on Rewire, please refer to the documentation provided by Propellerheads.

Project Manager (Logic Platinum only)

Don’t record audio during the Project Manager scan process

Generally, it is no problem to run the Project Manager in the background while working with Logic. It is not recommended,
however, that you perform any audio recording while the Project Manager is scanning your hard drives.

Waiting for the Data Base to load

If the number of entries in the Project Manager database is very large, it will take some time to load. Please remember that you
can determine when the loading process will take place – either while Logic is starting-up (default), or once you open the
Project Manager window for the first time.



Logic Menu > Preferences > Global > “Automatically load Project Manager database upon program start“. If you don’t need to
access the Project Manager every time you launch Logic, you can speed up the boot process by disabling this option.

Refresh Freeze Files
This Key Command recalculates all audio and instrument tracks that have been frozen. As an example, you should refresh
your freeze files after global cut operations or after changing the tempo of the song. You can simply use this command to start
the freeze process manually. (Default key: F).

Cycle Pre-Processing
For technical reasons, an internal pre-processing period is required to perform Cycle jumps smoothly. Logic 6 allows you to
adjust the duration of this process: Logic Menu > Preferences > General >Cycle Pre-Processing.

When in doubt, you should keep the default value of 1/96 note, but you can reduce this value to 1/192, 4 ticks and even off
which deactivates Cycle Pre-Processing entirely.

Numerical Input
Many parameters now allow you to hold the Control key while double-clicking on the parameter. This enables you to enter a
value numerically.

EVD6
As a bonus to owners of the EVD6 Software Instrument, Logic 6 features a new harp-like sound generation Model called Picked.
Enjoy!

Control Surface Support
Control Surface support has been expanded. Logic Platinum 6 supports the following devices:

Emagic Logic Control/XT, Tascam US-428/224, Roland SI-24, CM Labs Motormix, Yamaha DM2000/DM1000, 02R96, 01V96,
Radikal Technologies SAC-2K, SAC-2.2, Mackie HUI, Baby HUI plus any other HUI-compatible device.

You will find separate PDF files which document the assignments for these newly supported control surfaces.

New Features in Logic 6:
- Assigning and Editing of Groups
- Logic Control, Motormix and the SAC’s support Channel EQ editing in the EQ modes (EQ button on Logic Control)
- Logic Control supports a special mode which allows you to access all parameters which are currently visible in the track

automation of the Arrange window. This way, you can simultaneously control any parameters on the V-pots and motor
faders.


