All-New Messenger 6.0 Help
Yahoo! Messenger > Platform/Version Help > Messenger 6.0 Help > Install Help >
Related Links
· Messenger Tour
· Messenger Security
· Terms of Service

Further Reading
· More on Yahoo!

Essential Downloads
· Internet Explorer
· Macromedia Flash Player
· Windows Media Player

 
What are the system requirements?
To enjoy the All-New Messenger 6.0 you must meet or exceed the following requirements: Additional feature requirements: Please Note: We no longer support Windows 95 and NT.

Is this enough information?
Great! Click Yes to go back to Yahoo! Messenger.
Click No to contact Yahoo! Customer Care.