
Déj
déjàvu
´̀

´̀

A T R LI
LANGUAGE ENGINEERING
à Vu X Standard
Users' Guide





Copyright © 1993-2003 ATRIL Language Engineering, SL. All rights reserved.

Use of this software is subject to the terms of the license agreement included with 
the product. If the license is misplaced, a copy can be requested from ATRIL 
Language Engineering, SL.

Information contained in this document is proprietary to ATRIL Language 
Engineering, SL and may be used or disclosed only with written permission from 
ATRIL Language Engineering, SL. This manual, or any part thereof, may not be 
reproduced without the prior written permission of ATRIL Language Engineering, 
SL. 

This document and the related software described in this manual are supplied 
under license or nondisclosure agreement and may be used or copied only in 
accordance with the terms of the agreement. The information in this document is 
subject to change without notice and does not represent a commitment on the part 
of ATRIL Language Engineering, SL.

Sentry Spelling-Checker Engine is a registered trademark of Wintertree Software 
Inc. FrameMaker, Acrobat, InDesign and PageMaker are registered trademarks of 
Adobe Systems Inc. Interleaf and QuickSilver™ are trademarks of BroadVision Inc. 
QuarkXPress is a trademark of Quark, Inc. Unicode™ and the Unicode logo are 
trademarks of Unicode Inc. Microsoft is a registered trademark and Word, 
PowerPoint, Access, Excel, Windows 95, Windows 98,Windows NT, Windows 2000, 
Windows XP, and Windows Me are trademarks of Microsoft Corporation. Trados 
Workbench, MultiTerm and MultiTerm iX and Trados TagEditor are trademarks of 
Trados GmbH. IBM TranslationManager is a trademark of IBM Corporation. 
StarOffice is a trademark of Sun Microsystems. All other product names are 
trademarks or registered trademarks of their respective companies, and they are 
used without representation as to their general use. All third-party trademarks are 
the property of their respective owners.

If you have comments or suggestions about this documentation, contact ATRIL 
Language Engineering, SL at support@atril.com.

support@atril.com




Table of Contents
Table of Contents
Introduction 1

How to Use This Manual 1
Where Do I Start? 2
The Beginner—When You’re Starting from Scratch 2
The Convert—When You’re New to Déjà Vu but Familiar with Other Transla-
tion Memory Tools 3
The Upgrader—When You’re Familiar with Déjà Vu 3 4

Conventions Used in this Manual 4
User Interface Controls 4
Menu Commands 5
Path Names and Sample Text 5
Tips 5
Notes 5

Related Documentation 5
Readme 5
Website 5
User Groups 6

What Is New in Déjà Vu X Standard? 7
The Look and Feel 7
Mixing of File Types 10
Character Conversion and Supported Languages 10
Multilingual Databases 10
Fully Configurable Terminology Databases 10
New Analysis Features 11
New Search Module 11
DTD Support 11
New Supported Formats 11
Multilingual User Interface 11

The Déjà Vu X Standard Interface 13
The Project Interface 15

The Menu Bar 16
Keyboard Shortcuts 19
The Toolbar 20
The Translation Grid 23
The File Navigator 26
The Selector Row 26
The Status Bars 35
Rearranging the Windows 36
Managing Option Catalogs 39
Déjà Vu X Standard I



Table of Contents
Setting the Font 40
Moving Around 43
Selecting Rows 45
The Project Explorer 48

Workflow 63
Phase I: Preparation 64

Import of Existing Third-Party Databases into the Translation Memory 64
Import of Existing Translations into the Translation Memory 65
Import of Existing Third-Party Glossaries into the Terminology Database 65
Source Files 66

Phase II: Project Building 67
Selecting an Existing Project File 67
Creating a New Project File 69
Generating the Lexicon 76

Phase III: Pretranslation 80
Phase IV: Translation 83

Feeding the Databases 83
Phase V: Editing and Quality Assurance 86

Déjà Vu X Standard’s Integrated Quality Assurance Features 86
Editing and Proofing 97

Phase VI: Export 98

Translation Features in Déjà Vu X Standard—The Details 103
Database Performance 103

Fuzziness Setting 106
Searching the Databases 107

Scanning the Translation Memories 107
Lookup in the Terminology Databases 113

Assemble 118
Assemble and Example-Based Machine Translation 120

Sending Text to the Databases 123
Sending Information to the Translation Memory 123
Sending Information to the Terminology Database 127
Sending Information to the Lexicon 127
Locking Rows 127

Clients and Subjects 128
Working with Clients 131

Propagate 151
Embedded Codes 154

Relative Positioning of Embedded Codes Around Text 156
Relative Positioning of Embedded Codes in Shifted Syntax 157
Copying and Moving Embedded Codes 158
Deleting Embedded Codes 160
II Déjà Vu X Standard



Table of Contents
Modifying Embedded Codes 161
Context View 163
Conversions 164
Copying and Populate 166

Populating Single Sentences 166
Sentence Delimitation 169

Splitting and Joining Sentences 172
Common Windows Functions 174

Character Map 174
Search and Replace Features 177
Redo and Undo Features 179
Saving the Project 180
Change Case 180

Editing Features in Déjà Vu X Standard—The Details 183
Spelling Options 183
Dictionaries 187

Review Features in Déjà Vu X Standard—The Details 197
Bookmarking a Sentence 197
Marking Sentences as Pending 199
Adding Comments 200

Teamwork Features in Déjà Vu X Standard—The Details 203
Pack & Go Packages 203
Satellite Files 208

Security Features in Déjà Vu X Standard—The Details 211

Analysis Features in Déjà Vu X Standard—The Details 215
The Count Feature 215
The Analysis Feature 223

Working with Different File Formats 227
Microsoft Word 239
RTF (Rich Text Format) 245
Microsoft PowerPoint 246
Microsoft Excel 247
OpenOffice.org/StarOffice 250
Microsoft Access 251
Adobe FrameMaker 253
Adobe PageMaker 261
QuarkXPress 266
InDesign 269
Interleaf/QuickSilver 273
Déjà Vu X Standard III



Table of Contents
Plain Text 274
Help Content 274
HTML and Script-Based Files 275
SGML/XML 279
Java Properties 283
RC (Resource) 283
C/C++/Java 285
GNU Gettext 287
IBM TranslationManager 289
Trados RTF/Word Files 290
Trados TagEditor Files 292
TMX Files 294

Creating and Maintaining SGML/XML Filter Files 297
Tags and Attributes 297

The Lexicon 321
Working with the Lexicon 322

Resolving the Lexicon with the Databases 324
Sending the Lexicon to a Database 325
Exporting the Lexicon 327
Preparing a Lexicon for Translation Outside of Déjà Vu X Standard 333
Importing into the Lexicon 334

Creating and Maintaining Translation Memories 341
The Translation Memory Interface 341
Opening Translation Memories 347
Creating Translation Memories 347
Associating Translation Memories with a Project 352
Translation Memory Statistics 354
Importing External Data 356
Aligning Existing Files with the Basic Aligner 366
Spell Checking the Translation Memory 382
Exporting Data from Translation Memories 384

Creating and Maintaining Terminology Databases 401
Opening a Terminology Database 401
Terminology Database Statistics 402
Creating Terminology Databases 403
Templates 409
Associating Terminology Databases with a Project 420
Adding Records 423

Adding Translation Records 423
Importing External Data 427
IV Déjà Vu X Standard



Table of Contents
Adding Non-Translation Records 441
Exporting Data from Terminology Databases 446
Editing the Terminology Database 456

Modifying a Particular Term 457
Spell Checking the Terminology Database 461

Digging In—Advanced Topics 463
Sample Regular Expressions for Export from Translation Memory and 
Terminology Database 463
List of Language and Sublanguage Codes 468

The Menu Commands and Toolbar Icons 477

The Keyboard Shortcuts 486

Glossary 490
Déjà Vu X Standard V



Table of Contents
VI Déjà Vu X Standard



Introduction
Chapter 1
Introduction

How to Use This Manual

Like any other manual, this manual is not intended to be read through 
from the first to the last page; however, we hope that its internal logic 
may make you want to do just that.

Following this introduction, you can find these three chapters:

"What Is New in Déjà Vu X Standard?" on page 7—an overview of 
some of the most outstanding new features of Déjà Vu X Standard.

"The Déjà Vu X Standard Interface" on page 13—an introduction to 
Déjà Vu X Standard’s user interface. 

"Workflow" on page 63—a suggested workflow model for translation with 
Déjà Vu X Standard. The workflow chapter is followed by chapters that 
detail some of the features discussed in the workflow chapter:

"Translation Features in Déjà Vu X Standard—The Details" on page 
103

"Editing Features in Déjà Vu X Standard—The Details" on page 183

"Review Features in Déjà Vu X Standard—The Details" on page 197

"Teamwork Features in Déjà Vu X Standard—The Details" on page 
203

"Security Features in Déjà Vu X Standard—The Details" on page 211

"Analysis Features in Déjà Vu X Standard—The Details" on page 215

Next comes a chapter dealing with how to work with different file 
formats, and one that specifically discusses working with SGML/XML files:

"Working with Different File Formats" on page 227
Déjà Vu X Standard 1



Introduction
"Creating and Maintaining SGML/XML Filter Files" on page 297

The next three chapters are concerned with the creation and 
maintenance of Déjà Vu X Standard’s databases:

"The Lexicon" on page 321

"Creating and Maintaining Translation Memories" on page 341

"Creating and Maintaining Terminology Databases" on page 401

The "Appendix" on page 477 contains an overview, a listing of the menu 
commands, and a glossary.

Finally, there is a very comprehensive index at the end of the manual that 
is meant to be a substantial aid in finding relevant topics. We encourage 
you to use it extensively.

Where Do I Start?

Where you’ll start depends on who you are, what your goals for Déjà Vu X 
Standard are, and how experienced you are with translation memory 
tools in general and Déjà Vu in particular.

The Beginner—When You’re Starting from Scratch

If you’re a new user who has never worked with computer-assisted 
translation tools (commonly abbreviated as CAT tools), it would probably 
be a good idea to start with the Getting Started Guide that came with 
your software (or you can find it in the installation directory in PDF 
format). Going through the tutorial will give you a good place to start.

If you stumble on terms that you are not familiar with, turn to the 
"Glossary" on page 490.

When you feel familiar with the basic concepts, you can continue by 
looking at "Workflow" on page 63 in this manual. There you can see 
which steps you may not be familiar with and read about the relevant 
features in the details sections on pages 103-227. To find specific topics 
in these chapters, it may be a good idea to use the index at the end of 
this manual.

"Working with Different File Formats" on page 227 will familiarize you 
with the specific types of files that you will be working with.
2 Déjà Vu X Standard



Introduction
When you are comfortable with the general concepts of how to translate 
in Déjà Vu X Standard, you should then look into optimizing your 
databases in the database section, ranging from pages 321-463. Again, 
the index will help you to navigate through these sections.

The Convert—When You’re New to Déjà Vu but Familiar 
with Other Translation Memory Tools

First of all: we’re glad to have you reading this, and we feel confident that 
you’ll like what you see. One thing you should be aware of is that Déjà Vu 
X Standard does things a little differently from other tools, so you may 
need to try to free your mind as much as you can from what you know 
about how other translation memory tools work.

The "Glossary" on page 490 should be helpful for you to familiarize 
yourself with how Déjà Vu X Standard refers to concepts that the creators 
of other tools named differently (or didn’t know about!).

From there we would suggest the following learning path: Start with the 
Getting Started Guide that came with your software (or you can find it in 
the installation directory in PDF format) and work your way through the 
tutorial. This will give you a good idea of how Déjà Vu X Standard works 
and how it’s unique.

When you feel confident with the basic concepts that you have learned, 
you can continue by looking at "Workflow" on page 63 in this manual, see 
which steps you may not be familiar with, and read more about them in 
the details sections on pages 103-227. To find specific topics in these 
chapters, it may be a good idea to use the index at the end of this 
manual.

More about the specific kinds of files you will be translating can be found 
in the corresponding sections of "Working with Different File Formats" on 
page 227.

Please be aware that there is no need to learn everything about this 
program. Imagine Déjà Vu X Standard as a big tool box from which you 
can choose the tools that make sense for your specific needs. Do not 
overload yourself with information that you will not need later on.
Déjà Vu X Standard 3
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When you are comfortable with the general concepts of how to translate 
in Déjà Vu X Standard, you should then look into optimizing your 
databases in the database section, ranging from pages 321-463. Again, 
the index will help you to navigate through these sections. The first of 
these chapters, "The Lexicon" on page 321, should be of particular 
interest because this is a concept that is unique to Déjà Vu X Standard.

The Upgrader—When You’re Familiar with Déjà Vu 3

Your first questions will probably be: What’s new and what’s different? 
The short answer: Everything. But we do have a special section just for 
you: "What Is New in Déjà Vu X Standard?" on page 7.

After reading this section, you will probably want to look up individual 
chapters on topics that you’re not yet familiar with. You will find that the 
index in this manual is more extensive than earlier manuals to give you a 
quick reference point on where to look.

If you feel that you still aren’t getting the big picture of the new Déjà Vu, 
look at the tutorial in the Getting Started Guide (you can find it in the 
installation directory in PDF format) and the section "Workflow" on page 
63.

It might also be helpful to take a quick glance at the section "Working 
with Different File Formats" on page 227, in case you either missed one of 
the file formats that earlier version of Déjà Vu supported or you can now 
use one of the new filters (such as Trados BIF files).

Conventions Used in this Manual

User Interface Controls

All user interface controls, such as buttons, menus, tabs, or dialogs, 
are bolded. 

Please be aware that there is no need to learn everything about this 
program. Imagine Déjà Vu X Standard as a big tool box from which you 
can choose the tools that make sense for your specific needs. Do not 
overload yourself with information that you will not need later on.
4 Déjà Vu X Standard



Introduction
Menu Commands

Menu commands, such as Tools>Options>Font, are identified by the 
greater-than sign.

Path Names and Sample Text

All path names and user-entered sample text are in Courier New.

Tips

Notes

Related Documentation

Readme

Please consult the Readme file after the installation of Déjà Vu X 
Standard for the latest information on the product and any possible 
issues with the program along with their work-arounds.

Website

On www.atril.com you can find information about training seminars, user 
support, new versions of the product, and freely downloadable updates. 
Under www.transref.org, a translation knowledgebase, you can find a 
great variety of information related to Déjà Vu, other CAT tools, a 
translators’ database, and a host of other translation-related topics. 

Tips contain useful additional information on maximizing a specific 
feature. They are delineated by the light bulb symbol.

Notes contain important information that you need to be aware of. They 
are delineated by the thumbtack symbol.
Déjà Vu X Standard 5
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Introduction
User Groups

The Déjà Vu user group at http://groups.yahoo.com/group/dejavu-l and 
the newsgroups under news://news.atril.com are highly supportive and 
caring communities of worldwide Déjà Vu users. You are strongly 
encouraged to join these groups.

Please note that you can access the archives of the tens of thousands of 
questions and answers that have been submitted to these forums over 
the last few years.

In case you are not familiar with newsgroups, you can find information 
about them at www.howstuffworks.com/newsgroup.htm.
6 Déjà Vu X Standard
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What Is New in Déjà Vu X Standard?
Chapter 2
What Is New in Déjà Vu X 
Standard?

The question should probably be: What is not new in Déjà Vu X 
Standard? In this section, we have tried to limit ourselves to the most 
striking new features.

The Look and Feel

What used to be four different programs (Déjà Vu Interactive, Database 
Maintenance, Terminology Maintenance, and SGML Filter Maintenance) 
have been combined into one interface that allows you to open and edit 
all your databases, project files, and SGML/XML filters. All this is 
presented in a new and fresh Windows-standard graphical user interface 
(GUI) look that is completely user-configurable and filled with wizards to 
guide you through virtually every process.

Two new features inside Déjà Vu X Standard include the File Navigator 
and the Project Explorer. 
Déjà Vu X Standard 7
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The File Navigator is presented in a small pane on the right of your 
screen and displays all the files in your project so you can easily switch 
from one file to the next. This is especially helpful, because in Déjà Vu X 
Standard projects you can import and process any file or folder of any file 
type supported by Déjà Vu X Standard from anywhere on your local 
machine or network.
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The Project Explorer is a Windows Explorer-like interface from which 
you can import and export any supported file in and out of your project. 
The Explorer is also accessed from within the main Déjà Vu X Standard 
interface.

Translation can now be performed in editing boxes at the bottom of the 
screen or directly in the cells themselves, which now also resize 
themselves to fit all the text in one view.
Déjà Vu X Standard 9
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Selection of rows has been made much easier by switching between the 
edit and selection mode with one keystroke (Enter).

Navigation between open files is now available with a single mouse-click 
through an expanded status bar.

The tool windows—which include the File Navigator and the 
AutoSearch window—are freely dockable. This means that you can place 
them anywhere outside the main window on your desktop, making it easy 
to use several monitors.

Mixing of File Types

Although we already mentioned this in the previous section, it’s worth a 
repeat: Every file type that is supported by Déjà Vu X Standard can now 
be included in a single project.

Character Conversion and Supported Languages

Everything that takes place in Déjà Vu X Standard happens within 
Unicode. This means that all the languages supported by Windows are 
supported by Déjà Vu X Standard as source and target (including double-
byte and right-to-left languages). This does NOT mean that texts which 
did not originate in Unicode will be exported into Unicode. Depending on 
the file type, target language, and your choice of a code page, the 
translated text will have the same code page as the original, or one that 
corresponds more closely to the file type/target language in question.

Multilingual Databases

Terminology databases and translation memories are now multilingual. 
This means that you may have an unlimited number of target languages 
in one database!

Fully Configurable Terminology Databases

Terminology databases are now completely configurable by the user. You 
can add as many attributes as you like and define their relations.
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New Analysis Features

While you still have the word count features that give you an exact 
representation of how many words have been or are to be translated in 
which category, Déjà Vu X Workgroup also offers an analysis feature with 
which you can see how many of what kind of matches you have in your 
translation memories.

New Search Module

Déjà Vu X Standard’s new search module not only displays all matches in 
one window, it also gives you the option to select terms with several 
matches (marked with a blue underline) with a right-click and select any 
other option.

 

DTD Support

Déjà Vu X Standard’s completely overhauled SGML/XML filter now has the 
capability to use the source SGML/XML file(s) or the DTD, the document 
type definition file, to build an SGML filter.

New Supported Formats

Newly supported formats include Adobe InDesign, Trados BIF and TTX 
files, GNU gettext POT/PO files, OpenOffice.org/StarOffice files, and a 
completely overhauled PowerPoint filter.

Multilingual User Interface

The Déjà Vu X Standard user interface and documentation now comes in 
several languages (English, Dutch, French, Spanish, and Russian) that 
can all be switched on the fly.
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You’re probably starting to get the idea that things truly are new with 
Déjà Vu X Standard, and that it would make a lot of sense to spend a 
couple of hours familiarizing yourself with it. Once you do, we’re betting 
you’ll never want to go back....
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Chapter 3
The Déjà Vu X Standard 
Interface

Unlike its previous versions, Déjà Vu X Standard has only one interface 
from which you create, open, and edit all necessary files. The seven Déjà 
Vu internal file types are:

Déjà Vu Project Files (.dvprj)—the files in which you import the 
files that need to be translated, translate them, and from which you 
export them into their original formats. This file can contain only one 
source language but several target languages.

Déjà Vu Satellites Files (.dvsat)—the protected files which contain 
only one source and one target language plus all the information 
needed by the translator. These files can be exported from the main 
project and re-imported after translation.

Pack & Go Packages (.dvpng)—highly compressed exports from 
project files that are ideal for the transmission of Déjà Vu X Standard 
data. Like the satellite files, Pack & Go packages can be exported 
from the main project and re-imported after translation.

Déjà Vu Translation Memories (.dvmdb)—the files that store all 
previously translated segments (sentences, headings, cell content, 
bullet points, etc.) in source and target. This file is completely 
multilingual, i.e., it can have several target languages. You will notice 
that in the folder where the .dvmdb is created, other files are also 
created—one with the extension .<language>.dvmdi for each 
language used and one with the extension .dvmdx. These files 
contain the index and language-specific material. You may not delete 
or rename them.

Alignment Files (.dvapr)—intermediary database files in which 
data from already translated files is paired up. Once the alignment is 
completed, this file is fed into a translation memory.
Déjà Vu X Standard 13
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Déjà Vu Terminology Databases (.dvtdb)—the files that contain 
pairs of terms or short expressions (source and target) which you 
have added. Each pair is associated by additional information that is 
freely configurable. Like the translation memories, the terminology 
database is completely multilingual, i.e., it can have several source 
and several target languages.

SGML/XML Filters (.dvflt)—files that you will only need and use 
when you translate files that follow the SGML definition. There are 
many subgroups of SGML, one of which is XML, a widely used 
standard for data exchange and storage. Because each SGML file or 
group of SGML files is unique, you will have to create a unique filter 
for them. You can do that by having Déjà Vu either analyze the SGML 
files or read the DTD file, an associated file that contains all the 
relevant information.

You will notice that the toolbars and the menu bar change according to 
what kind of file you open. All of the toolbars are completely 
reconfigurable, so you can set them according to the tasks that you most 
often perform.
14 Déjà Vu X Standard
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The Project Interface

Let’s first have a look at the default Déjà Vu X Standard’s appearance 
with an open project file.

To switch the user interface language of Déjà Vu X Standard

1 Select Tools>User Interface Language.

2 The Select User Interface Language dialog appears, displaying the 
language that you selected when you first started Déjà Vu X 
Standard.
Déjà Vu X Standard 15



The Déjà Vu X Standard Interface
3 If you want to switch that language, click on the dropdown arrow and 
select the language of your choice. The available languages are:

English

Dutch

French

Russian

Spanish

The Menu Bar

As in most Windows applications, almost all of Déjà Vu X Standard’s 
functions are accessible through the menu bar.

The File Menu

The commands in the File menu are the standard Windows options for 
creating, opening, and closing a file as well as several import and export 
options.

You can find a complete list of File menu commands as well as the 
available keyboard shortcuts and toolbar icons in the Appendix under 
"The Menu Commands and Toolbar Icons" on page 477.

The Edit Menu

The commands in the Edit menu include the standard Windows options 
for copying, cutting, pasting, searching, replacing, and selecting text, as 
well as for changing the case of selected text and joining and splitting 
sentences.

You can find a complete list of Edit menu commands as well as the 
available keyboard shortcuts and toolbar icons in the Appendix under 
"The Menu Commands and Toolbar Icons" on page 477.
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The Insert Menu

The Insert menu includes AutoText- and AutoCorrect-specific commands 
and commands to populate (copy) text from source to target and to 
insert text from the databases.

You can find a complete list of Insert menu commands as well as the 
available keyboard shortcuts in the Appendix under "The Menu 
Commands and Toolbar Icons" on page 477.

The View Menu

The View menu lets you toggle the sorting order of your project and 
switch between the Project Explorer and the File Navigator.

You can find a complete list of View menu commands as well as the 
available toolbar icons in the Appendix under "The Menu Commands and 
Toolbar Icons" on page 477.

The Translation Menu

The Translation menu consists of commands to search and add to the 
databases, propagate translations, and perform consistency checks 
between the source and target.

You can find a complete list of Translation menu commands as well as 
the available keyboard shortcuts and toolbar icons in the Appendix under 
"The Menu Commands and Toolbar Icons" on page 477.

The Project Menu

The Project menu commands give you access to the Project Properties 
dialog, they allow you to add the complete project to the translation 
memory, to detect and/or unmark duplicates in source and/or target 
sentences, and provide access to SQL commands.

You can find a complete list of Project menu commands as well as the 
available keyboard shortcuts and toolbar icons in the Appendix under 
"The Menu Commands and Toolbar Icons" on page 477.

The Lexicon Menu

The commands in the Lexicon menu give you access to generate and 
maintain a lexicon.
Déjà Vu X Standard 17
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You can find a complete list of Lexicon menu commands in the Appendix 
under "The Menu Commands and Toolbar Icons" on page 477.

The Users Menu

In the Users menu, you can find commands to log in into your project 
and to log out of your project.

You can find a complete list of Users menu commands in the Appendix 
under "The Menu Commands and Toolbar Icons" on page 477.

The Tools Menu

In the Tools menu, you can find commands to access the spell checker, 
the word count module, different languages for the user interface, the 
Windows Character Map, the Déjà Vu X Standard Options dialog, 
commands to convert databases from earlier versions of Déjà Vu, to 
customize the look of Déjà Vu X Standard, and to repair or compact the 
project.

You can find a complete list of Tools menu commands as well as the 
available keyboard shortcuts and toolbar icons in the Appendix under 
"The Menu Commands and Toolbar Icons" on page 477.

The Window Menu

The Window menu consists of the standard Windows commands that 
allow you to re-configure the way in which Déjà Vu X Standard’s windows 
are displayed and to rearrange the icons.

You can find a complete list of Window menu commands as well as the 
available keyboard shortcuts and toolbar icons in the Appendix under 
"The Menu Commands and Toolbar Icons" on page 477.

The Help Menu

The commands in the Help menu give you access to the Help system and 
information about the current version of Déjà Vu X Standard.

You can find a complete list of Help menu commands as well as the 
available keyboard shortcuts and toolbar icons in the Appendix under 
"The Menu Commands and Toolbar Icons" on page 477.
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The Déjà Vu X Standard Interface
Keyboard Shortcuts

It is a good practice to learn the keyboard shortcuts for the Déjà Vu X 
Standard functions you use most often, since this will let you work faster 
and more efficiently. You will find the default keyboard shortcut for each 
function (if there is one) beside the function’s name on the menu. An 
additional expanded list can be found under "The Keyboard Shortcuts" on 
page 486.

However, all keyboard shortcuts can be customized to fit your particular 
preferences. 

To customize the keyboard shortcuts

To customize the keyboard shortcuts, select Tools>Customize and click 
Keyboard at the bottom of the Customize dialog.

The Customize Keyboard dialog appears.
 

In the edit box under Press New Shortcut Key, you can edit existing 
shortcuts or add shortcuts to commands that do not have an assigned 
shortcut.

1 Position your cursor in the edit field and press the new key 
combination.
Déjà Vu X Standard 19
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2 Click Assign and Close.

The Toolbar

The toolbar gives you access to the most often-used commands for each 
file type.

Here is an example of the Standard and the Project toolbar. (For an 
explanation of the buttons, see "The Menu Commands and Toolbar Icons" 
on page 477.)

Just like the shortcut keys, the toolbar is completely configurable as well.

By clicking on Reset, you can reset the keyboard shortcut values to the 
original values.
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To customize the toolbars

To customize the toolbars, select Tools>Customize and select the 
desired toolbars in the Toolbars tab of the Customize dialog.

You can also create new toolbars by clicking on the New button.
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To customize existing toolbars

To customize existing toolbars, select Tools>Customize>Commands 
and drag the desired commands out of or into the existing toolbars.

The final tab of the Customize dialog offers you several more options to 
customize your view of the menus, toolbars, and other features.

To customize currently displayed toolbars

You can customize currently displayed toolbars by the options described 
under "To customize existing toolbars" on page 22, or you can click on the 
down arrow at the end of these toolbars.
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This will open a menu with all default buttons. 

You can select or deselect each one of them and activate your selection 
by clicking Reset Toolbar. 

–Or–

You can select Customize to access the Customize dialog.

The Translation Grid

The main module of Déjà Vu X StandardProfessionalWorkgroup’s 
translation interface is the translation grid, the interface in which you 
actually perform any translation activity.
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Unlike in previous versions, translation activities are by default performed 
directly within the grid, which resizes itself automatically to accommodate 
differing lengths of sentences.

Edit and Selection Modes

There are two different modes in a Déjà Vu X Standard project: the edit 
and the selection mode. The edit mode is the default mode that you work 
in as you translate and edit sentences. In that mode you can select text 
in the source and/or target of the current row, but you cannot select 
(highlight) the complete row. To do that you will have to switch into the 
selection mode.

To switch into the selection mode

1 Make sure your cursor is in a specific row.

To help you find your current position within the open file or project, the 

current row is marked with a little black arrow ( ) to the left of the 
source sentence and is surrounded with emphasized row borders.

The colors of the translation grid lines can be changed to any color you prefer. For 
more information on changing colors, see "To change the colors of the indicator 
bars" on page 29.
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2 Press the Esc or the Enter key.

3 You can see that the complete row is now highlighted.

To switch back into the edit mode

1 Press the Enter key or double-click the source or target sentence.

2 You can see that the row is not highlighted anymore. 

Translating in a Separate Text Area

Some translators prefer to work in a vertical manner, i.e., with source and 
target positioned on top of each other. You can do that by selecting 
Tools>Options>Environment>Edit in separate text area>Split 
text area vertically.

Other benefits of this display mode include a more obvious highlighting of 
the currently selected row and the fact that you never have to scroll to 
find the currently selected row.

If you choose to work in this manner, the actual grid will automatically 
switch into selection mode so that you cannot edit directly within the 
cells.
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The File Navigator

The File Navigator is presented in a small pane on the right of your 
screen. It displays all the files and the lexicon in your project so you can 
easily switch from one file to the next. This is especially helpful because 
in Déjà Vu X Standard projects you can import and process any file of any 
file type that is supported by Déjà Vu X Standardfrom anywhere on your 
local machine or network.

The Selector Row

Above the source and the target cells, you will find a row with three 
boxes: text locator, rows selector, and target language selector.

From left to right, you will find:

Text/Record Locator

Rows Selector

Language Selector

The Text/Record Locator

If your sort order is the default "natural" order—the order in which the 
sentences appear in the source document—you can use this row to enter 
the number of the record project line you would like to jump to.
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If your sort order is "alphabetical"—the alphabetical order of the 
sentences in the source document—you can type the first few letters of 
the first word of the line you want to jump to.

To switch between natural and alphabetic order

1 To sort alphabetically, click the  button on the toolbar.

–Or–

To sort naturally, click the  button on the toolbar.

Generally you will want to translate in the natural order because it 
allows you to see how each particular sentence fits into the flow of the 
document.

When you switch from one mode to the other, Déjà Vu X Standard will 
keep the same current record.
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The Rows Selector

You can choose to filter and display only certain kinds of rows, e.g., exact 
matches, fuzzy matches, pending rows, etc. You can see that each status 
is associated with a colored status indicator bar that matches the color 
indicator in the translated cells.

The available status filters are:

All Empty Rows

All Empty Except Locked Rows

All Rows

All Unpainted Rows (default grey indicator bar)

Multiple Exact Match Rows (indicator: blue, underlined font)

Exact Match Rows (default dark green  indicator bar)

Guaranteed Exact Match Rows (default orange indicator bar)

Fuzzy Match Rows (default light green indicator bar)

Assembled Rows (default dark blue indicator bar)

Fuzzy Propagated Rows (default gold indicator bar)

Exact Propagated Rows (default light blue indicator bar)

Finished Rows (indicator symbol: )

Locked Rows (indicator symbol: golden  for manual lock and 

green  for a guaranteed match lock)

Rows with Comments (indicator symbol: blue  or, if combined with 

marker for inconsistent terminology: violet ) 

Usually, fuzzy matches are not displayed with a solid light green bar, but 
with a split green/grey bar that indicates the percentage of fuzziness.
28 Déjà Vu X Standard



The Déjà Vu X Standard Interface
Rows with Comments in Source (indicator symbol: blue ) 

Rows with Comments in Target (indicator symbol: blue  or, if 

combined with marker for inconsistent terminology: violet )

Rows with Inconsistent Terminology (indicator symbol: red  or, if 

combined with comments: violet )

Wrong Codes Rows (indicator symbol: )

Duplicate Rows (default indicator: grey vertical bar to the left of 
source)

SQL Statement (opens the Select SQL dialog. For more information, 
see "To use the SQL Statement view" on page 31.)

To change the colors of the indicator bars

1 Select Tools>Option>Display.

This dropdown box also provides an instant overview of the meaning of 
each of the colors displayed in the status indicator bar in each sentence.

Another helpful way of instantly reviewing the status of a certain row is 
to place your mouse cursor over the indicator bar section. A tooltip-like window 
will appear in which you can review the status information of the current row, the 
user who last modified it, the date and timestamp of the last modification, as well 
as various other bits of information.
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2 The Display tab in the Options dialog is displayed.

3 Select the status row whose indicator color you want to change.

4 Click the selector button ( ) that appears to the right of the row.

5 The Color dialog appears.
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6 Select the desired color and click OK.

7 The selected row is now displayed with the new color setting.

8 Click Apply and/or OK.

To remove the sentence status indicators

To reset the sentence status to the unpainted row status, you can 
right-click the row in question and select Reset Sentence Status.

–Or–

Press Ctrl+Shift+U.

To use the SQL Statement view

The idea of the SQL Statement view is to give you complete flexibility as 
to what subset of rows in your project you would like to view.

This will remove all status indicators with the exception of Wrong Codes, 
Comments, and Terminology Mismatch.
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1 Select SQL Statement from the Rows Selector dropdown list.

2 The Select SQL dialog appears.

3 If you are familiar enough with SQL and the database structure of 
Déjà Vu X Standard, you can directly enter an SQL expression 
starting after the WHERE clause.

–Or–
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You can select Build Expression to open the Build Status 
Expression dialog.

4 In this dialog you can check (include) or uncheck (exclude) certain 
status criteria. The Translation Status criteria are mutually 
exclusive and so are the criteria under Progress Status (i.e., they 
have an OR relationship), but the criteria from the two different 
groups are combinable. For instance, if you want to view all rows that 
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are empty or assembled and not locked, you make the following 
selection:

5 Upon clicking OK, you will see the following expression entered into 
the Select SQL dialog:
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6 Selecting Apply will now display all rows that are either empty or 
assembled but not locked.

The Language Selector

You can use the language selector to switch between the different target 
languages that you may have in your project.

The Status Bars

Déjà Vu X Standard has a stacked status bar:

The upper portion of the bar displays all currently open files (including 
memory and terminology databases) and allows for easy toggling 
between the files.

On the lower portion you can see from left to right:

five little shortcut buttons—AAs, ASr, APr, ASd, ACh—which you can 
click to activate and deactivate AutoAssemble, AutoSearch, 
AutoPropagate, AutoSend, and AutoCheck.

If you prefer to change this expression, you can easily modify it 
manually.

If you are viewing the whole project instead of a single file (see 
"Selecting the Complete Project" on page 43), you can also see the file 
name you are currently working on to the very left of the lower status 
bar.
Déjà Vu X Standard 35



The Déjà Vu X Standard Interface
an OVR (overwrite) field that can be activated and deactivated by 
pressing the Insert key on your keyboard.

information about the position in the project and in the current row. 
The numbers in the screenshot above have the following significance:

there are 26 characters in the source sentence (26),

the cursor is at position 6 of 9 in the target (6/9), and

the current record position is 9 of 518 (9/518) in the currently 
selected file.

to the right of the position information, the Current user will be 
displayed. The displayed user name will be the user name that is 
selected in the security settings (see "Security Features in Déjà Vu X 
Standard—The Details" on page 211) or—if the security settings are 
not enabled—the default Windows logon name will be displayed.

the user under Last modified by is the user who has previously 
worked on this particular sentence (if applicable).

the date and time setting to the very right of the status bar refers to 
the date and time this particular sentence had been worked on before 
(if applicable).

Rearranging the Windows

Déjà Vu X Standard’s integrated development environment (IDE) has two 
types of windows, tool windows and document windows. 

Some of this information can be especially helpful when translating files 
in which the target text is not supposed to be longer than the source.

Every entry into the databases will also be associated with the current 
user name. 
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The tool windows—which include the File Navigator, the AutoSearch 
window(s), the Properties window, or any of the toolbars—are freely 
dockable. This means that you can place them anywhere outside the 
main window on your desktop and use the standard docking features (see 
"Docking the Tool Windows" on page 37).

The document windows have to stay within the main window. They can 
be minimized within the main window and are subject to the commands 
in the Window menu (see "Window Menu" on page 483).

This allows you to arrange the windows so they fit your particular work 
environment.

Docking the Tool Windows

Dockable windows are windows that align themselves with the edge of 
another interface element, usually a window or a pane.

With this feature you can even work on more than one monitor.
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To dock a tool window

1 Click the window title bar and keep the mouse button pressed.

2 Drag the selected window to another location in the main window.

3 If you drag the window close to another interface element within the 
main window, the dockable window automatically aligns itself with 
the edge of the closest interface element.

To arrange tool windows within the main window

1 If you choose to have your tool windows within your main window, 
you can stack them above each other.

2 You can bring underlying windows to the front by clicking the  
button on the title bar.

–Or–

You can close individual windows by clicking the  button on the title 
bar.

If you want to move a window within the main window without using the 
docking feature, press the Ctrl key while you drag the window.
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Managing Option Catalogs

In a number of dialogs within Déjà Vu X Standard, long lists of options go 
beyond the dimensions of the dialog windows. 
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You can scroll through these lists with the help of the scrollbar or the 
wheel mouse, or you can minimize the option headings by double-clicking 
on them.

 

Setting the Font

The default font setting that Déjà Vu X Standard comes with is Tahoma 
10. You can change both font and size information.
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To change the font setting

1 Click the Display tab to display the corresponding page.

2 Click the Language drop-down arrow and select a language.

3 Click the Window Type drop-down arrow and select a window type.

4 Click Change.

This option allows you to define different fonts or font sizes to the main 
project, translation memory, or terminology database view (the primary 
windows) and the AutoSearch, lookup, or scan windows (the secondary 
windows).
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The Font dialog appears.

5 Select the font, style, and size you want Déjà Vu X Standard to use 
when displaying text in this language.

You should be able to see the new font in the Sample area of the 
Font dialog.

6 Click OK to accept the font settings.
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Moving Around

There are several ways to move around within Déjà Vu X Standard.

Selecting Individual Translation Files

You can select any of the imported files or the lexicon by double-clicking 
on the file name in the File Navigator or the Project Explorer. The file 
will be opened in the main area of the Déjà Vu X Standard interface.

Selecting the Complete Project

One of the great strengths of Déjà Vu X Standard is batch processing. 
While it allows you to work in individual files, it also allows you to view 
the complete project and work in it as if it were one file. We call this the 
All Files view. 

To view all files, double-click the name of the project in the File 
Navigator pane.

As soon as you switch to the All Files view, the name of the file you are 
currently working on appears in the status bar.
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Selecting Open Translation Files, Projects, and Databases

You can select already-opened files by clicking on the link in the upper 
portion of the status bar.

Jumping to a Specific Record in the Project

You can enter the record number or the first few letters of the first word 
of the record you want to jump to in the Text/Record Locator. For more 
information, see "The Text/Record Locator" on page 26.

Switching Lines within a Translation File or Project

As you translate, there are a number of keystrokes that you may want to 
use to go from one sentence to the next:

Ctrl+DownArrow to go to the next sentence.

Alt+DownArrow to go to the next untranslated sentence.

Ctrl+UpArrow to go to the previous sentence.

Alt+UpArrow to go to the previous untranslated sentence.

Alt+RightArrow to go to the next sentence. The row status will not be 
changed and none of the automated features will be enabled.

Alt+LeftArrow to go to the previous sentence. The row status will not 
be changed and none of the automated features will be enabled.

If you want to move to different sections of your current file, you can do 
that with the help of keystrokes by switching into the selection mode (see 
"Edit and Selection Modes" on page 24).

If you select Tools>Options>Lock vertical scrolling in project 
view, your row selection will always be in the same relative position in 
the project table, i.e., if you have selected a row in the middle of the 
project table, moving to the next row will shift the table instead of your 

position in the table.
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To jump to different sections of the open file in the selection 
mode

The following keystrokes are available:

Ctrl+PgUp to go to the beginning of the file

Ctrl+PgDown to go to the end of the file.

Selecting Rows

Selecting Rows in the Selection Mode

You can select a row in a Déjà Vu X Standard project file by switching into 
the selection mode. You can find more information about this under "To 
switch into the selection mode" on page 24. 

The scrollbar also offers a convenient way to quickly change position 
within your current file or project either in selection or edit mode. 
Clicking on the up and down arrows on the top and bottom of the scroll 
bar will scroll one sentence up or down in your project, or you can drag 

the selection button in the scroll bar to anywhere in your project. Windows 2000 
and XP users can also right-click the scrollbar and select one of the following 
options:

If you use a mouse with a wheel, you can also use the wheel to scroll up and 
down your project file.
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If you press the control key, you can select several rows at a time, and 
pressing Ctrl+Shift allows you to select a range of rows.

Other row selection keyboard shortcuts in combination with a mouse 
selection include:

Shift+Home (or Shift+Ctrl+Home) to select all the rows from the 
current selection up to the beginning of the current file (or project in 
the All Files view)

Shift+End (or Shift+Ctrl+End) to select all the rows from the current 
selection down to the end of the current file (or project in the All Files 
view)

Shift+PgUp (or Shift+Ctrl+PgUp) to select all the rows from the 
current selection up to the top of the current screen

Shift+PgDown (or Shift+Ctrl+PgDown) to select all the rows from the 
current selection down to the bottom of the current screen
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Selecting Rows by Status

As described under "The Rows Selector" on page 28, Déjà Vu X Standard 
allows you to select any number of rows according to their status.

Selecting Rows by Filtering

You can display only those rows that contain a certain word or phrase, 
either in source or in target. This will allow you to concentrate on a subset 
of your project if, for example, you are having a problem with that 
particular word or phrase.

To filter the project on a word or phrase

1 Select the desired text in the source and/or target cell.

2 Right-click the selection and select Filter on Selection.

3 Only rows that contain that particular word or phrase will be 
displayed.

To clear the filter

Right-click the source box or the target box and click Unfilter (or again 
on Filter on Selection). The checkmark beside the Filter on Selection 
option will disappear and all rows will be displayed again.

If you select text in the source and target, all sentence pairs that 
contain both selections will be displayed.

This feature is also extremely valuable for editing work because it allows 
the editor to quickly view the translation of a certain word or phrase in 
all occurrences within the project.
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The Project Explorer

The Project Explorer is the Windows Explorer-like interface within Déjà 
Vu X Standard that allows you to manage your files within a project. You 
can use the Project Explorer to import and export files into a project 
and to delete files out of a project.

To access the Project Explorer

1 Select Project Explorer from the View menu.

-Or-

Click the  button on the toolbar.

-Or-

Right-click the project icon in the File Navigator window and select 
Project Explorer.

-Or-

Select File>Import>Project Explorer or File>Export>Files (via 
Project Explorer).

It is important to learn the difference between the File Navigator and 
the Project Explorer. While the File Navigator allows you to navigate 
within your existing project, the Project Explorer allows you to explore 
the folder structure of your local and network drives to build your 

project. 
48 Déjà Vu X Standard



The Déjà Vu X Standard Interface
2 The Project Explorer view appears.

To import files with the Project Explorer

1 In the upper left-hand pane, select the directory where you have 
saved the file that you want to have translated.
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2 Click the file and drag it over to the lower right-hand pane.

3 Select the file name and set the format-specific properties in the 
Properties window to the right of the Project Explorer. For more 
information on this, see "To apply specific import options" on page 
233.

You can select several items by pressing the Ctrl key as you select them, 
or a range of items by pressing Ctrl+Shift as you select the first and the 
last item in that range.
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4 Right-click the file name and select Import.
 

5 When the import is finished, close the Project Explorer by clicking 
on the  symbol in the upper right-hand corner of the Explorer 
window. 

If you notice that the segmentation of the source files is not adequate, 
i.e., individual sentences are not being split in the desired manner, this 
can have two reasons: the original file may been formatted badly (e.g., 
soft or hard returns may have been used to force line breaks) or your 

segmentation rules may have to be adjusted. Depending on the situation, it may 
be advisable to either go to the source files and correct some of the poor 
formatting or adjust your segmentation rules (see "Sentence Delimitation" on 
page 169) and reimport the files.
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You are returned to the File Navigator, in which you can see both 
files displayed.
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To import folders with the Project Explorer

1 In the upper left-hand pane, select the directory where you have 
saved the folder that contains all the translatable files.

2 Click the file and drag it over to the lower right-hand pane.

3 The Add Folder dialog is displayed.

4 Check the Only add files with the following extensions check 
box if you would like to exclude certain file types from translation.

You do not have to worry about files that are not translatable within 
Déjà Vu X Standard, such as graphics files. These files will automatically 
be excluded. 
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If you check the check box, you can enter any file name and/or 
extension to which you would like to limit your import. You will have 
to use a semicolon if you use several file names/extensions and it is 
possible to use wildcards. As an example,

*.ht*;c*.txt

would include all files with an extension starting with .ht (such as 
.htm or .html) and all .txt files with a file name starting with c 
(such as correction.txt or cd.txt).

Check the Include subfolders check box if you would like to include 
all subfolders in the exact same structure as the original.

5 Select OK. 
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6 You are returned to the Project Explorer.

7 You can now see that the folder (dejavu) and a subfolder (toolbox) 
were brought over into the lower part of the Project Explorer, as 
well as only files adhering to the extension definition.

8 Select the folder and set the available properties in the Properties 
window (Prevent Segmentation) to the right of the Project 
Explorer.

It is possible to change the default import properties for each 
extension/specific file format. For more information on this, see "To 
apply specific import options" on page 233 and "To apply project-wide 
import options for each file extension" on page 234.
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9 Right-click the folder name and select Import.

10 The import progress is displayed in the Import Progress dialog.

11  When the import is finished, close the Project Explorer by clicking 
on the  symbol in the upper right-hand corner of the Explorer 
window. 
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You are returned to the File Navigator, in which you can see all the 
files displayed.

To export files with the Project Explorer

1 In the lower right-hand pane, select the file(s) or the folder(s) that 
you want to export.

You can select several items by pressing the Ctrl key as you select them, 
or a range of items by pressing Ctrl+Shift as you select the first and the 
last item in that range.

You can also select an entire folder for export. If you do that, Déjà Vu X Standard 
will export all translated files within that folder and all of its subfolders with the 
default export options.
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2 Right-click the file or folder name(s) and select Export.
 

3 The Export Options dialog appears.
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4 Under Destination, select the folder to which you want your files to 
be exported.

5 Under Languages, select the languages you want to export.

6 If applicable, you can define filter-specific options for the files within 
your project. For information about these options, see the 
corresponding sections in "Working with Different File Formats" on 
page 227.

If you have selected more than one file type with filter-specific export 
options, both sets of options will be listed and you will have to make 
sure that you set all available options.

7 Select OK.

8 Déjà Vu X Standard will verify if there are any discrepancies 

in embedded codes (see page 158) and/or 

spaces at the end of sentences.

9 For each language you are exporting, Déjà Vu X Standard will create 
a subfolder inside the export folder, named after the code for the 
specific locale of that target language. For example, if you were 
translating the file into German (Germany), the new folder would be 
called C:\My Projects\DE_DE.

If you have exported a complete folder, Déjà Vu X Standard will 
recreate the structure of that folder with all of its subfolders, 
containing all the files you have translated. 

10 Once the export is finished, close the Project Explorer by clicking on 
the  symbol in the upper right-hand corner of the Explorer window. 

If Déjà Vu X Standard finds a discrepancy in spaces following periods, 
question marks, or exclamation marks, it will offer to automatically fix 
that discrepancy.
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11 You are returned to the File Navigator.

To delete files with the Project Explorer

1 Select any file(s) or folder(s) listed in the Project Explorer and 
press the delete key.

–Or–

Right-click on any file(s) or folder(s) listed in the Project Explorer 
and select Delete.

2 A confirmation dialog appears.

3 Select Yes.

4 Once the deletion is completed, close the Project Explorer by 
clicking on the  symbol in the upper right-hand corner of the 
Explorer window. 

You are returned to the File Navigator, in which you can see that the 
files are deleted from the project.

How to view file details in the Project Explorer

You can view details for each file in your project in the Details fields in 
the Project Explorer.

You may have to scroll to the right to see some of the otherwise hidden 
fields.
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 The available fields are:

Name

Size

Type

Date Modified

Source Path

Date Last Imported

Export Path

Date Last Exported
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Chapter 4
Workflow

The following is a simplified suggested workflow model for translation. 
The lightly shaded parts are optional and/or will be not used for every 
project you work on.
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You will notice that the workflow chart is segmented in several phases. In 
the following sections you can find detailed information about each of the 
activities in the different phases.

Phase I: Preparation

The preparation phase consists of preparing the memory and terminology 
databases by optionally importing existing material into them (see 
"Import of Existing Third-Party Databases into the Translation Memory" 
on page 64, "Import of Existing Translations into the Translation Memory" 
on page 65, and "Import of Existing Third-Party Glossaries into the 
Terminology Database" on page 65), as well as selecting the source files 
for import (see "Source Files" on page 66). 

Import of Existing Third-Party Databases into the Transla-
tion Memory

This component is optional and will not have to be performed every time 
you work on a translation project. Situations where you may want to 
import existing databases could include the following:

you have received external databases from your client

you own existing databases in other formats

you are sharing databases with fellow translators

The formats of these databases can vary widely, including:

Déjà Vu X Translation Memory—for merging other Déjà Vu X 
translation memories into the existing one.

Déjà Vu 2.x/3.x Memory Database—for importing memory 
databases of earlier versions of Déjà Vu.

Text—for importing delimited text files (tab, comma, etc.).

Access 9x/2000/XP—for importing databases from various 
versions of Microsoft Access.

Excel 9x/2000/XP—for importing databases from various versions 
of Microsoft Excel.
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Trados Workbench Databases—for importing databases from 
translation memories from the Trados Workbench .txt format.

TMX—for importing databases from the Translation Memory 
EXchange format, an XML-based exchange format between 
different CAT tools.

For more information on importing external databases, see "Importing 
External Data" on page 356.

Import of Existing Translations into the Translation Memory

The alignment module in Déjà Vu X Standard allows you to take the 
source and the target texts of an existing translation and create a 
translation memory from them.

Import of Existing Third-Party Glossaries into the Terminol-
ogy Database

As with the option of importing external databases into the translation 
memories, this component is optional and will not have to be performed 
every time you work on a translation project. Situations where you may 
want to import existing glossaries would include the following:

you have received external glossaries from your client

you own existing glossaries in other formats

you are sharing glossaries with fellow translators

The formats of these glossaries can vary widely, including:

Plain text (delimited by any ASCII character)

Excel

Access

As a rule of thumb, it’s a good idea to primarily rely on building 
databases by actually doing translation within the Déjà Vu X Standard 
translation environment. But the alignment feature can be a very 
powerful tool when translating documents for which you have very 

similar file pairs. For more information about the alignment module see "Aligning 
Existing Files with the Basic Aligner" on page 366.
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Déjà Vu X Standard terminology databases

Déjà Vu 2 or 3 terminology databases;

For more information on importing external glossaries, see "Importing 
External Data" on page 427.

Source Files

Déjà Vu can import a great variety of source files, including:

tagged formats (SGML/XML, HTML, ASP)

word processing, presentation, and spreadsheet formats (Microsoft 
Word, Microsoft PowerPoint, Microsoft Excel, and the corresponding 
formats from the OpenOffice.org suite)

exchange formats (RTF, TMX)

desktop publishing formats (Adobe FrameMaker, Adobe PageMaker, 
Interleaf/Quicksilver, QuarkXPress)

database formats (Microsoft Access)

Help formats (WinHelp RTF, Help content files)

software development formats (Resource files, C/C++/Java source 
files, Java Properties, VBScript, JavaScript, GNU gettext)

preprocessed files from other TM tools (Trados Workbench RTF, IBM 
TranslationManager)

When importing external glossaries, make sure that these glossaries are 
useful in Déjà Vu’s workflow. Glossaries of most other tools are mere 
dictionaries, but in Déjà Vu X Standard’s case they are active entities 
that automatically insert text into segments. That means that if you 

have two different translations in one target field, Déjà Vu X Standard would 
insert both of them.

For more information on each of these file formats, see "Working with 
Different File Formats" on page 227.
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The unique power of Déjà Vu X Standard is that you can take any number 
of files of any variety of the above-listed formats from any location of 
your computer or network and import them into one project!

Phase II: Project Building

The project building phase consists of selecting an existing project file 
(see "Selecting an Existing Project File" on page 67) or creating a new 
project file ("Creating a New Project File" on page 69)—which includes 
importing the source files and associating the file with translation 
memories and terminology databases—as well as building the lexicon 
(see "Generating the Lexicon" on page 76).

Selecting an Existing Project File

The source files for a large translation project are rarely delivered in one 
batch. Typically they come in one large batch and several later ones. To 
accommodate this, Déjà Vu X Standard allows you to import files into 
already-existing projects with the help of the Project Explorer. 

To import files into existing projects

1 Open the project file.

2 Select View>Project Explorer.

-Or-

Click the  button on the toolbar.

-Or-

Right-click the project icon in the File Navigator window and select 
Project Explorer.

From a file management perspective, it may still make sense to have 
the files located in one folder or group of subfolders.

In most cases you do not need the originating applications installed on 
your machine. That means you can process QuarkXPress, PageMaker, or 
FrameMaker files without actually having to have the actual (and very expensive!) 
applications. However, there are exceptions that include Word, Excel, and 
Powerpoint. If you are planning to process any files that originate from these 
applications, you will have to have them installed.
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3 Select the file that you would like to import in the upper half of the 
window (Explorer) and drag it into the lower half (Project).

4 Select the file name and set the format-specific properties in the 
Properties window to the right of the Project Explorer. For more 
information on this, see "To apply specific import options" on page 
233.

5 Right-click the file or folder name, and select Import.

You can also select an entire folder for import. For more information on 
this, see "To import folders with the Project Explorer" on page 53.
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6 The file or folder is imported into the project.

Creating a New Project File

To create a new project file, Déjà Vu X Standard assists you with a 
powerful wizard that allows you to create a project file and associate it 
with existing databases and/or new databases.

To create a new project file

1 Open Déjà Vu X Standard.

2 Select File>New.

-Or-

Click the  button on the toolbar.

3 The New File dialog appears.

4 Double-click Project or select Project and click OK.
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5 The New Project Wizard appears.

6 In the steps that follow, the wizard will guide you through the process 
of creating a project file by

specifying a project name and file,
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selecting the languages,

You will notice that there are a great number of languages and sub-
languages. Déjà Vu X Standard ranks the sub-languages hierarchically. 
If the program finds a perfect or an equally fuzzy match with the same 
subject and client properties and the same source sub-language 

(English (United States), for instance) in the translation memory, it will choose it 
over another with a different source sub-language (English (United States) vs. 
English (United Kingdom), for instance). Further, it will prefer that constellation 
(different source sub-languages, equal target sub-languages) to a constellation 
where the source sub-languages are equal but the target sub-languages are 
different (French (Standard) vs. French (Belgian)). For more information on the 
matching hierarchy, see "Clients and Subjects" on page 128.

The list of displayed languages changes dynamically to display the last chosen 
languages at the top of the list.
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selecting or creating the associated main translation memory,

selecting or creating the associated main terminology database,
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selecting the source files,
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and selecting a subject and a client.

The specific import properties (see p. 233) are not available with the 
New Project Wizard. The default settings in the wizard are activated 
segmentation (i.e., all current segmentation rules are turned on) and all 
other format-specific options are turned off. For information on format-

specific import options, see "Working with Different File Formats" on page 227.

If you prefer to import all of your files with format-specific options, you can 
choose to create a project without importing any source files. In that case the 
Project Explorer is automatically opened so that you can customize the import 
process.
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7 When you have made your settings, click Finish, and your project is 
created.
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Generating the Lexicon

The project’s lexicon is a list of all the source language words or phrases 
present in the project—in other words, an index of all terms and phrases. 
Once you have created this index, you can translate the terms that seem 
relevant to you, batch delete all other terms (for instance, terms like 
"the" or "to" in the image below), and Déjà Vu X Standard will use what 
remains as the primary glossary for your project.

The lexicon is a very useful tool, but as indicated in the light shading in 
the workflow chart, it is an optional component.

To create the lexicon

1 Select Lexicon>Build Lexicon.

Clients will often ask you to provide them with a glossary for a project 
you’ve translated for them; this will help them keep a record of the 
terminology used, ensuring that the same terminology is used in future 
projects. With Déjà Vu X Standard, creating a glossary for your client is 

as simple as exporting the lexicon to a text file.
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2 The Build Lexicon dialog appears.

3 You are offered the following options:

Specify the maximum number of words for a lexicon entry.

Specify whether Déjà Vu X Standard should try to translate the 
lexicon entries as it creates them, using the terminology 
databases and translation memories for the project.

Specify whether you want a lexicon for the current or all files.

4 Select the options you want, and click OK.

Generally you will want to select 2 or 3 for this option. Higher numbers 
tend to result in a great deal of useless entries. Déjà Vu X Standard 
does not linguistically evaluate the words; it simply lists all occurrences 
in all combinations. For example, "The cat is black" with a maximum 

number of 4 would be listed as "The," "cat," "is," "black," "The cat," "cat is," "is 
black," "The cat is," "cat is black," and "The cat is black." Of those entries, only 
"cat," "black," and arguably "cat is black" would be useful entries in the lexicon.
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Depending on the size of the project, building the lexicon may take some 
time because Déjà Vu X Standard has to process each sentence in the 
project a number of times. While Déjà Vu X Standard is working on 
creating the lexicon, you will see a progress indicator in the Build 
Lexicon dialog.

Once Déjà Vu X Standard has finished building the lexicon, you can view 
it by double-clicking on Lexicon from the File Navigator.

The first column on the table, with the heading Words Freq, shows the 
number of words in the lexicon entry, and the frequency, i.e., the number 
of times it appears in the project.

To translate the lexicon

There are several ways to translate a lexicon:

As you generate the lexicon, you can choose to Automatically 
resolve lexicon with databases (see p. 77).
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Once the lexicon is generated, you can select Project>Resolve with 
Translation Memory/Terminology Database to leverage the 
content of your databases against the lexicon. For more information 
on this, see "Resolving the Lexicon with the Databases" on page 324.

You can manually translate it by entering the translation into the 
target column.

Either way, you will want to translate only those terms that are helpful for 
you to have in the lexicon and delete the remaining lexicon entries.

To remove rows from the lexicon

To avoid a large number of useless entries in the lexicon, you will 
probably want to delete the lexicon entries that only appear rarely in the 
project, or those that contain a very large number of words.

1 Select Lexicon>Remove Entries.

2 The Remove lexicon rows dialog appears.

3 You are offered the following options:

Remove the entire lexicon.

Déjà Vu X Standard will only use translated rows in its translation 
processes, so it is possible to skip this step.
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Remove those lexicon entries for which you have not entered a 
translation.

Remove lexicon entries based on the number of words they 
contain and/or their frequency. You can also specify whether to 
remove those entries that satisfy these conditions and have not 
been translated, thereby preserving any special entries you 
decided to keep. The selection in the image above instructs Déjà 
Vu X Standard to delete all rows with three or more words in the 
source field and ten or fewer occurrences.

4 Select the options you want and click OK.

When you are done building your lexicon, you have completed the project 
building phase.

For more information about the lexicon, see "The Lexicon" on page 321.

Phase III: Pretranslation

The third phase of a translation project in Déjà Vu X Standard is 
pretranslation. Pretranslation allows you to batch leverage the content of 
your databases—translation memory(s), terminology database(s), and 
(optionally) the lexicon—against your source files. 

To pretranslate a project

1 On the Translation menu, click Pretranslate.

This is useful when you have finished translating the useful entries in 
the lexicon and want to remove the rest, or when you want to export the 
relevant entries in the lexicon to send to your client as a glossary.

This kind of setting may make sense for a very large project where you 
have some occurrences of several hundred.

While you could leverage on a sentence-by-sentence level as you 
translate (see "Phase IV: Translation" on page 83), pretranslation has 
the advantage of giving you a better idea of what to expect, i.e., how 
much actually needs to be translated.
80 Déjà Vu X Standard



Workflow
–Or–

Press Ctrl+P.

–Or–

Click the  button on the toolbar.

2 The Pretranslate dialog appears.

3 Set the different options as shown above and click OK.

By unchecking Accept only exact matches, you instruct Déjà 
Vu X Standard to scan the translation memory for perfect 
matches; if it cannot find perfect matches, it will look for fuzzy 
matches.

By checking Assemble from portions, you instruct Déjà Vu X 
Standard to fill in portions (i.e., single words or short phrases) 
from the translation memory(s), the terminology database(s), 

You can set the degree of fuzziness under Tools>Options>General.
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and (if available) the lexicon. Déjà Vu X Standard will also try to 
turn fuzzy matches into perfect ones by supplying missing terms 
in whole segments from the translation memory with segments 
from the terminology database(s) and the lexicon. To learn more 
about this feature, see "Assemble and Example-Based Machine 
Translation" on page 120.

By unchecking Insert source text for failed portions, you 
instruct Déjà Vu X Standard to not copy over portions that it does 
not find in any of the databases from the source to the target.

The options under Overwriting allow you to pretranslate 
segments that have already been processed and have either an 
exact, fuzzy, or assembled status. Though these options are not 
relevant for our particular aim that we hope to achieve with 
pretranslating, they may be helpful when you receive a Déjà Vu X 
Standard project file that has already been translated, but you 
feel that your own database(s) has a greater amount of and more 
accurate project-specific terminology.

Limit to current record selection may be helpful if you only 
wish to pretranslate a section of a file that you are displaying 
through filtering or the row selector (see "Selecting Rows by 
Filtering" on page 47 and "Selecting Rows by Status" on page 
47).

4 Once the pretranslation is finished, a status report will be displayed at 
the bottom of the Pretranslate dialog, informing you of how many 
segments have been processed at what status.

Some texts are more likely to benefit from this option than others. If 
you are translating a text with a great amount of non-translatable code 
or proper names, it may make your translation task a lot easier if you 
activate this option.

At this point you can also generate a more detailed report on the word 
count by selecting Tools>Word Count.
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You will notice a colored status indicator to the left of the translations. By 
default, every guaranteed match has an orange indicator, every perfect 
match has a dark green indicator, every fuzzy match has a light green 
indicator, and so forth. All of these display options are configurable under 
Tools>Options>Display.

Phase IV: Translation

Although Déjà Vu X Standard may have done a great deal of your 
translation work for you, there will usually still be translation work left for 
you to do.

Translation—much like pretranslation—is a process where the translation 
work in the project file is greatly enhanced by the associated databases 
and the lexicon. You can manually access information in all these files and 
use it as a reference, but you can also let Déjà Vu X Standard do the work 
for you.

Essentially, there are two processes during the translation phase: 
leveraging from the databases, a process that can be largely automated 
in Déjà Vu (see "Feeding the Databases" on page 83); and feeding to the 
databases (see "Feeding the Databases" on page 83).

Feeding the Databases

As you can see, the databases allow you to greatly enhance your 
translation process; however, they can only do that because you feed 
them the information that they use to help you in the translation.

Even if the pretranslation inserts an exact match, it is a good practice to 
check the translation for any mistakes (you might have translated it 
wrong in the past or translated it in an entirely different context).

If the actual match is blue and has an underline, it is an exact match for which 
several perfect matches have been found in the database. Right-clicking on each 
of these records opens a context menu in which the other translation options are 
displayed. If you choose one of those over the existing one, you can select it by 
clicking on it. To jump to the next multiple exact match line, you can press 
Ctrl+F3. You are strongly encouraged to check each of these matches.

Guaranteed matches, however, are matches for which Déjà Vu X Standard has 
automatically checked the context for you.
Déjà Vu X Standard 83



Workflow
There are several ways to feed the databases. One is to create and 
translate a lexicon (see "Generating the Lexicon" on page 76), another is 
the manual feeding of the terminology database (see "Adding Terms to 
the Terminology Database" on page 84).

Adding Terms to the Terminology Database

While it makes sense to automate the process of sending data to the 
translation memory, the terminology database cannot be built 
automatically: you will have to teach the terminology database which 
word or phrase in your translation corresponds to which term or phrase in 
the source. While entering terms into the terminology database is 
probably the most manual process in Déjà Vu X Standard, it is still very 
easy and we encourage you to use it as much as possible.

To add terms to the terminology database

1 Highlight a term or phrase in the source segment and the 
corresponding term or phrase in the target segment with your 
mouse.

 

2 Send the highlighted terms to the terminology database.

3 On the Translation menu, click Add Pair to Terminology 
Database.

–Or–

Press F11.
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–Or–

Click the  button on the toolbar.

4 Add any specifications, including grammatical information (part of 
speech, gender, or number) and semantical definition (such as 
context information, subject, or client).

Minimize your entry time by entering only the information that will be 
relevant for you or your co-workers later on. For instance, it obviously 
would not make sense to enter gender information if your language does 
not have a grammatical gender, or if any skilled translator or editor 

would be familiar with this kind of information anyway.

If you are certain that you do not need to enter any additional information (aside 
from the standard user and date/time information), you can also send the 
highlighted terms or phrases to the terminology database by pressing Shift+F11 
or by right-clicking and selecting Add Pair to Terminology Database (No 
Prompt). This method will not prompt you to enter any additional information.

This way of entering term pairs into your terminology database is especially 
beneficial for terms that are completely unspecific to project, subject, or client, 
such as "and" or "or."
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5 Click Add.

Phase V: Editing and Quality Assurance

The editing and quality assurance phase consists of employing Déjà Vu X 
Standard’s advanced integrated quality assurance features ("Déjà Vu X 
Standard’s Integrated Quality Assurance Features" on page 86) and 
editing the project by reading it through

on a hard copy ("Exporting into the Original Format for Proofing" on 
page 97), and/or

within Déjà Vu X Standard’s own environment ("Proofing within Déjà 
Vu X Standard" on page 97).

Déjà Vu X Standard’s Integrated Quality Assurance Fea-
tures

Déjà Vu X Standard uses several methods to assure the quality of the 
translation project. These include:

consistency checks between source and target and different targets

spell check 

Terminology Consistency Checks

Déjà Vu X Standard provides for a terminology check that selects the 
next available discrepancy.

On the General tab in the Options dialog, you can define what 
databases will be considered during the terminology consistency check.

For other ways to send information to the databases, see "Sending Text 
to the Databases" on page 123.
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1 Select Tools>Options>General.

2 Under Terminology Checks you can specify whether numbers 
should be included in the checks and whether the checks should be 
performed against data in the

lexicon,

terminology databases, and/or

translation memories.

To check the current row for a terminology mismatch

1 Press Ctrl+Shift+T.

It is important to realize that any of the terminology consistency checks 
will also point out words or phrases that are identical with existing terms 
in any of the databases but are now part of compound words in the 
target. The best way to avoid this is to enter as many compound works 

in any of the databases as you can.
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2 Déjà Vu X Standard will check whether there is a terminology 
discrepancy and will display a red exclamation mark in that row (or a 
light violet exclamation mark if there is already a target comment on 
that row). 

3 The source terms for which inconsistencies were found are painted 
red. If you hold your mouse cursor over the exclamation mark, you 
can see what kind of inconsistencies were found and in what kind of 
database they were found.

4 After you review the information and decide to make changes or 
leave the translation as originally intended, the exclamation mark will 
disappear (or become light blue if there is a comment in that row) 
when you hit Ctrl+DownArrow. 

5 To jump to the next row and mark the row as Finished, hit 
Ctrl+DownArrow again.

To find the next terminology mismatch

1 Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the 
beginning of your open file or project (see "Selecting Rows in the 
Selection Mode" on page 45).

2 On the Translation menu, click Find Next Terminology 
Mismatch.

–Or–

Press Ctrl+F7.
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3 Déjà Vu X Standard will find the next terminology discrepancy and 
will display a red exclamation mark in that row (or a light violet 
exclamation mark if there is already a target comment on that row). 

4 The source terms for which inconsistencies were found are painted 
red. If you hold your mouse cursor over the exclamation mark, you 
can see what kind of inconsistencies were found and in what kind of 
database they were found.

5 After you review the information and decide to make changes or 
leave the translation as originally intended, the exclamation mark will 
disappear (or become light blue if there is a comment in that row) 
when you hit Ctrl+DownArrow. 

6 To jump to the next row and mark the row as Finished, hit 
Ctrl+DownArrow again.

Code Consistency Checks

To check whether there are any discrepancies between embedded 
codes in source and target

1 Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the 
beginning of your open file or project (see "Selecting Rows in the 
Selection Mode" on page 45).

2 On the Translation menu, click Check Embedded Codes.

–Or–

Press Ctrl+Shift+F8.

3 Déjà Vu X Standard will jump to the next occurrence of a discrepancy 
between embedded codes in source and target.

Discrepancies include:
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missing or additional codes,

codes that are in a different order than in the source sentence, 
and

codes at the very beginning or the very end of the source 
sentence that have something before or after them in the target 
sentence.

4 You can quickly fix the codes by pressing Ctrl+F8. This will copy all 
missing codes to the end of the current target segment.

5 Make sure that the codes are now located in the correct position.

6 Continue to check for code errors and fix them until you reach the 
end of the open file or project.

Translation Consistency Checks

To check whether there are any discrepancies in the translations 
of the same source

1 Select Project>Find Duplicate Sentence.

2 The Find Duplicate Sentences dialog appears.

3 Select whether you want to Find (all) sets of duplicate source 
sentences.

For more information about embedded codes, see "Embedded Codes" on 
page 154.
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–Or–

Find sets of duplicate source sentences with different 
translations.

4 If you select the second option, you will also have to select the target 
language.

5 Make the appropriate selections under Miscellaneous:

Ignore case—With this option, THIS SENTENCE would be 
considered a duplicate of this sentence.

Ignore numerals—With this option, A 100 m dash would be a 
duplicate of A 50 m dash.

Ignore embedded codes—With this option, This 
{101}sentence{102} would be a duplicate of This sentence.

6 Click OK.

7 All duplicates are indicated with a grey indicator to the left of the 
source sentence.

8 To view duplicates and their differing translations (provided that you 
have selected that option) side by side, you can select Duplicate 
Rows in the Rows Selector.

The colors of the duplication indicator can be changed to any color you 
prefer. For more information on changing colors, see "To change the 
colors of the indicator bars" on page 29.
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–And/Or–

Highlight the source in question, right-click, and select Filter on 
Selection.

9 The duplicated rows with different translations are now displayed on 
top of each other.

10 You can now enter your correction if necessary.

11 Display all rows by selecting All Rows from the Rows Selector.

–And/Or–

Right-click in the source column and select Unfilter.

To unmark duplicate sentences

To remove the indicator in duplicate sentences, select 
Project>Unmark Duplicate Sentence.

Spell checking

Integrated spell checking by Déjà Vu X Standard is available for the 
following languages: 

Danish

Dutch

English (U.S.)

English (U.K.) 

English (Canada)

Finnish
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French

German

Italian

Norwegian (Bokmål)

Spanish

Swedish

Portuguese (Brazil)

Portuguese (Portugal)

To spell check an open file or project with Déjà Vu X Standard’s 
integrated spell checker

1 Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the 
beginning of your open file or project (see "Selecting Rows in the 
Selection Mode" on page 45).

2 On the Tools menu, click Spelling.

–Or–

Press F7.

Other languages can be spell checked through the Microsoft Word spell 
checker if your version of Word provides the appropriate dictionary. For 
more information on this, see "To spell check an open file or project with 
Microsoft Office’s spell checker" on page 95.
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3 At the next occurrence of a misspelled or unrecognized word, the 
Check Spelling dialog opens.

4 The misspelled or unrecognized word is displayed in the Not in 
Dictionary box. The word is considered misspelled because it could 
not be located in any of the open dictionaries. 

5 You have the following options:

Change the word by selecting the correct word under Suggestions 
or entering the correct spelling in Change To box and clicking the 
Change button (Change All changes all occurrences of this word in 
the current file or project).

–Or–

Enter a correction into the Not in Dictionary box and click the 
Suggest button to see whether the spell checker recognizes this 
alternative. If it does, click Change (or Change All) to change the 
word in the current file or project.

–Or–

Skip it by clicking the Ignore button (Ignore All skips all of the 
occurrences of this word during this session of the spell checker).

–Or–
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Add it to the dictionary that is selected under Add words to by 
clicking the Add button (for more information on dictionaries, see 
"Dictionaries" on page 187).

6 According to the selection you made, the word is changed or remains 
unaltered and at the occurrence of the next misspelled or 
unrecognized word the Check Spelling dialog opens again.

For an in-depth discussion on spell checking options, see "Spelling 
Options" on page 183.

For languages that do not have a spell checking option in Déjà Vu X , you 
also have the option to use Microsoft Word’s spell checking option.

To spell check an open file or project with Microsoft Office’s spell 
checker

1 Select Tools>Options>Spelling.

–Or–

To use this option, you will have to have Word 2000 or higher as well as 
the appropriate Word spell checker installed on your computer.
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Click on Options in the Check Spelling dialog.

2 Select Use the Microsoft Office Spell Checker.

3 When you continue with spell checking, Déjà Vu X  will automatically 
use the dictionaries of the Microsoft Office spell checker for that 
particular language.

Loading the Microsoft Office spell checker

The very first time you started Déjà Vu X , all the available Office spell 
checkers were loaded. To avoid the rather time-consuming process of 
having to reload them during each startup, they are stored. If you change 
your configuration of Office spell checkers (e.g., update, add, or delete 
languages), these changes will not be automatically reflected within Déjà 
Vu X  until you select the Reload Office Proofing Tools button on the 
Spelling tab.
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Editing and Proofing

While the previous section described ways to use the integrated proofing 
tools that Déjà Vu X Standard provides, translators typically want to edit 
and proof their translations manually as well. There are several ways of 
doing this.

Exporting into the Original Format for Proofing

Some translators/editors prefer to see the translated text in its original 
format for proofing purposes.

To do this, you can export an intermediary copy of your document(s) to 
use for proofing. If you choose this option, you should be aware that:

it is important to apply all changes to the Déjà Vu project file rather 
than the exported file. This is the only way to make sure that your 
modifications will be reflected in your translation memory and that 
you will be able to benefit from that later on.

there is certain text that you will not be able to see on the screen or 
in a printout copy, including index markers or text within scripts.

this process applies more to print and desktop publishing formats 
than online, database, or resource formats. 

Proofing within Déjà Vu X Standard

Many translators and editors feel that the most efficient and safe way to 
edit and proof a document is directly in the Déjà Vu environment.

Here are some of the benefits:

All translated text is visible.

All codes are protected (for more information on codes, see 
"Embedded Codes" on page 154).

To locate sentences that need to be modified, you can use the search 

function (select Edit>Find, press Ctrl+F or click ).
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All text is organized in the tabular database view of Déjà Vu X 
Standard that can be viewed, sorted, and edited in all possible 
configurations:

You can choose to only display rows with a certain status (see 
"Selecting Rows by Status" on page 47).

You can choose to display all rows alphabetically (see "To switch 
between natural and alphabetic order" on page 27).

You can sort on a specific phrase or word to see the use of this 
phrase or word in the entire project (see "Selecting Rows by 
Filtering" on page 47).

Text can be marked and displayed as pending (see "Marking 
Sentences as Pending" on page 199).

You can do entire database scans for a certain word if you are not 
sure about its use (see "Searching the Databases" on page 107).

You can make sure that your changes are being implemented in all 
identical rows through the Propagate function (see "Propagate" on 
page 151).

Phase VI: Export

When you are done with translating and editing your files, you will want 
to export them into their original format. Déjà Vu X Standard offers you 
three different ways of doing that:

You can export the complete project via the menu command 
Finished Translation, 

you can export single files or folders through a right-click command 
from within the File Navigator, or

you can export single files or any subset of files from the Project 
Explorer.

For information on exporting with the Project Explorer, see "To export files 
with the Project Explorer" on page 57.

To export files with the menu command

1 Select File>Export>Project.
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2 The Export Options dialog appears.

3 Under Destination, select the folder to which you want your files to 
be exported.

4 Under Languages, select the languages you want to export.

5 If applicable, you can define filter-specific options for the files within 
your project under Filter-specific Options. For information about 
these options, see the respective sections in "Working with Different 
File Formats" on page 227.

If your project contains several file types with filter-specific export 
options, all sets of options will be listed and you will have to make 
sure that you set all available options.

6 Select OK.

7 Déjà Vu X Standard will verify if there are any discrepancies 

in embedded codes (see 158) and/or 
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spaces at the end of sentences.

8 For each language you are exporting, Déjà Vu X Standard will create 
a subfolder inside the export folder, named after the code for the 
specific locale of that target language. For example, if you were 
translating the file into German (Germany), the new folder would be 
called C:\My Projects\DE_DE.

To export files with the right-click command in the File Navigator

1 Right-click on any single file or folder in the File Navigator.

2 Select Export.

If Déjà Vu X Standard finds a discrepancy in spaces following periods, 
question marks, or exclamation marks, it will offer to automatically fix 
that discrepancy.
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3 The Export Options dialog appears.

4 Under Destination, select the folder to which you want your files to 
be exported.

5 Under Languages, select the languages you want to export.

6 If applicable, you can define filter-specific options for the files within 
your project under Filter-specific Options. For information about 
these options, see the respective sections in "Working with Different 
File Formats" on page 227.

7 Select OK.

8 Déjà Vu X Standard will verify if there are any discrepancies 

in embedded codes (see page 158) and/or 
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spaces at the end of sentences.

9 For each language you are exporting, Déjà Vu X Standard will create 
a subfolder inside the export folder, named after the code for the 
specific locale of that target language. For example, if you were 
translating the file into German (Germany), the new folder would be 
called C:\My Projects\DE_DE.

If your project contained a complete folder, Déjà Vu X Standard will 
recreate the structure of that folder with all of its subfolders, 
containing all the files you have translated.

If Déjà Vu X Standard finds a discrepancy in spaces following periods, 
question marks, or exclamation marks, it will offer to automatically fix 
that discrepancy.
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Chapter 5
Translation Features in Déjà 
Vu X Standard—The Details

While many of Déjà Vu X Standard’s features were discussed or 
mentioned in the previous two chapters ("The Déjà Vu X Standard 
Interface" on page 13 and "Workflow" on page 63), these and other 
features are presented in this resource chapter in a more in-depth 
manner:

Database Performance on page 103

Searching the Databases on page 107

Assemble on page 118

Sending Text to the Databases on page 123

Clients and Subjects on page 128

Propagate on page 151

Embedded Codes on page 154

Context View on page 163

Conversions on page 164

Copying and Populate on page 166

Sentence Delimitation on page 169

Common Windows Functions on page 174

Database Performance

It is important to understand that all the different file formats that you 
can create and work in with Déjà Vu X Standard are databases that are 
based on Microsoft’s Jet database engine version 4.0.
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This is important for several reasons:

The databases are accessible with standard SQL (Structured Query 
Language) commands. This means that the only limitation to the way 
you can modify databases is your own creativity (and SQL 
knowledge).

The data exchange between the Déjà Vu X Standard databases and 
other formats is very advanced. You can import and export into many 
of the formats supported by the Jet engine as well as a number of 
translation-specific formats (Trados Workbench, TMX).

Because each of the files, including the Déjà Vu project files, are 
databases, a great variety of sorting, filtering, and batch processing 
options are available.

Many of the standard Jet engine utilities such as Compact Database 
and Repair Database are available for each of the components, as 
well as a great number of third-party utilities.

Repairing and Compacting Files

Each of the file types that are supported by Déjà Vu X Standard (project 
and satellite files, terminology databases and translation memories, as 
well as SGML/XML filters) can be compacted, and almost all can be 
repaired.

To compact a file

Because Microsoft’s Jet engine handles data by allocating unnecessary 
disk space, any of the files in question can grow very large. To save disk 
space and increase performance, it is advisable to compact the files at 
regular intervals. The result can be very impressive as files can be shrunk 
to a third or more of their original size. It specifically makes sense to 
compact a database, after you have performed the following actions:

deleted a large number of examples from an SGML/XML file

deleted a large number of lexicon entries from a project file

deleted one or several files from a project

added a large amount of data to any file
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deleted any subset of data from a terminology database or 
translation memory

1 Select Tools>Compact>Project/Satellite/Translation Memory/
Terminology Database/Filter from anywhere within Déjà Vu X 
Standard.

2 Select the project/satellite/translation memory/terminology 
database/SGML filter file and click Open.

3 The compact process will start and Déjà Vu X Standard will notify you 
upon completion.

To repair a corrupted file

Repairing is necessary when a database file has become corrupted, 
probably because of an abnormal program ending caused by a power 
outage or by hardware problems.

1 Select Tools>Repair>Project/Satellite/Translation Memory/
Terminology Database from anywhere within Déjà Vu X Standard.

2 Select the project/satellite/translation memory/terminology database 
file and click Open.

3 The repair process will start and Déjà Vu X Standard will notify you 
upon completion.

Depending on the size of the original file, this process can take several 
minutes.

When compacting a file, data will be written to a new temporary file 
which is then copied back to the original file. This means that to successfully 
compact files, you need to have the necessary disk space for the temporary file.

This procedure involves time-consuming processes such as re-indexing 
the complete database and removing invalid entries. Depending on the 
size of the original file, this process can take a significant amount of 
time.

When repairing a file, data will be written to a new temporary file which is then 
copied back to the original file. This means that to successfully repair files, you 
need to have the necessary disk space for the temporary file.
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Fuzziness Setting

It is important for you to be able to control the level at which you want 
the databases to interact with your translation project. This level is 
generally called fuzziness, i.e., the degree of similarity of a database 
match to the original.

To set the fuzziness setting

1 Select Tools>Options>General.

Under Database Lookups, you can determine

how you want to sort your matches: 

whether older or newer database matches are preferred,

This setting only comes into effect when all other settings are of 
identical match quality, including sub-languages, client, and subject. If 
one match has the same fuzziness but a better matching sub-language, 
client, or subject, it will be preferred over the others regardless of their 

ages.
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whether the search operations for partial matches (single words 
or phrases that are displayed in the AutoSearch window or 
inserted in the Assemble features) are also be performed with a 
fuzzy index, and

what kind of Minimum Score (i.e., degree of fuzziness as a 
percentage) the matches are supposed to have to be used. 

2 Make the desired settings and click Apply and/or OK.

Searching the Databases

There are several ways to search for a sentence in your memory and 
terminology databases. Déjà Vu X Standard uses the terms scan for 
searching the translation memories and lookup for searching the 
terminology databases.

Scanning the Translation Memories

To manually scan the translation memory(s)

1 If you want to scan for a part of a sentence, select the text you want 
to search for in the source sentence. If you want to scan for the 
whole sentence, do not select any text.

2 On the Translation menu, click Scan.

–Or–

Press Ctrl+S.

–Or–

Click the  button on the toolbar.

The setting under Minimum Score will depend on your personal 
preference and the quality and extent of your databases. While the 
default setting is 75%, many users with extensive translation memories 
prefer a higher setting, while others try to benefit as much as possible 

from whatever they have in their translation memories.
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3 If Déjà Vu X Standard finds any matches in the translation memory, 
the Scan Results dialog appears.

The Scan Results dialog consists of the following elements:

Sought Source—The source language sentence (or portion) you 
were searching for. Any words that are different from the match in 
the translation memory will be marked red.

Proposed Translation—The target language sentence found in the 
translation memory with any changes that Déjà Vu X Standard has 
applied to it. This field can be edited.

Found Source—The source language sentence (or portion) that was 
found in the translation memory. Any words that are different from 
the segment you are looking for will be crossed out.

Found Target—The target language sentence found in the 
translation memory.

Matches—A list containing all the matches found by Déjà Vu X 
Standard, with their corresponding translations. The matches are 
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sorted primarily by their fuzziness percentage and secondarily by 
other criteria (subject, client, date, etc.). If you would like to review 
other matches, you can navigate through the list of matches by using 
the table’s scrollbar or the following keystrokes:

Ctrl+PageDown to go to the end of the list.

Ctrl+PageUp to go to the beginning of the list.

Ctrl+DownArrow to go to the next match.

Ctrl+UpArrow to go to the previous match.

Under the Matches list you can see information about the currently 
selected match, including Score (the percentage of fuzziness), 
Subject, Client, Database (origin of match), Date (date and time 
the record was entered into translation memory), and User (who 
entered the term into the translation memory). 

The buttons to the right have the following function:

Replace—Replaces the text in the current target cell with the 
proposed translation.

Close—Closes the dialog without any changes.

Insert <<—Inserts the proposed translation to the left of any 
existing text in the current target cell (this button is only 
displayed if there is some text in the current target cell).

Insert >>—Inserts the proposed translation to the right of any 
existing text in the current target cell (this button is only 
displayed if there is some text in the current target cell).

Copy—Copies the proposed translation to the Windows clipboard.

Power Scan—Launches the Power Scan feature that will do 
another deeper search in the translation memory. The regular 
Scan feature saves time by not displaying fuzzy matches when an 
exact match is found. Power Scan will perform a new scan, 
resulting in matches in which single words will be displayed in 
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context even if exact matches are found. The total number of 
matches that can be shown is not limited in this case.

4 Review the proposed translation, considering the information from 
the Sought Source and Found Source fields and, if applicable, 
scroll down the list of matches and select a different match.

5 Make any necessary changes in the Proposed Translation text box 
and select the appropriate insertion button.

6 The dialog closes and the match is inserted into the current target 
cell.

To scan with wildcards

To widen the scope of your searches, you can use wildcards at the end of 
text you are looking for. The wildcards you can use to build search 
patterns are:

* — zero or more characters

? — one character

# — one digit

[a-m] — one character in the specified range

[!a-m] — one character outside the specified range

The Power Scan feature is especially helpful when scanning for single 
words or short phrases.

If you have searched for a complete sentence and found a match for 
that, you will probably want to select the Replace button. If you have 
searched for only a part of the sentence, it would probably be a better 
choice to insert the match to the left or right of the current target, or 

copy it to the clipboard to paste it into the target with one of the standard paste 
features.
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Examples:

1 Select a part of the text that you would like to search for.

2 Right-click on the selection and select Scan with Wildcards.

–Or–

Press Ctrl+Shift+S.

–Or–

Select Translation>Scan with Wildcards.

3 The Enter Search Expression dialog appears, displaying the 
selected text.

Kind of Match Pattern Match No Match

Multiple characters a*a aa, aBa, aBBBa aBC

Multiple characters *ab* abc, AABB, Xab aZb, bac

Multiple characters ab* abcdefg, abc cab, aab

Special character a[*]a a*a aaa

Single character a?a aaa, a3a, aBa aBBBa

Single digit a#a a0a, a1a, a2a aaa, a10a

Range of 
characters

[a-z] f, p, j 2, &

Outside a range [!a-z] 9, &, % b, a

Not a digit [!0-9] A, a, &, ~ 0, 1, 9

Combined a[!b-m]# An9, az0, a99 abc, aj0
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4 Enter the wildcard(s).

5 Click OK.

6 The Scan Results dialog appears with all matches that Déjà Vu X 
Standard has found in the associated translation memory.

7 For information on how to insert a match, see "To manually scan the 
translation memory(s)" on page 107.
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Scan is one of the most helpful and frequently used functions in Déjà Vu 
X Standard.

Lookup in the Terminology Databases

To lookup a term in the terminology databases

In the same way that you can scan the translation memories for a 
sentence or a part of a sentence, you can search the terminology 
databases for data.

1 Select the term you want to look up.

2 On the Translation menu, click Lookup.

–Or–

Press Ctrl+L.

–Or–

Click the  button on the toolbar.

The Scan Results dialog will also display matches that have been 
turned from fuzzy to perfect matches with the help of Déjà Vu X 
Standard’s EBMT (example-based machine translation) technology. For 
more information on EBMT, see "Assemble and Example-Based Machine 

Translation" on page 120.
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3 If Déjà Vu X Standard finds any matches in the terminology 
databases, the Terminology Lookup dialog appears.

The Terminology Lookup dialog consists of the following elements:

Source—The source language terms you were searching for.

Target—The target language term found in the terminology 
databases.

Source Attributes—A list of all attributes that were entered for the 
source term.

Target Attributes—A list of all attributes that were entered for the 
target term.

For information on how to set up attributes, please see "Templates" on 
page 409.
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If you would like to review other matches, you can navigate through 
the list of matches by using the table’s scrollbar or the DownArrow 
and UpArrow keys.

Under the Attributes you can see information about the currently 
selected match, including Date (date and time the record was 
entered into terminology database), Subject, Client, Database 
(origin of match), and User (who entered the term into the 
terminology database). 

The buttons to the right have the following function:

Insert—Replaces the text in the current target cell with the 
proposed translation.

Close—Closes the dialog without any changes.

Insert <<—Inserts the proposed translation to the left of any 
existing text in the current target cell (this button is only 
displayed if there is some text in the current target cell).

Insert >>—Inserts the proposed translation to the right of any 
existing text in the current target cell (this button is only 
displayed if there is some text in the current target cell).

Copy—Copies the proposed translation to the Windows clipboard.

4 Review the proposed translation and, if applicable, scroll down the list 
of matches and select a different match.

5 Select the appropriate insertion button.

6 The dialog closes and the match is inserted into the current target 
cell.

To lookup with wildcards

To widen the scope of your searches, you can use wildcards at the end of 
text you are looking for. The wildcards you can use to build search 
patterns are:

* — zero or more characters

? — one character

# — one digit
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[a-m] — one character in the specified range

[!a-m] — one character outside the specified range

Examples:

1 Select a part of the text that you would like to search for.

2 Right-click on the selection and select Lookup with Wildcards.

–Or–

Press Ctrl+Shift+L.

–Or–

Select Translation>Lookup with Wildcards.

3 The Enter Search Expression dialog appears, displaying the 
selected text.

Kind of Match Pattern Match No Match

Multiple 
characters

a*a aa, aBa, aBBBa aBC

Multiple 
characters

*ab* abc, AABB, Xab aZb, bac

Multiple 
characters

ab* abcdefg, abc cab, aab

Special character a[*]a a*a aaa

Single character a?a aaa, a3a, aBa aBBBa

Single digit a#a a0a, a1a, a2a aaa, a10a

Range of 
characters

[a-z] f, p, j 2, &

Outside a range [!a-z] 9, &, % b, a

Not a digit [!0-9] A, a, &, ~ 0, 1, 9

Combined a[!b-
m]#

An9, az0, a99 abc, aj0
116 Déjà Vu X Standard



Translation Features in Déjà Vu X Standard—The Details
4 Enter the wildcard(s).
.

5 Click OK.

6 The Terminology Lookup dialog appears with all matches that Déjà 
Vu X Standard has found in the associated terminology database.

7 For information on how to insert a match, see "To lookup a term in 
the terminology databases" on page 113.
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Assemble

When scanning (see "To manually scan the translation memory(s)" on 
page 107) does not find a match, you can ask Déjà Vu X Standard to 
assemble a translation from smaller pieces that can be found in the 
project lexicon, terminology databases, and the translation memories (in 
this order if the similarity and other properties are equal).

To manually assemble a translation for a single sentence

1 Select the sentence you want to assemble a translation for.

On the Translation menu, click Assemble.

–Or–

Press Ctrl+A.

2 Déjà Vu X Standard will insert all relevant portions into the target 
sentence along with a blue status indicator to signify that this 
sentence has been assembled.

3 If Déjà Vu X Standard finds more than one match for any of the 
portions in the source, it will fill in the match with the highest 
fuzziness rate and underline and color-code it.

4 Right-clicking that portion will display a context menu with the other 
possibilities.
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5 You can choose to accept Déjà Vu X Standard’s choice or select one of 
the other choices by selecting it in the context menu.

To adjust the assemble settings

1 Select Tools>Options>General.

2 The General tab in the Options dialog is displayed.

The options under Assemble include:

First scan for whole sentence—Instructs Déjà Vu X Standard 
to first look for a match for the complete sentence in the 
translation memory before it assembles the sentence. In general, 
this option should be enabled. 

Accept only exact matches when scanning—Instructs Déjà 
Vu X Standard to reject fuzzy matches from the translation 

Déjà Vu X Standard will also attempt to copy embedded codes from the 
source to the target sentence, particularly when it finds those at the 
beginning and/or end of the sentence or around portions that it "knows" 
from any of the databases.
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memory(s) because assembling from portions is expected to yield 
better results. In general, this option should be disabled.

Insert source text for failed portions—This will make Déjà Vu 
X Standard insert unknown words into the target as they appear 
in the source text. This option should be enabled if your text 
contains a great amount of non-translatable words such as 
product names or if you prefer to overtype text as you translate.

Allow portions containing commas—With this option enabled, 
Déjà Vu X Standard will also consider portions with commas in its 
assemble processes. This option will slow down the assemble 
process.

3 Make the desired settings and click Apply and/or OK.

To quickly change the order of words

If a sentence is assembled from a great number of portions, the word 
order may need to be changed. Déjà Vu X Standard offers several 
keyboard shortcuts to quickly change the word order.

1 Select the word or phrase which you would like to move to another 
position within the sentence.

2 Press Ctrl+Shift+N to move the selected word or phrase forward one 
word at a time. Pressing Ctrl+Shift+N will continue to move the 
selected word or phrase forward.

–Or–

Press Ctrl+Shift+B to move the selected word or phrase one word 
backward. Pressing Ctrl+Shift+B again will continue to move the 
selected word or phrase backward.

Assemble and Example-Based Machine Translation

One of the unique aspects of Déjà Vu X Standard’s assemble processes is 
its employment of example-based machine translation (EBMT), which 
allows it to turn fuzzy matches into perfect matches.

Here is an example of how this works. For the source sentence

Prometheus, the heavy equipment and engine manufacturer

the French translation memory's target
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Prometheus, le producteur de matériel lourd et de moteurs 
(Prometheus, the heavy equipment and engine producer)

would be a fuzzy match. 

If, however, the French term for "manufacturer" is also in the 
terminology database, the tool will display it, allowing the user to delete 
"producteur (producer)" and add "fabricant (manufacturer)." If both 
the translations for "producer" and "manufacturer" are in the 
terminology database, Déjà Vu X Standard will assemble the translation 
by automatically deleting "producteur" and adding "fabricant" at the 
appropriate location, thus turning a fuzzy match into a perfect match 
without any user intervention:
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Prometheus, le fabricant de matériel lourd et de moteurs 
(Prometheus, the heavy equipment and engine manufacturer)

This shows how important it is to have extensive terminology databases. 
One of the most often-committed mistakes of new users of Déjà Vu is 
the complete reliance on translation memories. While these are 
obviously important, it is just as important to build up and maintain 

terminology databases—in fact, many experienced Déjà Vu users would argue 
that the terminology databases are more important than the translation 
memories. 

You should be aware that EBMT does not do any grammatical work for you. In the 
example above, if the gender of the exchanged term had not matched (as in the 
case of "(le) producteur" vs. "(la) société"), you would have had to manually 
change the article "le" to "la."

To have the EBMT process work correctly during Assemble, it is advisable to 
activate First scan for whole sentences (under 
Tools>Options>General>Assemble).
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Sending Text to the Databases

Sending Information to the Translation Memory

If you send information to the translation memory(s), your records not 
only contain source and target text, but also a date/time stamp, subject 
and client (if enabled), and user name, as well as various other project-
specific data.

By default, Déjà Vu X Standard will only store unique sentence pairs in 
the translation memory to allow for a smaller size of the translation 
memory.

You can send translated text either manually for every single row to your 
translation memory or in a batch process.

Manually Sending Sentence Pairs to the Translation 
Memory

To send a sentence pair to the translation memory

After you have translated and/or edited a sentence in Déjà Vu X 
Standard, click Add Pair to Translation Memory on the 
Translation menu.

–Or–

Press F12.

–Or–

Click the  button on the toolbar.

If you send a sentence pair to the translation memory multiple times, 
earlier instances of that specific sentence pair will be overwritten. If you 
prefer to have two different translations in your translation memory 
instead of only the most current one, you can highlight the source and 

target sentence and then send it. That way it will not overwrite earlier entries.
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To send only a portion of the sentence pair to the translation 
memory

1 Select the portion of the source sentence and the portion of the 
target sentence that you want to send to the translation memory.

2 On the Translation menu, click Add Pair to Translation Memory. 

–Or–

Press F12.

–Or–

Click the  button on the toolbar.

To send the whole project to the translation memory

1 On the Project menu, click Add Project to Translation Memory.

–Or–

Press Alt+F12.

–Or–

Click the  button on the toolbar.
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2 The Send Project to Translation Memory dialog appears, offering 
you the following options:

Select whether you want to send the currently selected language 
or all the target languages for the project.

Select whether you want to send any row with a status other than 
the default options Finished Rows or Unmarked manual 
translation.

Limit to current record selection allows you to select a certain 
section of a file to send to the memory database. For more 
information on how to select a certain subset of rows, see 
"Selecting Rows" on page 45.
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3 Click OK.

To prevent a row from being sent to the translation memory

1 If you would like to single out certain rows (for instance, rows that 
contain code information) that you do not want to be sent to your 
translation memory, you can right-click the sentence or the selection 
of sentences you do not want in the translation memory and click Do 
Not Send.

–Or–

Press Ctrl+Shift+D.

2 The Do Not Send symbol ( ) appears in the target cell.

To remove the Do Not Send status

1 Select the sentence you want to mark as normal.

2 Right-click the sentence table and click Do Not Send.

–Or–

Press Ctrl+Shift+D.

3 The  symbol disappears.

If you send a project/file to the translation memory, earlier instances of 
the sentence pairs within that project/file you have already sent will be 
overwritten. Déjà Vu X Standard is able to recognize earlier instances by 
assigning unique project, file, and row IDs to each sentence pair in the 

translation memory. If a file within a project is deleted and a new file is imported, 
the same project, file, and row IDs could be assigned to the new file, resulting in 
the deletion of anything sent from the earlier file to the associated translation 
memory. To avoid this, you should create new projects for your newly translatable 
files.

The Déjà Vu 3 option Delete all pairs previously sent from this project is not 
supported by Déjà Vu X Standard because of its more intelligent way of 
automatically deciding what sentence pairs in the translation memory to 
overwrite.
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Sending Information to the Terminology Database

For more information on sending terms to the terminology database, see 
"Adding Terms to the Terminology Database" on page 84.

Sending Information to the Lexicon

For more information on sending terms to the lexicon, see "To manually 
add entries to the lexicon" on page 323.

Locking Rows

It is possible to lock rows in the project so that you cannot accidentally 
change their target text.

To lock a group of rows

1 Select the row(s) you want to lock.

2 Right-click the selection and select Locked ( ).

–Or–

Press Ctrl+Shift+K.

To unlock a group of rows

1 Select the row(s) you want to unlock.

2 Right-click the selection and remove the checkmark from Locked 

( ) by clicking on it.

–Or–

Press Ctrl+Shift+K.

For information on how to select rows, see "Selecting Rows in the 
Selection Mode" on page 45.
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Target text in locked rows is protected against any modification.

Clients and Subjects

Déjà Vu X Standard has several ways to add additional information to the 
source and target sentences in the terminology database and translation 
memory. While some of that additional information is completely 
configurable for the terminology databases (see "Templates" on page 
409), there is only a limited and pre-defined number of fields that can be 
added to the translation memories.

These include:

User—the name or nickname of the user who entered that record 
into the translation memory.

Date/Time stamp—the date and time the record was entered into 
the translation memory or terminology database.

Project ID—the preassigned 7-digit project ID of every project file 
that accompanies every record that is entered from that project into 
the translation memory.

Subject—the user-assigned subject, or topic, of a record. This can be 
entered into the translation memories and terminology databases 
through the subject of a current project or manually.

Client—the user-assigned client of a record. This can be entered into 
the translation memories and terminology databases through the 
client of a current project or manually.

This additional information provides you with helpful data about each of 
these records when they are displayed in any of the database views, it 
allows you to specify subsets of your databases for exporting purposes, 
and it allows Déjà Vu X Standard to make choices when determining what 
match to use in any of its automated translation processes.

This feature can  be very helpful if you want to exclude a certain subset 
of rows for your view. You can lock these rows and then select All 
Except Locked Rows in the Rows Selector (see "The Rows Selector" on 
page 28).
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First and foremost, Déjà Vu X Standard will use similarity, or the degree 
of fuzziness, to decide which match to choose over another. However, 
with large databases, Déjà Vu X Standard will often encounter situations 
where there are two or more different perfect matches or matches of the 
same fuzziness. In these situations, the program will use sophisticated 
algorithms to decide which of these matches to choose.

The hierarchy in which Déjà Vu X Standard will decide on the match is as 
follows:

1 fuzziness

2 target sub-language (see p. 71)

3 client

4 subject

5 source sub-language (see p. 71)

6 case similarity (Atril vs. atril vs. ATRIL)

7 age (see p. 106)

The logic follows an exclusionary scheme: If the fuzziness of one match is 
of a higher percentage than that of another, the more identical match will 
be preferred, regardless of any other setting. If the match quality of the 
two matches is identical, and one has the same target sub-language as 
the source sentence but the other has a differing sub-language (French 
(Standard) vs. French (Belgian), for instance), the one with identical 
target sub-languages would be preferred, regardless of any other setting, 
and so on.

Storing the Client and Subject Settings

The client and subject settings, along with settings for sentence 
delimitation (see page 169), are automatically stored in the 
settings.dvset file. In the default setting, this file is located in the Déjà Vu 
X Standard installation folder (on an English Windows system typically at 
C:\Program Files\ATRIL\Deja Vu X). 

Regardless of Déjà Vu X Standard’s choice for a match, the other 
matches are always available in case you want to override Déjà Vu X 
Standard’s decision.
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If you work with other users over a network on the same file and/or 
databases, you should save this file to an accessible point on the network 
and have the different Déjà Vu X Standard installations access that file by 
selecting Tools>Options>General.

Clicking on Shared settings location under Miscellaneous displays an 
activated file selector with which you can select a path to the new 
location.
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Working with Clients

Under Tools>Options>Clients, you will see a sample list of clients that 
are associated with individual numeric codes.

You can assign clients directly to database records during import and 
align processes or to individual records in the terminology database or 
translation memory view, but most commonly you assign them to records 
through your project files. Every language pair record that you send to 
the databases from your project will by default have the client that you 
assigned in the project.

To assign clients to a project file

1 In the open project file, select Project>Properties>General.

–Or–

You can also assign non-numeric codes to clients.
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Right-click the project icon in the File Navigator and select 
Properties.

2 The General tab of the Project Properties dialog appears.

You can see that the project name (the name of the project file), the 
Type of Project (whether it is a normal or a satellite project), and 
the Project ID are automatically filled in. You will have to select 
Client and Subject.

3 Click on the down arrow in the Client line.
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4 The list of clients opens.

5 Select the client of your project and do the same with the Subject 
field.

6 Click OK.

To add clients to the list of clients

1 Enter a new code into the Code field.
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2 Enter a name into the Name field.

3 Click the Add button which is now activated.
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4 The new client has been added to the list.

5 Click Apply.

To import clients from Déjà Vu 3

1 Select Import in the lower left corner of the Options dialog.
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2 The Import DV3 Settings dialog appears.

3 Under Clients, you can select to import clients by either deleting or 
overwriting existing clients (if applicable).

4 Click OK.

To modify clients in the list of clients

1 Highlight the record that you want to modify.
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2 Change the name in the Name field.

3 Click the Replace button which is now activated.
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4 The changed client now appears in the list.

5 Click Apply.

To delete clients from the list of clients

1 Highlight the record that you want to delete.

2 Click Delete.

3 The record is deleted from the list.

4 Click Apply.

To find a client in the list of clients

1 Enter any digit that is contained in the code or any character that is 
contained in the client name into the Filter field.
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2 The records that match the find sequence are displayed

You can use wildcards when looking for clients (for more information on 
wildcards, see "To scan with wildcards" on page 110).
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Managing Clients—Tips and Tricks

The most important rule about clients is to apply them to every translation project 
and each other entry in the databases.

If you work within a large organization, instead of "company clients" it may make 
sense for you to use "department clients," or any other category that makes 
sense for your particular situation.

If you work as a freelancer, you should always use the end client (i.e., the 
company that the translation is actually produced for), even if that differs from 
the organization that you are directly performing your services for (a translation 
vendor, for instance). If you are performing legal, medical, and technical 
translations for one translation vendor, the client field becomes useless and 
potentially distorting if you use the name of the translation vendor rather than the 
end client’s name.
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Under Tools>Options>Subject, you will see that each of the listed 
subjects is associated with a numeric code. These codes are organized in 
a hierarchical structure of main topics and subtopics.

The code 6, for instance, is the code for Applied sciences. Medicine. 
Technology, of which 61, Medical sciences, is a subcategory, of which 
611, Anatomy. Human and comparative anatomy, is yet another 
subcategory.

You can also assign non-numeric codes to subjects, but this will result in 
the loss of the hierarchical structure.

The preset subjects and clients that come with Déjà Vu X Standard 
represent the UDC list. UDC stands for "Universal Decimal Classifications" and is 
the most commonly used bibliographic system. For more information about UDC, 
see www.udcc.org.
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Déjà Vu X Standard’s matching algorithms would recognize that a record 
with the associated code 611 is closer to the code 61 (of which it is a 
subcategory) than for instance to 62 (of which it is not a subcategory) or 
even to 6 (of which it is only a subcategory of a subcategory). 611 is 
more closely related to 61, 62, or 6 than, for instance, to 7 (The Arts). 

You can assign subjects directly to database records during import and 
align processes or to individual records in the terminology database or 
translation memory view, but most commonly you assign them to records 
through your project files. Every language pair record that you send to 
the databases from your project will by default have the subject that you 
assigned in the project.

To assign subjects to a project file

1 In the open project file, select Project>Properties>General.

–Or–

Right-click the project icon in the File Navigator and select 
Properties.

This means that the more sophisticated your system of classification is, 
the more precise the matches will be that Déjà Vu X Standard will be 
using.
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2 The General tab of the Project Properties dialog appears.

You can see that the project name (the name of the project file), the 
Type of Project (whether it is a normal or a satellite project), and 
the Project ID are automatically filled in. You will have to select 
Client and Subject.

3 Click on the down arrow in the Subject line.
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4 The list of subjects opens.

5 Select the subject of your project and do the same with the Client 
field.

6 Click OK.

To add subjects to the list of subjects

1 Enter a new code into the Code field.
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2 Enter a description into the Description field.

3 Click the Add button which is now activated.
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4 The new category, in this case a subcategory to 611, Anatomy, has 
been added to the list.

5 Click Apply.

To import subjects from Déjà Vu 3

1 Select Import in the lower left corner of the Options dialog.
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2 The Import DV3 Settings dialog appears.

3 Under Subjects, you can select to import clients by either deleting or 
overwriting existing subjects.

4 Click OK.

To modify subjects in the list of subjects

1 Highlight the record that you want to modify.
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2 Change the description in the Description field.

3 Click the Replace button which is now activated.
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4 The changed category now appears in the list.

5 Click Apply.

To delete subjects from the list of subjects

1 Highlight the record that you want to delete.

2 Click Delete.

3 The record is deleted from the list.

4 Click Apply.

To find a subject in the list of subjects

1 Enter any digit that is contained in the code or any character that is 
contained in the subject description into the Filter field.
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2 The records that match the find sequence are displayed

You can use wildcards when looking for subjects (for more information 
on wildcards, see "To scan with wildcards" on page 110).
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Propagate

Once you have translated a sentence, you can apply this translation to 
the same or similar sentences within Déjà Vu X Standard. This process is 
called Propagation.

When searching for cells to propagate to, Déjà Vu X Standard only looks 
for linguistic matches and assumes that digits and embedded codes are 
not to be changed between source and target languages. This means that 
the samples in the following screenshot are all considered to be perfect 
matches, even though the number and codes differ from each other. 

Managing Subjects—Tips and Tricks

The most important rule about subjects is to apply them to every translation 
project and each other entry in the databases.

The next most important consideration is how to set them up. Essentially, there 
are two ways to do that. You can

• use the existing list of subjects and either try to find subjects that are 
relevant to your projects or set them up within the preassigned order, or

• delete the list of subjects and build your own list with its own hierarchical 
structure from scratch.

While the second option may give you more flexibility in defining your choices (if, 
for instance, you only work with legal translation and you would like to fine-tune 
the whole range of subject codes to legal topics), only the first option allows you 
to effectively exchange Déjà Vu databases with other translators without having 
to redefine their structure.

No matter which way you choose to go, you should take your time to define (or 
fit) your subject structure as thoroughly as you can. Many translators find it 
helpful to do this planning on a piece of paper and then later transfer it into Déjà 
Vu X Standard.
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There are several ways to propagate a sentence with Déjà Vu X Standard:

The manual propagate option allows you to either propagate in your 
current file or throughout the project.

The overwrite option (see "To manually propagate a translation to all 
files in the project" on page 153) allow you to overwrite any existing 
translation, regardless of its status.

There are differences between these three options in terms of how 
sentences are being overwritten:

AutoPropagate overwrites any empty, fuzzy match or assembled row 
but does not do any fuzzy propagation.

Manual propagate overwrites any empty, fuzzy match or assembled 
row and prompts for confirmation when it finds a fuzzy match.

The overwrite option overwrites anything, including perfect and 
guaranteed matches and unmarked empty rows (i.e., manually 
translated rows), except finished and locked rows.

To manually propagate a translation in the current file

1 Select the sentence with the translation you want to propagate.

2 On the Translation menu, click Propagate In Current File.

–Or–

Press Shift+F9.

–Or–

Click the  button on the toolbar.

3 After propagating to identical source rows, Déjà Vu X Standard will 
look for rows where the source text is only similar to the one being 
propagated. If any such rows are found, Déjà Vu X Standard will 
152 Déjà Vu X Standard



Translation Features in Déjà Vu X Standard—The Details
display the row in question and the fuzzy match in the Confirm 
Fuzzy Propagation dialog.

4 Make any corrections in the Confirm Fuzzy Propagation dialog.

5 Click Yes, and the match will be inserted into the target row.

To manually propagate a translation to all files in the project

1 Select the sentence with the translation you want to propagate.

You can see that Déjà Vu X Standard automatically placed the corrected 
codes into the target and gave that row a different status indicator.
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2 On the Translation menu, click Propagate To All Files.

–Or–

Press Alt+Shift+F9.

–Or–

Click the  button on the toolbar.

3 After propagating to identical source rows, Déjà Vu X Standard will 
look for rows where the source text is only similar to the one being 
propagated. If any such rows are found, Déjà Vu X Standard will 
display the row in question and the fuzzy match in the Confirm 
Fuzzy Propagation dialog. For more information on this, see the 
description under "To manually propagate a translation in the current 
file" on page 152.

Embedded Codes

When you work with file types other than plain text, Déjà Vu X Standard 
only displays translatable text—everything else is hidden. However, in 
formats such as HTML, FrameMaker, or Word, formatting information is 
often embedded within a sentence, such as a particular word in bold, 
cursive, or small caps. Since Déjà Vu X Standard cannot automatically 
decide which formatting belongs to which word, it leaves the decision on 
where to place this formatting information to the translator. These are 
"embedded codes." If you have created a Déjà Vu X Standard project for, 
say, HTML, you will probably have noticed that many sentences contain 
embedded codes such as {142} or {835}.

It is important for anyone working with Déjà Vu X Standard to 
understand what "embedded codes" are. They are arguably one of Déjà 
Vu X Standard’s most powerful features because they protect the 
integrity of your documents and allow you to leverage your translation 

across many formats—to a much greater degree than most other CAT tools.
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Consider the following example:

You can see that the translator chose to place the codes in the target 
around the corresponding word in the translation. 

In most cases you don’t need to worry about what the embedded codes 
really contain, but it’s clear that—whatever effect they have—they must 
be placed before and after the word gewartet (the German translation of 
waited).

Take a look at the original text:

You can see that each of the instances of "waited" was formatted 
differently. Not only did this not make a difference to Déjà Vu X Standard 
when it processed the document (or the translators as they translated the 
document), but as indicated by the light blue status indicator, Déjà Vu X 
Standard even allowed the translator to only translate the first instance of 
that line and to propagate that translation to the other lines as perfect 
matches (for more information on propagation, including why the 
numbers are automatically copied over, see "Propagate" on page 151).
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After the export of the translated document, all the formatting is retained 
at the appropriate positions:

Though Déjà Vu X Standard stores the "meaning" of each code within a 
project—so that the correct formatting can be applied when you export 
the document—it treats the codes as mere placeholders when it 
propagates them or when it stores them in the translation memories or 
terminology databases. The effect of this is that Déjà Vu X Standard can 
be used across all file formats and internal format differences. Not only 
does 

I waited for 8 hours 

represent a perfect match to 

I waited for 16 hours

within Word, but also to 

I waited for 24 hours 

within an HTML or FrameMaker file.

Relative Positioning of Embedded Codes Around Text

It is important to maintain the order of the codes relative to each 
sentence in the source because each embedded code in the Déjà Vu X 
Standard project stores specific formatting information.
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Here are a few examples where this becomes relevant. Assume that

I waited for 8 hours
from an HTML file (in HTML code: I <b>waited<\b> for 8 hours) is 
displayed in Déjà Vu X Standard as:

I {446}waited{447} for 8 hours.

The placement of codes in the translation can only be like this:

Ich habe 8 Stunden {446}gewartet{447}.

If the codes were reversed in the translation:

Ich habe 8 Stunden {447}gewartet{446}

the resulting text would be corrupted because the tag that determines 
the beginning of the bold formatting (in our HTML example: <b>) would 
be preceded by the tag that closes it (in our HTML example: <\b>), with 
the result that the rest of the document would be in bold.

Relative Positioning of Embedded Codes in Shifted Syntax

Another thing to consider is the placement of codes when the syntax of 
the target language requires a re-arrangement of codes. Assuming that

I waited for 8 hours
from an HTML file (in HTML code: I <b>waited<\b> for 8 
<i>hours<\i>) is displayed in Déjà Vu X Standard as:

I {446}waited{447} for 8 {448}hours{449},

the placement of codes in the translation can only be like this:

Ich habe 8 {448}Stunden{449} {446}gewartet{447}.

If the codes were reversed in the translation:

Ich habe 8 {446}Stunden{447} {448}gewartet{449},

the resulting text after the export would have a reversed formatting:

Ich habe 8 Stunden gewartet.
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Copying and Moving Embedded Codes

When you are translating a sentence that contains embedded codes, you 
must make sure that the target sentence contains the same embedded 
codes, or Déjà Vu X Standard will not be able to export the project files 
properly. 

In fact, Déjà Vu X Standard has several measures implemented to 
guarantee that the codes are not overlooked or deleted.

It marks rows with a warning symbol ( ) where it finds a 
discrepancy in codes between source and target.

It allows you to jump to rows with inconsistencies in embedded codes 
through the selection of Translation>Check Embedded Codes.

–Or–

Pressing Ctrl+Shift+F8.

It write-protects codes in the target cells and marks them by painting 
them in a light gray.

It allows for several ways to quickly insert embedded codes into the 
target.

It warns when exporting documents with corrupted codes.
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To automatically copy the next embedded code

1 Place your cursor in the target cell on the position you want the next 
available code to be copied to, and click Copy Next Code.

–Or–

Press F8 (or Ctrl+D).

2 Déjà Vu X Standard will insert the first embedded code that is in the 
current source sentence and not already in the target sentence at the 
position of the cursor.

To automatically copy all embedded codes

1 Right-click the target box, and click Copy All Codes.

–Or–

Press Alt+F8.

2 Embedded codes found in the current source sentence will be 
inserted at the cursor position in the current target sentence.

To automatically fix all embedded codes

1 Select the row for which you want to fix the embedded codes and 
select Translation>Fix Embedded Codes.

–Or–

Press Ctrl+F8.

You should only use this option when you prefer to first copy the codes 
and then type around them. Just copying the codes into the sentence 
will disable the warning features in Déjà Vu X Standard, but it will not 
guarantee the correct placement of the embedded codes and the 

subsequent export of the file.
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2 Embedded codes found in the current source sentence will be 
inserted at the end of the current target sentence.

To manually copy an embedded code from source to target

1 Double-click the desired code in the source sentence.

2 Drag the selected code to the target box, hold down the Ctrl key 
(otherwise the code will be moved rather than copied), and release 
the mouse button at the position where you want the code to be 
inserted.

–Or–

Press Ctrl+C (or Ctrl+Ins) and position the cursor in the appropriate 
position in the target cell and press Ctrl+V (or Shift+Ins).

–Or–

Right-click, select Copy, position the cursor in the appropriate 
position in the target cell, right-click, and select Paste.

To move an embedded code in the target cell

1 Double-click the code you want to move.

2 Use drag and drop to move the selected code to the desired position.

Deleting Embedded Codes

In some cases, you may want to temporarily delete the embedded codes 
from the target sentence.

To delete a single embedded code

1 Select the entire code (double-clicking on a code will select it).

2 Press Ctrl+X (or Shift+Del).

You should only use this option when you prefer to first copy the codes 
and then type around them. Just copying the codes at the end of a 
sentence will disable the warning features in Déjà Vu X Standard, but it 
will not guarantee the correct placement of the embedded codes and the 

subsequent export of the file.
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To delete all embedded codes in a sentence

1 Right-click the target text box to bring up the context menu, and click 
Delete Codes.

–Or–

Press Ctrl+Space.

Modifying Embedded Codes

Embedded codes are protected in such a way that it is difficult to tamper 
with them. If you were to delete even only one, the export function might 
not be able to reconstruct a valid DTP file. It is possible, however, to 
modify the contents of a code in a target sentence.

To modify the contents of an embedded code

1 Right-click anywhere on the code and select Display Code from the 
shortcut menu.

–Or–

Highlight the code and press Shift+F6.

You can also select Delete Codes and Text or press Ctrl+Space twice 
to delete the whole sentence.
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2 The Embedded Code dialog appears with the embedded code being 
displayed.

3 Enter your changes in the target box.

4 Click Accept.

You should only change the contents of embedded codes when 
absolutely necessary and when you are very familiar with the coding of 
the file format you are working in.
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Context View

In some cases, it is helpful to have a more thorough context view than 
Déjà Vu X Standard offers in its project view. For these cases, Déjà Vu X 
Standard offers you the See in Context view.

To see text in context

1 Select the sentence for which you would like to see the context.

2 Select Edit>See in Context.

–Or–

Press F6.

3 The Source Sentence in Context dialog appears.
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4 You can see the source sentence of your current selection in red and 
the surrounding text and code in black.

Conversions

Whenever Déjà Vu X Standard inserts a match into a translation, it 
automatically performs certain conversions, including:

embedded codes (see "Embedded Codes" on page 154).

acronyms—Déjà Vu X Standard will assume that any word of two or 
less characters is an acronym that does not need to be translated and 
will thus take it over from source to target. For double-byte 
languages, this feature will only work with one-character words.

numbers—the assumption is made that numbers will not be 
translated and will be taken over from the source to the target, 
regardless of what is found in the databases.

Other conversion features are not performed automatically but are 
dependent on your settings.

To control the conversion features

1 Select Tools>Options>General.

The context view is not the same as you would see in a particular 
viewer, such as Internet Explorer or Microsoft Word; instead it is the 
view of the underlying code, in this case HTML.

File formats for which this view is not available include Access, Excel, PowerPoint, 
and Trados.

While the acronym and number conversions are extremely helpful 
features, it is wise to verify any of these conversions. Examples of 
where an automatic conversion may not be successful would include 
toll-free telephone numbers that are valid for the region of the source 

language but not for the region of the target language.
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2 The General tab of the Options dialog is displayed.

Under Conversion, you can enable the following conversion 
processes:

Control leading and trailing symbols—Enables Déjà Vu X 
Standard to automatically fill in symbols such as punctuation 
marks or spaces at the beginning or end of a sentence. This is a 
helpful setting if the punctuation systems of your languages 
match each other. Between English and Japanese, for example, 
this would not be a very helpful setting.

Allow decimal conversion—If enabled, Déjà Vu X Standard will 
automatically convert numbers, such as 1,000,000.00 (American 
English) to 1.000.000,00 (Spanish) to 1 000 000,00 (French).

Allow case conversion—If enabled, Déjà Vu X Standard will 
automatically convert the case of a word in the target to the case 
of the source. While this is a helpful setting between languages of 
a similar capitalization system, it would not be a helpful setting 
between English and German, for instance.

3 Make the desired settings and click Apply and/or OK.
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Copying and Populate

Déjà Vu X Standard employs the standard Windows commands and paths 
to copy, cut, and paste text. You can copy, cut, and paste text by:

Selecting the text and pressing Ctrl+C (or Ctrl+Ins) for Copy, Ctrl+X 
(or Ctrl+Ins) for Cut, or Ctrl+V (or Shift+Ins) for Paste.

–Or–

Selecting the text and selecting Edit>Copy, Edit>Cut, or 
Edit>Paste.

–Or–

Selecting the text and clicking on  (Copy), or  (Cut), or  
(Paste) on the toolbar.

–Or–

Selecting the text and pressing the Ctrl key while dragging and 
dropping the text elsewhere.

However, there are a number of copy functions available that are specific 
to Déjà Vu X Standard. These are called "Populate."

Populating Single Sentences

To copy the current source to the current target

1 Select the row you want.

2 On the Insert menu, select Populate>Current Sentence.

–Or–

Populating single sentences can be especially helpful when you have a 
sentence with a lot of untranslatable text, such as product names, 
proper names, addresses, or codes.
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Press F5.

To insert the current target with the current source

1 Select the row you want.

2 Press Ctrl+F5.

3 The source sentence is inserted to the beginning of the existing 
target sentence.

To populate all the target columns for the current target language

On the Insert menu, select Populate>Current Language

–Or–

You can also copy the content of several rows into the target with this 
command by selecting the desired rows in the selection mode (see 
"Selecting Rows in the Selection Mode" on page 45).

You can also copy the content of several rows into the target with this 
command by selecting the desired rows in the selection mode (see 
"Selecting Rows in the Selection Mode" on page 45).
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Press Alt+F5.

You can also populate all target languages in the project by pressing 
Ctrl+Alt+F5.

You should be careful with this option because it can be difficult to batch 
delete a certain subgroup of sentences again. The possibilities that Déjà Vu X 
Standard readily offers are to delete all translations, all assembled translations, 
and all fuzzy match translations. You can access these options by right-clicking on 
a row and choosing the appropriate option from the context menu.

One significant difference between populating only one sentence and all the 
sentences of a language is that only in the first option are the contents of the row 
in question overwritten. In the second option, only the empty rows are filled in.
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Sentence Delimitation

Sentence delimitation rules are the rules by which Déjà Vu X Standard 
determines how text in a specific language should be segmented. You can 
change or add the default delimitation rules so that it corresponds to your 
specific language and the style of the author of your source documents. 
The delimitation rules allow you to specify for each language what rules 
are to be used as well as the exceptions to these rules.

Déjà Vu X Standard’s default rules are the most common rules for most 
languages. It segments text when it sees one of the following punctuation 
marks:

period,

question mark,

explanation mark,

colon, or

semi-colon

followed by a white space. For periods, questions marks, and explanation 
marks, Déjà Vu X Standard also defines that they may not be followed by 
a lower-case letter.

Though these are good rules, in many cases they may only provide a 
starting point for your particular delimitation rules. Examples include the 
following:

Certain frequently occurring abbreviations in your source language, 
such as "P.O. Box," would be considered to be splittable by these 
rules.

Certain languages may make very heavy use of some punctuation 
marks, such as the semi-colon, which then should probably be 
deleted as a delimitation rule for that language.

Certain languages may not make use of any of these rules because 
they use a completely different set of punctuation marks. That would 
include languages such as Chinese and Japanese.

In these cases you will have to define new rules.
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To modify sentence delimitation rules

1 Select Tools>Options>Delimiters.

2 The Delimiters tab is displayed with the source language of your 
current project.

3 In the left part of the tab you can see the Rules, and in the right part 
the Exceptions to the rules.

To define rules you can use any actual character plus these symbols:
170 Déjà Vu X Standard



Translation Features in Déjà Vu X Standard—The Details
The character string .^w would thus mean a period followed by a 
white space, or e.g.,^w would mean (the abbreviation) "e.g.," 
followed by a white space.

4 Select the desired language

5 Type the desired character and symbols in the Before Split and 
After Split fields.

–Or–

Type the desired character. To enter the desired symbols, right-click 
and select the symbols from the shortcut menu.

6 Once you have entered or modified your rule, click Add.

To remove a rule or exception

1 Click the desired row on the table to select it.

2 Click Delete.

Symbol Meaning

^w white space

^# a digit (1, 2, 3...)

^$ a letter (upper-case, lower-case, or any case)

^a a lower-case letter

^A an upper-case letter

^? any character

^^ the caret character (^) itself
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To import sentence delimitation rules from Déjà Vu 3

1 Select Import in the left-hand lower corner of the Options dialog.

2 Though the resulting Import DV3 settings dialog does not contain 
any option that is specific to sentence delimitation, if you start the 
import process by clicking OK, all custom delimitation rules for all 
languages will be imported.

Splitting and Joining Sentences

After importing, it is possible that you may find that a sentence has been 
incorrectly split. Déjà Vu X Standard splits the source text into sentences 
using the rules and exceptions you set for the project’s source language 
(see "Sentence Delimitation" on page 169). However, even with the most 
carefully built set of rules and exceptions, there may be errors in the way 
Déjà Vu X Standard breaks text into sentences. The most common 
reasons for these errors are 

uncommon abbreviations that are not included in your list of 
exceptions (see "To modify sentence delimitation rules" on page 
170), and 

In cases where several sub-languages have replaced a single language 
in Déjà Vu 3—e.g., German in Déjà Vu 3 is now German (Standard), 
German (Austria), German (Liechtenstein), German (Luxemburg), and 
German (Switzerland)—the rules for the main language will be imported 

to all sub-languages.

Tips and Tricks on Sentence Delimitation:

For languages that do not use any of the typical punctuation marks, such as 
Chinese, you can delete all the existing rules and add new rules by typing the 
appropriate characters and the symbols that Déjà Vu X Standard uses. For 
Chinese, for instance, you can add "º" to have Déjà Vu X Standard split segments 
every time that character is used in the document. Because typically spaces are 
not used after that character (or any other punctuation mark in Chinese), you 
would not have to add "^w."

The sentence delimitation settings are stored in the settings.dvset file. For more 
information, see "Storing the Client and Subject Settings" on page 129.
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incorrectly placed soft or hard returns added by the author for 
formatting purposes.

You can correct such errors by:

editing the source file.

adding a new exception rule and importing the file(s) again.

manually splitting a sentence at a certain point.

manually joining two sentences together.

To split a sentence

1 Place the insertion caret to the position in the source sentence where 
you want to split the sentence.

2 Select Split Sentences from the Edit menu.

–Or–

Click the  button on the toolbar.

–Or–

Press Ctrl+I.

3 The sentence should now be split.

To join two sentences

1 Click the row that you want to have joined with the next sentence.

2 Select Join Sentences from the Edit menu.

–Or–

Click the  button on the toolbar.

–Or–

In some formats (such as PowerPoint, where this is an extremely typical 
error), Déjà Vu X Standard automatically ignores soft returns. There is 
no case, however, where hard returns can be ignored.
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Press Ctrl+J.

3 The sentences are now joined.

Common Windows Functions

Character Map

You can press Ctrl+K or select Tools>Character Map to display the 
Windows Character Map—a convenient way to enter special characters 
that you cannot type with your keyboard or whose ANSI code you don’t 
remember.

Depending on what is between the sentences in the source file, Déjà Vu 
X Standard may or may not add an embedded code. If the undesired 
split is due to an incorrectly set sentence delimitation rule, Déjà Vu X 
Standard will typically not add an embedded code. If it is because of an 

incorrectly set soft or hard return, Déjà Vu X Standard will place an embedded 
code between the sentences.

In general, it is not possible to join segments in certain file formats, including 
Excel, Trados, PowerPoint, and Access.
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Windows 2000 and XP Character Map

Windows 98, ME, and NT4 Character Map

If you use Windows 98, ME, or NT4 and the Windows character map 
does not appear when you press Ctrl+K, it is probably because it is not 
installed.
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To install the Windows Character Map

1 Open the Windows Start menu.

2 Open the Settings submenu, and select Control Panel.

3 Double-click Add/Remove Programs.

4 Select the Windows Setup tab.

5 Click System Tools (Windows 98 and ME).

6 Click Details.

7 Make sure Character map is selected.

8 Click OK.

To enter characters with the Windows Character Map

1 Select a font and the character you want to enter.

2 Click Select and Copy.

3 The character is now on your clipboard and you can paste it into any 
position within your open file by placing your cursor at the 
appropriate location and

pressing Ctrl+C (or Ctrl+Ins)

–Or–

selecting Edit>Copy

–Or–

clicking on  on the toolbar.

Windows will probably ask you for your Windows installation CD-ROM.
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Search and Replace Features

If you are looking for a specific term, you can use the standard Windows 
Find features to find it. If you want to replace the term, you can use the 
standard "search and replace" features to locate and replace it.

To use the find feature

1 On the Edit menu, click Find.

–Or–

Press Ctrl+F.

–Or–

Click the  button on the toolbar.

2 The Find dialog appears.

3 Select whether you want to search the Source Text or the Target 
Text and/or the Current File or All Files by checking the 
appropriate check boxes.

4 In the Find box, enter the text you want to search for.

5 If you want to only search for complete words, check Find whole 
word only. If this option is not selected, words that begin with the 
search text will also be found.

By default, the text that you last entered will be displayed. You can also 
use the dropdown list to select any text you searched for recently, or 
you can highlight the text you want to search for and then open the 
Find dialog.
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6 If you want to only search for words with capitalization identical to 
what you entered, check Match case.

7 Click Find Next.

8 The next row that contains the search word will be selected.

9 To continue searching for that word, you can continually click Find 
Next.

–Or–

Close the Find dialog and press F3 (or Shift+F4).

–Or–

Close the Find dialog and click  on the toolbar.

10 The next row that contains the search word will be selected.

To use the search and replace feature

1 Press Ctrl+H.

–Or–

Select Edit>Replace.

–Or–

Within the Find dialog, click Replace.

2 The Replace dialog appears.
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3 Select whether you want to replace text in the Source Text or the 
Target Text and/or the Current File or All Files by checking the 
appropriate check boxes.

4 Enter the text you are looking for into the Find box and the text you 
want to replace it with into the Replace With field.

5 If you want to only replace complete words, check Find whole word 
only. If this option is not selected, words that begin with the search 
text will also be replaced.

6 If you want to only replace words with capitalization that is identical 
to what you entered, check Match case.

7 Click Find Next.

8 The next row that contains the search word will be selected.

9 If you want to replace the word that has been found, click Replace. 
If you want to have all occurrences of this word replaced, click 
Replace All.

Redo and Undo Features

Déjà Vu X Standard supports an unlimited number of redo and undo 
actions.

To undo an action

Press Ctrl+Z.

–Or–

Select Edit>Undo.

–Or–

Click  on the toolbar.

By default, the text that you last entered will be displayed. You can also 
use the dropdown lists to select any text you searched for and replaced 
recently, or you can highlight the text you want to search for and then 
open the Replace dialog.
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To redo an action

Press Ctrl+Y.

–Or–

Select Edit>Redo.

–Or–

Click  on the toolbar.

Saving the Project

One of the great benefits of working in a database environment is that 
the database saves itself automatically when a new cell is selected or the 
database is closed. Because even the Déjà Vu project file is a database, 
there is no need to ever save your project! 

Change Case

You can either change the case (capitalization) of a certain selection 
within a target sentence or for the content of a whole target sentence.

To change the case for a selection

1 Select the text whose case you want to have changed.

2 Press Shift+F3.

–Or–

Select Edit>Change Case.

–Or–

Click  on the toolbar.

3 The case will change in the following cycle:

first letter uppercase, the rest lowercase

all lowercase

all uppercase
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To change the case for the content of target cell

1 Select the row for which you want to have the case changed for all 
the source text.

2 Press Shift+F3.

–Or–

Select Edit>Change Case.

–Or–

Click  on the toolbar.

3 The case will change in the following cycle:

first letter uppercase, the rest lowercase

all lowercase

all uppercase

The change of case does not affect numbers and symbols. On a U.S. 
English keyboard layout, for instance, a single quote (’) will not change 
to a double quote (").
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Chapter 6
Editing Features in Déjà Vu X 
Standard—The Details

Déjà Vu X Standard includes a multitude of editing and quality assurance 
features, most of which are described in the workflow chapters (p. 63). 
These include:

Terminological consistency check

Numeral consistency check

Embedded code check

Spell check

Below you will find an in-depth description of the spelling module of Déjà 
Vu X Standard.

Spelling Options

There are several spelling options in Déjà Vu X Standard. 

To access the spelling options

1 Select Tools>Options>Spelling.

–Or–

Click on Options in the Check Spelling dialog (see "Spell checking" 
on page 92).
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2 The Spelling tab in the Options dialog is displayed.

Going from top to bottom, you will find the following options:

General>Use the Microsoft Office Spell Checker—When this 
option is enabled, the dictionaries of the Microsoft Office spell checker 
are used rather than Déjà Vu X Standard’s own spell checking 
dictionaries.

General>Allow accented capital—When this option is enabled, 
words with accented capitals, such as ESPAÑA, are accepted. This 
option is selected by default.

General>Case sensitive—When this option is enabled, any word 
that does not match the exact case in the dictionary will be reported. 

This option is particularly helpful for spell checking languages without a 
native spell checker in Déjà Vu X Standard, but it does tend to slow the 
spell checking process. If you are translating into a language that 
includes a spell checking dictionary in Déjà Vu X Standard, you may 

work more efficiently if you leave this option unselected.

Enabling this option disables all other options.
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This would, for example, include "canada," "CANADA," or "cANADA," 
whereas "Canada" would be considered correct.

Report>Doubled words—When this option is enabled, any word 
appearing twice in a row is reported in the Check Spelling dialog.

Report>Uncapitalized words—When this option is enabled, any 
word that does not match the capitalization in the dictionary will be 
reported in the Check Spelling dialog. For example, “canada” is 
considered different from "Canada," so "canada" would be reported 
as a misspelling. "CANADA," however, would not be reported (see p. 
184).

Report>Words with embedded capital letters—When this option 
is enabled, any word in which a capital letter is embedded is reported 
in the Check Spelling dialog. Examples would include DejaVu or 
QuarkXPress. This option is selected by default.

Report>Words with digits—When this option is enabled, any word 
that contains digits is reported in the Check Spelling dialog. 
Examples would include Win2000 or B2B.

Ignore>Words in capitals—When this option is enabled, any words 
containing all capital letters are ignored (i.e., are skipped without 
being checked). 

Ignore>Words that begin with a capital letter—When this option 
is enabled, any words beginning with a capital letter are ignored (i.e., 
are skipped over without being checked).

Ignore>Words with embedded capital letters—When this option 
is enabled, any word with a capital letter in the middle is ignored. 
Examples would include DejaVu or QuarkXPress.

Ignore>Words with digits—When this option is enabled, any word 
that contains digits is ignored. Examples would include Win2000 or 
B2B.

Ignore>Numbers—When this option is enabled, any number—such 
as 255.255.255.0 or 1-800-255-1212—is ignored. This option is 
selected by default.

Ignore>Internet addresses—When this option is enabled, any 
Internet address—such as http://www.atril.com—is ignored. This 
option is selected by default.
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Split>Contracted words—When this option is enabled, contracted 
words are split. Examples include words such as the Italian 
"quell’anno" into "quell anno."

Split>Hyphenated words—When this option is enabled, 
hyphenated words are split. Examples include words such as "self-
control" into "self control" or "log-on" into "log on." This option is 
selected by default.

Split>Compound words—When this option is enabled, compound 
words are split. Examples include words such as "logon" into "log on" 
or "toolbar" into "tool bar."

Split>Strip possessives—When this option is enabled, possessives 
are stripped. Examples include "Emilio’s" into "Emilio" or "Déjà Vu X 
Standard’s" into "Déjà Vu X Standard." This option is selected by 
default.

Suggestions>Phonetic—When enabled, suggestions are made 
based on phonetic similarity as well as typographical similarity. This 
option tends to improve suggestions for badly misspelled words. 
Enabling this option will increase the time required to locate 
suggestions.

Suggestions>Typographical—When enabled, suggestions are 
made only based on typographical similarity. You will have to choose 
between phonetic and typographical suggestions.

Suggestions>Suggest split words—When this option is enabled, 
two separate words will be suggested as a replacement for a 
misspelling containing two joined words. For example, "is the" would 
be suggested as a replacement for "isthe."

3 Set the appropriate options for each language you are working in.

The spelling options you check in this dialog also take effect in any 
spelling you may perform in your translation memories or terminology 
databases. For more information on this, see "Spell Checking the 
Translation Memory" on page 382 and "Spell Checking the Terminology 

Database" on page 461.
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Dictionaries

Dictionaries are customized lists of words that you want to have 
automatically or conditionally changed, ignored, or excluded.

Though Déjà Vu X Standard is pre-equipped with extensive dictionaries 
for the languages with supported spell check engines, there will always 
be words that you encounter during spell checks which are not included. 
You can choose to include those in your custom dictionaries.

To add words to user dictionaries

1 If a correctly spelled word is displayed in the Not in Dictionary box 
on the Check Spelling dialog (see "Spell checking" on page 92), the 
word should be added to a user dictionary. 

2 Select the desired dictionary under Add words to and click Add.

3 The word is added to the dictionary with the default setting of Ignore, 
and will no longer be marked as misspelled.

You can choose to send the word to the userdic.tlx, which is a general-
purpose user dictionary. We recommend that you select this user 
dictionary in the Add Words To list so words will be added to it when 
you click the Add button in the Check Spelling dialog.
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To add words to the custom dictionaries with settings other than 
Ignore

1 On the Check Spelling dialog, click Dictionaries.

2 The Dictionaries dialog appears.

The Dictionaries dialog allows you to add and remove user 
dictionaries and edit the contents of any added user dictionary. 

3 Open the drop-down list under Dictionaries. 

Here you can see a list of all associated user dictionaries for that 
language. The default dictionary is userdic.tlx. 

In our case we would like to add Wotr to our German user dictionary 
with the setting Automatic Change to Wort.

4 Enter "Wotr" under Words and Wort under Replace with.

5 Open the drop-down list under Action and select Automatic 
Change.

For information on how to create other dictionaries, see "To create a 
new dictionary" on page 190.
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6 Click on Add Word.

7 Click Close. The next time you encounter Wotr in your German spell 
check, it will automatically be changed to Wort.

Other possible settings include:

Automatic change - preserve case—This automatically 
changes the word while preserving the case of the original (in our 
case, "wotr" would have been changed to "wort").

Conditional change—This option prompts the defined correction 
in the Change to field in the Check Spelling dialog.

Conditional change - preserve case—This option prompts the 
defined correction in the Change to field in the Check Spelling 
dialog while preserving the case of the original.

Exclude (always treat as misspelled)—This option always 
treats that word as misspelled.

Ignore—This option, which is the default setting, always ignores 
the word during spell checks.

You can also delete or edit words in the same dialog.
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To create a new dictionary

1 On the Check Spelling dialog, click Dictionaries.

2 The Dictionaries dialog appears.

3 Click on New File in the Dictionaries dialog.

4 The New Dictionary dialog appears.

5 Click Browse and select a name and path for your new dictionary.

6  Select a language from the drop-down list under Language.

7 Click OK.

The default path for dictionaries is C:\Program Files\Atril\Deja Vu 
X\Spelling\<LanguageCode> (on an English Windows installation) but 
you are free to save it elsewhere.
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8 You are returned to the Dictionaries dialog. If you select the drop-
down list under Dictionaries, you can now see the added dictionary.

To add existing dictionaries

1 On the Check Spelling dialog, click Dictionaries.

2 The Dictionaries dialog appears.

3 Click on Add File in the Dictionaries dialog.

Situations where it may be useful to add dictionaries may include 
projects where you have a very specific vocabulary that may not be 
valid for other projects.
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4 The Select Name and Location of the User Dictionary dialog 
appears.

5 Select name and location of the new dictionary and click Open.

6 The dictionary is added.

To import a dictionary

It is possible to import 

existing .tlx dictionaries from earlier versions of Déjà Vu or other 
programs that use the same spell checker,

simple text files (with words listed in a simple column format), or

While it is possible to simply add the existing user dictionaries of the 
"ignore" type of an earlier version of Déjà Vu, you should be aware that 
this will automatically change the internal file format which makes them 
unusable for Déjà Vu 2 or 3 installations. A better way of adding these 

would be to import them into existing Déjà Vu X Standard user dictionaries (see 
"To import a dictionary" on page 192).
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external .dic files (such as from an Office installation).

While words from the .dic files and text files can only be included in the 
"ignore" property, words from existing .tlx dictionaries will retain the 
property they had previously (automatic or conditional change, ignore, or 
exclude).

1 On the Check Spelling dialog, click Dictionaries.

2 The Dictionaries dialog appears.

3 Make sure that the dictionary you want to import into is selected 
under Dictionaries.

4 Click on Import.

To find the installation path of your Microsoft Office dictionary, open 
Word, select Tools>Options>Spelling & Grammar, and click 
Dictionaries or Custom Dictionaries. In the resulting dialog, you can 
see the full path of your custom dictionary files:
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5 A file selector dialog appears. Select the dictionary that you would 
like to import.

6 Click Save.

7 Depending on the size of the dictionary, the import process can take 
several minutes.

Make sure that you select a dictionary for the correct language!
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8 Once it is finished, you can see the imported entries in the 
Dictionary dialog.

9 Note that the imported entry was correctly interpreted as an 
Automatic change entry.

10 Click Close.

To export a dictionary

The dictionary export function of Déjà Vu X Standard converts the user 
dictionary files into mere text files.

1 On the Check Spelling dialog, click Dictionaries.

2 The Dictionaries dialog appears.

3 Make sure that the dictionary you want to export is selected under 
Dictionaries.

4 Select Export.

5 Select the folder path and the name of the text file.

6 Select Open.
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Chapter 7
Review Features in Déjà Vu X 
Standard—The Details

Translators often encounter passages that are difficult to translate. The 
more you think about them, the harder they become to translate. The 
best way to deal with this would probably be to forget about it for a while, 
continue translating, and come back to it when your mind is fresh. If you 
cannot come up with a good solution even then or you are still not certain 
about your solution, Déjà Vu X Standard provides tools to highlight these 
rows for an editor or another translator.

Bookmarking a Sentence

Déjà Vu X Standard allows you to set a "bookmark" to mark a position in 
a project. All the bookmark commands are available through the 
Bookmarks submenu within the Files menu:

Bookmarks help you to select sentences on the fly that you can later 
easily locate.

To set a bookmark

1 Select the row where you want to set a bookmark.

2 Select Edit>Bookmarks>Toggle.

–Or–

Press Ctrl+B (or Ctrl+F2).

–Or–
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Right-click on the row and select Toggle from the shortcut menu.

3 A Bookmark icon  will appear to the left of the row.

To remove a single bookmark

1 Select the row in which you have previously set a bookmark.

2 Select Edit>Bookmarks>Toggle.

–Or–

Press Ctrl+B (or Ctrl+F2).

–Or–

Right-click on the row and select Toggle from the shortcut menu.

3 The Bookmark icon  at the left of the row will disappear.

To remove all bookmarks

1 Select Edit>Bookmarks>Remove All.

2 All Bookmark icons  will disappear.

To move to the next bookmark after the currently selected row

1 Select Edit>Bookmarks>Next.

–Or–

Press F2.

2 If there are only bookmarks above your current position, the 
following dialog is displayed:
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To move to the previous bookmark before the currently selected 
row

1 Select Edit>Bookmarks>Previous.

–Or–

Press Shift+F2.

2 If there are only bookmarks below your current position, the 
following dialog is displayed:

Marking Sentences as Pending

Déjà Vu X Standard allows you to mark questionable rows as "pending" 
so that you or someone else can come back at a later time to finish or 
review these rows.

To mark a row as pending

1 Right-click the sentence you want to mark as pending and click 
Pending.

–Or–

Press Ctrl+Shift+P.

2 The Pending symbol ( ) appears in the target cell.

To remove the pending status

1 Select the sentence you want to mark as normal (non-pending).

2 Right-click the sentence table and click Pending.

3 The Pending symbol disappears.
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To view all your pending rows

Select Pending Rows from the Rows Selector. For more information, see 
"The Rows Selector" on page 28.

Adding Comments

It is often important to add notes to  communicate something to 
translators or editors who work  you.

To add a comment

1 Right-click on the source or the target section of a row to which you 
want to add a comment and select Add Comment from the context 
menu. 

–Or–

Place your cursor in the source and target section and press Ctrl+M.

2 The Add Comment dialog appears. Here you can enter any 
appropriate comment.

3 Select Apply.
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4 The light blue Comment icon appears to the left of the source or the 
target section of the row.

To view all rows with comments

Select Rows with Comments, Rows with Comments in Source, or 
Rows with Comments in Targets from the Rows Selector. For more 
information, see "The Rows Selector" on page 28.

To review a comment

1 The easiest way to review a comment is to place your cursor over the 
left section of the source or target section of the row.

2 A tooltip-like window will appear in which you can review the 
comment. 

To edit a comment

1 Right-click on the row that contains a comment.

2 Select Edit Comment from the context menu. 

In case the target section already contains an inconsistency mark (see 
"Terminology Consistency Checks" on page 86), the exclamation mark 
will be light violet.
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3 The Edit Comment dialog appears. Here you can edit the existing 
comment or add a response to the comment.

4 Select Apply.

To delete a comment

Right-click on the row that contains a comment and select Delete 
Comment from the context menu. 

–Or–

Press Ctrl+Shift+M.

To delete all comments

Right-click on the row that contains a comment and select Delete All 
Comments from the context menu. 
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Chapter 8
Teamwork Features in Déjà Vu X 
Standard—The Details

Déjà Vu X Standard allows the creation of sub-projects and databases to 
pass on to team members—translators, editors, reviewers, or project 
managers.

There are many benefits to these files:

much smaller size resulting in faster transmission speed

added security by limiting the work of translators/editors to their 
specific language combination (satellites only)

added control by limiting database sharing to the necessary data

greater speed in local area networks by being able to split up files and 
have translators work on their local computers

Pack & Go Packages

Pack & Go packages are highly compressed exports from project files that 
are ideal for the transmission of Déjà Vu X Standard data. The Pack & Go 
feature is available as a stand-alone feature for the transfer of complete 
projects, or as part of the satellite creation for the transfer of even 
smaller bilingual satellite projects (for more information on satellites, see 
"Satellite Files" on page 208).

Opening a Pack & Go package will start the Pack & Go Wizard, which 
will allow you to define where you want to have your new project stored. 
When the translation of the project is finished, you can once again export 
it into the Pack & Go format to transmit it back to the project owner.

To create a Pack & Go project

1 Open the project that you would like to export into a Pack & Go 
package.
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2 Select File>Export>Pack & Go.

3 The Select Location of "New Pack & Go Package" dialog appears.

4 Click on Save after you have selected the folder where you want this 
file to be stored and have named the file.

5 The Pack & Go Export Progress dialog appears.

6 When the export is finished, a new file with the extension .dvpng will 
have been placed in the specified folder. You will notice that the size 
of the .dvpng file is significantly smaller than the originating project 
file:

To open a Pack & Go package

1 Select File>Open.
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–Or–

Click .

2 In the Open dialog, navigate to the location of your Pack & Go 
Package, select All Deja Vu X Files or Pack & Go Projects, and 
select the .dvpng file. 

3 Click Open.
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4 The Pack & Go Import Wizard starts.

5 Click Next and create a project to host your Pack & Go package.

6 Select Next.
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7 The wizard displays the current settings.

8 Click Finish. The wizard shows you the import progress and notifies 
you when the import process is finished.

9 Déjà Vu X Standard displays the open project.
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To translate a project created from a Pack & Go package

Once the file is open, you can start to work in it right away. It may be a 
good idea, however, to first re-adjust the settings of the current project.

1 Select Project>Properties.

2 On the General tab, make sure that the client and subject setting is 
set to match the configuration of your subjects and clients.

3 On the Databases tab, make sure that the project is mapped to 
databases on your computer or network.

To return a Pack & Go package

When you are done with your work on the project file, you can create a 
new Pack & Go package (see "To create a Pack & Go project" on page 
203) and return it to the project owner.

Satellite Files

A satellite file contains only one source and one target language (as 
opposed to a full project file, which typically consists of the source 
language plus a number of target languages) with all the information 
needed by the translator. This information can exclude the formatting and 
image code, thus significantly reducing the file size and making it easier 
to transmit.

A satellite file contains a number of automatic restrictions. It is not 
possible to:

delete files,

split/join rows,

edit the source, or

lock/unlock rows.

For more information on subjects and client, see "Clients and Subjects" 
on page 128.
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If the security options for the originating project file are enabled(for 
information on security, see "Security Features in Déjà Vu X Standard—
The Details" on page 211), users of the satellite files will have to log in 
with a user name and password. This will give them access to a 
predefined security level, which in turn will either permit or prohibit the 
overwriting of translation entered by other users or the project owner.

Once the translation of a satellite is finished, it can be sent back to the 
project owner who can import it into its parent project file.
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Chapter 9
Security Features in Déjà Vu X 
Standard—The Details

Déjà Vu X Standard’s most basic user-based security feature, i.e., the 
tracking of any user’s activities, is enabled by default. Every process that 
any user performs in Déjà Vu X Standard will be associated with his or 
her computer or login name. 

In a Déjà Vu X Standard project created in a version of Déjà Vu X 
Workgroup where the project owner has enabled the advanced security 
features, additional security features will be set up. With these in play, 
translation users can be limited to working in only one language 
combination and will not be allowed to perform any of the following 
activities:

delete files from the project

split/join rows in the project

edit the source in the project

lock/unlock rows and files in the project

merge segments in the translation memories and terminology 
databases

execute SQL statements

access the project/database configuration (the Project/
Translation Memory/Terminology Database Properties 
dialogs)

Each translation user in a project, translation memory, or terminology 
database with the enabled advanced security features has one of nine 
different stages of permission levels. Users with the highest security 
clearance can overwrite anything from users of the other eight levels; 
users with the lowest level are unable to overwrite anything from any 
user except one with the same level.
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Furthermore, the ability to import and/or export data in and out of 
projects, translation memories, or terminology databases has to be 
individually assigned to each translation user.

If you work in a project with advanced security features, you will have to 
log yourself into that project with the user name and password provided 
by the project owner.

To log into a project, translation memory, or terminology 
database

1 Select Users>Login.

2 The User Login dialog appears.

3 Enter your user name and password and click OK.

4 Every record that you edit or translate will now be associated with 
that user name

in the status bar of the project:

–Or–
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in the translation memory or terminology database:

and be protected by your particular set of rights.

To log out from a project, translation memory, or terminology 
database

1 Select Users>Logout.

2 You are now logged out of the project.

Because the login will not notify you if your profile is not part of this 
project or database, it may be a good idea to try logging in again if you 
are blocked from activities that your security clearance should enable 
you to do.

To repeat a login, you do not have to first log out.

You do not have to log out of a file to log into that file with a different 
logon. The function of the logout feature is merely a security feature 
that, for instance, allows an administrator to work on someone else’s 
computer, log in with the administrative password, and simply log out 

when the task is finished.
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Chapter 10
Analysis Features in Déjà Vu X 
Standard—The Details

Déjà Vu X Standard offers two different project analysis features that 
allow you 

to count words, characters, and embedded codes in a number of 
different configurations and 

to analyze the repetition within your project and the number of exact 
and fuzzy matches from your existing translation memory(s).

The Count Feature

Because of the different attributes that Déjà Vu X Standard applies to 
every row within a project, word counts can be a very complex matter. 
While some attributes are mutually exclusive (e.g., a row cannot be a 
fuzzy and a perfect match at the same time, or a row cannot be 
simultaneously locked and pending), the combination of other attributes 
makes sense and may be of interest to the user (e.g., a row can be an 
exact match and be finished). To satisfy the need for an accurate overall 
word count as well as detailed word counts of all attributes and possible 
combinations, Déjà Vu X Standard offers two different count modes 
(Simple and Full) that use three different groups of categories.

The first mutually exclusive group is that of the flagged categories:

Finished ( ),

Locked ( ),

Pending ( ),

Unmarked (i.e., the non-flagged translation status).
Déjà Vu X Standard 215



Analysis Features in Déjà Vu X Standard—The Details
The second mutually exclusive group is that of mutually exclusive 
translation status categories:

Empty (default grey indicator bar),

Manual (default grey indicator bar),

Exact (default dark green indicator bar),

Guaranteed Exact (default orange indicator bar),

Fuzzy (default light green indicator bar),

Assembled (default dark blue indicator bar),

Exact Propagated (default light blue indicator bar), and

Fuzzy Propagated (default gold indicator bar).

The third group consists of several unrelated categories that are 
counted by Déjà Vu X Standard independently of the preceding 
categories (and are counted independently of the total count):

Multiple Matches (indicator: blue, underlined font),

Renumbered Matches (i.e., exact matches in which either 
embedded codes or numerical values were renumbered)

Stopped ( )

Wrong Codes ( )

Duplicates (i.e., duplicated source sentences in a file or project)
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What does all of this mean in practice?

Here is the simplest word count module (Current Language, All Files, 
Simple): 

In this count, the flagged categories (Unmarked, Finished, Locked, 
and Pending) are the main categories that make up the Total, and the 
status categories are treated as sub-categories of the Unmarked 
category.

All other categories are counted independently of the Total.

This count is most suitable for a quick overview of the dimensions of the 
project.
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Following is the same word count module for the same project in Full 
mode:

In this count, the status categories are the main categories that make up 
the Total, and the flagged categories (Unmarked, Finished, Locked, or 
Pending) are treated as sub-categories to the status categories.

Even though the Total numbers are the same as in the previous count, 
you can see that the numbers of the different status categories are 
slightly different. In the graphic above, for example, 4 lines of the 
manually translated rows have been flagged as Finished, 1 as Locked, 
and 1 as Pending. In the simple word count these categories were 
counted individually as the main categories, so a total of 181 instead of 
187 was given for Manual Translation (which was a sub-category).

All other count modules are derivatives of these two modules with the 
current or all languages, the current, for each or for all files, or with or 
without repetition count.
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To count the words and characters in a single file or the whole 
project

1 In an open project, select Tools>Word Count. 

–Or–

Press Ctrl+W.

2 The Word Count dialog appears with individual tabs to display 
counts for Words, Characters, and (Embedded) Codes. 

3 Make your selections from the following options:

Language—View the counts for the current language (the language 
combination that you are currently viewing) or all languages.

Files—View the counts for the currently displayed file (this option is 
disabled if you are using the All Rows view) or for all files.

If you only want to count the words in a single file, you will have to 
make sure that you view only that file.
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Output—View simple or full counts (see page 215).

Miscellaneous—Check whether you would like to have the words, 
characters, and codes in duplicate rows counted.

4 Select Calculate.

5 The desired word count is displayed.
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6 To view the corresponding character count, select the Character tab.
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7 To view the corresponding count of embedded codes, select the 
Codes tab.

To save the results in an external file format

1 Select Copy in the Word Count dialog.

2 Open a text editor or word processor.

3 Paste the text into a new document.

–Or–

1 Select Save in the Word Count dialog.

2 A file selector dialog appears.

3 Choose the folder in which the file is going to be saved, name the file, 
and select whether your want to save it as a text file or as a comma-
separated value (.csv) file.

4 Click Save.
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If you selected CSV as the output type and have Microsoft Excel 
installed on your computer, this file will open by default in Excel.

You can see that numbers—including words, characters, and codes—
are displayed in the external file format.

The Analysis Feature

The analysis feature allows you to analyze the amount of matches from 
your translation memory(s) in a variety of degrees of fuzziness, as well as 
the repetition within your project.

To analyze the repetition of sentences in a project

1 In a newly-created project, select Tools>Analysis.

–Or–
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Press Ctrl+Shift+W.

2 The Analysis dialog appears.

This dialog gives you access to an analysis of the following data for 
each language at the current state of the project:

number of guaanteed and exact matches from the translation 
memory(s);

duplicates within the project;

number of fuzzy matches in various levels (percentages) of 
fuzziness from the translation memory(s);

You can perform the Analysis function at any point during the translation 
of your project (before pre-translation or well into the translation), but 
you will probably gain the best overview and the most benefit from the 
analysis if you do this before you start your actual translation work.
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total number of (source) words in the project;

total number of matches;

internal repetition of portions in percentage.

3 Select the language for which you want to perform the analysis and 
click Analyze.

4 Repeat this procedure for every language in your project.

To save the results in an external file format

1 Select Copy in the Analysis dialog.

The internal repetition percentage will give you a good idea of how 
useful features such as Assemble and the Lexicon will be!
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2 Open a text editor or word processor.

3 Paste the text into a new document.

–Or–

1 Select Save in the Analysis dialog.

2 A file selector dialog appears.

3 Choose the folder in which the file is going to be saved, name the file, 
and select whether your want to save it as a text file or as a comma-
separated value (.csv) file.

4 Click Save.
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Chapter 11
Working with Different File 
Formats

One of Déjà Vu X Standard’s distinctive advantages is that you have the 
possibility of working with a wide range of file formats. Whatever type of 
file you work with, Déjà Vu X Standard presents you with a uniform 
interface, displaying only translatable text, so you can work comfortably 
without having to worry about overwriting formatting and layout 
information.

Déjà Vu X Standard has built-in filters that allow you to work with:

Microsoft Word (see p. 239)

RTF (see p. 245)

Microsoft PowerPoint (see p. 246)

Microsoft Excel (see p. 247)

OpenOffice.org/StarOffice (see p. 250)

Microsoft Access (see p. 251)

FrameMaker (see p. 253)

PageMaker (see p. 261)

QuarkXPress (see p. 266)

InDesign (see p. 269)

Interleaf/Quicksilver (see p. 273)

Plain Text (see p. 274)

Help Content (.cnt) (see p. 274)

HTML (including scripts and ASP) (see p. 275)
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SGML/XML (for more information on SGML, see p. 279)

Java Properties (see p. 283)

RC (see p. 283)

C/C++/Java source files (see p. 285)

GNU gettext files (see p. 287)

IBM TranslationManager (see p. 289)

Trados Word/RTF (see p. 290)

Trados TagEditor (see p. 292)

TMX (see p. 294)

All of these formats are recognized by their appropriate extensions but 
can be reconfigured.

To reconfigure the default relationship between file format and 
file extension

1 If you need to change the default association between file format and 
file extension, select Project>Properties>Filters.

An example of when this may become necessary would include 
situations where you continuously have to work with Interleaf or Trados 
documents, both of which have the .doc extension, which by default is 
assigned to Word. 
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2 The Filters tab in the Project Properties dialog appears.
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3 Select the extension for which you want to have the association 
changed.
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4 Select a new association from the drop-down list at the bottom of the 
screen.
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5 Click Replace.

6 Click Apply and/or OK.

7 A new default extension-filter association has been created. Now 
during the import process, the Interleaf filter will be applied to every 
.doc file.

To reconfigure the individual relationship between file format and 
file extension

When importing through the Project Explorer, the default extension-
filter association can be changed on an individual file basis. For more 
information on how to import files through the Project Explorer, see "To 
import files with the Project Explorer" on page 49.

When you import through the New Project Wizard, these options are 
not available. If you would like to apply some of these options to 
already-imported files, you can re-import them through the Project 
Explorer.
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1 When selecting a file for import in the Project Explorer, the default 
extension-filter association is displayed in a pane labeled Properties 
on the right side of the screen.

2 Click the drop-down arrow that appears when you select the Filter 
row, and select the desired filter for this specific file.

3 The new filter will be applied to this file during the import process.

To apply specific import options

When importing through the Project Explorer, all of the file formats 
have file-specific import options that you can select and apply to the 
import process.

1 When selecting a specific file or several files of the same format in the 
Project Explorer, the import options for that format will be 

When importing through the New Project Wizard, these options are 
not available.
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automatically displayed in a pane labeled Properties on the right 
side of the screen.

2 Make the appropriate selections by checking the check boxes.

3 Right-click the file name and select Import from the context menu.

4 The file is being imported with the options you specified.

To apply project-wide import options for each file extension

Rather than specifying the format-specific import options for single or 
small numbers of files, it can be helpful to change the default option on a 
project-wide basis. This is especially advantageous when importing large 
projects in numerous folders and subfolders. 

You can change the options on the basis of the file extension. This means 
that although .htm files may be of the same format as .html files, they 
could have different import options.

1 Select Project>Properties>Filters.
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2 The Filters tab in the Project Properties dialog appears.
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3 Select the extension for which you want to change the default import 
option for the current project.

4 Select the selector button ( ) to the right of the filter options in the 
lower part of the dialog.
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5 The Filter Options dialog appears where you can make the desired 
changes.

6 Click OK.

7 Click Apply and/or OK.

8 The default filter options for every file with the extension .htm have 
been created for this project.

Global Import Options

Prevent Segmentation

There is one option that is common to all file formats: Prevent 
Segmentation. In fact, if you choose to import several files of more than 
one file format with the Project Explorer, this option will still be 
displayed in the Properties window.

By checking this option, you override all segmentation rules that you set 
under Tools>Options>Delimiters. For more information on setting up 
segmentation rules, see "Sentence Delimitation" on page 169.

The only segmentation rules that will still be followed when this option is 
checked are 
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hard returns or their equivalents,

the end of cells (such as in tables or in Excel), or 

the end of other already-marked segments (such as in Trados or IBM 
TM files).

Encoding

Encoding is an import and export option for a variety of formats, 
including:

C/C++ and Java

Help Contents

IBM TranslationManager

Java Properties

Microsoft Access 

QuarkXPress

PageMaker

Interleaf/Quicksilver

HTML

JavaScript/VBScript

RC Files

SGML/XML

Text

TMX (only during export)

BIF (only during export)

InDesign (only during export)

You should use this option sparingly. As a rule of thumb, the larger your 
translation segments become, the more difficult it will be for your 
translation memory to come up with good matches. Situations where 
this option may prove to be helpful could include software source files 

(RC, C/C++, Java) where existing glossaries often contain complete strings that 
encompass several sentences, documents that are to be translated very freely 
(across source sentence levels), or documents that are imported into Déjà Vu X 
Standard for the purpose of editing or proofreading.

The only file format for which this option is enabled by default are RC files.
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Clicking on the down-arrow at the end of the encoding line allows you to 
define a code page for the file(s) you are importing and/or exporting.

If a selection is not made during the import, Déjà Vu X Standard will 
select the code page that it recognizes in the source file (i.e., a Unicode 
UTF-8 file will be imported with that code page).

If you do not make a selection during the export, Déjà Vu X Standard will 
select the best code page based on the following information:

code page of the source file

the target language

the actual text found in the target file

the file format

Microsoft Word

Déjà Vu X Standard includes support for Microsoft Word documents (.doc 
files). No special procedure is required to translate them; however, you 
must have Microsoft Word installed on your computer. Déjà Vu X 
Standard supports Word 6.0, 95 (7.0), 97 (8.0), 2000 (9.0), and XP 
(2002 or 10.0).

It is recommended that you use Word 97 or higher due to limitations in 
previous versions.
Déjà Vu X Standard 239



Working with Different File Formats
Word-Specific Import Options

Ignore Hidden Text

This option controls whether hidden text in a Word document will be 
displayed in Déjà Vu X Standard. 

Situations where this is a very helpful option include:

documents where you want to only translate a certain section and in 
which you can choose to hide the sections that are not translatable;

documents that contain hidden code, including WinHelp source files 
that contain hidden text defining "jumps" within the Help (see graphic 
below).

Non-translatable Notes

The option for non-translatable notes refers strictly to WinHelp source 
files that contain footnotes, some of which are translatable and others 
which are not.

If you do not translate Help files, you do not have to worry about 
modifying this setting.
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In the following example of a WinHelp file, you can see both the hidden 
text and the markers for the footnotes.
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Word-Specific Export Options

When you export a Word document, you will be presented with the 
following filter-specific options:

Export source comments as Office comments—allows the export of 
source comments to Microsoft Word comments.

Export target comments as Office comments—allows the export of 
target comments to Microsoft Word comments.

Highlight text in exported files—allows the highlighting of text 
according to the translation status in Déjà Vu X Standard.

Selecting the Highlight text option activates two more options:

Highlight options—lets you access a dialog that allows you to select 
what kind of rows should be highlighted in what manner.

Highlight order of preference—lets you choose whether rows with 
Translation Status (pending, locked, etc.) or Match Type (exact, fuzzy, 
assembled, etc.) should take preference.
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Clicking on the file selector button on the Highlight options row (the file 
selector only becomes activated when you actually select the row) brings 
up the Row Highlight Options dialog.

Clicking Add lets you select individual formatting options (including any 
combinations of bold, italics, underline, strikethrough, text color, or 
underlying color) for as many different Row Types as you like.

When you are done with your selection, click OK.

Assuming that the Word file in the following Déjà Vu X Standard project 
had one pending line and one comment—
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—and the user chooses to display comments in Word and highlight 
pending rows in bright magenta, the exported file would look like this:

This is the display of Word XP. Earlier version of Word display comments 
when the mouse cursor is moved over the inserted comment.

Tips and Tricks with Word

When importing Word documents, Déjà Vu X Standard will run macros in the 
Word program that you have installed. If your version is Word 2000 or higher, you 
will have to set the security settings (Tools>Macro>Security) in Word to 
Medium or Low to be able to import and export Word files. 

If character spacing was used in your document, it is advisable to take that out 
before importing the document into Déjà Vu X Standard. You can do that by 
selecting the complete document (Ctrl+A) and then selecting 
Format>Font>Character Spacing>Spacing>Normal.

If you have used the Track Changes or the Comments function in Word, make 
sure that you accept all changes and delete all comments before you process the 
Word document. Otherwise, you will see both options (before and after edit) as 
well as the text of the comments displayed in Déjà Vu X Standard.
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RTF (Rich Text Format)

The options for RTF files are almost identical to that of Word (see 
"Microsoft Word" on page 239), only that there is no need to have an 
installation of Word on your computer and therefore the security settings 
in Word have no influence on the import process.

If you import a Word document from Word 97 or any higher version that contains 
text boxes, the text in these will be duplicated in the Déjà Vu X Standard project. 
The Word document contains duplicates of the text boxes to guarantee the 
compatibility with earlier versions.

Finally, it is possible to make good use of Word’s AutoFormat option. It’s not 
possible to add formatting that is not contained in the source documents to your 
Word documents directly within Déjà Vu X Standard , but you can enclose words 
with certain characters (such as _these_ for italics and *these* for bold 
formatting) and use Word’s AutoFormat feature (Tools>AutoFormat) to apply 
the desired formatting. Here are the preconfigured AutoFormat options that Word 
offers:

 

Déjà Vu X Standard adheres strictly to the Microsoft RTF standard of 
Word 2002 and lower, and will process any files that follow that 
standard. There are several non-Microsoft applications that export RTF 
files; in some situations, these applications may export RTF files that do 

not conform to the standard. In such cases, it is possible that Déjà Vu X Standard 
may not be able to correctly import those RTF files.
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Microsoft PowerPoint

As is the case with Word files, no special procedure is required to 
translate PowerPoint .ppt files. However, you must have Microsoft 
PowerPoint 97 (or later) installed on your computer.

PowerPoint-Specific Import Options

Process notes

This option controls whether PowerPoint notes are included in the 
translation project. To see whether you have notes in your project, open 
the PPT file in PowerPoint and select View>Notes Page.

Because of the way in which Déjà Vu X Standard works with PowerPoint 
files, once a translation is finished and ready to be exported, the 
original, unaltered .ppt file must be in the location from which it was 
imported. This is essential, because any slight modification to the file 

may prevent Déjà Vu X Standard from being able to export the final translation.
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Process Slide Master

This option controls whether the Slide Master that contains formatting 
information is to be included in the translation project. Typically you do 
not need to translate the information on the Slide Master.

Microsoft Excel

As with Word files, no special procedure is required to translate Excel .xls 
files. However, you must have Microsoft Excel 97 (or later) installed on 
your computer.

Because of the way in which Déjà Vu X Standard works with Excel files, 
once a translation is finished and ready to be exported, the original, 
unaltered .xls file must be in the location from which it was imported. 
This is essential, since any slight modification to the file may prevent 
Déjà Vu X Standard from being able to export the final translation.

Excel-Specific Import Options

Tips and Tricks with PowerPoint

PowerPoint files are often written by people who are inexperienced in formatting 
documents. Instead of using styles and correctly sized text boxes, they tend to 
use soft returns and hard returns to force line breaks. Déjà Vu X Standard will 
ignore soft returns by default, but it will break a segment in which a hard return 
occurs. To avoid that, it is a good practice to go through the PowerPoint document 
and replace all the unnecessary hard returns with soft returns.

PowerPoint files often contain graphics that at first sight look just like text. If 
there is a whole slide or a part of a slide that has not been imported into Déjà Vu 
X Standard, make sure that this is not a graphic or another non-translatable 
object. To do that, you can right-click that specific area in the open PowerPoint 
file. If one of the options is either Format Picture or Format Object, chances are 
that you will not be able to use Déjà Vu X Standard for the translation of this.
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Ignore Red Text

Excel files often contain both translatable information and other 
information that you do not want to have translated. Instead of having to 
go through an imported Excel file and manually sorting out the 
information that needs to be translated, you can open the file in Excel, 
highlight the cells that do not have to be translated, and paint them red 
by selecting Format>Cells>Font>Color. 
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Déjà Vu X Standard will now ignore text in these cells when it imports the 
file. When the file has been translated and exported, you can remove the 
red formatting.

Tips and Tricks with Excel

It is not possible to join lines in Excel files between sentences. You will, however, 
be able to join two sentences that originate from the same cell.

In situations where a target column has to be added to a source column (rather 
than overwriting the existing source), you can duplicate the source column within 
Excel and paint the first of the columns red. If you then enable Ignore Red Text 
during the import into Déjà Vu X Standard, the first column will not be imported 
and thus not be changed, and the second column will be imported and translated.

Some Excel installations do not immediately respond to the macro that Déjà Vu X 
Standard runs in Excel to import or export the files. If you are experiencing this 
kind of delay, press the Tab key. This should bring up the following dialog:

Click Switch To to start the macro in Excel.

The size of some Excel files grows exponentially when certain tables or columns 
are carelessly formatted to the end of the spreadsheet rather than the necessary 
cells. This can cause Excel to save hundreds of thousands of unnecessary cells. To 
limit both the size of the Excel file and the resulting Déjà Vu X Standard project to 
the appropriate size, you can copy the necessary content of the spreadsheet in 
question into a new spreadsheet, delete the old spreadsheet, and rename the 
newly created one with the correct name.
Déjà Vu X Standard 249



Working with Different File Formats
OpenOffice.org/StarOffice

Déjà Vu X Standard directly supports the compressed XML-based format 
of files of OpenOffice.org and StarOffice 6. The supported file types 
include word processing (.sxw), spreadsheets (.sxc), and presentations 
(.sci). There is no need to disassemble any of the files before translation 
or reassemble them after the export—Déjà Vu X Standard does all that 
for you.

Tips and Tricks with OpenOffice.org/StarOffice files

If you have used the Record Changes or the Notes function in a .sxw or .sxc 
document, make sure that you accept all changes and delete all comments before 
you process the document. Otherwise, you will see the corrected option displayed 
at the beginning of the document as well as the text of the notes displayed in Déjà 
Vu X Standard.

Like in Word, it is possible to make good use of OpenOffice.org/StarOffice’s 
AutoFormat option. It’s not possible to add formatting that is not contained in the 
source documents to your .sxw documents directly within Déjà Vu X Standard, 
but you can enclose words with certain characters (such as _these_ for underline 
and *these* for bold formatting) and use OpenOffice.org/StarOffice’s AutoFormat 
feature (Tools>AutoCorrect/AutoFormat) to apply the desired formatting. 
Here are the preconfigured AutoFormat options that OpenOffice.org/StarOffice 
offers:
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Microsoft Access

Though the translation of database content has become very important, it 
still presents a great challenge to translation memory tools.

Typically, only a small part of the database—often only one field 
(of many hundred existing ones)—needs to be translated.

By overwriting the content of the translatable field, relationships 
may get lost.

The records may contain a variety of text—including HTML, RTF, 
and SGML, to only name a few—for which other specified filters 
are necessary.

Déjà Vu X Standard has found creative ways to deal with these 
challenges, and it supports Access97, 2000, and XP (2002) files. 

Access-Specific Import Options
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When you select the Custom field, an ellipsis button appears to the right 
of that line. If you click that button, the ODBC Import Options dialog 
appears.

In this dialog, you can see the tables of the database in question (under 
Tables), the fields or columns in each of the tables (under Columns), and 
you can see samples of the content of the fields on the right side of the 
dialog. By default, all fields are selected as non-translatable; indeed, in 
this example, only one field, "s_content," needs to be translated.
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By selecting that field, checking the Translate check box, specifying the 
type of text that needs to be translated (in this example Plain Text), and 
specifying that the translation should be sent to the field "t_content" 
under Send translation to field, you can easily set up the translation of 
the relevant content of this database.

For options to define the code page during export and import, see 
"Encoding" on page 238.

Adobe FrameMaker

Déjà Vu X Standard includes support for Adobe FrameMaker 5, 5.5, 6, 
and 7 MIF files.

Déjà Vu X Standard cannot import FrameMaker binary FM files; if you 
have an FM file that you want to translate in Déjà Vu X Standard, you 
must convert it to MIF format.
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To convert an FM file to MIF format

1 Open the file you want to convert in Adobe FrameMaker 5, 5.5, 6, or 
7.

2 On the File menu, click Save As.

3 The Save Document dialog appears.

4 Select the path you want to save the document to.

5 Click the Save as type dropdown list and select MIF (*.mif).

6 Change the extension of the file name to .mif.

7 Click Save.

If you do not own a copy of FrameMaker, you should ask your client to 
send FrameMaker files in MIF format.
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FrameMaker-Specific Import Options

Encoding

For general options to define the code page during export and import, see 
"Encoding" on page 238.

FrameMaker does not support Unicode, but Déjà Vu X Standard offers the 
six different supported East Asian code pages plus Western European 
(Windows) as choices during import and export. 

If you do not select a specific code page, Déjà Vu X Standard will select 
the best code page for the source language (import) or target language 
(export).

Exposable Markers

The default setting for exposable markers is 2 (index markers). This is a 
setting that you probably do not want to change, as index markers 
usually are the only translatable markers.

Ignore Variable Definitions

If checked, Déjà Vu X Standard will ignore all variable definitions, such as 
the book title.
Déjà Vu X Standard 255



Working with Different File Formats
Ignore Automatic Numbering

If checked, Déjà Vu X Standard will ignore all automatically generated 
automatic numbering information, such as Section 1.1.1.1 or Table 
1.1.1.1.

Ignore Cross-Reference Definitions

If checked, Déjà Vu X Standard will ignore all automatically generated 
cross-reference format texts, such as See XX on page XX, etc.

Ignore Text on Master Page

If checked, Déjà Vu X Standard will ignore all text on the master page, 
including all non-variable information in the header and footer.

Convert Hard Spaces to Soft Spaces

If checked, Déjà Vu X Standard will convert all non-breaking spaces 
(inserted into the FrameMaker document with the key combination 
Ctrl+Space) to regular spaces. If unchecked, Déjà Vu X Standard will 
embed all non-breaking spaces with an embedded code. Generally, this 
option should be enabled.

Font Mapping

Because FrameMaker does not support Unicode, it may be necessary to 
change the fonts for translations into languages that use a completely 
different font system from your source language (i.e., from English to 
Chinese, or from Japanese to German). 
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To access the MIF Font Mapping tab, select Project>Properties>MIF 
Font Mapping.

You can now see a list of all fonts and their properties used in the 
FrameMaker files within your project. 

To make changes to the individual fonts, select a different font by clicking 
the down arrow to the right of the Map to row and making the other 
appropriate changes in each of the other rows (Angle: regular or italic; 
Weight: regular or bold; Variant: regular, oblique, narrow, or 
condensed; Size; and—in the case of Japanese—Tsume: to move a 
character closer to the next).

When you are done with your changes, click Apply and/or OK.

You can also change the fonts globally by selecting Global Replacement 
and selecting a different font by clicking the down arrow to the right of 
the Map to row in the Global Font Replacement dialog.
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By using the up and down arrows to the right of the Size delta rows, you 
can make proportional adjustments to the size of the fonts.

FrameMaker-Specific Export Options

When you export a FrameMaker document, you will be presented with the 
following filter-specific options:

Export source comments as conditional text—allows the export of 
source comments to the DVXSourceComments condition.
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Export target comments as conditional text—allows the export of 
target comments to the DVXTargetComments condition.

Highlight text in exported files—allows the highlighting of text 
according to the translation status in Déjà Vu X Standard.

Selecting the Highlight text option activates two more options:

Highlight options—lets you access a dialog that allows you to select 
what kind of rows should be highlighted in what manner.

Highlight order of preference—lets you choose whether rows with 
Translation Status (pending, locked, etc.) or Match Type (exact, fuzzy, 
assembled, etc.) should take preference.

Clicking on the file selector button on the Highlight options row (the file 
selector only becomes activated when you actually select the row) brings 
up the Row Highlight Options dialog.

Clicking Add lets you select individual formatting options (including any 
combinations of bold, italics, underline, strikethrough, or text color) for 
as many different Row Types as you like.

When you are done with your selection, click OK.
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Assuming that the FrameMaker file in the following Déjà Vu X Standard 
project had one pending line and one comment—

—and the user chooses to display target comments in FrameMaker and 
highlight pending rows in bright magenta, the exported file would look 
like this:

 

You can choose to display or hide conditions in FrameMaker with the 
command Special>Conditional Text>Show/Hide.
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Adobe PageMaker

Déjà Vu X Standard includes support for Adobe PageMaker 6.5 and 7 
files.

To process Adobe PageMaker documents, you must first save the text you 
want to translate as a "tagged text" file.

To export a story

1 Open the file you want to process in PageMaker.

2 In Layout view, click anywhere on the story you want to export.

3 Select Edit>Edit Story.

4 The story appears as editable text. 

5 Select File>Export>Text.

Tips and Tricks with FrameMaker

If all files of your FrameMaker book follow one or possibly two sets of formats, 
you can avoid a large amount of repetition in your project by doing the following: 
Uncheck all the special "Ignore" options for one representative file and check 
them for all other files. Once you have exported all of your files, you can import 
the formats of the representative file to all other files (in FrameMaker, select, 
File>Import>Formats).

Make sure that your FrameMaker files do not contain any change bars (markers 
that indicate changes to the file). To delete existing change bars, select 
Format>Document>Change Bars>Clear All Change Bars. 

If you need to convert FrameMaker books with a great number of files, it is 
tedious to convert these files individually. The little utility MifSave allows you to 
batch-convert all files of one book. For more information, check the tools section 
of the Frame User group at frameusers.com.

To re-import a file that has already been exported as a MIF file from a Déjà Vu X 
Standard project, you will have to open that file in FrameMaker, save it as an FM 
file, close and re-open that FM file in FrameMaker, and save it as MIF.
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6 The Export Document dialog appears.

7 Select the correct export location.

8 Accept the default name or enter a name for the export file.

9 Click the Save as type dropdown list and select Tagged text.

10 Make sure the options Entire story and Export tags are selected.

11 Click Save.

You can either repeat this procedure for each text chain (which 
constitutes a story) in the PageMaker document, or you can combine and 
export all stories within one document.

To combine and export stories

1 Open the PageMaker document from which you want to combine and 
export stories.

2 Select File>Save As. 

3 Save the document as A copy in 6.0 format (PageMaker 7: A copy 
in 6.5 format).

4 Open a new PageMaker publication by selecting File>New.
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5 In the Document Setup dialog, adjust the settings to match the 
settings from the original.

6 Select File>Place, select the formerly saved document, and then 
click OK.

7 The Place PageMaker Stories dialog appears, listing every story in 
the publication in the order in which they were placed.

8 If necessary, enter 1 into the characters field to include all stories and 
click Relist.

9 Click Select All to combine all stories in the document, or hold down 
the Shift key while clicking on the stories you want to combine, and 
then click OK.
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10 The pointer changes to a loaded icon ( ).

11 Click the loaded icon. All the stories are pasted into the new 
document as one story.

12 To export this story into a text file, see "To export a story" on page 
261.

When you have imported, translated, and exported the tagged TXT file in 
Déjà Vu X Standard, you have to replace the text into the PageMaker 
document.

To re-import the story

1 Make a copy of the original file from which you exported the tagged 
text file.

2 Open the copy in PageMaker.

3 In Layout view, click anywhere on the original story you want to 
replace.

4 On the Edit menu, click Edit story.

5 On the File menu, click Place.

This procedure will not copy any non-text items (such as graphics) into 
the new document, so you will have to either manually paste those into 
the new document or revert to exporting each story individually in the 
old document.
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6 The Import to Story Editor dialog appears.

7 Select the TXT file which Déjà Vu X Standard has exported (the one 
containing the final translation).

8 Make sure that the following options are selected:

In the Place option group: Replacing entire story.

In the Options option group: Retain format, Convert quotes, 
and Read tags.

9 Click Open.

10 The translation is being imported.

Encoding

For general options to define the code page during export and import, see 
"Encoding" on page 238.
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Because PageMaker does not support Unicode, none of the Unicode code 
pages is offered. If you use the default encoding option, Déjà Vu X 
Standard will select the code page that is used in the file (import) or 
select one according to the target language (export).

QuarkXPress

Déjà Vu X Standard includes support for QuarkXPress 4 and 5 files.

To process QuarkXPress documents, you must first save the text you 
want to translate as an XPress Tag file.

To export text as an XTG file

1 Open the file you want to process in QuarkXPress.

2 Make sure that the Content tool ( ) is selected. If it is not 
displayed, press F8.

3 Click the text box that contains the beginning of the text chain you 
want to export.

4 Select File>Save Text.

Tips and Tricks with PageMaker

PageMaker files are often delivered in Mac format. Though it is usually no problem 
to open these files on a PC, your client may not want you to convert these files to 
PC files. To avoid problems with special characters in the original or translated 
TXT files, you will have to change the code page of the tagged file between Mac 
and Windows. Do this by selecting a Mac code page during the import and export 
processes.

Double-byte PageMaker files (Chinese, Japanese, Korean) can only be opened and 
processed on a native (Chinese, Japanese, or Korean) version of PageMaker.
266 Déjà Vu X Standard



Working with Different File Formats
5 The Save Text dialog appears.

6 Select the correct export location.

7 Enter a name for the export file.

8 Click the Save as type dropdown list and select XPress Tags.

9 Make sure the option Entire Story is selected.

10 Click Save.

After you have imported, translated, and exported the .xtg file in Déjà Vu 
X Standard, you have to replace the text into the QuarkXPress document.

To re-import the XTG file

1 Make a copy of the original file from which you exported the .xtg file.

2 Open the copy in QuarkXPress.

3 Click the text box containing the beginning of the story you exported.

4 Select File>Get Text.

For each text chain (which constitutes a story) in the XPress document, 
you will have to repeat this procedure because QuarkXPress does not 
provide an automated way of exporting all the stories together.
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5 The Get Text dialog appears.

6 Select the XTG file which Déjà Vu X Standard has exported (the one 
containing the final translation).

7 Make sure that the Include Style Sheets option is selected.

8 Click Open.

9 The translation is being imported.

Encoding

For general options to define the code page during export and import, see 
"Encoding" on page 238.
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As QuarkXPress does not support Unicode, none of the Unicode code 
pages are offered. If you use the default encoding option, Déjà Vu X 
Standard will select the code page which is used in the file (import) or 
select one according to the target language (export).

InDesign

Déjà Vu X Standard includes support for InDesign 2 files.

To process Adobe InDesign documents, you must first save the text you 
want to translate as a "tagged text" file.

To export a story

1 Open the file you want to process in InDesign. 

2 Select the Type tool ( ) and click in the story you want to export. 

3 Select File>Export. 

Tips and Tricks with QuarkXPress

For jobs that contain a large number of stories, we recommend that you obtain a 
copy of CopyFlow, a QuarkXPress XTension for Quark 4.1, or CopyFlow Gold for 
Quark 5. These allow you to export text from all the stories in the document to a 
single TTG file, a format that can be read by the XTG filter (for more information, 
see napsys.com). If you identify yourself as a registered Déjà Vu user, you will 
receive a 15% discount on any purchase of CopyFlow.

Quark files are often delivered in Mac format. Though it is usually no problem to 
open these files on a PC, your client may not want you to convert these files to PC 
files. To avoid problems with special characters in the original or translated TXT 
files, you will have to change the code page of the tagged file between Mac and 
Windows. Do this by selecting a Mac code page during the import and export 
processes.

To open and edit files in a version of QuarkXPress in any other language than 
English, they will have to be saved as a single language (U.S. English) document. 
With (the more expensive) QuarkXPress Passport, other, non-double-byte 
languages can be processed without restriction. Double-byte QuarkXPress files 
(Chinese, Japanese, Korean) can only be opened and processed on a native 
(Chinese, Japanese, or Korean) version of QuarkXPress.
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4 The Export dialog appears.

5 Specify a name and location for the exported story, and select Adobe 
InDesign Tagged Text under Save as Type.

6 Click Save.

7 The Adobe InDesign Tagged Text Export Options dialog appears.

8 Select Verbose under Tag Form and the correct encoding under 
Encoding.

9 Click OK.

Make sure that you select Unicode if you are translating into or from any 
non-Western language. 
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You can either repeat this procedure for each text chain (which 
constitutes a story) in the InDesign document, or you can batch-export 
all stories within one document. For this you will need the Export All 
Stories plug-in from the plug-in section on the Adobe website at 
share.studio.adobe.com.

To batch-export stories

1 Open the InDesign document you want to export.

2 Save the ExportAllStories.exe to your hard drive and open it by 
double-clicking on it.

3 Select Tagged Text and click Export Stories.

4 Select the export folder and click OK.

When you have imported, translated, and exported the tagged .txt file in 
Déjà Vu X Standard, you have to replace the text into the InDesign 
document.

To re-import the story

1 Open the .indd file in InDesign.

2 Select the Type tool ( ) and click in the story you want to import. 

This procedure only exports files into ASCII format, regardless of their 
source language. Tag Converter, a utility available at 
www.clickomania.ch, also allows for a batch export and will 
automatically select Unicode as the export format if there are any non-

ASCII characters in the text.
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3 Select File>Place. 

4 The Place dialog appears.

5 Select Convert Quotes, Retain Format, and Replace Selected Items 
and navigate to the location of your translated file.

6 Select the file and click Open.

7 The translation is being imported.

Encoding

For general options to define the code page during export and import, see 
"Encoding" on page 238.

There is no need to define a code page for the import because Déjà Vu X 
Standard will take that information from the header of each InDesign file. 
The possible export code pages include ANSII, ASCII, Unicode, ShiftJIS, 
and Big5. If you use the default encoding option, Déjà Vu X Standard will 
select the code page according to the target language (export).
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Interleaf/QuickSilver

Déjà Vu X Standard can process Interleaf/Quicksilver ASCII files exported 
with Interleaf 6 or later. Binary Interleaf/Quicksilver files are not 
supported, so make sure that you save the Interleaf/Quicksilver 
documents as ASCII, or ask your client to do so if you do not own a copy 
of Interleaf/Quicksilver.

To save an Interleaf document in ASCII format

1 Open the document in Interleaf/Quicksilver.

2 On the File menu, click Save As.

3 The Save As dialog appears.

4 Select the correct folder and enter the name of the file you want to 
save to.

5 Click the Save as type dropdown list and select ASCII (*.doc).

6 Click Save.

Encoding

For general options to define the code page during export and import, see 
"Encoding" on page 238.
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Plain Text

Déjà Vu X Standard can, of course, process plain text files. For general 
options to define the code page during export and import, see "Encoding" 
on page 238.

All code pages that are supported by Windows can be selected for the 
export or import. If none is selected for the import, Déjà Vu X Standard 
will detect the code page in the file or choose the code page best suited 
for the language in the source file. If no code page is selected for the 
export, Déjà Vu X Standard will choose the best suitable code page for 
the target language and/or the actual content, with a preference to 
Unicode (UTF-16). 

Help Content

Help content files are simple text files that automatically create the table 
of contents in a WinHelp file.

View of a Help Contents .cnt file in a text editor:
 

Déjà Vu X Standard will ignore the non-translatable content following the 
equal signs and the numbers when importing these files.
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Encoding

For general options to define the code page during export and import, see 
"Encoding" on page 238.

All code pages that are supported by Windows can be selected for the 
export or import. If none is selected for the import, Déjà Vu X Standard 
will detect the code page in the file or choose the code page best suited 
for the language in the source file. If no code page is selected for the 
export, Déjà Vu X Standard will choose the best suitable code page for 
the target language and/or the actual content, with a preference to 
Unicode (UTF-16). 

HTML and Script-Based Files

Déjà Vu X Standard includes extended support for HTML and script-based 
files. 

HTML-Specific Import Options

Ignore Strings in Script

This option controls whether translatable text in scripts such as 
JavaScript or VBScript should be translated or excluded. 

Encoding

For general options to define the code page during export and import, see 
"Encoding" on page 238.

Unless you know that there is no translatable text within any script, you 
should not enable this option.
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All code pages that are supported by Windows can be selected for the 
import of SGML files. If none is selected for the import, Déjà Vu X 
Standard will detect the code page from the META tag in the HTML file or, 
if there is no META tag, it will attempt to detect the code page used in the 
file(s) or choose the code page best suited for the language in the source 
file. 

HTML-Specific Export Options

When you export a file that adheres to the HTML specification, you will be 
presented with the following filter-specific options:

Encoding—Regardless of the format of the imported file, you can choose 
to export the files in any of the code pages that are supported by 
Windows. When exporting the file, Déjà Vu X Standard will not only 
change the actual code page but also the corresponding META tag.

In the above example of a Simplified Chinese file, after the export the 
meta tag will read:
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<META http-equiv=Content-Type content="text/html; 
charset=gb2312">

Export special characters as entities—If you select this option, 
special characters will be exported in the appropriate code (© will, for 
instance, be exported as &copy;). If you select Export as they are, they 
will not be converted (© will stay ©).

Export source comments as pop-up text—allows the export of source 
comments to text in HTML pop-ups.

Export target comments as pop-up text—allows the export of target 
comments to text in HTML pop-ups.

Highlight text in exported files—allows the highlighting of text 
according to the translation status in Déjà Vu X Standard.

Selecting the Highlight text option activates two more options:

Highlight options—lets you access a dialog that allows you to select 
what kind of rows should be highlighted in what manner.

Highlight order of preference—lets you choose whether rows with 
Translation Status (pending, locked, etc.) or Match Type (exact, fuzzy, 
assembled, etc.) should take preference.

Clicking on the file selector button on the Highlight options row (the file 
selector only becomes activated when you actually select the row) brings 
up the Row Highlight Options dialog.

If no code page is selected, Déjà Vu X Standard will select a code page 
suitable to the target language and actual language used, with a 
preference to the same code page used during the import.
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Clicking Add lets you select individual formatting options (including any 
combinations of bold, italics, underline, strikethrough, or text color) for 
as many different Row Types as you like.

When you are done with your selection, click OK.

Assuming that the HTML file in the following Déjà Vu X Standard project 
had one pending line and one comment—
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—and the user chooses to display target comments in HTML and highlight 
pending rows in bright magenta, the exported file would look like this:

SGML/XML

SGML stands for Standardized General Markup Language, which is not a 
file type but a metalanguage used to define markup languages. These 
definitions are called Document Type Definitions or DTDs. Each set of 
SGML documents has its DTD, which means that—unlike with Word, 
Excel, or FrameMaker—you will have to teach Déjà Vu X Standard how to 

Tips and Tricks with HTML and Script-Based Files

When you translate a website that you have copied to your hard drive, and export 
it to a different path than the original files, the HTML files will look different than 
the original files because of missing graphic files. To display the images correctly 
in the webpages, you will have to copy the image folder(s) to the exact same 
relative position that they held in the folder structure of the source files (for 
instance, as a subfolder to the root of the website).

If you translate HTML files and need to open and save them in an application 
other than Déjà Vu X Standard or an Internet browser, make sure that you only 
open them in a simple text editor, an HTML editor that does not add any 
additional coding, or the HTML editor the files were originally created in. 
Otherwise you will run the risk of corrupting the files. 
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interpret these files. You can do this by creating a specific SGML/XML 
filter for each SGML/XML project you work on. For more information on 
how to build an SGML/XML filter, see "Creating and Maintaining SGML/
XML Filter Files" on page 297.

Déjà Vu X Standard includes support for all documents that follow the 
SGML standard. Because SGML and XML are widely used in all kinds of 
applications of data storage and data exchange, the use of the SGML filter 
goes far beyond the translation of files that have the default .sgml, .sgm, 
or .xml extension.

SGML/XML-Specific Import Options

Encoding

For general options to define the code page during export and import, see 
"Encoding" on page 238.

All code pages that are supported by Windows can be selected for the 
import of SGML/XML files. If none is selected for the import, Déjà Vu X 
Standard will attempt to detect the code page used in the file(s) or 
choose the code page best suited for the language in the source file. 
Should the code page of the source file be Unicode (UTF-16), Déjà Vu X 
Standard will use that code page even if that overrides the user selection. 

Filter Definition File

In the SGML filter, you will have to select a project-specific filter definition 
file (for information about creating these files, see "Creating and 
Maintaining SGML/XML Filter Files" on page 297).

A good way to determine whether files can be imported with the SGML/
XML filter is to open the file in question in a text editor and verify that it 
follows the basic structure of:

<TAG ATTRIBUTE1="translatable" ATTRIBUTE2="not translatable">translatable 
text</TAG>
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1 When you select the Filter Definition File line, a file selector button 
( ) appears at the right of the line.

2 Click .

3 The Select Name and Location of Filter File dialog appears.

4 Select your filter definition file and click Open.

5 You can see that the filter is now selected.

Once you have selected the filter file, the import process is the same as 
with any other file.

For options to define the code page during import, see "Encoding" on 
page 238. 
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SGML/XML-Specific Export Options

When you export a file that adheres to the SGML/XML specification, you 
will be presented with the following filter-specific options:

Special Characters—If you select Export as Entities, special 
characters will be exported in the appropriate code (© will, for instance, 
be exported as &copy;). If you select Export as they are, they will not 
be converted (© will stay ©).

Encoding—Regardless of the format of the imported file, you can choose 
to export the files in any of the code pages that is supported by Windows. 

If no code page is selected, Déjà Vu X Standard will select a code page 
suitable to the target language and actual language used, with a 
preference to the same code page used during the import.

Tips and Tricks with SGML/XML

A good way to determine whether your settings for the SGML/XML filter file are 
correct is to import a few sample files and see whether you are satisfied with the 
segmentation. If not, determine where the problem occurs, fix the SGML/XML 
filter file, and import your files again.
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Java Properties

Java Properties files are simple text files that are used in Java 
applications.

View of a Java Properties file in a text editor:

Déjà Vu X Standard will ignore the non-translatable content preceding the 
equal signs as well as all text preceded by the number sign (#), and it will 
use an HTML sub-filter to interpret the HTML coding in the file.

Encoding 

For general options to define the code page during export and import, see 
"Encoding" on page 238.

All code pages that are supported by Windows can be selected for the 
export or import. If none is selected for the import, Déjà Vu X Standard 
will detect the code page in the file or choose the code page best suited 
for the language in the source file. If no code page is selected for the 
export, Déjà Vu X Standard will choose the best suitable for the target 
language and/or the actual content. 

RC (Resource)

RC files are simple text files that are compiled into binary files such as 
.exe’s and .dll’s.
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To create an RC file from an .exe or .dll file, you will have to save the file 
in your development environment as an RC file.

View of an RC file in a text editor:

Déjà Vu X Standard will ignore all non-translatable content. This includes 
everything outside quotation marks, with the exception of the copyright 
note (which is in quotation marks but should not be translated). 

Encoding 

For general options to define the code page during export and import, see 
"Encoding" on page 238.
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All code pages that are supported by Windows can be selected for the 
export or import. If none is selected for the import, Déjà Vu X Standard 
will detect the code page in the file or choose the code page best suited 
for the language in the source file. If no code page is selected for the 
export, Déjà Vu X Standard will choose the best suitable for the target 
language and/or the actual content, with a preference for Unicode (UTF-
16). 

C/C++/Java

C/C++ and Java files are simple text source files that are compiled into 
C/C++ and Java applications.

Tips and Tricks with RC Files

If you use glossaries—such as the Microsoft glossaries—to aid in the translation of 
RC files, it may be helpful to activate the Prevent Segmentation setting for the 
import process because these and other glossaries contain the complete strings 
that sometimes consist of several sentences. For RC files, this setting is enabled 
by default. 

Because the syntax of RC files uses the quotation mark as a functional character, 
it requires a duplicated quotation mark ("") for every linguistic quotation mark 
("Click on ""Next"" to continue"). To make the translation process easier, 
Déjà Vu X Standard will display every duplicated quotation mark ("") as a single 
quotation mark ("), and then replace those instances with a required duplicated 
quotation mark ("") during the export of the file.

RC files often have a limitation for the length of a string (for instance, a string 
may not be longer than 255 characters). For these situations, the current record 
position indicator on the status bar (see p. 36) is very helpful.
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View of a .cpp file in a text editor:

Déjà Vu X Standard will ignore all non-translatable content. This includes 
everything outside quotation marks.

File types that are supported by this filter by default include .cpp, .c, .h, 
and .hpp files.

C/C++/Java-Specific Import Options

Ignore Text in Single Quotes

This option allows you to specify whether you would like to have text in 
’single quotes’ treated the same as text in "double quotes" or ignored.
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Encoding 

For general options to define the code page during export and import, see 
"Encoding" on page 238.

All code pages that are supported by Windows can be selected for the 
export or import. If none is selected for the import, Déjà Vu X Standard 
will detect the code page in the file or choose the code page best suited 
for the language in the source file. If no code page is selected for the 
export, Déjà Vu X Standard will choose the best suitable code page for 
the target language and/or the actual content, with a preference for 
Unicode (UTF-16). 

GNU Gettext

GNU gettext PO and POT files are the translatable language resource files 
used in the free GNU gettext concept for translating software and 
documentation (from docbook or XML). GNU gettext is the de-facto 
standard in many open source projects, and it works with a large variety 
of programming languages.

PO files are typically translated or pretranslated files, whereas POT files 
are the translatable templates.

Tips and Tricks with C/C++ and Java Files

If you use glossaries—such as the Microsoft glossaries—to aid in the translation of 
these files, it may be helpful to activate the Prevent Segmentation setting for 
the import process because these and other glossaries contain the complete 
strings that sometimes consist of several sentences. For C/C++ and Java files, 
this setting is enabled by default. 
Déjà Vu X Standard 287



Working with Different File Formats
View of a pretranslated POT file in a text editor:

Déjà Vu X Standard imports the pretranslated bilingual file that you can 
now edit and (where applicable) translate. View of the same passage in 
Déjà Vu X Standard:

When the translation is finished, the file will be exported back into its 
legal code page, Unicode (UTF-8).
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IBM TranslationManager

Déjà Vu X Standard can process IBM untranslated segments files.

To obtain the untranslated segments file for a particular file

1 Run IBM TranslationManager.

2 Locate your folder in TranslationManager's Folder List.

3 Double-click it to open its list of files.

4 Right-click the desired file. Select Analyze.

5 Check the Create file containing untranslated segments box.

6 Click Analyze.

To translate IBM TranslationManager files

1 Analyze the IBM TranslationManager documents to obtain the 
"untranslated segments" files.

2 Import these "untranslated segments" files into a Déjà Vu X Standard 
project.

3 Translate in Déjà Vu X Standard.

4 Export the finished translation from Déjà Vu X Standard.

5 Import the resulting files into the IBM TM translation memory.

6 Re-analyze the IBM TranslationManager documents. This will yield a 
fully translated document.

7 Return the IBM TranslationManager folder to your client. The folder 
contains all translated documents and a translation memory with all 
the material you have translated.

To export a translation memory from IBM TM

1 Display TM's Translation Memory List.

It is not possible to split and join sentences from IBM 
TranslationManager.
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2 Right-click the desired database. Select Export.

3 Select the External format.

4 Specify the destination file.

5 Click Export.

Encoding 

For general options to define the code page during export and import, see 
"Encoding" on page 238.

All code pages that are supported by Windows can be selected for the 
export or import. If none is selected for the import, Déjà Vu X Standard 
will detect the code page in the file or choose the code page best suited 
for the language in the source file. If no code page is selected for the 
export, Déjà Vu X Standard will choose the best suitable for the target 
language and/or the actual content. 

Trados RTF/Word Files

Déjà Vu X Standard is able to import pre-processed Trados Word or RTF 
files and export them after the translation into the original Trados format. 

Déjà Vu X Standard is also able to interpret the perfect and fuzzy match 
setting from Trados and apply that to its own project:

To process Trados Workbench 2.3, 3, 5, or 5.5 files, you need Microsoft 
Word 97 or later installed on your computer; however, you do not need 
an installation of Trados.
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View of pre-processed Trados file within Word (note the numbers 
between the segments that describe the level of fuzziness):

View of the same file in Déjà Vu X Standard (note the indicator 
bars for the fuzzy and the perfect match):
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Because of the way in which Déjà Vu X Standard works with Trados files, 
after a translation is finished and ready to be exported, the original, 
unaltered Trados file must be in the location from which it was imported. 
This is essential, because any slight modification to the file may prevent 
Déjà Vu X Standard from being able to export the final translation.

Trados TagEditor Files

Déjà Vu X Standard is able to import pre-processed Trados TagEditor BIF 
and TTX files and export them after the translation into the original BIF 
and TTX formats. 

As with Trados Word files (see "Trados RTF/Word Files" on page 290), 
Déjà Vu X Standard is able to interpret the perfect and fuzzy match 
setting from Trados and apply that to its own project. 

Tips and Tricks with Trados RTF/Word Files

Make sure that during the Trados processing, the Trados setting 
Tools>Translate>Segment Unknown Sentences is checked. Otherwise, not 
all sentences will be imported into Déjà Vu X Standard.

Because Trados files typically have the extension .doc or .rtf, you should not 
import Trados files with the Import Wizard unless you have changed the default 
association for .doc or .rtf files (see "To reconfigure the default relationship 
between file format and file extension" on page 228). Import Trados files through 
the Project Explorer and change the association on an individual file level 
instead (see "To reconfigure the individual relationship between file format and 
file extension" on page 232). 

It is not possible to split and join sentences from a Trados Workbench file.

The protected XTranslated units from the BIF and TTX documents will be 
imported as perfect matches, whereas non-protected 100% matches 
will be imported as 99% matches.
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BIF-Specific Import Options

Language Mapping

When importing a BIF or TTX file, Déjà Vu X Standard will recognize the 
languages that are present in the importable file(s) but will prompt you to 
map each language extension from the BIF file to one of the languages 
that are defined within Déjà Vu X Standard.

BIF-Specific Export Options

The options under Encoding are the three possible code pages for BIF 
and TTX files: US-ASCII, Unicode, and Unicode (UTF-8). For more 
information on the options defining the code page during export and 
import, see "Encoding" on page 238.

You will notice that in most cases Déjà Vu X Standard has already made 
the correct choice for you.
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TMX Files

You can translate TMX files in Déjà Vu X Standard. TMX (Translation 
Memory eXchange) is widely used as an interchange format between 
different translation memory formats (for a list of tools that support TMX, 
please see www.lisa.org/tmx). This means that with this format filter you 
are able to translate TMX translation memories of any tool that supports 
this format and apply that translated translation memory in its original, 
native environment.

Because of the multi-lingual nature of TMX files, Déjà Vu X Standard will 
import source and, where applicable, target(s). You are free to edit or 
overwrite the target sentences.

TMX-Specific Import Options

Language Mapping

When importing a TMX file, Déjà Vu X Standard will recognize the 
languages that are present in the importable file(s) but will prompt you to 
map each language extension from the TMX file to one of the languages 
that are defined within Déjà Vu X Standard.

You will notice that in most cases Déjà Vu X Standard has already made 
the correct choice for you.
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TMX-Specific Export Options

Because TMX files can have several target languages, Déjà Vu X Standard 
allows you to export individual bilingual files for every target language in 
your project, or one TMX file with several target languages.

If you want all target languages in one TMX file, you can leave the 
selection as presented in the Export Options dialog. If you prefer 
individual TMX files or any combination of languages, you can select the 
respective languages and make the appropriate choices under Export 
each language to a separate file.

The options under Encoding are the three possible code pages for TMX 
files: US-ASCII, Unicode, and Unicode (UTF-8). For more information 
on the options defining the code page during export and import, see 
"Encoding" on page 238.

If you choose to export more than one target language, Déjà Vu X 
Standard will export the file(s) into a subfolder named according to the 
source language rather than the usual target language naming 
convention.
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Chapter 12
Creating and Maintaining SGML/
XML Filter Files

Unlike other file formats (FrameMaker, Word, Excel, etc.), SGML 
(Standardized General Markup Language) and XML (eXtensible Markup 
Language) are not real file formats; they are a standard for tagging files, 
and for defining those tags. Since every set of SGML/XML files uses a 
different set of tags, an SGML/XML filter must be created for every set of 
SGML/XML files.

SGML defines a standard for creating DTDs (Document Type Definition). 
For example, the World Wide Consortium (W3C) has DTDs for the various 
specifications of HTML; this means that HTML is a markup language 
defined according to SGML rules. You will probably be somewhat familiar 
with the structure and tags in HTML, so we will use it as an example in 
our explanations.

Tags and Attributes

SGML files are text files that encode formatting, layout, and image 
information using tags. Tags are in the format of:

<TAGNAME ATTRIBUTE1="VALUE1" ATTRIBUTE2="VALUE2" …>

A tag can contain attributes that further define a value of the tag.

Because Déjà Vu X Standard does not need to interpret tags and keys, 
there are only two pieces of information that you must provide:

Embeddable tags—An embeddable tag is one that can appear in the 
middle of a sentence, and Déjà Vu should not split the sentence 
before or after this tag. For example, the <B> and <I> tags in HTML 
(which specify bold and italic attributes) are embeddable, while the 
<P> tag (which specifies a paragraph change) is not.

Extractable text between tags—It is possible to define whether text 
between certain tags is extractable (default) or not extractable, i.e., 
not translatable. For example, if text between certain tags always 
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contains dates or numbers that may not need to be translated, you 
can choose to embed that text.

Extractable attributes—Certain tags may contain attributes whose 
values are translatable, and must therefore be extracted. For 
example, the <IMG> tag in HTML (which inserts an image into the 
text) has the ALT=“[alternate text for the image]” attribute, 
which specifies the text to display if the browser cannot load the 
image. This text should be translated, so the attribute is extractable.

Déjà Vu X Standard offers two combinable possibilities for creating an 
SGML filter file:

from the DTD file

directly from the SGML/XML files

To create an SGML filter from SGML/XML files 

1 Open Déjà Vu X Standard.

2 On the File menu, click New.

–Or–

Click the  button on the toolbar.

If you define a text between tags with nested subtags (for example, 
<tag1> text <tag2> text </tag2></tag1>) as non-extractable, text 
between the nested subtags will not be extracted either.

However, attributes (see below), are not affected by a choice to not extract text 
between tags (for example, the attributetext in: <tag1 
attribute="attributetext"> text </tag1> would be extracted if so defined, 
even though the text of tag1 may be defined as not extractable).

In general, it is advisable to combine the methods to allow for greater 
accuracy of the SGML filter.
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3 The New File dialog appears.

4 Double-click SGML/XML Filter, or select it and click OK.

5 The New SGML/XML Filter Wizard appears.

6 Click Next.
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7 The wizard prompts you to create an SGML/XML filter.

8 Click Create, select a folder in which you want to have the SGML/
XML filter saved, and type a name for the filter.
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9 Click Open.

10 Click Next. The wizard prompts you to either specify a DTD file or to 
generate the SGML/XML filter directly from an SGML/XML file.
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11 For this exercise we will use an XML file. Click Next.

If you do have a DTD file for your SGML/XML project, it is advisable to 
combine the import of the DTD with some representative SGML/XML 
files.
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12 Click the Add button.

13 Select your SGML/XML file(s) and click Open. 

14 Click Next.
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15  The New SGML/XML Filter Wizard displays the current settings.

16 Click Finish. 

17 The wizard displays the import progress.
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18 Click Finish after the import process has finished. 

19 The Tags and Attributes tab is displayed.

The newly created SGML filter has made the following definitions:

all the tags of the imported SGML/XML file(s) are interpreted as 
extractable (by having the ...<>... column in the Tags field 
unchecked), 

all text between tags is defined as extractable (by having the 
<>...<> column in the Tags field checked), and

all attributes are defined as embeddable (by not having the 
<=...> column in the Attributes field checked).

20 You will have to review each of these tags and attributes and decide 
whether the default setting is appropriate or not. To ease that 
process, Déjà Vu X Standard displays examples from the occurrences 
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of the tags and attributes in the respective file(s) under and to the 
right of Examples.

Typically, the vast majority of tags should not be embedded. 
Below is an example of tags that could be embedded; the ...<>... 
column in the Tags fields is therefore checked:
306 Déjà Vu X Standard



Creating and Maintaining SGML/XML Filter Files
Typically, the majority of text between tags should be extracted. 
Below are examples of text that should probably not be 
extracted; the <>...<> column in the Tags field is therefore 
unchecked:
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Most of the attributes will only contain internal, non-translatable 
information. Leaving the checkboxes in the <=...> column in the 
Attributes field unchecked ensures that they will not be 
extracted, i.e., displayed in the Déjà Vu X Standard project. For 
those that should be translated, add a check mark.

21 When you are finished defining the tags and attributes, you can 
reduce the size of your SGML/XML filter by deleting all the examples.

This is especially helpful when you have imported a great number of 
SGML or XML files, which can blow up the size of the filter to several 
hundred megabytes.
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22 Select Edit>Delete All Examples.

23 Select the Entities and Characters tab. 

Here you can find definitions of the Begin Tag and the End Tag as 
well as for the Begin Entity and the End Entity. These settings are 
the standard settings and typically do not have to be changed.

On this tab you can also find a great number of pre-defined special 
characters. The definition of each will determine how Déjà Vu X 
Standard will display the character and export it again. The copyright 
sign (©), for instance, will be displayed as &copy; in the SGML file 
before and after the translation, but as © in the project file.

Other SGML/XML-specific options include the deletion of all tags and 
attributes and all entities. These options are only used on very rare 
occasions.
Déjà Vu X Standard 309



Creating and Maintaining SGML/XML Filter Files
24 In the process of generating the SGML/XML filter file below, Déjà Vu X 
Standard has detected one character, a y with an accent (ý), that is 
not in its predefined lists of special characters. With the appropriate 
Unicode sequence, you can now define how you want this character 
to be handled.

25 Type the appropriate Unicode sequence into the field to the right of 
U+. The correct character will now be displayed in the adjacent field.
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26 Click Replace.

27 The new entity will now be displayed correctly as ý in Déjà Vu X 
Standard, but as &yac; when exported.

To create an SGML filter from the DTD file

1 Open Déjà Vu X Standard

2 On the File menu, click New.

–Or–

Click the  button on the toolbar.
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3 The New File dialog appears.

4 Double-click SGML/XML Filter, or select it and click OK.

5 The New SGML/XML Filter Wizard appears.

6 Click Next.
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7 The wizard prompts you to create an SGML/XML filter.

8 Click Create, select a folder in which you want to have the SGML/
XML filter saved, and type a name for the filter.
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9 Click Open.

10 Click Next. The wizard prompts you to either specify a DTD file or to 
generate the SGML/XML filter directly from an SGML/XML file.
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11 For this exercise, we will use an existing DTD file. Click Select and 
select your DTD file.

12 Click Open. The wizard displays the current settings.

13 Click Next.
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14 The wizard prompts you to specify the location of your SGML/XML 
files. 

15 Click Next.

Although we are not adding any SGML files for this exercise, it is 
generally a good idea to combine data from a DTD and some 
representative SGML/XML files.
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16 The New SGML/XML Filter Wizard displays the current settings.

17 Click Finish. 

18 The Tags and Attributes tab is displayed.

The newly created SGML filter has made the following definitions:

most of the tags that are listed in the DTD file are interpreted as 
extractable (by having the ...<>... column in the Tags fields 
unchecked), 

all text between tags is defined as extractable (by having the 
<>...<> column in the Tags field checked), and
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all attributes are defined as extractable (by having the <=...> 
column in the Attributes field checked).

19 You can now choose to review each of these tags and attributes and 
decide whether the default setting is appropriate or not.

For further information on how to decide how to treat the different 
tags and attributes, see page 305.

To ease this process, it is advisable to combine the DTD import with the 
import of some representative SGML/XML files. Déjà Vu X Standard will 
then display examples from the occurrences of the tags and attributes in 
the respective file(s) under and to the right of Examples. For 

information on how to import SGML/XML files, see "To create an SGML filter from 
SGML/XML files" on page 298.
318 Déjà Vu X Standard



Creating and Maintaining SGML/XML Filter Files
To add data to the SGML filter

1 If you want to add data at a later point from an existing SGML filter or 
other SGML files, you can do that by selecting File>Import>Data 
from SGML File (or: Data from Another Filter).

2 Select the SGML file or the filter file and click Open.

3 The new data will be imported into your existing filter.

To import from a Déjà Vu 2/3 filter file

1 Select File>Import>Data from DV v.2.x/3.x Filter.

You can convert Déjà Vu 2/3 SGML filters to Déjà Vu X Standard SGML/
XML filters. If you do, you should be aware that certain properties in 
Déjà Vu X Standard SGML/XML filters were not available in Déjà Vu 2/3 
SGML filters, such as non-extractable text or predefined special 

characters. After the conversion it may be a good idea to verify that all settings 
are appropriate.
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2 The Select Name and Location of Deja Vu v.2.x/3.x Filter dialog 
appears.

3 Select the location and name of a .dvt file you would like to import 
and click Open. 

4 The data is being imported.
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Chapter 13
The Lexicon

If you are not familiar with Déjà Vu’s lexicon concept, get ready for 
something completely different and new. 

You probably have a relatively good understanding of how the 
terminology database and the translation memory work. Both are 
project-unspecific, external databases that contain segments, phrases, 
and terms from a large variety of subjects, clients, and projects. While 
the translation memory is primarily used for segment matching, the 
terminology database provides the individual components of a segment 
when no match is found in the translation memory.

So how does the lexicon fit in?

The project’s lexicon is a list of all the source language words or phrases 
present in the project—in other words, an index of all terms and phrases. 
Once you have created this index, you can translate the terms that seem 
relevant to you, batch delete all other terms (for instance, terms like 
"the" or "to" in the image below), and Déjà Vu X Standard will use what 
remains as the primary glossary for your project.
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While creating this index, the lexicon also provides you with the number 
of occurrences of the individual terms or segments (see the Freq column 
in the image above), thus giving you a pretty good idea of what terms are 
central to your project. And even though the same terms may reside in 
your terminology database, chances are that there will be several 
translations for many terms in the database. The word "cat," for instance, 
could be a feline animal, a piece of heavy equipment, or "computer-
assisted translation." Each of these meanings will have a different 
translation in different languages, making it difficult for Déjà Vu X 
Standard to know which one to choose over the other. By providing the 
one correct translation in the project-specific internal lexicon, Déjà Vu X 
Standard will always choose that over any other translation.

Working with the Lexicon

You can access the different functions and aspects of the lexicon through 
the Lexicon menu.

For information on how to create and translate a lexicon and how to 
remove rows from a lexicon, please see "Generating the Lexicon" on page 
76.

To change the lexicon sorting

As with normal files in a project, you can change the order in which the 
lexicon entries appear.

1 Click the  button on the toolbar.

Clients will often ask you to provide them with a glossary for a project 
you’ve translated for them; this will help them keep a record of the 
terminology used, ensuring that the same terminology is used in future 
projects. With Déjà Vu X Standard, creating a glossary for your client is 

as simple as exporting the lexicon to a text file.
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2 The Sort Lexicon dialog appears.

3 You can sort alphabetically, by number of words, by frequency, or by 
any combination of the three in either descending or ascending order.

4 Click OK.

To manually add entries to the lexicon

1 If you want to add a selection, select the corresponding portions in 
the source and target cells.

2 On the Translation menu, click Add Pair to Lexicon.

–Or–

Press F10.

You will generally want to choose the settings shown in the image 
above.
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3 At the bottom of the screen, you will be able to see: Pair added to 
the Lexicon.

Resolving the Lexicon with the Databases

After the lexicon has been built and you have added and removed those 
entries you considered necessary, you should translate it. You can do this 
manually, but you can also decide to use the content in your databases.

To resolve the lexicon with the translation memory(s)

1 Select Lexicon>Resolve with Translation Memory.

2 The Resolve Lexicon dialog appears and shows how many entries 
have been processed.

There could be two reasons why you may want to add to the lexicon and 
not to the terminology database. Because Déjà Vu X Standard treats the 
lexicon as the most relevant database in its assemble processes, it is 
helpful to add to the lexicon as you translate. This will overwrite 

anything you may have in the project-unspecific terminology database. 
Furthermore, there are entries that are so project-specific that you may not want 
to have them in your terminology database, but they may be very helpful in the 
lexicon.

The resolve options are also available during the lexicon build process 
(see "To create the lexicon" on page 76).

This process is comparable to a pretranslation; i.e., it finds both exact 
and fuzzy matches in the translation memory.
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To resolve the lexicon with the terminology database(s)

1 Select Lexicon>Resolve with Terminology Database.

2 The Resolve Lexicon dialog appears and shows how many entries 
have been processed.

Sending the Lexicon to a Database

After expanding, translating, and correcting the lexicon, you can send it 
to the terminology database or the translation memory so that the data 
in the lexicon will also be available for later projects.

To send the lexicon to the translation memory

1 If you only want to send a portion of the lexicon, select the respective 
records (for more information on how to select records, see 
"Selecting Rows" on page 45).

2 Select Lexicon>Add Lexicon to Translation Memory.

Both of the resolve processes are done with the currently selected target 
language. If there is more than one language in the project, you can 
choose which one to display by selecting a language from the Language 
Selector (see "The Language Selector" on page 35).

It is advisable to check the translations generated by the "resolve" procedures.
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3 The Send Lexicon to Translation Memory dialog appears.

4 Select whether you want to send the Current Language or All 
Languages, any rows with a status other than the default options 
Finished Rows or Unmarked manual translation, and whether 
you want to send all of the lexicon or only a previously selected 
subset.

5 Click OK.

6 At the bottom of the dialog, you will be able to see how many entries 
have been sent.

7 Click Close.

To send the lexicon to the terminology database

1 If you only want to send a portion of the lexicon, select the respective 
records (for more information on how to select records, see 
"Selecting Rows" on page 45).

2 Select Lexicon>Add Lexicon to Terminology Database.
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3 The Send Lexicon to Terminology Database dialog appears.

4 Select whether you want to send the Current Language or All 
Languages, any rows with a status other than the default options 
Finished Rows or Unmarked manual translation, and whether 
you want to send all of the lexicon or only a previously selected 
subset.

5 Click OK.

6 At the bottom of the dialog, you will be able to see how many entries 
have been sent.

7 Click Close.

Exporting the Lexicon

Once you have processed the lexicon, you may want to export it to send 
it to your client, to have it translated outside of Déjà Vu X Standard, or to 
import it into another Déjà Vu project. 

Déjà Vu X Standard can create a text or an Excel file with the lexicon 
entries from the source language and any number of target languages.
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To export the lexicon

1 In an open project with an existing lexicon, select 
File>Export>Lexicon.

–Or–

Right-click on the lexicon icon and select Export. 

2 The Lexicon Export Wizard opens.
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3 Select Next and choose the format you would like to export into. 
Supported formats include various versions of Excel and Text. For 
this example, we are going to select Text.

4 Select Next, choose the folder where the file is supposed to be 
saved, name the file, and select Save.
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5 The wizard displays the current settings to you.

6 Select Next and choose the target languages you are intending to 
export.
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7 Select Next and choose how the records should be separated from 
each other (Delimiter), whether you want column headings in the 
exported file (First Row Contains Field Names), and the 
codepage. Because one of our export languages is a non-Western 
language—Greek— Unicode may be a good choice as a codepage.

 

You will not be presented with these choices if you use Excel as an 
export format.
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8 Click Next. The wizard displays the current settings to you.

9 Click Finish. After the export process is finished, the wizard displays 
the number of exported records.

10 Select Close.
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Preparing a Lexicon for Translation Outside of Déjà Vu X 
Standard

If you are planning to prepare a lexicon for translation outside of Déjà Vu 
X Standard, you can follow these steps.

1 Determine which terms or phrase are helpful, copy them over from 
source to target, and select the desired rows.

2 On the Insert menu, select Populate>Current Sentence.

–Or–

Press F5.

3 Select Lexicon>Remove Entries.

4 The Remove lexicon rows dialog appears.

5 Select All rows with empty targets.

6 Click OK.

7 You can now export the remaining entries into a text or Excel (see 
"Exporting the Lexicon" on page 327), translate the file outside of 
Déjà Vu X Standard by overwriting the target segments and, once the 
translation is finished, re-import the file into the lexicon.

You can also copy the content of several rows into the target with this 
command by selecting the desired rows in the selection mode (see 
"Selecting Rows in the Selection Mode" on page 45).
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Importing into the Lexicon

The option to import a lexicon can prove to be helpful in a variety of 
situations, including the following:

the lexicon has been translated, edited, or proofread outside of Déjà 
Vu X Standard and needs to be reimported into the project, 

you would like to transfer the lexicon from an earlier project to the 
current project, or

a project-specific glossary has to be imported into the project’s 
lexicon.

To import an external file into the lexicon

1 In an open project with or without an existing lexicon, select 
File>Import>Lexicon.

–Or–

With an existing lexicon, right-click on the lexicon icon and select 
Import. 

The last item is arguably the most important one. As mentioned before, 
the lexicon is used as the primary glossary for the project, so it is very 
helpful to import a project-specific glossary into the lexicon rather than 
the generic terminology database.
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2 The Lexicon Import Wizard appears.

3 Click Next and select the format of the file you would like to import. 
The supported formats include Text, Excel, and Access. For this 
example we are going to select Access.
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4 Select Next, choose the folder where the file is located, name the 
file, and select Save.

5 The wizard displays the current settings to you.
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6 Select Next and select the database table which contains the 
material that needs to be imported.

You will not be presented with these choices for Excel or text.
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7 Select Next, specify which of the available fields needs to be 
imported, and map it to the appropriate language and code page.
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8 Select Next and choose whether you want the entries in the glossary 
to overwrite any existing similar entries in the current lexicon and 
whether you want to recalculate the frequencies (i.e., add the 
existing number of occurrences to the one in the new glossary).

9 Click Next. The wizard displays the current settings to you.
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10 Click Finish. After the import process is finished, the wizard displays 
the number of imported records.

11 Click Close. If you now open the lexicon in your project, you will be 
able to see the imported entries.
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Chapter 14
Creating and Maintaining 
Translation Memories

The Translation Memory Interface

The translation memory interface consists of a number of elements.

Source Language—though you can only view one source language 
at a time, the multilingual nature of Déjà Vu X Standard’s translation 
memories makes it possible to select a different source language 
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from the Source Language dropdown list and have the present 
source language become a target language:

Target Language—allows you to view each individual target 
language or—as in the examples above—all target languages.

Locate Sentence—this field allows you to enter the first few letters 
of the first word in the target sentence you are searching for to have 
Déjà Vu X Standard jump to a matching entry.

Even though you can use this feature in any mode, it is particularly 
useful in alphabetical order. To switch to alphabetical order, select 
View>Toggle Sorting.
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Filter—allows you to enter any full word (partial word or wildcard 
searches are not possible). By clicking the Filter button to the right 
of the text box, the translation memory displays all records where the 
source contains that word.

Add—clicking this button in either the source or target column will 
open a new field in which you can enter a new sentence or term.

Remove—clicking these buttons will remove the source or target 
sentence.

If you have all All Languages selected under Target Language, the Add 
button in the target column will be disabled as the selection under 
Target Language determines the languages of the sentence that is going 
to be added.
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Merge—this option allows you to merge two identical source 
sentences with translations into different languages. Highlight two 
source sentences by clicking on them while holding down the Ctrl key.
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Select Merge.

All Rows—the standard view that displays all source segments with 
their associated target sentences.
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Duplicates Only—displays all source rows.

SQL—this option opens the Select SQL dialog in which you can enter 
any SQL statement to view a certain subset of the translation 
memory.

A more powerful option for managing duplicates is to select 
Database>Find Duplicate Sentences.

The Find Duplicate Sentences dialog gives you a wide variety of 
options for finding sets of duplicates, sets of duplicates with identical translations, 
or sets of duplicates with different translations for all possible language 
combinations. It also allows you to delete duplicates if both source and target are 
identical.
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Opening Translation Memories

1 On the File menu, click Open.

–Or–

Press Ctrl+O.

–Or–

Click the  button on the toolbar.

2 The Open dialog appears.

3 Select Memory Databases under Files of type, select the database 
you want to open, and click Open.

Creating Translation Memories

There are two different ways to create a translation memory:

you can create one during the process of creating a Déjà Vu X 
Standard project file (see "Creating a New Project File" on page 69), 
or
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you can create a translation memory as a stand-alone file.

By creating a terminology database as a stand-alone file (which you can 
later associate with project files), a creation wizard allows you to select 
several customized options.

To create a translation memory as a stand-alone file

1 Open Déjà Vu X Standard.

2 On the File menu, click New. 

–Or–

Click the  button on the toolbar.

3 The New File dialog appears.

4 Double-click Translation Memory, or select it and click OK.
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5 The New Translation Memory Wizard appears.

6 Click Next.

7 The wizard prompts you to create a translation memory.
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8 Click Create, select a folder in which you want to have the translation 
memory saved, and type a name for the translation memory.

9 Click Open.
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10 Click Next. The New Translation Memory Wizard displays the 
current settings.

11 Click Finish. Déjà Vu X Standard displays an empty translation 
memory.
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Associating Translation Memories with a 
Project

Translation memories can be associated with your project during the 
creation of a project (see p. 72) or at a later point.

To associate translation memories with projects

1 In an open project, select Project>Properties>Databases.

2 If you would like to disassociate the existing translation memory from 
the project, select Remove in the Translation Memories section.

3 If you would like to add an additional translation memory, select Add 
in the Translation Memories section.
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4 A file selector dialog appears.
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5 Select the additional database which can be located on a drive of your 
local computer or anywhere in your network and click Open.

6 Click Apply and/or OK.

Translation Memory Statistics

It is possible to obtain statistical data about your translation memory, 
such as number of records and languages in the translation memory.

To view translation memory statistics

1 In an open translation memory, select 
Database>Properties>Statistics.
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2 The Statistics tab in the Translation Memory Properties dialog is 
displayed.
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3  Click Calculate.

4 The statistics for the current translation memory are displayed.

Importing External Data

You add records to your translation memory as you translate (see 
"Sending Information to the Translation Memory" on page 123), but Déjà 
Vu X Standard also enables you to import external data into translation 
memories. For example, this allows you to convert data you have 
accumulated with other translation memory software, or even from data 
found on the Internet.

To import data

1 With an open translation memory, click File>Import>Database.
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2 The Translation Memory Import Wizard appears.

3 Click Next.

4 The wizard prompts you to specify an import format. The supported 
formats are:
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Déjà Vu 2.x/3.x Memory Database—for importing memory 
databases of earlier versions of Déjà Vu 

Text—for importing delimited text files (tab, comma, etc.)

Access 9x/2000/XP—for importing databases from various 
versions of Microsoft Access

Excel 9x/2000/XP—for importing databases from various versions 
of Microsoft Excel

Trados Workbench Databases—for importing databases from 
translation memories from the Trados Workbench .txt format

TMX—for importing databases from the Translation Memory 
EXchange format, an XML-based exchange format between 
different CAT tools

For this example, we will select Text to import a multilingual comma-
separated value file (.csv).

5 Select Text and click Next.

You can also convert Déjà Vu 2.x/3.x memory databases into new Déjà 
Vu X Standard translation memories. For more information on this, see 
"To convert Déjà Vu 2.x/3.x memory databases" on page 363).
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6 Select the text file you want to import and click Open. The wizard 
displays the current settings.

7 Click Next. The wizard displays the data of the file and allows you to 
adjust the delimiter settings.
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8 Select the delimiter of your original file (in this case Comma), and 
check the appropriate option if the first row contains field names.

9 Click Next. The wizard now allows you to specify the field information 
for the fields of your original file.

The available standard fields are:

Main Sentence (typically the source language)

Translation

Date

User ID

Subject

Client
360 Déjà Vu X Standard



Creating and Maintaining Translation Memories
10 Select Main Sentence and the appropriate language and code page 
settings for the source language, and Translation and the 
appropriate language and code page settings for the target 
languages.

11 Click Next.
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12 The wizard displays the current settings. Click Next.

13 The wizard displays the import progress; when it is finished, it shows 
how many records have been added.
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14 Click Close and you are returned to your translation memory view. If 
you now look for one of the imported segments, you will find that it 
has been imported with English as the source language and the 
different specified languages as target languages:

To convert Déjà Vu 2.x/3.x memory databases

1 Select Tools>Convert>DV 2.x/3.x Memory Database.
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2 The Convert v2.x/3.x Memory Database dialog appears.

3 Click Select and select the memory database you would like to 
convert.

Déjà Vu X Standard will automatically recognize the language setting 
of the old database and will propose a new translation memory with 
the same name, in the same folder, with a new extension.

4 If necessary, change the language setting and/or the name or path of 
the new translation memory.

5 Click OK.
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6 Déjà Vu X Standard will show you the import process.

7 Once the import is finished, Déjà Vu X Standard will show you how 
many records have been added.

8 Click Close.

If you open the new database, you will be able to see that not only 
source and target terms have been imported, but also all other 
information that was present in the old memory database, including 
subject, client, datestamp, user, project ID, etc. 
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Aligning Existing Files with the Basic 
Aligner

Alignment is the process in which pairs of already translated files that 
were translated in a monolingual environment (i.e., outside a translation 
memory tool) are paired up to become part of an existing or a new 
translation memory. The process of pairing up these files is done in an 
intermediary alignment file, a .dvapr file; once the alignment is 
completed, this file is fed into the translation memory.

The alignment module that is part of this edition of Déjà Vu X Standard, 
the Basic Aligner, limits the amount of files that can be aligned in one 
alignment process to one source and one target file. It also delimits these 
files (i.e., splits the text of the files) strictly to the default delimitation 
rules or the rules that you have set up (see "Sentence Delimitation" on 
page 169). The more advanced module, the Translation Memory Builder, 
allows for batch alignment (i.e., numerous file pairs at one time) and 
adds an automated matching recognition to the basic delimitation. For 
more information on purchasing that module, please contact 
sales@atril.com.

Regardless of which Aligner you use, Déjà Vu X Standard’s advanced 
concept of using placeholders for embedded codes in the translation 
memory allows for:

aligning of different file types (i.e., you can align an HTML file in 
language A with a Word document in language B), or

using the translation memory that you built up from aligning from 
files of type A to translate files of type B.

To align a pair of files

1 Open Déjà Vu X Standard.

Though this feature can be very powerful, especially for users who start 
without any existing bilingual material, you should be cautious of blindly 
feeding existing material into your translation memory, just to "make it 
grow." In our experience, the best procedure for alignment is to choose 

very carefully what kind of textual material you will benefit from most, or align in 
a specific situation when you have to translate a file and you have a set of very 
similar, already translated files that are not yet contained in the translation 
memory.
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2 On the File menu, click New. 

–Or–

Click the  button on the toolbar.

3 The New File dialog appears.

4 Double-click Alignment Workfile, or select it and click OK.

Alternatively, you can also align from within an existing translation 
memory. To do that, open the translation memory that you would like to 
align new material into and select File>Import>Align.
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5 The Alignment Wizard appears.

6 Select Next.
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7 Check Create new alignment workfile and select Next.

8 Click Select.

9 Give the new alignment file a name and choose a folder in which to 
save it.
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10 Select Save.

11  Select Next.

12 Make the following selections:
370 Déjà Vu X Standard



Creating and Maintaining Translation Memories
choose the source and target files by clicking on the ellipsis 
buttons;

choose the language for each of these files from the dropdown 
list; and

choose the format for each of these files.

13 If you need to select any file format-specific import options, select 
Options for both source and target.

14 Select Next. The wizard shows the progress of the import process.
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15 In the following screen you will have to adjust the alignment.

You can make adjustments in source or target by selecting one or 
several rows in either source and target (press Ctrl while selecting 
several rows or Ctrl+Shift while selecting a range) and using one of 
the following options to adjust the alignment:

Joining the current segment with the next or joining all selected 
segments by clicking one of the Join buttons.

Splitting the current segment at the cursor’s location by clicking 
one of the Split buttons.

You can resize this window by dragging the resizing corner in the bottom 
right corner. The next time you open this screen, Déjà Vu X Standardwill 
have "remembered" your earlier sizing adjustments.

You can recognize whether your selection is in the source or the target 
column by the yellow dotted line that surrounds your selection.
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Deleting the current segment or all selected segments by clicking 
one of the Delete buttons. 

Moving the current segment or all selected segments up by 
clicking one of the Move Up buttons. 

Moving the current segment or all selected segments down by 
clicking one of the Move Down buttons.

The most common adjustments that you will have to make are due to 

soft or hard returns that were set for formatting purposes (as in 
the first two lines in both source and target in the example 
above);

differences in the sentence structure; or

differences in the use of sentence delimiters (such as the 
semicolon in English and the comma in German in the example 
above).

If you see great differences in how sentences are delimited because of 
delimitation rules, it may be advisable to discard the current alignment 
workfile, change the delimitation rules for one or both languages, and 
import the files again into a new alignment project. For more 

information on sentence delimitation, see "Sentence Delimitation" on page 169.
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When you are done with your adjustments, all the rows should be 
aligned perfectly.
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16 Select Next.
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17 Select the appropriate client and subject for this alignment project 
and click Next.

The following step of selecting or creating a translation memory is 
omitted if you are aligning through the Import>Align command within 
an existing translation memory.
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18 Create a translation memory that the alignment file can be entered 
into by clicking Create, or select an existing one by clicking Select.

 

19 Select Next.

20 The wizard displays the current settings.
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21 Select Finish.

22 The wizard shows you the progress of sending the sentence pairs into 
your translation memory and eventually the numbers of sentences 
that have been sent.

23 Select Close.

To open an existing alignment file

1 On the File menu, click Open.

–Or–

Press Ctrl+O.

–Or–

Click the  button on the toolbar.
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2 The Open dialog appears.

3 Select Alignment Workfiles under Files of type, select the 
alignment workfile you want to open, and click Open.

Alternatively, you can also open an alignment file from within an 
existing translation memory. To do that, open the translation memory 
that you would like to align new material into and select 
File>Import>Align.
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4 The Alignment Wizard appears.

5 Select Next.
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6 Select Open existing alignment workfile and click Next.

7 The wizard displays the last created alignment workfile. If you would 
like to select another file, click Select. If you would like to open the 
currently displayed file, click Next.
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8 The alignment workfile is displayed.

9 For instructions on adjustments of the alignment workfile and how to 
send it to the translation memory, see p. 370. 

Spell Checking the Translation Memory

To activate spell checking

1 Select Tools>Spelling.

–Or–

Press F7.
382 Déjà Vu X Standard



Creating and Maintaining Translation Memories
2 The Spell Checking Options dialog appears.

3 Under Language, you can choose to check any language present in 
the project, including the source language.

4 Under Scope, you can choose to check all entries in that language or 
just those that have not been checked before.

It is a good practice to include the source language in your spell checks. 
Any misspelling in the source is unlikely to occur a second time in later 
texts, but it will prevent Déjà Vu X Standard from finding perfect 
matches.

Limiting the spell check to records that have not been checked is an 
efficient way to avoid duplicating your work.
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5 The Check Spelling dialog appears.

6 For more information on spelling, see "Spell checking" on page 92.

Exporting Data from Translation Memories

There are various situations where it may be very helpful to export parts 
or all of your translation memories, the most obvious being:

storing a translation memory in a compact format, or 

sharing translation memory content with co-workers or teammates.

To export data

1 With an open translation memory, click File>Export>Database.
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2 The Translation Memory Export Wizard appears.

3 Click Next.

4 The wizard prompts you to specify an export format. The supported 
formats are:
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Text—for exporting delimited text files (tab, comma, etc.)

Access 9x/2000/XP—for exporting databases into various 
versions of Microsoft Access

Excel 9x/2000/XP—for exporting databases into various versions 
of Microsoft Excel

Trados Workbench Databases—for exporting databases into 
translation memories of the Trados Workbench .txt format

TMX—for exporting databases into the Translation Memory 
EXchange format, an XML-based exchange format between 
different CAT tools

In the following two examples, we will first select TMX and then Excel 
as the export format.

Access 9x does not support Unicode. Depending on your languages, this 
may be an important consideration in choosing the right format for you.

Excel 97 made an end to Excel 95’s limitation of 255 characters per cell 
(they upped it to 32,000) and 16,384 rows in a worksheet (extended to 
more than 65,000). This is an important consideration when choosing 
the correct Excel format. Another important consideration may be that 

anything before Excel 2000 does not support Unicode.
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To continue the export process with TMX as the data format

1 Select TMX.

2 Click Select.

The export process into the Trados WB database text format is similar to 
the one into TMX.
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3 Select the desired export path, give the file an appropriate name, and 
click Save. The wizard displays the current settings. 

4 Click Next.

5 The wizard displays the languages in your translation memory. 

6 Copy the desired languages over the Export languages field by 
selecting them and clicking on Add.

7 Click Next.

A TMX file can be multilingual, so you can select as many languages as 
you like.
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8 The wizard prompts you to enter any filtering condition, i.e., criteria 
by which you want to filter the export of your database. 

9 If you choose to enter an expression, verify it by clicking the 
Validate button. If the expression proves to be valid, select Next.

–Or–

If you choose not to enter an expression, select Next.

Unless you are very familiar with the underlying structure of the 
databases, you should probably resort to using and modifying the 
provided samples in the Advanced Topics chapter (see "Sample Regular 
Expressions for Export from Translation Memory and Terminology 

Database" on page 463).
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10 The wizard gives you a choice of the three possible ways to encode a 
TMX file (Unicode UTF-16, Unicode UTF-8, and US-ASCII) and lets 
you select what other information besides source and target should 
be exported.
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11 Make the appropriate choices and select Next.

The export into the Trados WB database format differs in this step. 
Instead of selecting the correct encoding, you will have to select the 
Trados-specific language specifier for each language.
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12 The wizard displays the current settings.

13 Click Finish.

14 The wizard displays the import progress; when it is finished, it shows 
how many records have been added.
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15 Click Close and you are returned to your translation memory view.

To continue the export process with Excel as the data format

1 Select Excel 97/2000/XP.

The export process into Access or text formats is similar to the 
procedure for Excel.
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2 Click Select.

3 Select the desired export path, give the file an appropriate name, and 
click Save. The wizard displays the current settings. 

4 Click Next.

5 The wizard prompts you to specify the fields you are planning to 
export.
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6 Click Add and specify for each exportable field the Field Type, 
Language, and the column header in the Excel file (Export As). 
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7 Continue until you have selected and specified all necessary fields.

You can move the fields with the up and the down arrows to the right of 
the selection field.
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8 The wizard prompts you to enter any filtering condition, i.e., criteria 
by which you want to filter the export of your database. 

9 If you choose to enter an expression, verify it by clicking the 
Validate button. If the expression proves to be valid, select Next.

–Or–

If you choose not to enter an expression, select Next.

Unless you are very familiar with the underlying structure of the 
databases, you should probably resort to using and modifying the 
provided samples in the Advanced Topics chapter (see "Sample Regular 
Expressions for Export from Translation Memory and Terminology 

Database" on page 463).

If you are exporting to text or Access 97, the wizard prompts you to 
select the encoding of the resulting data.
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10 Give the worksheet within the Excel spreadsheet the desired name or 
leave the default name (Sentences).

11 Click Next.

12 The wizard displays the current settings.
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13 Click Finish.

14 The wizard displays the import progress; when it is finished, it shows 
how many records have been added.

15 Click Close and you are returned to your translation memory view.
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Chapter 15
Creating and Maintaining 
Terminology Databases

Opening a Terminology Database

1 On the File menu, click Open.

–Or–

Press Ctrl+O.

–Or–

Click the  button on the toolbar.

2 The Open dialog appears.
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3 Select Terminology Databases under Files of type, select the 
database you want to open, and click Open.

Terminology Database Statistics

It is possible to obtain statistical data about your terminology database, 
such as number of records and languages in the terminology database.

To view terminology database statistics

1 In an open terminology database, select 
Database>Properties>Statistics.

2 The Statistics tab in the Terminolgy Database Properties dialog 
is displayed.
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3  Click Calculate.

4 The statistics for the current terminology database are displayed.

Creating Terminology Databases

There are two different ways to create a terminology database:

you can create one during the process of creating a Déjà Vu X 
Standard project file, or

you can create a terminology database as a stand-alone file.

If you create a terminology database in the process of creating a project 
file, Déjà Vu X Standard will create a basic terminology database with a 
default template that you should refine at a later point.

By creating a terminology database as a stand-alone file (which you can 
later associate with project files), a creation wizard allows you to select 
several customized options.
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To create a terminology database as a stand-alone file

1 Open Déjà Vu X Standard.

2 On the File menu, click New.

–Or–

Click the  button on the toolbar.

3 The New File dialog appears.

4 Double-click Terminology Database or select it and click OK.
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5 The New Terminology Database Wizard appears.

6 Click Next.

7 The wizard prompts you to create a terminology database.
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8 Click Create, select a folder in which you want to have the 
terminology database saved, and type a name for the terminology 
database.

9 Click Open.
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10 Click Next and select the template to define relationships and 
attributes that you would like to associate with your terminology 
database. For more information on templates, see Templates on page 
409.
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11 Click Next. The New Terminology Database Wizard displays the 
current settings.

12 Click Finish. Déjà Vu X Standard displays an empty terminology 
database.
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Templates

Templates are small files in XML format with the extension .dvtdt (Déjà 
Vu terminology database template) that are located in the \Templates 
folder within your Déjà Vu X Standard installation folder (by default 
C:\Program Files\Atril\Deja Vu X\Templates on an English Windows 
installation). These files define what kind of relations, attributes, and 
categories your terminology database will have—in short, how your 
terminology database is going to behave.

In the default installation of Déjà Vu X Standard, there are several preset 
templates:

Template 
Name

Organization No. of 
Attr.

No of 
Rel.

Reference URL

Minimal 0 1

ATRIL Déjà 
Vu X

ATRIL 5 3

Eurodicautom European 
Commission

11 3 http://europa.eu.int/
eurodicautom/login.jsp

TIS Council of the 
EU

9 3 http://tis.consilium.eu.int/
utfwebtis/frames/
introfsEN.htm

Criter Corpus du 
Réseau Inter-
ministériel de 
Terminologie

13 4 http://www.culture.fr/
culture/dglf/garde.htm 

IIF Interval 
Project

14 2 http://
www.computing.surrey. 
ac.uk/ai/new_interval/

Vintars UN at Vienna 21 3 http://vintars.unvienna.org/

Unterm UN at New 
York

6 2 http://157.150.197.21/
dgaacs/unterm.nsf

Termite International 
Telecomm. 
Union

7 2 http://www.itu.int/
terminology/index.html
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When creating a new terminology database, Déjà Vu X Standard will by 
default assign the minimal template that only contains the relation 
"translation." You can easily assign a different template, or you can 
create your own custom templates from scratch or on the basis of 
existing templates.

To assign a different template

1 While you have a terminology database open, select 
Database>Properties.

–Or–

Click the  button on the toolbar.

2 Click Templates.

ILOTerm International 
Labour 
Organization

8 2 http://ilis.ilo.org/ilis/
ilisterm/ilintrte.html

CILF Conseil 
international 
de la langue 
française

8 2 http://www.cilf.org/bt.fr.html

SilvaTerm International 
Union of 
Forestry 
Research 
Organization

8 2 http://iufro.boku.ac.at/iufro/
silvavoc/svdatabase.htm

TBX LISA 23 69 http://www.lisa.org/tbx

Template 
Name

Organization No. of 
Attr.

No of 
Rel.

Reference URL
410 Déjà Vu X Standard

http://ilis.ilo.org/ilis/ilisterm/ilintrte.html
http://www.cilf.org/bt.fr.html
http://iufro.boku.ac.at/iufro/silvavoc/svdatabase.htm
http://www.lisa.org/tbx/


Creating and Maintaining Terminology Databases
3 The Terminology Database Templates dialog appears.

4 Select a different template and click OK.

5 The new template has now been assigned to your terminology 
database.

To create a custom template

1 While you have a terminology database open, select 
Database>Properties.

–Or–

Click the  button on the toolbar.

2 Click Templates.
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3 The Terminology Database Templates dialog appears.

4 Select the existing template on which you would like to base a new 
template and click Save.

5 The Template Name dialog appears.

6 Type in the name you want the new template to have. For this 
sample, we want to create a template that will not hold any 
grammatical information, so we call it No Grammar.

7 Click OK.
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8 You are returned to the Terminology Database Templates dialog. 
Note that the new template No Grammar has already been added.

9 Make sure that the new template is highlighted and click OK.
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10 The Terminology Database Properties dialog appears again. Click 
the General tab if it is not already displayed.

11 Enter an internal name for the template, enter a description, and 
select whether the subject and client information from the project 
should automatically be entered for each of the records that you add 
to the terminology database.
414 Déjà Vu X Standard



Creating and Maintaining Terminology Databases
12 Select the Relations tab.

13 The default settings—which are taken over from the ATRIL Déjà Vu X 
template—have three different relations: Translation, Synonym (a 
word with the same or similar meaning), and Antonym (a word with 
the opposite meaning). Each relation is defined by a number of 
properties.

Name—the internal name of the relation.

Caption—the name of the relation as it appears in the list on the left 
in other views of the terminology database.

Scope—a dropdown field from which you can choose whether this is 
an interlanguage relation, i.e., a relation between different 
languages, or an intralanguage relation, i.e., a relation within one 
language.

Reflexive, symmetric, and transitive—the three most basic 
relationships in a relational database model that describe the 
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relationship of an element to itself (reflexive), to one other element 
(symmetric), or to several others (transitive).

14 Click Add to define a new relation, or Delete to delete an existing 
relation.

Reflexive—A reflexive relationship is a relationship that is valid for itself. 
For example, a translation relation cannot be reflexive, because a term 
cannot be translated with itself. A synonym relation is reflexive, 
however, because every term is also a synonym of itself. An antonym by 

definition cannot be reflexive, because a term cannot be its own opposite.

Symmetric—In a symmetric relationship, the relationship of A to B is also true of 
B to A. This is the classical translation relationship: if term A is the translation of 
term B, then term B is also the translation of term A. Synonym and antonym 
relations are symmetric relationships as well.

Transitive—In a transitive relationship, the relationship from A to B and A to C is 
the same as that of B to C. Translations from language A to B are not transitive 
(the German translation of the English term "file" can be either "Datei" or "Akte"; 
however, "Datei" is not the translation of "Akte"), nor are synonyms (though 
"square" is the synonym for both "four-sided figure" and "plaza," "plaza" is not a 
synonym for "four-sided figure") or—by the same logic—antonyms.

A A B

A

B C

Reflexivity Symmetry Transitivity
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15 Click the Attributes tab.

16 On the left-hand side, you can see the default grammatical 
Attributes (Part of Speech (=word class), Gender, and Number); 
their Properties are on the right-hand side (Name, Caption, and 
Type).

17 In our case we want to delete all existing grammatical attributes, so 
we click the Remove button until there are no more attributes listed.

18 Now we decide to add a new category, "Style." 
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19 Click the Add button, change the Caption and the Name to Style, 
and select Category under Type.
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20  Click the Categories tab and select Style in the Attribute 
dropdown list.

21 Add as many appropriate attributes as you would like and click Apply 
and OK. 

22 You are returned to the terminology database view.

23 To verify that your new settings have taken effect, click Add.
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24 The Add Term dialog appears. Click the dropdown list next to the 
newly created attribute Style, and you can see that all the new 
categories are listed.

Associating Terminology Databases with a 
Project

Terminology databases can be associated with your project during the 
creation of a project (see p. 72) or at a later point.
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To associate terminology databases with projects

1 In an open project, select Project>Properties>Databases.

2 If you would like to disassociate the existing terminology database 
from the project, select Remove in the Terminology Databases 
section.

3 If you would like to add an additional terminology database, select 
Add in the Terminology Databases section.
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4 A file selector dialog appears.
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5 Select the additional database which can be located on a drive of your 
local computer or anywhere in your network and click Open.

6 Click Apply and/or OK.

Adding Records

Just as Déjà Vu X Standard offers you the possibility of adding term pairs 
of different relations (see Templates on page 409), there are different 
ways to enter them. Naturally, the emphasis is on adding translation 
records (see Adding Translation Records on page 423), for which there 
are a variety of different methods, but there are also ways in which you 
can add terms of other relations (see Adding Non-Translation Records on 
page 441). 

Adding Translation Records

There are three ways to add translation records to a terminology 
database:

Manually in the terminology database view
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Manually as you translate your project

Automatically through import processes

Though Déjà Vu X Standard provides the opportunity to manually add 
entries in the terminology database view (see page 419), this is a rarely 
used and rather tedious way to enter translation information.

A much more efficient way to enter single term pairs to the terminology is 
during the actual translation process.

To manually add term pairs during the translation process

1 While you have a project open, highlight a term or phrase in the 
source segment and the corresponding term or phrase in the target 
segment with your mouse.

 

2 Send the highlighted terms to the terminology database:

On the Translation menu, click Add Pair to Terminology 
Database.

–Or–

Press F11.

–Or–

Click the  button on the toolbar.
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3 The Add Term Pair dialog appears.

4 You can see that several entries are already filled in, including the 
actual terms (under Lemma, a term for word or phrase), as well as 
the languages.

The attributes that are listed as well as their categories depend on 
the template you have chosen or created for your terminology 
database. In this example we have chosen the ATRIL Déjà Vu X 
template. For more information on terminology database templates, 
see Templates on page 409.

The subject and client are automatically filled in if the appropriate 
options in the Terminology Database Properties dialog are selected 
(see page 414). 
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5 Add any specifications, including grammatical information (part of 
speech (=word class), gender, or number) and semantical definition 
(such as definition information, subject, or client). 

6 You may use the Copy button to copy any of the selections from the 
first to the second column.

Note that for most of the attributes there are predefined categories 
which you can select. Some fields, including the Definition field, are 
text fields in which you can freely enter all appropriate information. 

Be as judicious and at the same time as thorough as you can by only 
entering the information that will be relevant for you or your co-workers 
later on. For instance, it obviously would not make sense to enter gender 
information if your language does not have a grammatical gender, or if 

any translator or editor should be familiar with this kind of information. On the 
other hand, it may very well be worthwhile to spend some time entering 
information into the Definition field to give yourself or your co-workers 
necessary context information.
426 Déjà Vu X Standard



Creating and Maintaining Terminology Databases
7 Click Add.

8 Your term pair is now entered into your terminology database and 
can be accessed through the standard searching and assemble 
functions.

Importing External Data

You add records to your terminology databases as you translate (see 
Adding Translation Records on page 423), but Déjà Vu X Standard also 
enables you to import external data into terminology databases. For 
example, this allows you to convert data you have accumulated in other 
glossaries or even from data found on the Internet.

To import data

1 With an open terminology database, click File>Import>Database.

2 The Terminology Database Import Wizard appears.

Because you can simultaneously have several terminology databases 
assigned in Déjà Vu X Standard, make sure that under 
Project>Properties>Database you assign the correct database as 
the destination database, i.e., the database that is to contain all new 

material from the current project.
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3 Click Next.

4 The wizard prompts you to specify an import format. The supported 
formats are:

Déjà Vu 2.x/3.x Terminology Database—for importing 
terminology databases of earlier versions of Déjà Vu 

Text—for importing delimited text files (tab, comma, etc.)

Access 9x/2000/XP—for importing databases from various 
versions of Microsoft Access

Excel 9x/2000/XP—for importing databases from various 
versions of Microsoft Excel

For this example, we will select Text to import a multilingual comma-
separated value file (.csv).

You can also convert Déjà Vu 2.x/3.x terminology databases into new 
Déjà Vu X Standard terminology databases. For more information on 
this, see To convert Déjà Vu 2.x/3.x terminology databases on page 
436).
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5 Select Text and click Next.

6 Select the text file you want to import and click Open. The wizard 
displays the current settings.
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7 Click Next. The wizard displays the data of the file and allows you to 
adjust the delimiter settings.

8 Select the delimiter of your original file (in this case Comma), and 
check the appropriate option if the first row contains field names.
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9 Click Next. The wizard now allows you to specify the field information 
for the fields of your original file.

The available standard fields depend on the template you have 
assigned to that database. If you have attached the default ATRIL 
Déjà Vu X template you will see the following relations:

Main Lemma (typically the source term) 

Translation

Synonym

Antonym
Déjà Vu X Standard 431



Creating and Maintaining Terminology Databases
New Relation...

and the following attributes:

Part of Speech

Gender

Number

Definition

Subject

Client

Selecting New Relation will open the New Relation dialog in which 
you can create a new relation and assign it to the template of the 
terminology database.
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New Attribute...

10 Select Main Lemma and the appropriate language and code page 
settings for the source language, and Translation, the appropriate 
language, relation, and code page settings for the target languages.

Selecting New Attribute will open the New Attribute dialog in which 
you can create a new attribute and assign it to the template of the 
terminology database.
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11 Click Next.

12 The wizard displays the current settings. Click Finish.
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13 The wizard displays the import progress; when it is finished, it shows 
how many records have been added.
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14 Click Close and you are returned to your terminology database view. 
If you now look for one of the imported segments, you will find that 
all languages have been imported:

To convert Déjà Vu 2.x/3.x terminology databases

1 Select Tools>Convert>DV 2.x/3.x Terminology Database.

2 The Convert v2.x/3.x Terminology Database dialog appears.
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3 Click Select and select the terminology database you would like to 
convert.

Déjà Vu X Standard will automatically recognize the language setting 
of the old database and will propose a new terminology database with 
the same name, in the same folder, with a new extension.

4 If necessary, change the language setting and/or the name or path of 
the new terminology database.

5 Click OK.

6 Déjà Vu X Standard will show you the import process.
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7 Once the import is finished, Déjà Vu X Standard will show you how 
many records have been added.

8 Click Close.

If you open the new database, you will be able to see that not only 
source and target terms have been imported, but also all other 
information that was present in the old terminology database, 
including subject, client, datestamp, grammatical information, user, 
etc. 

To import data from a Trados MultiTerm database

While it is not possible to import data directly from Trados MultiTerm, it is 
possible through an interim format.

When importing data from a MultiTerm database, there are several things 
you should consider. The processes below only describe how to import 
source and target terms and not any additional information.

When importing data from a MultiTerm database, it is important to 
consider that Trados uses its terminology database very different from 
how they are used in Déjà Vu X Standard. Because Trados employs its 
terminology database primarily as a reference tool and not as an 

interactive part of the program as in Déjà Vu X Standard, you may have to "clean" 
the database before importing it into Déjà Vu X Standard. This would include 
making sure that you do not have several target terms for one source or any 
additional information in either the source or target fields.
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Though the file structures of the two different Trados MultiTerm products 
on the market (MultiTerm iX and MultiTerm) are very different from each 
other, the process of exporting their data to an external file format is very 
similar. For either option, you will have to have access to a MultiTerm 
installation

Importing from MultiTerm

1 Open the MultiTerm database that you would like to import into Déjà 
Vu X Standard.

2 Open Word and activate the MTerm-XX.dot template under 
Tools>Templates and Add-Ins.

3 Select Table>MultiTerm table in Word.

4 The MultiTerm Table dialog appears.

5 Select Two columns if you would like to have only source and target 
displayed, or Three columns if you would also like to have possible 
synonyms to the source displayed.

6 Click OK.

7 The data from the MultiTerm database will be copied into Word in a 
tabular format.

8 Once that process is finished, select the complete table and copy it 
onto your clipboard (by pressing Ctrl+C or selecting Edit>Copy 
within Word).

9 Open an empty spreadsheet in Excel.

10 Copy the table into the Excel spreadsheet (by pressing Ctrl+V or 
selecting Edit>Paste within Excel).
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11 Save the file and import it with the normal Déjà Vu X Standard import 
process (see Importing External Data on page 427).

Importing from MultiTerm iX

1 Open Word and activate the MultiTermiX.dot template under 
Tools>Templates and Add-Ins.

2 Select MultiTerm>Select Termbase.

3 Select the MultiTerm termbase you would like to import into Déjà Vu 
X Standard in the Select Termbase dialog.

4 Select OK.
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5 Select MultiTerm>Insert Table within Word.

6 Press Insert Table.

7 The data from the MultiTerm database will be copied into Word in a 
tabular format.

8 Once that process is finished, select the complete table and copy it 
onto your clipboard (by pressing Ctrl+C or selecting Edit>Copy 
within Word).

9 Open an empty spreadsheet in Excel.

10 Copy the table into the Excel spreadsheet (by pressing Ctrl+V or 
selecting Edit>Paste within Excel).

11 Save the file and import it with the normal Déjà Vu X Standard import 
process (see Importing External Data on page 427).

Adding Non-Translation Records

1 Open the terminology database to which you want to enter term pairs 
of non-translation relations. In this example we are going to add a 
synonym for a term.

2 Locate the term for which you would like to add a synonym.

Enter the term in the Locate Term text field.

–Or–
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Search for the term with the common search function (see Search 
and Replace Features on page 177).

3 Click Add in the Related Terms section of the window.

If you want to add a completely new term, you can do that by clicking 
Add in the Source Language section of the window.
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4 The Add Relation dialog appears.

5 Under Relation Type, select Synonym.

6 Under Language, select the same language as the source language.

7 Under Locate Term, enter the synonym or select one from the list of 
terms.
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8 Click Add Term and modify or enter any attributes.

9 Click Add.
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10 You are returned to the Add Relation dialog.

11 Click Add and Close. You are returned to the terminology database 
view.
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12 If you select All under Related Terms and All under Target 
Languages, you can see that there is now an entry under 
Translation and under Synonym.

Exporting Data from Terminology Data-
bases

There are various situations where it may be very helpful to export parts 
or all of your terminology databases, the most obvious being:

storing a terminology database in a compact format, or 

sharing terminology database content with co-workers or teammates.

To export data

1 With an open terminology database, click File>Export>Database.
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2 The Terminology Export Wizard appears.

3 Click Next.

4 The wizard prompts you to specify an export format. The supported 
formats are:
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Text—for exporting delimited text files (tab, comma, etc.)

Access 95/97 and Access 2000/XP—for exporting databases into 
various versions of Microsoft Access

Excel 3.0/4.0/5.0/9x/2000/XP—for exporting databases into 
various versions of Microsoft Excel

In the following example, we will select Excel as the export format.

Access 9x does not support Unicode. Depending on your languages, this 
may be an important consideration in choosing the right format for you.

Excel 97 made an end to Excel 95’s limitation of 255 characters per cell 
(they upped it to 32,000) and 16,384 rows in a worksheet (extended to 
more than 65,000). This is an important consideration when choosing 
the correct Excel format. Another important consideration may be that 

anything before Excel 2000 does not support Unicode.
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To continue the export process with Excel as the data format

1 Select Excel 97/2000/XP.

2 Click Select.

The export process into Access or text formats is similar to the 
procedure for Excel.
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3 Select the desired export path, give the file an appropriate name, and 
click Save. The wizard displays the current settings. 

4 Click Next.

5 The wizard prompts you to specify the fields you are planning to 
export.
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6 Click Add.

7 Specify for each exportable field the Field Type, Language, the 
column header in the Excel file (Export As), and the relation to other 
selected fields.
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8 Continue until you have selected and specified all necessary fields.

You can move the fields with the up and the down arrows to the right of 
the selection field.
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9 The wizard prompts you to enter any filtering condition, i.e., criteria 
by which you want to filter the export of your database. 

10 If you choose to enter an expression, verify it by clicking the 
Validate button. If the expression proves to be valid, select Next.

–Or–

Unless you are very familiar with the underlying structure of the 
databases, you should probably resort to using and modifying the 
provided samples in the Advanced Topics chapter (see Sample Regular 
Expressions for Export from Translation Memory and Terminology 

Database on page 463).
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If you choose not to enter an expression, select Next.

If you are exporting to text, or Access 97, the wizard prompts you to 
select the encoding of the resulting data. In the case of text, it will also 
prompt you to enter delimitation information:
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11 Give the worksheet within the Excel spreadsheet the desired name or 
leave the default name (Terms).

12 Click Next.

13 The wizard displays the current settings.
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14 Click Finish.

15 The wizard displays the import progress; when it is finished, it shows 
how many records have been added.

16 Click Close and you are returned to your terminology database view.

Editing the Terminology Database

To locate a particular term

In the terminology database, terms are either sorted naturally (the order 
in which they were entered) or alphabetically.

You can change the sorting order by selecting View>Toggle Sorting.
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You can enter the term that you are looking for in the Locate Term text 
box, or you can search for the term with the common search function 
(see Search and Replace Features on page 177).

When you locate the term by entering it in the Locate term text field, 
Déjà Vu X Standard will reposition to the first record that begins with the 
letters you have typed so far. This action is artificially delayed so that you 
will have time to type in a few letters before the repositioning occurs.

Modifying a Particular Term

Once you have located the term that you want to modify, you can:

edit the attributes of the term or the term itself,

delete that term, or

merge that term with several other source terms.

To edit a term

1 Select the source term or (one of) the related term(s).

2 Click on Edit in the Source Language section to edit the source 
term.

–Or–

Click on Edit in the Related Terms section to edit the source term.

You can also search and replace within a terminology database with the 
common Search & Replace features.
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3 The Edit Terms dialog appears.

4 Change the term or the attributes as necessary.

5 Click OK.

To delete a term

1 Select the source term or (one of) the related term(s).

2 Click Delete in the Source Language section to delete the source 
term and all related terms. 

–Or–

Click on Delete in the Related Terms section to delete the source 
term.

To merge several source terms

1 Select several identical or nearly identical source terms. 

2 Press the Ctrl key while selecting individual records.

–Or–
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Press the Shift key while selecting a range of records. 

3 Click Merge.
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4 The source records are merged into one record with several related 
terms.

To view all rows or certain subsets of rows

All Rows is the standard view that displays all source segments with 
their associated target sentences.

Only the attributes of the first of the selected source terms are 
preserved.
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If you want to view only a subset of terms, you can select SQL. This 
option opens the Select SQL dialog in which you can enter any SQL 
statement to view a certain subset of the terminology database.

Spell Checking the Terminology Database

To activate spell checking

1 Select Tools>Spelling.

–Or–

Press F7.

2 The Spell Checking Options dialog appears.

3 Under Language, you can choose to check any language present in 
the project, including the source language.

It is a good practice to include the source language in your spell checks. 
Any misspelling in the source is unlikely to occur a second time in later 
texts, but it will prevent Déjà Vu X Standard from finding perfect 
matches.
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4 Under Scope, you can choose to check all entries in that language or 
just those that have not been checked before.

5 The Check Spelling dialog appears.

6 For more information on spelling, see Spell checking on page 92.

Limiting the spell check to records that have not been checked is an 
efficient way to avoid duplicating your work.
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Chapter 16
Digging In—Advanced Topics

Sample Regular Expressions for Export 
from Translation Memory and 
Terminology Database

The following regular expressions can be used in the Filtering 
Conditions window of the Terminology Database/Translation 
Memory Export Wizards (see pages 389 and 453) to export only a 
subset of your databases into one of the supported formats. After you 
have entered or copied and pasted the expressions into the provided text 
field, you should make sure that you validate them by selecting the 
Validate button below the text field. 

Export records belonging to project 1234567 from 
translation memory

PrjID=1234567

Export records of subject "123" from translation memory

Subject='123'

Export records of subject "123" from terminology database

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 5 and 
TextValue = '123')

Before you execute this command, you will have to verify what 
AttrTypeID "subject" has in your terminology database. You can do that 
by opening the AttrTypes table within the terminology database with 
Microsoft Access. Look for the ID that represents subject. In this 

example we assume that this code is 5, but this will not necessarily be the case 
for your database.
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Export records of client "987" from translation memory

Client='987'

Export records of client "987" from terminology database

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 6 and 
TextValue = '987')

Export records of client "987" and subject "123" from 
translation memory

Client='987' AND Subject='123'

Export records of client "987" and subject "123" from 
terminology database

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 6 and 
TextValue = '987') AND ID IN (SELECT LemmaID FROM Attributes 
WHERE AttrTypeID = 5 and TextValue = '123')

Export translation memory records entered on or after 
December 21, 2002

ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/
2002#)

Before you execute this command, you will have to verify what 
AttrTypeID "client" has in your terminology database. You can do that 
by opening the AttrTypes table within the terminology database with 
Microsoft Access. Look for the ID that represents client. In this example 

we assume that this code is 6, but this will not necessarily be the case for your 
database.

Before you execute this command, you will have to verify what 
AttrTypeIDs "client" and "subject" have in your terminology database. 
You can do that by opening the AttrTypes table within the terminology 
database with Microsoft Access. Look for the IDs that represents client 

and subject. In this example we assume that the codes are 5 and 6, but this will 
not necessarily be the case for your database.
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Export terminology database records entered on or after 
December 21, 2002

ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= 
#12/21/2002#) OR ID IN (SELECT DstLemmaID FROM Relations WHERE 
Datestamp >= #12/21/2002#)

Export translation memory records entered on December 
21, 2002

ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/

2002# AND Datestamp<#12/22/2002#)

Export terminology database records entered on December 
21, 2002

ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= 
#12/21/2002# AND Datestamp<#12/22/2002#) OR ID IN (SELECT 
DstLemmaID FROM Relations WHERE Datestamp >= #12/21/2002# AND 

Datestamp<#12/22/2002#)

Export translation memory records entered between 
January 1, 2003, and January 31, 2003

ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #1/1/2003# 
AND Datestamp<#2/1/2003#)

Export terminology database records entered between 
January 1, 2003, and January 31, 2003

ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #1/
1/2003# AND Datestamp<#2/1/2003#) OR ID IN (SELECT DstLemmaID 
FROM Relations WHERE Datestamp >= #1/1/2003# AND Datestamp<#2/

Because the date field also contains a time value, you have to add lower 
and upper boundaries.

Because the date field also contains a time value, you have to add lower 
and upper boundaries.
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1/2003#)

Export translation memory records entered on December 
21, 2002, between 12 pm and 3 pm

ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/2002 
11:00# AND Datestamp<#12/21/2002 15:00#)

Export terminology database records entered on December 
21, 2002, between 12 pm and 3 pm

ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= 
#12/21/2002 11:00# AND Datestamp<#12/21/2002 15:00#) OR ID IN 
(SELECT DstLemmaID FROM Relations WHERE Datestamp >= #12/21/
2002 11:00# AND Datestamp<#12/21/2002 15:00#)

Export all translation memory records in U.S. English 
starting with "ABC"

ID IN (SELECT ID FROM Sentences WHERE Lang = 9 AND SubLang = 1 
AND Sentence LIKE 'ABC*')

Export all terminology database records in U.S. English 
starting with "ABC"

Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*'

For a list of language and sublanguage codes, see "List of Language and 
Sublanguage Codes" on page 468.

For a list of language and sublanguage codes, see "List of Language and 
Sublanguage Codes" on page 468.
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Export all terminology database records in U.S. English 
containing "ABC"

ID IN (SELECT ID FROM Sentences WHERE Lang = 9 AND SubLang = 1 
AND Sentence LIKE '*ABC*')

Export all terminology database records in U.S. English 
containing "ABC"

Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*'

Export all translation memory records from User "Joe"

ID IN (SELECT ID FROM Sentences WHERE UserNick = 'Joe')

Export all terminology database records from User "Joe"

ID IN (SELECT OrgLemmaID FROM Relations WHERE UserNick = 
'Joe') OR ID IN (SELECT DstLemmaID FROM Relations WHERE User-
Nick = 'Joe')

For a list of language and sublanguage codes, see "List of Language and 
Sublanguage Codes" on page 468.

For a list of language and sublanguage codes, see "List of Language and 
Sublanguage Codes" on page 468.
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List of Language and Sublanguage Codes

The following tables provide you with a list of codes for the languages and 
sublanguages used in Déjà Vu X Standard that can be used in filtering 
expressions.

For commands involving any field for which the language code is part of 
the field name (such as Status_xxxx or Target_xxxx) in projects, you 
will have to use a four- or five-digit language ID that follows this 
formula: (Sublanguage * 1024) + Language, i.e., Standard Spanish 

would be (1 * 1024) + 10 = 1034.

Language Decimal Code
Afrikaans  54
Albanian  28
Amharic  94
Arabic  1
Armenian  43
Assamese  77
Azeri  44
Basque  45
Belarusian  35
Bengali  69
Bosnian  26
Bulgarian  2
Burmese  85
Catalan  3
Cherokee  92
Chinese  4
Croatian  26
Czech  5
Danish  6
Divehi  101
Dutch  19
Dzongkha  81
Edo  102
English  9
Estonian  37
Faeroese  56
Farsi  41
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Filipino  100
Finnish  11
French  12
Frisian  98
Fulfulde  103
Gaelic  60
Galician  86
Georgian  55
German  7
Greek  8
Guarani  116
Gujarati  71
Hausa  104
Hawaiian  117
Hebrew  13
Hindi  57
Hungarian  14
Ibibio  105
Icelandic  15
Igbo  112
Indonesian  33
Inuktitut  93
Italian  16
Japanese  17
Kannada  75
Kanuri  113
Kashmiri  96
Kazakh  63
Khmer  83
Konkani  87
Korean  18
Kyrgyz  64
Lao  84
Latin  118
Latvian  38
Lithuanian  39
Macedonian  47
Malay  62
Malayalam  76

Language Decimal Code
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Maltese  58
Manipuri  88
Marathi  78
Moldavian  24
Mongolian  80
Nepali  97
Neutral  0
Norwegian  20
Oriya  72
Oromo  114
Papiamentu  121
Pashto  99
Polish  21
Portuguese  22
Punjabi  70
Rhaeto Romanic  23
Romanian  24
Russian  25
Sami  59
Sanskrit  79
Serbian  26
Sindhi  89
Sinhalese  91
Slovak  27
Slovenian  36
Somali  119
Sorbian  46
Spanish  10
Sutu  48
Swahili  65
Swedish  29
Syriac  90
Tajik  40
Tamazight  95
Tamil  73
Tatar  68
Telugu  74
Thai  30
Tibetan  81

Language Decimal Code
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Tigrigna  115
Tsonga  49
Tswana  50
Turkish  31
Turkmen  66
Ukrainian  34
Urdu  32
Uzbek  67
Venda  51
Vietnamese  42
Welsh  82
Xhosa  52
Yi  120
Yiddish  61
Yoruba  106
Zulu  53

Sublanguage Decimal Code
Neutral  0
Default  1
Sys Default  2
Arabic Saudi Arabia  1
Arabic Iraq  2
Arabic Egypt  3
Arabic Libya  4
Arabic Algeria  5
Arabic Morocco  6
Arabic Tunisia  7
Arabic Oman  8
Arabic Yemen  9
Arabic Syria  10
Arabic Jordan  11
Arabic Lebanon  12
Arabic Kuwait  13
Arabic UAE  14
Arabic Bahrain  15
Arabic Qatar  16

Language Decimal Code
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Azeri Latin  1
Azeri Cyrillic  2
Bengali India  1
Bengali Bangladesh  2
Chinese Traditional  1
Chinese Simplified  2
Chinese Hong Kong  3
Chinese Singapore  4
Chinese Macau  5
Croatian Standard  1
Croatian Bosnia  4
Dutch Standard  1
Dutch Belgium  2
English United States  1
English United Kingdom  2
English Australia  3
English Canada  4
English New Zealand  5
English Ireland  6
English South Africa  7
English Jamaica  8
English Caribbean  9
English Belize  10
English Trinidad  11
English Zimbabwe  12
English Philippines  13
English Indonesia  14
English Hong Kong  15
English India  16
English Malaysia  17
English Singapore  18
French Standard  1
French Belgium  2
French Canada  3
French Switzerland  4
French Luxembourg  5
French Monaco  6
French West Indies  7
French Reunion  8

Sublanguage Decimal Code
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French Congo DRC  9
French Senegal  10
French Cameroon  11
French Cote D'Ivoire  12
French Mali  13
French Morocco  14
French Haiti  15
French North Africa  57
Gaelic Scotland  1
Gaelic Ireland  2
German Standard  1
German Switzerland  2
German Austria  3
German Luxembourg  4
German Liechtenstein  5
Greek Standard  1
Greek Alternative  2
Italian Standard  1
Italian Switzerland  2
Kashmiri Pakistan  1
Kashmiri South Asia  2
Korean Standard  1
Korean Johab  2
Lithuanian Standard  1
Lithuanian Classic  2
Malay Standard  1
Malay Brunei  2
Mongolian Cyrillic  1
Mongolian Mongolian  2
Nepali Nepal  1
Nepali India  2
Norwegian Bokmål  1
Norwegian Nynorsk  2
Portuguese Standard  2
Portuguese Brazil  1
Punjabi India  1
Punjabi Pakistan  2
Romanian Standard  1
Romanian Moldova  2

Sublanguage Decimal Code
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Russian Standard  1
Russian Moldova  2
Serbian Latin  2
Serbian Cyrillic  3
Sindhi India  1
Sindhi Pakistan  2
Spanish Standard  1
Spanish Mexico  2
Spanish Modern Sort  3
Spanish Guatemala  4
Spanish Costa Rica  5
Spanish Panama  6
Spanish Dominican Republic  7
Spanish Venezuela  8
Spanish Colombia  9
Spanish Peru  10
Spanish Argentina  11
Spanish Ecuador  12
Spanish Chile  13
Spanish Uruguay  14
Spanish Paraguay  15
Spanish Bolivia  16
Spanish El Salvador  17
Spanish Honduras  18
Spanish Nicaragua  19
Spanish Puerto Rico  20
Spanish United States  21
Spanish Latin America  57
Swedish Standard  1
Swedish Finland  2
Tamazight Berber  1
Tamazight Latin  2
Tigrigna Ethiopia  1
Tigrigna Eritrea  2
Tibetan Tibet  1
Tibetan Dzongkha  2
Urdu Standard  1
Urdu India  2
Uzbek Latin  1

Sublanguage Decimal Code
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Uzbek Cyrillic  2

Sublanguage Decimal Code
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Appendix
The Menu Commands and 
Toolbar Icons

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action

File Menu

New Ctrl+N Creates a project file, 
translation memory, 
terminology database, or SGML/
XML filter.

Open Ctrl+O Opens an existing project file, 
translation memory, 
terminology database, or SGML/
XML filter.

Close Closes an open project file, 
translation memory, 
terminology database, or SGML/
XML filter.

Import Imports a satellite project, a 
lexicon, or and External View. It 
also gives access to the Project 
Explorer.

You cannot import a 
source file with this 
command.

Export Exports a Pack & Go project, an 
External View, a satellite 
project, a lexicon, a project-
specific subset of the translation 
memories or terminology 
databases, or the completed 
translation project.
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Exit Alt+F4 Closes the application.

Edit Menu

Undo Ctrl+Z Undoes an unlimited amount of 
actions.

Redo Ctrl+Y Redoes the previously undone 
action.

Cut Ctrl+X
-or-
Shift+Del

Cuts the selected text and sends 
it to the clipboard.

Copy Ctrl+C
-or-
Ctrl+Insert

Copies the selected text and 
sends it to the clipboard.

Paste Ctrl+V
-or-
Shift+Insert

Pastes the content of the 
clipboard at the mouse insertion 
point.

Delete DEL Deletes the selected text.

Select All Ctrl+Shift+A Selects all text within one cell.

Find Ctrl+F Searches for a specified 
character string within the 
project or file.

Find Next F3
-or-
Shift+F4

Continues with the search for a 
specified character string within 
the project or file.

Replace Ctrl+H Replaces a specified character 
string with another specified 
character string.

Change 
Case

Shift+F3 Changes the case of the 
selected text.

Join 
Sentences

Ctrl+J Joins the current segment with 
the next.

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action
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Split 
Sentences

Ctrl+I Splits the current segment in 
two at the mouse insertion 
point.

See in 
Context

F6 Displays the source segment of 
the current selection in the 
original code view.

Insert Menu

Populate>
Current 
Language 

Alt+F5 Copies all segments from source 
into empty target cells in 
current language.

Populate>
Current 
Sentence

F5 Copies current source segment 
to target.

View Menu

Project 
Explorer

Opens the Project Explorer.

File 
Navigator

Opens the File Navigator.

Toggle 
Sorting

Toggles the sorting order of the 
source segments from natural 
(the order in which they appear 
in the original) to alphabetical 
and vice versa.
Selecting this command from 
with an open lexicon opens the 
Sort Lexicon dialog.

Translation 
Menu

Pretranslate Ctrl+p Pretranslates the project in any 
one or all languages within the 
project or the current file.

Scan Ctrl+S Scans for matches for the 
current segment or selection in 
the translation memory(s).

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action
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Scan with 
Wildcards

Ctrl+Shift+S Opens a windows that allows a 
scan for matches in the 
translation memory(s) with the 
help of wildcards.

Lookup Ctrl+L Looks for matches for the 
current segment or selection in 
the terminology database(s).

Lookup with 
Wildcards

Ctrl+Shift+L Opens a windows that allows to 
look for matches in the 
terminology database(s)) with 
the help of wildcards.

Assemble Ctrl+A Assembles the current segment 
from portions out of the lexicon, 
the terminology database(s), 
and the translation memory(s).

Add Pair to 
Lexicon

F10 Adds current pair or current 
selection in source and target to 
the lexicon.

Add Pair to 
Translation 
Memory

F12 Adds current pair or current 
selection to the assigned 
translation memory.

Add Pair to 
Terminology 
Database

F11 Adds current pair or current 
selection in source and target to 
the assigned terminology 
database.

Find Next 
Terminology 
Mismatch

Ctrl+F7 Jumps to the next row with 
terminology inconsistencies 
between the translation in the 
project and the content in the 
lexicon and the memory and 
terminology databases.

Check 
Embedded 
Codes

Ctrl+Shift+F8 Checks for inconsistencies 
between the embedded codes in 
the source and target fields.

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action
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Fix 
Embedded 
Codes

Ctrl+F8 Inserts the embedded codes 
found in the current source 
sentence at the end of the 
current target sentence.

Propagate to 
Current File

Shift+F9 Propagates the translation of 
the current segment to all 
identical matches in the current 
file.

Propagate to 
All Files

Alt+Shift+F9 Propagates the translation of 
the current segment to all 
identical matches in the project.

Project 
Menu

Properties Opens the Project Properties 
dialog with access to general, 
languages, filters, user, and 
databases configuration options 
for the current project.

Add to 
Translation 
Memory

Alt+F12 Adds the current or all files and 
the current or all languages of 
the project to the assigned 
translation memory.

Find 
Duplicate 
Sentences

Opens the Find Duplicate 
Sentences dialog with options 
to detect duplicates in source 
and/or target sentences.

Unmark 
Duplicate 
Sentences

Unmarks any segments that 
were previously marked as 
duplicates.

Lexicon 
Menu

Build 
Lexicon

Opens the Build dialog to 
generate a lexicon.

Remove 
Entries

Opens the Remove lexicon 
rows dialog to remove records 
from a lexicon.

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action
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Resolve with 
Translation 
Memory

Leverages the content from the 
associated translation memory 
to translate lexicon records.

Resolve with 
Terminology 
Database

Leverages the content from the 
associated terminology 
database to translate lexicon 
records.

Add Lexicon 
to 
Translation 
Memory

Opens the Send to Translation 
Memory dialog to send lexicon 
records to the associated 
translation memory.

Add Lexicon 
to 
Terminology 
Database

Opens the Send to Translation 
Memory dialog to send lexicon 
records to the associated 
terminology database.

Users Menu

Login Opens the User Login dialog to 
log in to the current project.

Logout Logs the current user out of the 
current project.

You do not have to log out 
to log in under a different 
user name. 

Tools Menu

Spelling F7 Checks the spelling of the target 
in the current language in the 
current or all files.

Word Count Ctrl+W Opens the Word Count dialog 
with several options to count 
words and characters in the 
current or all files. 

Character 
Map

Ctrl+K Opens the Windows Character 
Map.

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action
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Options Opens the Options dialog with 
access to general, delimitation, 
spelling, subject, client, 
AutoText and display options.

User 
Interface 
Language

Opens the Select User 
Interface dialog in which the 
language of the user interface 
can be switched.

Customize Opens the Customize dialog 
with access to several options to 
customize the appearance of 
menus and toolbars.

Convert Imports Déjà Vu 2 or 3 
terminology databases and 
memory databases. 

Compact Compacts a project, satellite, 
translation memory, 
terminology database, or SGML/
XML filter. 

Repair Repairs a project, satellite, 
translation memory, or 
terminology database.

Window 
Menu

Next Opens the next minimized 
window.

Previous Opens the previous minimized 
window.

Close All Closes all windows.

Tile 
Horizontally

Arranges document windows 
horizontally as non-over-lapping 
tiles.

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action
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Tile 
Vertically

Arranges document windows 
vertically as non-over-lapping 
tiles.

Cascade Cascades document windows 
diagonally on the screen.

Arrange 
Icons

Arranges icons for minimized 
document windows at the 
bottom of the main window. If 
there is an open document 
window, some or all of the icons 
may not be visible because they 
will be underneath the open 
document window.

Help Menu

Contents Opens the HTML Help system.

Index Opens the index of the HTML 
Help system.

Search Opens the search feature of the 
HTML Help system.

About Deja 
Vu X

Displays Déjà Vu version and 
build information as well as 
copyright information.

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action
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Translation Memory-Specific Menu Commands

Terminology Database-Specific Menu Commands

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action

File Menu

Import Imports an external database in 
a variety of formats or opens 
the Alignment Wizard with 
access to Déjà Vu’s alignment 
feature.

Export Exports to an external database 
in a variety of formats and gives 
access to filtering functions.

Database 
Menu

Properties Opens the Translation 
Memory Properties dialog 
with access to general and user 
configuration options.

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action

File Menu

Import Imports an external glossary in 
a variety of formats.

Export Exports to an external glossary 
in a variety of formats and gives 
access to filtering functions.

Database 
Menu
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SGML/XML Filter-Specific Menu Commands

The Keyboard Shortcuts
The following pages contain a complete list of keyboard shortcuts that are 
available by default within Déjà Vu X Standard. It is important to keep in 
mind, however, that all keyboard shortcut associations can be 
reconfigured. For more information on this, see "Keyboard Shortcuts" on 
page 19. 

Properties Opens the Terminology 
Database Properties dialog 
with access to general, user, 
relations, attributes, and 
categories options.

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action

File Menu

Import Imports an SGML or XML file or 
data from another SGML/XML 
filter file.

Edit Menu

Delete All 
Tags and 
Attributes

Deletes all tags and attributes 
from the SGML/XML filter file.

Delete All 
Entities

Deletes all entities from the 
SGML/XML filter file.

Delete All 
Examples

Deletes all examples from the 
SGML/XML filter file.

Command Name Keyboard Shortcut

Open File Ctrl-O

Command 
Name

Keyboard 
Shortcut

Toolbar 
Icon

Action
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The Keyboard Shortcuts
New File Ctrl-N

Exit Déjà Vu X Alt-F4

Help F1

Copy Ctrl-C or Ctrl-Ins

Copy All Codes Alt-F8

Copy Next Code F8 or Ctrl+D

Delete Del

Delete Codes Ctrl-Space

Delete Codes and Text Ctrl-Space

Paste Ctrl-V or Shift+Insert

Undo Ctrl-Z

Redo Ctrl-Y

Find Ctrl-F

Find Next F3 or Shift+F4

Replace Ctrl-H

Select All Ctrl-Shift-A

Pretranslate Ctrl-P

Assemble Ctrl-A

Scan Ctrl-S

Scan with Wildcards Ctrl-Shift-S

Lookup Ctrl-L

Lookup with Wildcards Ctrl-Shift-L

Check Embedded Codes Ctrl-Shift-F8

Fix Embedded Codes Ctrl-F8

Command Name Keyboard Shortcut
Déjà Vu X Standard 487



The Keyboard Shortcuts
Check for Multiple Exact Matches Ctrl-F3

Check Terminology (Single Row) Ctrl-Shift-T

Find Next Terminology Mismatch Ctrl-F7

Change Case Shift-F3

Expand AutoText entry Ctrl-Shift-F3

Display Code Shift-F6

Do Not Send to Translation Memory Ctrl-Shift-D

Split Sentences Ctrl-I

Join Sentences Ctrl-J

Swap Current and Next Words Ctrl-Shift-N

Swap Previous and Current Words Ctrl-Shift-B

Lock/Unlock Rows Ctrl-Shift-K

Pending Ctrl-Shift-P

Reset Sentence Status Ctrl-Shift-U

See in Context F6

Character Map Ctrl-K

Spelling F7

Word Count Ctrl-W

Go to the Beginning of Table Ctrl-PgUp

Go to the End of Table Ctrl-PgDn

Go to Next Row Ctrl-DownArrow

Go to Next Row (Overwrite Propagated Rows) Alt-Ctrl-DownArrow

Go to Next Untranslated Row Alt-DownArrow

Go to Previous Row Ctrl-UpArrow

Command Name Keyboard Shortcut
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Go to Previous Untranslated Row Alt-UpArrow

Populate All Languages Ctrl-Alt-F5

Populate Current Language Alt-F5

Populate Current Sentence F5

Populate Current Sentence (Insert) Ctrl-F5

Propagate in Current File F9

Propagate in Current File (Overwrite) Shift-F9

Propagate to All Files Alt-F9

Propagate to All Files (Overwrite) Alt-Shift-F9

Delete Comment Ctrl-Shift-M

Add Comment Ctrl-M

Next Bookmark F2

Previous Bookmark Shift-F2

Toggle Bookmark Ctrl-F2 or Ctrl+B

Add Pair to Lexicon F10

Add Pair to Terminology Database F11

Add Pair to Terminology Database (No Prompt) Shift-F11

Add Pair to Translation Memory F12

Add Project to Translation Memory Alt-F12

Command Name Keyboard Shortcut
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Glossary
alignment

Alignment is the process by which existing source and (translated) 
target documents are matched up to build or add to a translation 

memory.

alphabetic order

Refers to the order of source sentences within a project file. In 
alphabetic order, segments are sorted by alphabet, as opposed to the 

natural order, where they are sorted according to their occurrence in 
the source text.

antonym

A word with the opposite meaning (compare synonym).

assemble

When scanning does not find a match, you can ask Déjà Vu X 
Standard to assemble a translation from smaller pieces found in the 
project lexicon, terminology databases, and the translation 
memories (in this order if the similarity and other properties are equal).

attribute

In HTML, SGML, and XML, an attribute is a definition within a tag that 
may or may not have to be translated. A well-known translatable 
example is the alt attribute within an <IMG> tag (<IMG alt="Atril 
Software" border=0 src="/atril.jpg">).

lexiconbatch processes

Procedures that process many files simultaneously. This is one of the core 
competencies of Déjà Vu X Standard.

bookmarks

Déjà Vu X Standard allows you to set a bookmark to mark a position in a 
project so that you can later easily locate certain sentences.
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case sensitive

The ability to distinguish between uppercase (capital) and lowercase 
(small) letters. Programs or features that distinguish between uppercase 
and lowercase are said to be case sensitive. For instance, if you enter atril 
to search for Atril in a case-sensitive feature, the program would not find 
it.

CAT

CAT (Computer-Aided Translation) is a term used to classify a wide 
variety of software tools that are employed to assist translators in their 
work, either in consistency, speed, or simply workload. Some definitions 
include machine translation tools in the CAT category, while others 
consider CAT to be exactly equivalent to translation memory tools. 

comments

Comments are fields in the source or target row to which you can add 
comments or questions for your own or someone else’s review.

date stamp

A date stamp in a database record is the field that defines the date on 
which the record was created or modified (compare time stamp).

delimitation rules

Delimitation rules are the rules by which Déjà Vu X Standard determines 
how text in a specific language should be segmented. You can change or 
add default delimitation rules so that they correspond to your specific 
language and the style of the author of your source documents. The 
delimitation rules allow you to specify for each language what rules are to 
be used as well as the exceptions to these rules. You can access the 
delimitation rules by selecting Tools>Options>Delimiters.

delimiter

A punctuation character or group of characters that separates two pieces 
of data, or marks the beginning or end of a piece of data. Déjà Vu X 
Standard uses delimiters in defining delimitation rules and in database 
import and export processes. 
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demo mode

You can work with Déjà Vu X Standard’s demo mode, but with some 
restrictions that make it impossible to use in an actual production 
process.

dockable

Dockable windows are windows that align themselves with the edge of 
another interface element, usually a window or a pane. In Déjà Vu X 
Standard, dockable windows can be placed anywhere on the desktop. See 
also tool windows.

Document window

A window that has to stay within the main window and is subject to the 
commands in the Window menu. In Déjà Vu X Standard this includes all 
the main grids, including project files, terminology databases, 

translation memories, Pack & Go packages, and SGML/XML filter. 
See also tool window.

dongle

Déjà Vu X Standard employs a hardware key that acts as a protection 
device. The dongle has to be connected to either your parallel port or 

USB port to fully activate the software.

DTD

Document Type Definition file used by SGML and XML to define mark-up 
languages. 

EBMT

EBMT (Example-Based Machine Translation) is a relatively new 
technology aimed at combining both translation memory and 

machine translation paradigms by reusing previous translations and 
applying various degrees of linguistic knowledge to convert fuzzy 
matches into perfect matches. 
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embeddable tags

An embeddable tag in Déjà Vu X Standard’s SGML/XML filter is a tag that 
can appear in the middle of a sentence which should not be split before or 
after this tag. For example, the <B> and <I> tags in HTML (which specify 
bold and italic attributes) are embeddable, while the <P> tag (which 
specifies a paragraph change) is not.

embedded code

When working with file types other than plain text, Déjà Vu X Standard 
only displays translatable text—everything else is hidden. However, in 

formats such as HTML, FrameMaker, or Word, formatting information is 
often embedded within a sentence, such as a particular word in bold, 
cursive, or small caps. Because Déjà Vu X Standard cannot automatically 
decide which formatting belongs to which word, it lets the translator 
decide where to place this formatting information. These are "embedded 
codes." If you have created a Déjà Vu X Standard project for HTML, for 
example, you will probably have noticed that many sentences contain 
embedded codes such as {142} or {835}.

exact match

An exact match (also: perfect match) is the perfectly identical equal 
match of a stored source sentence in the translation memory (often 
ignoring any formatting information that may be stored with it) with the 
segment being sought. 

extractable attributes

While most SGML attributes are not translatable, some may be 
translatable, and must therefore be extracted. For example, the <IMG> 
tag in HTML (which inserts an image into the text) has the 
ALT=“[alternate text for the image]” attribute, which specifies the 
text to display if the browser cannot load the image. This text should be 
translated, so the attribute is extractable.

extractable text

Extractable text between tags refers to text between certain SGML/XML 
tags that should be extracted, i.e., translated, or not. Users have the 
option to define this property in Déjà Vu X Standard’s SGML/XML filter.
Déjà Vu X Standard 493



Glossary
File Navigator

In a project file, a small pane on the right of your screen that displays all 
the files in your project so you can easily switch from one file to the next.

format

Format is the term that is used to describe different file formats, such as 
Word, HTML, or FrameMaker.

format filters

Déjà Vu X Standard uses different rules to separate non-translatable code 
and translatable text for different formats. These rules are sometimes 
referred to as format filters.

fuzzy match

A fuzzy match is a source sentence that only partially matches the 
sentence being sought.

guaranteed match

A guaranteed match is an exact match for which Déjà Vu X Standard 
has also checked that the surrounding sentences match, thus greatly 
increasing the likelihood of its accuracy.

hard return

A hard return, also called carriage return or paragraph marker, is an 
actual symbol inserted into text that separates one paragraph from the 
next, usually inserted by the Return or Enter key. In most programs you 
can view the hard return as the symbol "¶" (compare soft return).

lemma

A word or phrase.
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lexicon

The project file’s lexicon is an optional project-internal list of all the 
source language words or phrases present in the project—in other words, 
an index of all terms and phrases. Once you have translated this list, it 
will be used by Déjà Vu X Standard as the primary glossary for your 
project. You can build and manage the lexicon by selecting 
Project>Lexicon. 

lookup

Refers to search processes in the terminology databases. See also 
scan.

machine translation

MT (machine translation, often called automatic translation) systems are 
those that use linguistic information about the languages being translated 
to automatically generate translations. 

match

A match is a bilingual record of a sentence or term whose source is 
identical or similar to the source in the project file. 

natural order

In Déjà Vu X Standard, the natural order refers to the original order of 
sentences in the source document (compare alphabetic order). 

ODBC

Open DataBase Connectivity is a standard database access method 
developed by Microsoft Corporation. The goal of ODBC is to make it 
possible to access any data from any application, regardless of which 
database management system (DBMS) is handling the data. ODBC 
manages this by inserting a middle layer, a database driver, between an 
application and the DBMS. The purpose of this layer is to translate the 
application's data queries into commands that the DBMS understands. 
For this to work, both the application and the DBMS must be ODBC-
compliant—that is, the application must be capable of issuing ODBC 
commands and the DBMS must be capable of responding to them.
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parallel port

Also called printer port. An interface for connecting an external device 
such as a printer. On PCs, the parallel port uses a 25-pin connector and is 
used to connect printers, computers, and other devices. Déjà Vu X 
Standard connects a dongle to the parallel or USB port to activate the 
program. 

pending

Déjà Vu X Standard allows you to mark questionable rows as pending so 
that you or someone else can come back at a later time to finish or 
review these rows.

perfect match

See exact match.

populate

A process by which either a single sentence or all sentences of one 
language pair are copied over from source to target in the project 
file. The populate commands are available from the Insert menu.

pretranslate

The process in Déjà Vu X Standard that allows you to batch leverage 
the content of your databases—translation memory(s), terminology 
database(s), and (optionally) the lexicon—against your source files.

primary window

A window type to which you can assign a distinct font. Includes the 
project files, translation memories, or terminology databases (the 

primary windows). See also secondary window.

Pack & Go packages

Pack & Go packages are highly compressed exports from project files that 
are ideal for the transmission of Déjà Vu X Standard data. The Pack & Go 
feature is available as a stand-alone feature for the transfer of complete 
projects, or as part of the satellite creation for the transfer of even 
smaller bilingual satellite projects.
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Project Explorer

A Windows Explorer-like interface from which you can import, export, or 
delete any supported file or folder in and out of your project. The Explorer 
is also accessed from within the main Déjà Vu X Standard interface.

project file

Also called translation file. The .dvprj file that contains all source files 
and the lexicon, and in which all translation processes are performed.

propagate

The process by which Déjà Vu X Standard applies a translation to the 
same or similar sentences within the project file after you have translated 
a sentence. The propagate options are accessible through the 
Translation menu. 

Properties window

A window with import-specific options that appears when selecting files 
for import in the Project Explorer.

reflexive

One of the three most basic relationships in a relational database model 
(compare symmetric and transitive). A reflexive relationship is a 
relationship that is valid for itself. For example, a translation relation 
cannot be reflexive, because a term is usually not translated with the 
very same term. A synonym relation is reflexive, however, because every 
term is also a synonym of itself. An antonym by definition cannot be 
reflexive, because a term cannot be its own opposite.

regular expressions

Any legal combination of symbols that represents a value and that you 
can employ to communicate with certain features of an application. Each 
programming language and application has its own rules for what is legal 
and illegal. The scripting language that Déjà Vu X Standard uses is 
VBScript. For more information on VBScript, see the MSDN library at 
http://msdn.microsoft.com/library. 
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Rows Selector

The second of three record selectors in the selector row in a project 
file. You can use the rows selector to filter and display only certain kinds 
of rows, e.g., exact matches, fuzzy matches, pending rows, etc.

satellite files

A satellite file is an export from a project file that contains only one 
source and one target language (as opposed to a full project file, which 
typically consists of the source language plus a number of target 
languages) with all the information needed by the translator. This 
information can exclude the formatting and image code, thus significantly 
reducing the file size and making it easier to transmit. A satellite file 
restricts the translator from performing any task that would have an 
effect on all the target languages, such as deleting files, splitting/joining 
rows, editing the source, or locking/unlocking rows.

scan

Refers to search processes in the translation memories. See also 
lookup.

secondary window

A window type to which you can assign a distinct font. Includes the 
AutoSearch, lookup, or scan windows. See also primary window.

security

Security settings define user roles with different levels of access in Déjà 
Vu X Standard. The three major different roles are project owner, 
administrator, and various levels of language users. Project owners have 
access to all possible functions, administrators do not have the ability to 
disable the project security features, and users have different levels of 
language-specific sets of rights.

segment

See sentence.
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selector row

The row with the three record selection fields on the top of a project file. 
See Text/Record Locator, Rows Selector, and Target Language 
Selector.

sentence

Any segment that is delimited by either a punctuation mark (such as a 
full stop or a question mark) or by any other means of separation (such 
as the end of a paragraph, heading, or table cell).

SGML

SGML stands for the Standardized General Markup Language. It is the 
result of generalizing and then standardizing a number of Rich Text 
Formats (RTF) developed for word processing software on personal 
computers by the International Organization for Standardization (ISO) in 
1986. 

SGML is actually a metalanguage used to define mark-up languages. The 
definitions are called Document Type Definitions or DTDs. 

SGML/XML filter

A file used when translating files that follow the SGML definition. 
Because each SGML file or group of SGML files is unique, a unique filter 
must be created for each of them. You can do that by having Déjà Vu X 
Standard either analyze the SGML files or read the DTD file.

soft return

A marker that forces a line break without starting a new paragraph, 
usually inserted by a key combination such as Shift+Enter (compare 

hard return).

source

Refers to the language or sentence that is being translated. See also 
target.
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SQL

Structured Query Language is the most commonly used language to 
communicate with databases. 

symmetric

One of the three most basic relationships in a relational database model 
(compare reflexive and transitive). In a symmetric relationship, the 
relationship of A to B is also true of B to A. This is the classical translation 
relationship: if term A is the translation of term B, then term B is also the 
translation of term A. Synonym and antonym relations are symmetric 
relationships as well. 

synonym

A word with the same or similar meaning (compare antonym)

tag

A tag is an element in SGML, XML, or HTML that allows for the 
structuring of the content, page layout, text formatting, insertion of 
images, etc. Tags are typically enclosed in <angled brackets>. Internal 
tags, such as the <b>bold<\b> tag, are embedded in segments, whereas 
external tags, such as the <p>paragraph<\p> tag, are located outside 
sentences. 

target

The target language or sentence in which the translation is being 
conducted. See also source.

Target Language Selector

The third of three record selectors in the selector row in a project file. 
You can use the selector to switch between the different target 
languages that you may have in your project.
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templates

Files in XML format with the extension .dvtdt (Déjà Vu terminology 
database template) that are located in the \Templates folder within your 
Déjà Vu X Standard installation directory (by default C:\Program 
Files\Atril\Deja Vu X\Templates on an English Windows installation). 
These files define what kind of relations, attributes, and categories your 
terminology database will have.

terminology database

Multilingual files that contain pairs of terms or short expressions (source 
and target) which you have added. Each pair is associated by additional 
information that is freely configurable.

Text/Record Locator

The first of three record selectors in the selector row in a project file. 
You can use the selector to enter the number of the project line you 
would like to jump to (in the natural order), or any combination of 
letters at the beginning of the row that you would like to jump to (in 

alphabetic order).

TMX

Translation Memory eXchange is an XML-based standard for data 
exchange between memory databases.

tool window

Windows that are freely dockable, i.e., that can be placed anywhere 
outside the main window on your desktop and be subject to the standard 
docking features. In Déjà Vu X Standard, these windows include the 

File Navigator, the Properties window, or any of the toolbars. See 
also Document window.

time stamp

A time stamp in a database record is the field that defines at what time 
the record was created or modified (compare date stamp).
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transitive

One of the three most basic relationships in a relational database model 
(compare symmetric and reflexive). In a transitive relationship, the 
relationship from A to B and A to C is the same as that of B to C. 
Translations from language A to B are not transitive (the German 
translation of the English term "file" can be either "Datei" or "Akte"; 
however, "Datei" is not the translation of "Akte"), nor are synonyms 
(though "square" is the synonym for both "four-sided figure" and "plaza," 
"plaza" is not a synonym for "four-sided figure") or—by the same logic—
antonyms.

translation memory

The files that store all previously translated segments (sentences, 
headings, cell content, bullet points, etc.) in source and target. This file is 
multilingual, i.e., it can have several target languages.

wildcard

A special symbol that stands for one or more characters. Used to widen 
the scope of searches in scan processes.

XML

XML—eXtensible Markup Language—has been developed by the World 
Wide Web Consortium as an alternative to HTML, which was not 
sophisticated enough for the creation of interactive content, and SGML, 
which proved to be too complex for web applications. Much like SGML, 
XML is a metalanguage to enable users to create their own markups in 
Document Type Definition (DTD) files. 

Unicode

A standard for representing characters as integers. Because it is possible 
to represent all characters of all known languages with Unicode, there is 
no need for different character sets between languages anymore. Déjà Vu 
X Standard deals with two different Unicode encoding schemes, UTF-8 
and UTF-16.
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UTF-8 is an 8-bit encoding scheme. Most characters from Western-
language alphabets are all encoded using a single byte, whereas 
characters for other languages are encoded using 2, 3, or even 4 bytes. 
UTF-8 therefore produces compact documents for Western languages, 
but for other languages, documents tend to be half as large as they 
would be if they used UTF-16.

UTF-16, a 16-bit encoding scheme, is large enough to encode all the 
characters from all the alphabets in the world. It uses 16-bits for most 
characters, but includes 32-bit characters for ideogram-based languages 
like Chinese. A Western-language document that uses UTF-16 will be 
twice as large as the same document encoded using UTF-8. But 
documents written in most Asian languages will be far smaller using UTF-
16.

USB

Universal Serial Bus is an external bus standard that supports data 
transfer rates of 12 Mbps. A single USB port can be used to connect up to 
127 peripheral devices, such as mice, modems, keyboards, and 

dongles.
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Index
A
abbreviation

add to terminology database 441
About

command 484
accept only exact matches

option 120
Access

description of export 393, 449
file formats 251
import into lexicon 335
import options 251
specifying translatable fields 252
terminology database export 448
terminology database import 428
translation memory export 386
translation memory import 358

acronyms
conversions 164

Add
translation memory 343

add
existing dictionaries 191

Add Comment
dialog 200
keyboard shortcut 489

Add Folder
dialog 53

Add Lexicon to Translation Memory
command 482

Add Pair to Lexicon
command 480
keyboard shortcut 489

Add Pair to Terminology Database
command 480
keyboard shortcut 489

Add Pair to Terminology Database (No Prompt)
keyboard shortcut 489

Add Pair to Translation Memory
command 123, 480
keyboard shortcut 489

Add Project to Translation Memory
command 124
keyboard shortcut 489

Add Relation
dialog 443

Add Term
dialog 420

Add Term Pair
dialog 425

add terms
terminology database 84

Add to Terminology Database
command 482

Add to Translation Memory
command 481

add words
dictionaries 187

adding
comments 200

adding non-translation records
terminology database 441

adding records
databases 83
terminology database 84, 423
translation memory vs. terminology database 84

adding specifications
terminology database records 85

adding translation records
terminology database 423

additional information in databases
purpose 128

Adobe FrameMaker. See FrameMaker
Adobe PageMaker. See PageMaker
aligning

files 366
aligning files 366
alignment 65, 366

and code handling 366
and sentence delimitation 373
definition 366, 490
deleting lines 373
joining lines 372
moving lines 373
possible adjustments 372
splitting lines 372
Translation Memory Builder 366
use of 366

alignment file
definition 13
open 378

alignment vs. translation 65
alignment window

resizing 372
Alignment Wizard 368
All Files

view 43
all rows

select 46
all rows downwards

select 46
all rows upwards

select 46
All Rows view

terminology database 460
translation memory 345

allow accented capital
spelling option 184

allow case conversion
command 165
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allow decimal conversion
command 165

allow portions containing commas
option 120

alphabetic order
definition 490
switch to natural order 27

alphabetical order 27
Analysis

dialog 224
analysis

internal repetition 224
new feature 11
number of exact matches 224
number of fuzzy matches 224
number of matches 224
project 223
save results in external file 225

analysis feature
definition 223

antonym
add to terminology database 441
definition 490

Arrange Icons
command 484

Asian languages
sentence delimitation 172

Assemble
command 480
keyboard shortcut 487

assemble 118
adjust settings 119
context menu 119
definition 118, 490
embedded codes 119
fuzzy setting 107
manually 118
options 119
several choices 119
status indicator 118

assemble from portions
pretranslation 82

assign clients 131
assign subjects 142
Atril website 5
attribute

definition 490
Attributes

tab (Terminology Database Properties dialog) 417
attributes

defining for terminology database 417
terminology database records 85

attributes (SGML/XML)
definition 297

AutoAssemble
on Ctrl+DownArrow 44

AutoFormat
use in OpenOffice.org/StarOffice 250
use in Word 245

automatic change
dictionary 188

automatic change-preserve case
dictionary 189

automatically fix codes
uses 160

AutoPropagate
difference to manual propagate 152
on Ctrl+DownArrow 44
shortcut 35

AutoSearch
fuzzy setting 107
shortcut 35

AutoSend
on Ctrl+DownArrow 44
shortcut 35

B
Basic Aligner

aligning files 366
vs. Translation Memory Builder 366

batch processes
definition 490

batch processing 43
beginning of file

jump to 45
BIF

export options 293
import options 293
language mapping 293

bif files. See Trados TagEditor
bookmark

icon 198
set 197

Bookmarks
submenu 197

bookmarks
adding 197
definition 197, 490
move to the next 198
move to the previous 199
remove 198
remove all 198

Build
command (lexicon) 76

Build Lexicon
command 481
dialog 77

Build Status Expression
dialog 33

C
C/C++

file formats 285
C/C++ files

definition 285
sample 286
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C/C++/Java
import options 286

C/C++/Java files
encoding 287
tips and tricks 287

C/C++/Java import
Ignore Text in Single Quotes 286

capitalization
change 180

caret character 171
Cascade

command 484
cascade

windows 38
case

change 180
conversion 165

case sensitive
definition 491
spelling option 185

CAT
definition 491

Categories
tab (Terminology Database Properties dialog) 419

categories
defining for terminology database 419

change
color of indicator bars 29

Change Case
command 180, 478
keyboard shortcut 488

change case 180
change cycle 180
exceptions 181
perform 180

change font 40
changing

fonts in FrameMaker 256
Character Map 174

access 174
command 482
installation 176
keyboard shortcut 488
Windows 2000/XP 175
Windows 95/98/ME/NT4 175

character spacing
Word 244

Check Embedded Codes
command 158, 480
keyboard shortcut 487

Check for Multiple Exact Matches
keyboard shortcut 488

Check Spelling
dialog 94, 187, 384, 462

check spelling 92
Check Terminology (Single Row)

keyboard shortcut 488
checks

terminology consistency 86

Clear All Assembled Translations
command 168

Clear All Fuzzy Match Translations
command 168

Clear All Translations
command 168

client
add to list of clients 133
assigning to records 131
definition 128
delete 138
find 138
modify 136
purpose 128
search 138
select for project 132, 143
storing settings 129

Clients
tab (Options dialog) 131

clients 128
import from Déjà Vu 3 135
managing 140
non-numeric codes 131
numerical listing 131
relevance 140

Close
command 477

Close All
command 483

cnt files. See Help content
codes

assemble 119
for languages and sublanguages 468

codes. See embedded codes
Color

dialog 30
color

change 29
color indicator

definition 28
list 28

color indicator bar 28
command

About 484
Add Lexicon to Translation Memory 482
Add Pair to Lexicon 480
Add Pair to Terminology Database 480
Add Pair to Translation Memory 480
Add to Terminology Database 482
Add to Translation Memory 481
Arrange Icons 484
Assemble 480
Build Lexicon 481
Cascade 484
Change Case 478
Character Map 482
Check Embedded Codes 480
Close 477
Close All 483
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command (continued)
Compact 483
Configure 486
Contents 484
Convert 483
Copy 478
Customize 483
Cut 478
Delete 478
Delete All Entities 486
Delete All Examples 486
Delete All Tags and Attributes 486
Exit 478
Export 477, 485
File Navigator 479
Find 478
Find Duplicate Sentences 481
Find Next 478
Find Next Terminology Mismatch 480
Fix Embedded Codes 481
Import 477, 485, 486
Index 484
Join Sentences 478
Login 482
Logout 482
Lookup 480
Lookup with Wildcards 480
New 477
Next 483
Open 477
Options 483
Paste 478
Populate All Languages 479
Populate Current Language 479
Pretranslate 479
Previous 483
Project Explorer 479
Propagate to All Files 481
Propagate to Current File 481
Properties 481, 485
Redo 478
Remove Entries 481
Repair 483
Replace 478
Resolve with Terminology Database 482
Resolve with Translation Memory 482
Scan 479
Scan with Wildcards 480
Search 484
See in Context 479
Select All 478
Spelling 482
Split Sentences 479
Tile Horizontally 483
Tile Vertically 484
Toggle Sorting 479
Undo 478
Unmark Duplicate Sentences 481
User Interface Language 483

command (continued)
Word Count 482

commands
SGML/XML filter-specific 486
terminology database-specific 485
translation memory-specific 485

Comment
icon 201

comment
delete 202
delete all 202
edit 201
review 201

comments
add 200
definition 491
use 200
view all rows with comments 201
Word 244

common Windows functions 174
Compact

command 483
compact

project file 104
reasons 105
satellite file 104
SGML filter file 104
terminology database 104
translation memory 104

compact database 104
complete project

select 43
view 43

compound words
spelling option 186

concept
lexicon 321

conditional change
dictionary 189

conditional change-preserve case
dictionary 189

configuration access
security restriction 211

Configure
command 486

Confirm Fuzzy Propagation
dialog 153

confirmation dialog
delete files 60

consistency checks
embedded codes 89
terminology 88
translations for duplicate source 90

Contents
command 484

context view 163
definition 164
format limitations 164
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contracted words
spelling option 186

control leading and trailing symbols
option 165

conversion
case 165
decimal 165
punctuation marks 165
spaces 165

conversions 164
acronyms 164
embedded codes 164
numbers 164
options 164
settings 164

Convert
command 483

convert Déjà Vu 2/3
terminology database 436

Convert Hard to Soft Spaces
FrameMaker import 256

Convert v2.x/3.x Memory Database
dialog 364

Convert v2.x/3.x Terminology Database
dialog 436

Copy
command 478
keyboard shortcut 487

copy
all sentences 167
embedded codes 158, 159, 160
single sentences 166
standard features 166

Copy All Codes
command 159
keyboard shortcut 487
uses 159

Copy Next Code
command 159
keyboard shortcut 487

CopyFlow
special discounts 269

count
characters 219
codes 219
words 219

create
new dictionary 190
project 69
project file 69

creating
translation memory 347

creating projecting
without source files 74

Ctrl+DownArrow
AutoAssemble 44
AutoPropagate 44
AutoSend 44

current file
status bar 35, 36, 43

current record
position 36

current row
check terminology mismatch 87
indicator 24

custom dictionaries 187
Customize

command 483
dialog 21

customize
keyboard shortcuts 19
toolbars 21

Customize Keyboard
dialog 19

Cut
command 478

cut
standard features 166

D
Database

menu 485
database formats

source file 66
database lookups

options 106
Databases

tab (Project Properties dialog) 208, 352, 421
databases

adding additional information 128
adding records 83
challenge of translation 251
compact utility 104
data exchange 104
feeding 83
fuzziness setting 106
lookup 107
Microsoft Jet 103
minimum score 107
newer matches 106
overview 103
performance 103
repair utility 104
scan 107
sending text 123
SQL 104
TMX import 104

databases, multilingual
new feature 10

date last exported
file details 61

date last imported
file details 61

date modified
file details 61
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date stamp 128
definition 491
field in databases 128

decimal conversion 165
default font 40
definition

bookmarks 490
embeddable tags 493
extractable attributes 493
extractable tags 493
ODBC 495
Pack & Go packages 496
pending 496
satellite files 498
security 498
Unicode 502
USB 503
UTF-16 502
UTF-8 502

Déjà Vu
analysis features 215
toolbox 3

Déjà Vu 2/3
terminology database import 428
translation memory conversion 363
translation memory import 358

Déjà Vu 3
import clients 135
import sentence delimiters 172
import subjects 146

Déjà Vu alignment file 13
Déjà Vu codes. See embedded codes
Déjà Vu interface 13
Déjà Vu project files 13
Déjà Vu SGML/XML filter 14
Déjà Vu terminology databases 14
Déjà Vu translation features 103
Déjà Vu translation memory 13
Déjà Vu user group 6
Déjà Vu workflow 63
Déjà Vu X

look and feel 7
new features 7

Déjà Vu’s quality assurance feature 86
Delete

command 478
keyboard shortcut 487

delete
all embedded codes 161
comment 202
embedded codes 160
single embedded code 160
translations 168
whole sentence 161

delete all
comments 202

Delete All Entities
command 486

Delete All Examples
command 309, 486

Delete all pairs previously sent from this project
Déjà Vu 3 command 126

Delete All Tags and Attributes
command 486

Delete Codes
command 161
keyboard shortcut 487

Delete Codes and Text
keyboard shortcut 487

Delete Comment
keyboard shortcut 489

delete files 60
confirmation 60
satellite files 208
security restriction 211
with Project Explorer 60

deleting term
terminology database 458

delimitation
incorrect 172
sentences 169

delimitation rules
definition 491

delimiter
definition 491

Delimiters
tab (Options dialog) 170

demo mode
definition 492

desktop publishing formats
source file 66

Dictionaries
dialog 188

dictionaries
add existing 191
add words 187
automatic change 188
automatic change-preserve case 189
conditional change 189
conditional change-preserve case 189
create 190
custom 187
default path 190
default setting 187
definition 187
exclude 189
ignore 189
spell checking 187
use of new 191
userdic.tlx 188

dictionary
export 195
import 192

digits
in propagate 151

Display
tab (Options dialog) 41
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Display Code
command 161
keyboard shortcut 488

Do Not Send
command 126
remove status 126
symbol 126

Do Not Send to Translation Memory
keyboard shortcut 488

dockable
definition 492

dockable windows
new feature 10

docking
disable 38
tool window 38

document window
definition 36, 492
Window menu 37

documentation
related 5

dongle
definition 492

dongle. See Getting Started Guide
doubled words

spelling option 185
down one screen

move 45
dragging files

Project Explorer 68
DTD

definition 492
use in SGML 297
use in XML 297

DTD support
new feature 11

DTP formats
source file 66

duplicate rows
displaying 91
indicator 29

duplicate sentences
unmark 92

Duplicates Only view
translation memory 346

Dutch
interface 11
user interface language 16

E
EBMT

definition 492
EBMT. See example-based machine translation
Edit

menu 478, 486
menu options 16

edit
comment 201

edit box
translating in 25

edit mode 24
new feature 10
switch into 25

edit source
satellite files 208
security restriction 211

Edit Term
dialog 458

edit vs. selection mode 24
editing phase 86
editing term

terminology database 457
embeddable tag

SGML/XML 297
embeddable tags

definition 493
Embedded Code

dialog 162
embedded code

definition 493
joining/splitting sentences 174

embedded codes 154
across formats 156
across tags 156
assemble 119
automatically copying all 159
automatically fixing 159
consistency checks 89
conversions 164
copying 158
copying automatically 159
definition 154
deleting 160
deleting all 161
deleting single 160
drawbacks of modifying 162
example 155
in propagate 151
manually copying 160
modifying 161
moving 158
moving from source to target 160
positioning 156
problems when reversing 157
protection 161
relative positioning 156
relevance 154
safety features 158

encoding
C/C++/Java files 287
Help content 275
HTML 276, 277
IBM TM 290
InDesign 272
PageMaker 266
Properties files 283
RC files 285
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encoding (continued)
SGML 280
SGML/XML 282
text files 274

end of file
jump to 45

end rule. See sentence delimitation
English

user interface language 16
entire project

view 43
entities

adding for SGML/XML filter 310
Entities and Characters (SGML/XML)

tab 309
Eurodicautom

template 409
exact match

definition 493
example-based machine translation 120

and assemble 120
definition 120
first scan for whole sentences option 122

Excel
application hangs 249
description of export 393, 449
file formats 247
import options 247
installation requirements 247
joining lines 249
limit file size 249
location of original files 247
splitting lines 249
terminology database export 448
terminology database import 428
translation memory export 386
translation memory import 358
v. 95 vs. later versions 386, 448

exclude
dictionary 189

exclude files
folder import 53

execute SQL
security restriction 211

existing project file
select 67

existing translation
aligning 65
import 65

Exit
command 478

Exit Déjà Vu X
keyboard shortcut 487

Expand AutoText
keyboard shortcut 488

Explorer. See Project Explorer
Export

command 477, 485

export 98
entire folder 57
files from project 98
folder structure 59, 100, 102
from lexicon 327
selecting several items 57
spelling dictionary 195

export data
security restriction 212

export files 57
with menu command 98, 100
with Project Explorer 57

Export Finished Translation
command 100

export folder 59, 100, 102
export for proofing 97
Export Options

dialog 58, 99, 101
export options 59

BIF 293
FrameMaker 258
HTML 99, 101, 276
SGML/XML 99, 101, 282
TagEditor 293
TMX 295
TTX 293
Word 242

export path
file details 61

Export Project
command 98

Export source comments as conditional text
command 258

Export source comments as Office comments
command 242

Export source comments as pop-up text
command 277

Export target comments as conditional text
command 259

Export target comments as Office comments
command 242

Export target comments as pop-up text
command 277

exporting data
terminology database 446
translation memory 384

Exposable Markers
FrameMaker import 255

external databases
Access database 64
Déjà Vu 2/3 memory database 64
Déjà Vu X translation memory 64
Excel format 64
formats 64
origin 64
text files 64
TMX 65
Trados Workbench 65
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external glossaries
Access 65
Déjà Vu 2/3 terminology databases 66
Déjà Vu X terminology databases 66
Excel files 65
formats 65
origin 65
text files 65

extractable attribute
SGML/XML 298

extractable attributes
definition 493

extractable tags
attributes 298
definition 493

extractable text 305
SGML/XML 298

extractable text in SGML/XML
nested tags 298

F
features

translation 103
File

menu 477, 485, 486
file details

date last exported 61
date last imported 61
date modified 61
export path 61
name 61
Project Explorer 60
size 61
source path 61
type 61

file extension
Trados Word 292

file formats
Access 251
C/C++ 285
embedded codes 156
Excel 247
FrameMaker 253
GNU gettext 287
Help content 274
HTML 275
IBM TranslationManager 289
InDesign 269
Interleaf 273
Java 285
Java properties 283
OpenOffice.org 250
overview 227
PageMaker 261
plain text 274
PO/POT 287
PowerPoint 246
QuarkXpress 266

file formats (continued)
RC 283
RTF 245
SGML/XML 279
StarOffice 250
text 274
TMX 294
Trados TagEditor 292
Trados Word 290
working with different 227

file management 67
File menu 16

options 16, 17
File Navigator 10, 26

command 479
definition 26, 494
differences from Project Explorer 48
navigating the project 48
selecting files to view 43
switching with Project Explorer 17

file size
limit in Excel 249

file types mixing
new feature 10

files
align 366
compacting and repairing 104
import 67

Filter
translation memory 343

filter
select rows by 47
status 28

filter by selection
benefits 98

Filter Definition File
select 280
SGML/XML import 280

Filter on Selection
command 47

filter on selection
clear 47
editing 47

Filter Options
dialog 237

filtering conditions
terminology database export 453
translation memory export 389, 397

Filters
tab (Project Properties dialog) 235

Find
command 478
dialog 177
keyboard shortcut 487

find
features 177
use 177

Find Duplicate Sentences
command 481
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Find Duplicate Sentences (continued)
dialog 90, 346
translation memory 346

Find Next
command 178, 478
keyboard shortcut 487

Find Next Terminology Mismatch
command 480
keyboard shortcut 488

finished row
symbol 28

first scan for whole sentences
option and EBMT 122
options 119

Fix Embedded Codes
command 481
keyboard shortcut 487

fixing
embedded codes 159

folder
import 68

folder import
exclude files 53

folder structure
import 68

font
change 40
default 40
set 40

Font Mapping 256
font size

change 40
Fonts

dialog 42
fonts

changing in FrameMaker 256
format

definition 494
format filters

definition 494
formats

embedded codes 156
external glossaries 65
source files 66
working with different 227

Found Source
Scan Results dialog 108

Found Target
Scan Results dialog 108

FrameMaker
.fm vs. .mif 253
batch convert to .mif 261
change bars 261
Convert Hard to Soft Spaces 256
converting .fm to .mif 254
export options 258
Exposable Markers 255
file formats 253
font mapping 256

FrameMaker (continued)
Ignore Automatic Numbering 256
Ignore Cross-Reference Definitions 256
Ignore Text on Master Page 256
Ignore Variable Definitions 255
import options 255
soft returns 173
tips and tricks 261
use of Ignore options in book 261

French
interface 11
user interface language 16

French bracket codes. See embedded codes
full word count 215
fuzziness

recommended setting 107
fuzziness setting

adjusting 106
fuzzy match

definition 494
percentage bar 28

G
General

tab (Options dialog) 106, 119, 130, 165
tab (Project Properties dialog) 132, 143, 208
tab (Terminology Database Properties dialog) 414

Global Font Replacement
dialog 258

glossaries
Access 65
Déjà Vu 2/3 terminology databases 66
Déjà Vu X terminology databases 66
Excel files 65
text files 65

glossary 490
alignment 490
alphabetic order 490
antonym 490
assemble 490
attribute 490
batch processes 490
case sensitive 491
CAT 491
comments 491
date stamp 491
delimitation rules 491
delimiter 491
demo mode 492
dockable 492
document window 492
dongle 492
DTD 492
EBMT 492
embedded code 493
exact match 493
File Navigator 494
format 494
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glossary 490 (continued)
format filters 494
fuzzy match 494
guaranteed match 494
hard return 494
lemma 494
lexicon 495
lookup 495
machine translation 495
match 495
natural order 495
parallel port 496
perfect match 496
populate 496
pretranslate 496
primary window 496
Project Explorer 497
project file 497
propagate 497
Properties window 497
regular expressions 497
Rows Selector 498
scan 498
secondary window 498
segments 498
sentences 499
SGML 499
SGML/XML filter 499
soft return 499
source 499
SQL 500
symmetric 500
synonym 500
tag 500
target 500
Target Language Selector 500
template 501
terminology database 501
Text/Record Locator 501
time stamp 501
TMX 501
tool window 501
transitive 502
translation memory 502
wildcard 502
XML 502

glossary for clients
lexicon 76

GNU gettext
definition 287
file formats 287

GNU gettext format
new feature 11

Go to Next Row
keyboard shortcut 488

Go to Next Row (Overwrite)
keyboard shortcut 488

Go to Next Untranslated Row
keyboard shortcut 488

Go to Previous Row
keyboard shortcut 488

Go to Previous Untranslated Row
keyboard shortcut 489

Go to the Beginning of Table
keyboard shortcut 488

Go to the End of Table
keyboard shortcut 488

graphics
in PowerPoint 247

guaranteed match
definition 494

H
hard return

definition 494
hard returns

PowerPoint 247
sentence delimitation 173

Help
keyboard shortcut 487
menu 484

Help content
definition 274
encoding 275
file formats 274
sample 274

Help formats
source file 66

Help menu 18
options 18

hidden text
ignore in Word 240

hierarchy
subjects 141

Highlight text in exported files
command 242, 259, 277

HTML
editor 279
encoding 276, 277
export options 99, 101, 276
file formats 275
Ignore Strings in Script 275
import options 275
missing images 279
special characters 276
tips and tricks 279
Unicode 277

hyphenated words
spelling option 186

I
IBM TM

encoding 290
IBM TranslationManager

file formats 289
translate 289
untranslated segment file 289
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ignore
dictionary 189

Ignore Automatic Numbering
FrameMaker import 256

Ignore Cross-Reference Definitions
FrameMaker 256

Ignore Hidden Text
import option for Word 240
use 240

ignore Internet addresses
spelling option 185

ignore numbers
spelling option 185

Ignore Red Text
Excel import option 248

Ignore Strings in Script
HTML import 275

Ignore Text in Single Quotes
C/C++/Java import 286

Ignore Text on Master Page
FrameMaker import 256

Ignore Variable Definitions
FrameMaker import 255

images
HTML 279

Import
command 477, 485, 486

import
.tlx dictionaries 192
external file into lexicon 334
folder 68
folder structure 68
selecting several items 50
spelling dictionary 192
subfolder 68
text spelling dictionaries 192

import data
security restriction 212

Import DV3 Settings
dialog 136, 147

import files 49, 67
with Project Explorer 49

import folders 53
with Project Explorer 53

import of glossaries
Access 65
Déjà Vu 2/3 terminology databases 66
Déjà Vu X terminology databases 66
Excel files 65
text files 65

import options
Access 251
BIF 293
C/C++/Java 286
Excel 247
FrameMaker 255
HTML 275
New Project Wizard 74
PowerPoint 246

import options (continued)
project-wide settings 234
RTF 245
SGML/XML 280
TagEditor 293
TMX 294
TTX 293

importing data
into terminology database 427
into translation memory 356

importing databases
Access database 64
Déjà Vu 2/3 memory database 64
Déjà Vu X translation memory 64
Excel format 64
text files 64
TMX 65
Trados Workbench 65

importing glossaries
preparing 66

InDesign
batch-export 271
batch-export and Unicode 271
encoding 272
export a story 269
file formats 269
tagged text file 269

InDesign filter
new feature 11

Index
command 484

index
lexicon 321

indicator
current row 24
duplicate rows 29

indicator bars
change color 29

individual translation files
display 43
select 43

Insert
menu 479

insert
current target with source 167

Insert menu 17
options 17

insert text for failed portions
option 120
pretranslation 82
uses and benefits 82

installation. See Getting Started Guide
installing Déjà Vu. See Getting Started Guide
installing dongle. See Getting Started Guide
integrated development environment 36
interface

Déjà Vu 13
project 15
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Interleaf
ASCII files 273
file formats 273
save as ASCII file 273

internal codes. See embedded codes

J
Java

file formats 285
Java files

definition 285
Java properties

definition 283
file formats 283
sample 283

Jet engine 103
join lines

Excel 249
join rows

satellite files 208
security restriction 211

Join Sentences
command 173, 478
keyboard shortcut 488

joining sentences 172, 173
embedded code 174
reasons 172

jump to
previous sentence 44
previous untranslated sentence 44

jump to next sentence
no status change 44

K
keyboard shortcuts 19

access to Déjà Vu features 19
add new 19
customize 19
list of 486
modify 19

L
language

selecting in project 35
language mapping

BIF 293
TMX 294
TTX 293

language selector 35
languages

available for spell check 92
display order 71
select 71
switch user interface 15
vs. sub-languages 71

leading symbols 165

lemma
definition 494

levels
user access 211

Lexicon
menu 481
sub-menu 17

lexicon
automatically resolve with databases 78
Build command 76
change sorting 322
concept 76
create 76
current language 325
current vs. all files 77
definition 76, 321, 495
export 327
frequency (Freq) 78
generating 76
glossary for clients 76, 322
importing external file 334
in comparison to other databases 76
language 325
manual translation 79
manually add entries 323
new concept 321
number of words 78
open from File Navigator 78
optional workflow component 76
reasons for adding entries 324
removal options 79
remove entries 79, 333
remove rows 79
resolve with databases 79
resolve with terminology databases 325
resolving the translation memories 324
resolving with databases 324
send to terminology database 326
sending data 127
sending text 123
sending to translation memories 325
sorting options 323
translate 78
translating with other databases 77
useful vs. useless entries 77
uses 322
vs. terminology database 322

lexicon export
into text format 329
supported formats 329

Lexicon Export Wizard 328
lexicon import

supported formats 335
uses 334

Lexicon Import Wizard 335
Lexicon menu 17
limit to current record selection

option 125
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lines
moving 44
switching 44

load
Microsoft Office spell checker 96

local drive
Project Explorer 48

Locate Sentence
translation memory 342

Locate Term
terminology database 443

locating term
terminology database 456

location of source files 67
Lock

symbol 127
lock

group of rows 127
unlock rows 127

lock rows
satellite files 208
security restriction 211

Lock vertical scrolling in project view
command 44

Lock/Unlock Rows
keyboard shortcut 488

locked row
symbol 28

locked rows
and propagate 152
view 128

Locking Rows
command 127

log in
project 212
repeat 213
terminology database 212
translation memory 212

log out
project 213
terminology database 213
translation memory 213

Login
command 482

login name 211
Logout

command 482
Lookup

command 480
keyboard shortcut 487

lookup
database 107
definition 107, 495
terminology database 107, 113
with wildcards 115
with word stems 115

Lookup with Wildcards
command 480
keyboard shortcut 487

M
machine translation

definition 495
Macintosh

change code page 266
macros disabled

Word 244
main interface

translation grid 23
main sentence

in translation memory 360
manual

convention 4
how to use 1
index 2
menu commands 5
notes 5
overview 1
path names 5
related documentation 5
sample text 5
tips 5
user interface controls 4

manual assemble 118
manual propagate 152

difference to AutoPropagate 152
manually adding records

terminology database 424
manually resize

windows 38
mapping

fonts 256
marking sentences as pending 199
match

definition 495
maximum number of words

lexicon 77
memory databases. See translation memory
menu

Database 485
Edit 16, 478, 486
File 16, 477, 485, 486
Help 18, 484
Insert 17, 479
Lexicon 17, 481
Project 17, 481
Tools 18, 482
Translation 17, 479
Users 18, 482
View 17, 479
Window 18, 483

menu bar 16
Merge

translation memory 344
merge segments

security restriction 211
merging

terminology database 458
Microsoft Access. See Access
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Microsoft Excel. See Excel
Microsoft Jet

databases 103
Microsoft Office spell checker 184

loading 96
MIF Font Mapping

tab (Project Properties dialog) 257
minimize options 40
minimum score 107

recommended setting 107
mode

edit 24
edit vs. selection 24
selection 44

model
workflow 63

modify
embedded codes 161
sentence delimitation rules 170

modifying term
terminology database 457

monitor
working with several 37

mouse
move 45

move
beginning of file 45
context menu 45
embedded codes 158, 160
end of file 45
lines 44
mouse 45
screen up and down 45
scrollbar 45
wheelmouse 45

moving around
project file 43

multilingual interface
new feature 11

multiple exact matches 83

N
name

file details 61
natural order 26

definition 495
switch to alphabetic order 27

navigation bar
new feature 10

Navigator. See File Navigator
nested tags

extractable text in SGML/XML 298
network drive

Project Explorer 48
New

command 477
New Dictionary

dialog 190

new feature
analysis 11
configurable terminology databases 10
dockable windows 10
DTD support 11
edit/selection mode 10
GNU gettext format 11
InDesign filter 11
mixing of file types 10
multilingual databases 10
multilingual interface 11
navigation bar 10
newly supported formats 11
PowerPoint filter improved 11
Project Explorer 9
Project Navigator 8
search module 11
subtitling format 11
Trados BIF format 11
translation in table 9
Unicode 10

new features
overview 7

New File
dialog 69, 299, 312, 348, 367, 404
keyboard shortcut 487

new files
import into old vs. new projects 126

new project
create 69

New Project Wizard 70
no import options 74

New SGML/XML Filter Wizard 299, 312
New Terminology Database Wizard 405
New Translation Memory Wizard 349
newer matches

databases 106
newly supported formats

new feature 11
Next

command 483
Next Bookmark

dialog 198
keyboard shortcut 489

next sentence
jump to 44

nickname. See user
Non-translatable Notes

WinHelp example 241
WinHelp files 240
Word import option 240

notes
import option for PowerPoint 246
non-translatable in Word 240
OpenOffice.org/StarOffice 250

number conversions
limitations 164

number of characters
RC files 285
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number of characters (continued)
status bar 36

number of records
terminology database 402
translation memory 354

numbers
conversions 164
in propagate 151

numerical listing
clients 131

O
ODBC

definition 495
description of export 393, 449

ODBC Import Options
dialog 252

Office Proofing Tools
reload 96

Office spellchecking dictionaries
locating 193

Open
command 477

Open File
keyboard shortcut 486

open files
access from status bar 44

opening
alignment file 378
translation memory 347

OpenOffice.org
file formats 250

OpenOffice.org/StarOffice
notes 250
record changes 250
use AutoFormat 250

option catalogs
managing 39

Options
command 483

options
minimize 40
spelling 183

options for pretranslation 81
order

alphabetical 27
natural 26

overview
databases 103
manual 1

overwriting
pretranslation 82

P
Pack & Go Export Progress

dialog 204
Pack & Go Import Wizard 206

Pack & Go packages 203
create 203
definition 203, 496
open 204
return 208
size reduction 204
translate 208
uses 203

PageMaker
encoding 266
export a story 261
file formats 261
re-import the story 264, 271
tagged text file 261
tips and tricks 266
working with double-byte languages 266
working with Mac files 266

parallel port
definition 496

partial matches
fuzzy setting 107

Paste
command 478
keyboard shortcut 487

paste
standard features 166

Pending
keyboard shortcut 488

pending
definition 496
mark sentences 199

pending rows
view 200

pending symbol 199
pending, mark as

benefits 98
perfect match

definition 496
performance

databases 103
phonetics

spelling option 186
plain text

file formats 274
PO/POT

file formats 287
populate

all sentences 167
definition 166, 496
one vs. all sentences 168
overwrite 168
risks 168
single sentences 166

Populate All Languages
command 479
keyboard shortcut 489

Populate Current Language
command 479
keyboard shortcut 489
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Populate Current Sentence
command 166, 168, 333
keyboard shortcut 489

Populate Current Sentence (Insert)
keyboard shortcut 489

populating
all target languages 168

position indicator 285
position of characters

status bar 36
position of current record

status bar 36
Power Scan 110

use 110
PowerPoint

check for graphics 247
file formats 246
import options 246
installation requirements 246
location of original files 246
prepare files 247
soft returns 173
tips and tricks 247

PowerPoint filter improved
new feature 11

preparing glossaries for import 66
preprocessed files

source files 66
presentation formats

source file 66
Pretranslate

command 479
dialog 81
keyboard shortcut 487

pretranslate
definition 496

pretranslation
accept only exact matches 81
assemble from portions 82
benefits 80
definition 80
insert text for failed portions 82
options 81
overwriting 82
process 80

pretranslation phase 80
prevent row

sending to translation memory 126
Prevent Segmentation

use in C/C++/Java files 287
use in RC files 285

Previous
command 483

Previous Bookmark
dialog 199
keyboard shortcut 489

previous sentence
jump to 44

previous untranslated sentence
jump to 44

primary window 41
definition 496

Process notes
import option for PowerPoint 246

Process Slide Master
import option for PowerPoint 247

Project
menu 481

project
analysis 223
associate terminology databases 420
associate translation memories 352
creating without importing source files 74

project building phase 67
Project Explorer 48

access 48
close 51, 56
command 479
definition 497
delete files 60
detail fields 60
differences from File Navigator 48
export files 48, 57
import files 48, 49
import folders 53
import new files into projects 67
local drive and network 48
new feature 9
switching with File Navigator 17

Project Explorer view 68
project file 13

compact 104
create 69
definition 497
moving around 43
reading 86
reading in Déjà Vu 86
repair 105

project glossary
lexicon 321

project ID 128
field in databases 128
on General tab 132, 143

project interface 15
Project menu 17

options 17
project name

specify 70
Project Navigator

new feature 8
project toolbar 20
proofing

export into original format 97
proofing in Déjà Vu

pros and cons 97
proofing in original format

pros and cons 97
Déjà Vu X Standard 521



Index
propagate 151
definition 151, 497
manually 152
manually to all files 153
overwrite 152

Propagate in Current File
command 152
keyboard shortcut 489

Propagate in Current File (Overwrite)
keyboard shortcut 489

Propagate to All Files
command 154, 481
keyboard shortcut 489

Propagate to All Files (Overwrite)
keyboard shortcut 489

Propagate to Current File
command 481

propagation
differences between different modes 152

propagation. See propagate
Properties

command 481, 485
Properties files

encoding 283
properties files. See Java properties
Properties window 50, 55, 68

definition 497
in Project Explorer 50, 55, 68

Proposed Translation
Scan Results dialog 108

protect
rows 127

Q
quality assurance features 86
quality assurance phase 86
QuarkXPress

batch export .xtg files 269
CopyFlow 269
export .xtg file 266
file formats 266
re-import .xtg file 267
Tag file 266
working with double-byte languages 269
working with Mac files 269

QuarkXpress
tips and tricks 269

QuarkXPress Passport 269
QuickSilver. See Interleaf

R
range of rows

select 46
RC

file formats 283
RC files

character count 285
converting quotes 285

RC files (continued)
copyright note 284
definition 283
encoding 285
Prevent Segmentation 285, 287
sample 284
tips and tricks 285

reading the project file
different methods 86

readme file 5
rearrange windows 36
record

jumping to specific 44
record changes

OpenOffice.org/StarOffice 250
record locator 26
red text

ignore in Excel 248
Redo

command 180, 478
keyboard shortcut 487

redo
perform 179, 180

reflexive relation
definition 416

regular expressions
definition 497
for filtering export from terminology database 463
for filtering export from translation memory 463

related documentation
readme 5
user group 6
website 5

Relations
tab (Terminology Database Properties dialog) 415

relations
defining for terminology database 415

reload
Office Proofing Tools 96

Remove
translation memory 343

remove
duplicate sentences indicator 92
sentence delimitation rule 171
status indicators 31

Remove Entries
command 481

Remove lexicon rows 79
dialog 333

renumbered matches 216
Repair

command 483
repair

project file 105
reasons 105
satellite file 105
terminology database 105
translation memory 105

repair database 104
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repairing installation. See Getting Started Guide
Replace

command 178, 478
dialog 178
keyboard shortcut 487

replace 178
features 177

reset
status indicators 31

Reset Sentence Status
keyboard shortcut 488

resize
windows 38

Resolve Lexicon
dialog 324, 325

Resolve with Terminology Database
command 482

Resolve with Translation Memory
command 482

resource files. See RC
review

comment 201
review features 197
Rich Text Format. See RTF
Row Highlight Options

dialog for FrameMaker export 259
dialog for HTML export 277
dialog for Word export 243

rows
locking 127
protecting 127

Rows Selector
definition 498
Duplicate Rows 91

rows selector 28
view pending rows 200

RTF
file formats 245
import options 245
Microsoft standard 245
non-Microsoft versions 245
security settings 245

RTF import options. See Word
rules

delimitation 169
Russian

interface 11
user interface language 16

S
satellite file

compact 104
repair 105

satellite files 208
definition 208, 498
restrictions 208
security options 209
vs. project files 208

save 180
project 180

Scan
command 479
keyboard shortcut 487

scan
database 107
definition 107, 498
navigate matches 109
translation memories 107
translation memory 107
with wildcards 110
with word stems 110

Scan Results
dialog 108

Scan with Wildcards
command 480
keyboard shortcut 487

sci files
support 250

script-based files 275
scrollbar

move 45
Search

command 484
search

features 177
terminology database 113
with wildcards 110, 115

search and replace 178
terminology database 457

search module
new feature 11

secondary window 41
definition 498

security
definition 498

security features
in Déjà Vu 211
limitations to translation user 211

security options
satellite files 209

security restriction
configuration access 211
delete files 211
edit source 211
execute SQL 211
export data 212
import data 212
join rows 211
lock rows 211
merge segments 211
split rows 211

See in Context
command 163, 479
keyboard shortcut 488

segmentation rule. See sentence delimitation
segments

definition 498
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select
all rows 46
all rows downwards 46
all rows upwards 46
existing project file 67
languages 71
range of rows 46
rows by filtering 47
rows by status 47
SQL 31

Select All
command 478
keyboard shortcut 487

Select Location of "New Pack & Go Package"
dialog 204

select rows 45
in selection mode 45

Select SQL
dialog 32, 346, 461

Select User Interface Language
dialog 15

selection mode 24, 44
moving in the project 45
new feature 10
switch into 24, 44

selection vs. edit mode 24
selector row 26
selector rows

language selector 35
rows selector 28
text/record locator 26

Send Lexicon to Terminology Database
dialog 327

Send Lexicon to Translation Memory
dialog 326

Send Project to Translation Memory
dialog 125

sending data
lexicon 127
terminology database 127

sentence delimitation 169, 171
alignment 373
Asian languages 172
common abbreviations 169
common rules 169
correcting errors 173
definition 169
differing punctuation between languages 169
exceptions 169, 170
modify rules 170
non-Western punctuation systems 172
remove rule 171
symbols and definition 171

sentence delimiters
import from Déjà Vu 3 172

sentence pairs
duplicates in translation memory 123
overwriting in translation memory 123, 126

sentence scan 107

sentences
definition 499
delete whole 161
joining 172, 173
mark as pending 199
splitting 172, 173

separate sentences. See sentence delimitation
set font 40
settings.dvset file

changing location 129
setup. See Getting Started Guide
SGML

definition 280, 297, 499
encoding 280
filter file 14
how to recognize 280
support 280

SGML filter
create from SGML file 298

SGML filter file
compact 104

SGML filter files
creating 297
maintaining 297

SGML/XML
defining the filter 282
definition of attributes 297
definition of tags 297
encoding 282
export options 99, 101, 282
extractable attribute 298
extractable text 298
file formats 279
Filter Definition File 280
import options 280
special characters 282
tips and tricks 282

SGML/XML attributes
extracted 308

SGML/XML filter
adding data 319
convert Déjà Vu 2/3 filter 319
create from DTD 311
definition 14, 499
delete examples 308
import from Déjà Vu 2/3 filter 319

SGML/XML tags
embedded 306, 307

Shared settings location
option 130

shortcuts
keyboard 19

simple word count 215
single translation files

select 43
size

file details 61
slide master

import option for PowerPoint 247
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soft return
definition 499

soft returns
FrameMaker 173
PowerPoint 173, 247
sentence delimitation 173

software development formats
source file 66

sort alphabetically
benefits 98

sort by status
benefits 98

Sort Lexicon
toolbar 323

sort order
switch 27
terminology database 456

sorting
lexicon 322

Sought Source
Scan Results dialog 108

Source
Terminology Lookup dialog 114

source
definition 499

source files
database format 66
desktop publishing format 66
file management 67
formats 66
Help format 66
location 67
network 67
originating application 67
preprocessed files 66
presentation format 66
selecting in New Project Wizard 73
software development formats 66
spreadsheet format 66
tagged formats 66
word processing formats 66

source language
terminology database interface 442

source path
file details 61

Source Sentence in Context
dialog 163

source view. See context view
Spanish

interface 11
user interface language 16

special characters
HTML 276
SGML/XML 282

specific record
jumping to 44

specify
project name 70

spell check
Déjà Vu’s spell checker 93
of non-supported languages 93
with Microsoft Word 95

spell check with Word
condition 95

spell checker
Microsoft Office 184

spell checking 92
dictionaries 187
integrated languages 92
options 94
terminology database 461
translation memory 382

Spell Checking Options
dialog 383, 461

Spelling
command 482
keyboard shortcut 488
tab (Options dialog) 184

spelling
options 183

spelling dictionary
export 195
import 192

spelling option
allow accented capital 184
case sensitive 185
doubled words 185
ignore Internet addresses 185
ignore numbers 185
split compound words 186
split contracted words 186
split hyphenated words 186
strip possessives 186
suggest phonetics 186
suggest split words 186
suggest typographical 186
uncapitalized words 185
use the Microsoft Office spell checker 184
words in capitals 185
words that begin with a capital letter 185
words with digits 185
words with embedded capital letters 185

split compound words
spelling option 186

split contracted words
spelling option 186

split hyphenated words
spelling option 186

split lines
Excel 249

split rows
satellite files 208
security restriction 211

Split Sentences
command 173, 479
keyboard shortcut 488

split sentences 173
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split words
spelling option 186

splitting sentences 172
embedded code 174
reasons 172

spreadsheet formats
source file 66

SQL
access to databases 104
definition 500

SQL select 31
terminology database 461
translation memory 346

SQL Statement
record locator 29
view 31

standard toolbar 20
StarOffice

file formats 250
Statistics

tab (Terminology Database Properties dialog) 402
tab (Translation Memory Properties dialog) 355

statistics
terminology database 402
translation memory 354

status
select rows by 47
tooltip 29

status bar 35
access to open files 44
currently open files 35
number of characters 36
position of current record 36
position of cursor 36
shortcut to automated options 35
stacked 35

status filter 28
status indicator

reference 29
review 29

status indicator bar 28
status indicators

remove 31
reset 31

strip possessives
spelling option 186

subfolder
import 68

subject
add to list of subjects 144
assigning to records 142
definition 128
delete 149
find 149
modify 147
purpose 128
search 149
storing settings 129

Subjects
tab (Options dialog) 141

subjects 128
associated codes 142
hierarchical listing 141
import from Déjà Vu 3 146
managing 151
non-numeric codes 141
preset list 141
relevance 151
relevance of hierarchy 142
select for project 143

sub-languages
matching hierarchy 71

subtitling format
new feature 11

suggest phonetics
spelling option 186

suggest split words
spelling option 186

suggest typographical
spelling option 186

Swap Current and Next Words
keyboard shortcut 488

Swap Previous and Current Words
keyboard shortcut 488

switching lines 44
sxc files

support 250
sxw files

support 250
symbol

Do Not Send 126
finished row 28
Lock 127
locked row 28
pending 199
Warning 158
wrong codes 29

symbols
sentence delimitation 171

symmetric
definition 500

symmetric relation
definition 416

synonym
add to terminology database 441
definition 500

T
tag

definition 500
TagEditor

export options 293
import options 293

TagEditor. See Trados TagEditor
tagged formats

source files 66
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tags (SGML/XML)
definition 297

Tags and Attributes (SGML/XML)
tab 305, 317

Target
Terminology Lookup dialog 114

target
definition 500

Target Language Selector
definition 500

teamwork features
benefits 203

Template Name
dialog 412

templates
assigning 410
creating 411
defining in wizard 407
definition 409, 501
Eurodicautom 409
terminology databases 409

terminology
consistency checks 88

terminology consistency checks 86
terminology database

add terms 84
adding additional information 128
adding non-translation records 441
adding records 84, 423
adding translation records 423
All Rows view 460
associate with project 420
compact 104
convert Déjà Vu 2/3 436
create 72
create as stand-alone file 404
create with New Project Wizard 72
creating 403
defining attributes 417
defining categories 419
defining relations 415
definition 14, 501
deleting term 458
editing 456
editing term 457
exporting data 446
filtering the export 453
fuzziness setting 106
importing data 427
importing glossaries 65
Locate Term 443
locating term 456
lookup 107, 113
manually adding records 424
merging 458
modifying term 457
opening 401
options to create 403
relevance 122

terminology database (continued)
remove from project 421
repair 105
search 113
search and replace 457
select 72
select with New Project Wizard 72
sending data 127
sending text 123
sort order 456
spell checking 186, 461
SQL select 461
standard fields 431
statistics 402
supported export formats 447
supported import formats 428
templates 409
views 460

terminology database attributes
considerations 85

Terminology Database Export Wizard 447
Terminology Database Import Wizard 427
terminology database interface

source language 442
Terminology Database Properties

dialog 414
terminology database records

specifications 85
Terminology Database Templates

dialog 411, 412
terminology databases

creating and maintaining 401
terminology databases, configurable

new feature 10
Terminology Lookup

dialog 114
terminology mismatch

check current row 87
text

description of import 393, 449
file formats 274

text area
translating in 25

text box
translating in 25

text boxes
Word 245

text files
encoding 274
terminology database import 428
translation memory import 358

text locator 26
Text/Record Locator

definition 501
text/record locator 26
third-part glossaries

Déjà Vu X terminology databases 66
third-party databases

Access database 64
Déjà Vu X Standard 527



Index
third-party databases (continued)
Déjà Vu 2/3 memory database 64
Déjà Vu X translation memory 64
Excel format 64
formats 64
import in translation memory 64
text files 64
TMX 65
Trados Workbench 65

third-party glossaries
Access 65
Déjà Vu X terminology databases 66
Excel files 65
formats 65
import in terminology database 65
origin 65
text files 65

Tile Horizontally
command 483

tile horizontally
windows 38

Tile Vertically
command 484

tile vertically
windows 38

time stamp 128
definition 501
field in databases 128

tips and tricks
C/C++/Java 287
FrameMaker 261
HTML 279
PageMaker 266
PowerPoint 247
QuarkXpress 269
RC 285
SGML/XML 282
Trados Word 292
Word 244

TMX
definition 501
description of import 387
export options 295
file formats 294
import options 294
language mapping 294
source and target 294
translation memory export 386
translation memory import 358
use as a translation format 294
vs. Trados export 387

Toggle Bookmark
keyboard shortcut 489

Toggle Sorting
command 479

tool window
arrange several 38
closing 38
definition 36, 37, 501

tool window (continued)
disable docking 38
docking 37

toolbar 20
project 20
Sort Lexicon 323
standard 20

toolbars
configurable 14
create new 21
customize 21
customize view 22

toolbox
Déjà Vu 3

Tools
menu 482

Tools menu 18
options 18

tooltip
status 29

track changes
Word 244

Trados
vs. TMX export 387

Trados BIF format
new feature 11

Trados RTF. See Trados Word
Trados TagEditor

file formats 292
Trados Word

configure file extension 292
file formats 290
fuzzy matches 290
installation requirements 290
location of original file 292
Segment Unknown Sentences 292
split/join sentences 292
tips and tricks 292

Trados Workbench
description of import 387

Trados Workbench databases
translation memory export 386
translation memory import 358

TradosTagEditor
fuzzy matches 292
XTranslated units 292

trailing symbols 165
transitive

definition 502
transitive relation

definition 416
Translation

menu 479
translation features

Déjà Vu 103
translation grid 23

automatic resizing 24
translation in table

new feature 9
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translation memories
creating and maintaining 341

translation memory 13
Add 343
adding additional information 128
All Rows view 345
associate with project 352
compact 104
create 72
create with New Project wizard 72
creating 347
creating as stand-alone file 348
definition 13, 502
Duplicates Only view 346
exporting data 384
Filter 343
filtering the export 389, 397
Find Duplicate Sentences 346
fuzziness setting 106
importing data 356
importing databases 64
interface 341
Locate Sentence 342
manually sending data 123
Merge 344
opening 347
options to create 348
prevent sending row 126
Remove 343
remove from project 352
repair 105
scan 107
select 72
select with New Project Wizard 72
send portion of sentence 124
send project options 125
send whole project 124
sending data 123
sending text 123
spell checking 186, 382
SQL select 346
standard fields 360
statistics 354
supported export formats 385
supported import formats 357

Translation Memory Export Wizard 385
Translation Memory Import Wizard 357
translation memory interface

source language 341
target language 342

Translation menu 17
options 17

translation phase 83
translation user

nine levels 211
usage limitations 211

translation workflow 63
TranslationManager. See IBM TranslationManager

translations
delete 168

translations for duplicate source
consistency checks 90

Transref website 5
TTX

export options 293
import options 293
language mapping 293

type
file details 61

type of project
on General tab 132, 143

typographical
spelling option 186

U
UDC. See Universal Decimal Classification
uncapitalized words

spelling option 185
Undo

command 179, 478
keyboard shortcut 487

Unfilter
command 47

unfilter
filter on selection 47

Unicode
definition 502
HTML 277
new feature 10

uninstalling Déjà Vu. See Getting Started Guide
Universal Decimal Classification 141
unlock rows 127
unmark

duplicate sentences indicator 92
Unmark Duplicate Sentences

command 481
up one screen

move 45
USB

definition 503
use the Microsoft Office spell checker

spelling option 184
user 128

field in databases 128
user access

levels 211
user dictionaries. See dictionaries
user group

Déjà Vu 6
user interface

Déjà Vu 13
project 15
switch language 15

User Interface Language
command 483
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User Login
dialog 212

user name 211, 213
default Windows logon 36
in databases 36

user types 2
beginner 2
convert 3
upgrader 4

userdic.tlx
dictionary 188

Users
menu 482

Users menu 18
options 18

UTF-16
definition 502

UTF-8
definition 502

V
View

menu 479
view

All Files 43
context 163
SQL Statement 31

View menu 17
options 17

views
terminology database 460

W
Warning

symbol 158
wheelmouse

move 45
wildcard

definition 502
wildcards

client search 139
lookup with 115
scan with 110
subject search 150

Window
menu 483

window
primary 41
secondary 41

Window menu 18
options 18

Window Type
option 41

windows
rearrange 36

Windows functions
common 174

Windows logon
user name 36

wizard
New Project 70

Word
character spacing 244
comments 244
duplicated text in text boxes 245
export options 242
macros 244
security setting 244
tips and tricks 244
track changes 244
use AutoFormat 245

Word Count
command 482
dialog 219
keyboard shortcut 488

word count 219
save in external file 222

word count modules
simple vs. full 215

word processing formats
source file 66

word stems
lookup 115
scan 110

words in capitals
spelling option 185

words that begin with a capital letter
spelling option 185

words with digits
spelling option 185

words with embedded capital letters
spelling option 185

workflow
editing and QA phase 86
editing phase 86
export phase 98
phases 64
preparation phase 64
pretranslation 80
project building phase 67
quality assurance phase 86
suggestions 63
translation phase 83

workflow phase
preparation 64

wrong codes
symbol 29

X
XML

definition 502
XML filter

create from XML file 298
XML filter files

creating 297
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XML filter files (continued)
maintaining 297

XML. See SGML/XML
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