DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> Kyocera KR1 RK1010 firmware update SUCCESS/FAILURE thread : EVDOforums.com


Discuss EVDO PC Cards, ExpressCards, EVDO USB, PDAs, Phones, Coverage and Mobile Broadband Cards. Discuss Verizon and Sprint Coverage. Kyocera KR1, CradlePoint CTR350 / PHS300 & LinkSys WRT54G3G-ST Forums!
EVDOforums.com
Discussion forum for EVDO users
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Our sites Include: EVDO Info :: EVDO Forums :: EVDO Maps :: EVDO Blog :: 3Gstore.com

To purchase your EVDO Card / Antenna / Amplifier / Router from the EVDO Experts, just contact us!

Kyocera KR1 RK1010 firmware update SUCCESS/FAILURE thread

Goto page 1, 2, 3, 4  Next  
Post new topic   Reply to topic    EVDOforums.com Forum Index -> Kyocera KR1 / KR2 Router Support Forum
View previous topic :: View next topic  
Author Message
Michael
Site Admin


Joined: 13 Jan 2005
Posts: 4698
Location: Cary, IL

PostPosted: Fri May 04, 2007 8:41 pm    Post subject: Kyocera KR1 RK1010 firmware update SUCCESS/FAILURE thread Reply with quote

This thread if for success and failure related to the new RK1010 firmware for the KR1. All RK1010 updaters, please post your experiences with this update here, THANKS.

RK1010 firmware adds support for:

- Verizon USB720
- Sprint Novatel U720
- Sprint PX-500
- Verizon PC5750
- Kyocera KPC680 (not yet released)

As noted in RK1007/RK1008, RK1010 still has support for DynDNS.org removed, yet still has EasyDns.com.

For more information see:

Kyocera KR1 Now Supports More EVDO Rev A Devices - EVDOinfo.com

Kyocera will be releasing RK1010 next week sometime. If you purchased your KR1 from 3Gstore.com (formerly Booster-Antenna.com), follow directions in above story to request a password to download.

Please note, the Sierra AirCard 595 PCMCIA and AirCard 595U ARE NOT SUPPORTED.

Also, the V640/V740/EX720 with ExpressCard Adapter ARE NOT SUPPORTED (previously worked with limited speeds - now they don't work at all).

Here is a Sprint U720 finally working, and notice the speeds:





ONLY POST SUCCESS/FAILURES with RK1010 to this thread - posts not related to success failures will be deleted.
_________________
EVDO :: EVDO News :: EVDO Antennas :: Buy Verizon :: Buy Sprint :: EVDO Amplifier


Last edited by Michael on Thu Nov 29, 2007 8:57 pm; edited 2 times in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
Bigdave
EVDO Junkie


Joined: 08 Nov 2006
Posts: 775

PostPosted: Fri May 04, 2007 10:47 pm    Post subject: Reply with quote

Well, I upgraded to RK1010. Everything went smoothly. KR1 recognizes U720 (see below)
Dell Dimension 8400
Win XP (service pk 2)
Sprint U720

Obviously so far, this doesn't fix the problem with the U720 download speeds for me. I am however seeing a bit of an increase in my UL's (At least when I test at speedtest.net) What should I do to see Michael's speeds? I will repost in a few minutes when I reconnect directly without the KR1 to show that the DL speeds are available here. It's just not happening with the KR1 yet. Mackieman, I know you've put a lot of time into this . . . .what gives?



But . . . . . . Download speeds still like before with RK1008 U720 connected directly to PC via a powered USB hub averages around 1200kbps - ish





Also, pinging google I'm seeing a little better latency. Down from in the 280ms range.

Pinging www.l.google.com [209.85.165.104] with 32 bytes of data:

Reply from 209.85.165.104: bytes=32 time=243ms TTL=234
Reply from 209.85.165.104: bytes=32 time=249ms TTL=234
Reply from 209.85.165.104: bytes=32 time=250ms TTL=234
Reply from 209.85.165.104: bytes=32 time=247ms TTL=234

Ping statistics for xxx.xxx.xx.xxx:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 243ms, Maximum = 250ms, Average = 247ms
Back to top
View user's profile Send private message
Bigdave
EVDO Junkie


Joined: 08 Nov 2006
Posts: 775

PostPosted: Fri May 04, 2007 11:15 pm    Post subject: Reply with quote

Well. I may have jumped the gun. After powering down the KR1 and removing the U720, hooking it back up via the powered USB hub I use and connected directly to my desktop I am now getting the same 500 to 600ish kbps downloads I was getting with the KR1 while ago. Apparently there's an issue with the Sprint network here right now. Never would have guessed that would be the case. Normally this is the time for the best speeds obviously - 1:00am on a Saturday morning. Not having to share the tower with too many folks this time of night!

Most importantly the upgrade went smoothly. The KR1 recognizes the U720 and the uploads speeds are fine. Will report back later when the DL's get back "to speed". Way cool seeing the Novatel-Ovation-U720 beside the Connection field!!

EDIT: Well, before I go to bed I wanted to report that I discovered something . Probably nobody else will be dumb enough to do this but just in case. Apparently, it is very easy to wind up with the power cord for the KR1 laying on the flip out antenna of the U720 the way it sits attached to the KR! sideways. When I discovered this I rearranged it and voila!!! Real EVDO Rev A speeds began to return!!



This will work!! Thanks Mackieman and everyone else for this upgrade. I am one happy camper. The KR1 rules once again!!!

Bigdave . . . . . out!!
Back to top
View user's profile Send private message
BillLee
EVDO Fledgling


Joined: 18 Feb 2007
Posts: 13
Location: Chandler, TX

PostPosted: Sat May 05, 2007 3:18 pm    Post subject: Successful upgrade Reply with quote

Just successfully upgraded the KR1 with version RK1010.

Platform: Linux desktop running Fedora Core 5, Firefox browser. Absolutely no problems.

Bill Lee
Back to top
View user's profile Send private message
Shrek
EVDO Fledgling


Joined: 06 Mar 2007
Posts: 18
Location: central IL

PostPosted: Sat May 05, 2007 5:55 pm    Post subject: Reply with quote

Just completed the upgrade. Easy to do and no issues at all.Speedtested after completion:


Also noted that my signal bar showed improvement after. Hopfully that will eliminate the occasional disconnects I was having before.Thanks
Back to top
View user's profile Send private message
Clue
EVDO Newbie


Joined: 29 Mar 2007
Posts: 10
Location: St. Louis, MO

PostPosted: Sat May 05, 2007 8:24 pm    Post subject: Reply with quote

I also posted this in the PX-500/KR1 compatibility thread:

I have the PX-500 card in a KR1. I just downloaded and installed the RK1010 firmware. (thanks!) It DOES allow the router to recognize the card and it works but I am only getting about 600K download speeds and about 100k upload speeds. I was getting about 400-500k download and 100k upload speeds before the upgrade (with RK1002).

Do I need to do a firmware update on the Pantech card itself? How do I tell what the FW on the card is or upgrade it?

FYI..I'm near St. Louis, MO zip 63049. I've heard rumors about Sprint network problems. Could this be part of it?
Back to top
View user's profile Send private message
rdurham
EVDO Newbie


Joined: 09 Apr 2006
Posts: 5

PostPosted: Sun May 06, 2007 8:38 am    Post subject: Reply with quote

Just did the firmware update and all went great. I have the
Sprint Novatel U720 and now my speeds are just like my S720
thanks so much for the update.
Back to top
View user's profile Send private message
Michael
Site Admin


Joined: 13 Jan 2005
Posts: 4698
Location: Cary, IL

PostPosted: Sun May 06, 2007 9:18 am    Post subject: Reply with quote

Thanks to everyone who are posting their results. I am sure we will have a lot more users posting their comments starting on Monday.

We have been helping beta test for the last few weeks and have been *really* impressed what we have seen during our testing.
_________________
EVDO :: EVDO News :: EVDO Antennas :: Buy Verizon :: Buy Sprint :: EVDO Amplifier
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
homer
EVDO Newbie


Joined: 06 May 2007
Posts: 1

PostPosted: Sun May 06, 2007 11:25 pm    Post subject: RK1010 successful update Reply with quote

Router firmware update to RK1010 updated without a hitch.
It seemed to only take a few minutes to complete.

I did not do any resets, but did remove card and network cables before booting KR1. Then inserted ethernet cable and opened router with my non-default IP address I have assigned (to match my network).
And goto Tools/Firmware and browsed to RK1010.biz.

I am not in a fast tower, so have not achieved Rev-A yet with router.

Status/Device/Info reports my Verizon USB720 as Novatel-Ovation-U270.
This sounds like a Sprint description, different than Verizon name.

Thank you EVDO.
_________________
Homer
Back to top
View user's profile Send private message
ljnelson109
EVDO Fledgling


Joined: 22 Nov 2005
Posts: 19

PostPosted: Mon May 07, 2007 6:45 pm    Post subject: Reply with quote

Performed the firmware upgrade without any issues. Having issues using my KPC650 in this router. On the suggestion of Scott, I just tried my wife's PC5750. The KR1 recognizes it as a PX-500. I assume that this might be normal. More importantly, it never completed a connection with the 5750 in my KR1.

Any suggestions?

Lee
Back to top
View user's profile Send private message
orbitalcomp
EVDO User


Joined: 28 Apr 2007
Posts: 32
Location: Texas

PostPosted: Tue May 08, 2007 1:24 am    Post subject: Success! Reply with quote

Upgraded from RK1008 to RK1010 without any problems, took less than 5 minutes. I'm using an S720, so I was up and running at full speed before the upgrade...figured I might as well have the latest firmware. This was my first firmware upgrade, so I followed the directions to a "T", even booted into WinXP thru BootCamp, instead of using Parallels - just in case Smile My speeds are the same as before, getting full Rev. A coverage here in San Antonio...
Back to top
View user's profile Send private message
Michael
Site Admin


Joined: 13 Jan 2005
Posts: 4698
Location: Cary, IL

PostPosted: Tue May 08, 2007 5:45 am    Post subject: Reply with quote

BTW, you can do the upgrade on any OS, only the "Firmware Recovery" needs to be done in IE6 XP.

I mostly use Mac (Safari & Camino), have done 100 of KR1 upgrades and never had one fail Smile
_________________
EVDO :: EVDO News :: EVDO Antennas :: Buy Verizon :: Buy Sprint :: EVDO Amplifier
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
DHESS
EVDO User


Joined: 08 Jan 2007
Posts: 42

PostPosted: Wed May 09, 2007 8:28 am    Post subject: Reply with quote

I updated fine to the new firmware. (Just bought a new kr1 and it came with the new firmware disk). I would like to thank Mike and Victor for their help trying to get my laptop to see the router. I figured out the problem last night(it was not the router). I would strongly suggest anyone going to buy a KR1 get it from 3Gstore. The customer support you get from these guys can not be matched. The helped me trouble shoot my laptop for an hour.
Back to top
View user's profile Send private message
drdrtheerdr
EVDO Fledgling


Joined: 25 Jul 2005
Posts: 12

PostPosted: Wed May 09, 2007 12:14 pm    Post subject: Reply with quote

I used the firmware from evdoforums and it worked perfectly the first time. Mac/safari. DR
Back to top
View user's profile Send private message