BusyBox Bug and Patch Tracking
BusyBox
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001406 [buildroot] Architecture Specific major always 06-28-07 04:04 07-08-07 12:17
Reporter bjdooks View Status public  
Assigned To buildroot
Priority normal Resolution no change required  
Status closed   Product Version
Summary 0001406: ARM: gcc is not configured for the ARM cpu selected in the menuconfig
Description The CPU selected in the menuconfig is not used to configure the gcc build to use the configured CPU. This causes code to be built that will not run on the target due to instructions that can never be executed.

If the cpu type is not specified, then not only is the compiler producing builds of packages that are incorrect, but it will also produce an libgcc with invalid instructions in it.

Passing CFLAGS with -mcpu=<configured-cpu> to the package builds was considered as a posibility, but this will not ensure that libgcc is built with the correct architecture flags.
Additional Information
Attached Files  gcc-pass-cpu-config.patch [^] (1,590 bytes) 06-28-07 04:04

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
06-28-07 04:04 bjdooks New Issue
06-28-07 04:04 bjdooks Status new => assigned
06-28-07 04:04 bjdooks Assigned To  => buildroot
06-28-07 04:04 bjdooks File Added: gcc-pass-cpu-config.patch
07-08-07 12:17 bernhardf Status assigned => closed
07-08-07 12:17 bernhardf Resolution open => no change required


Copyright © 2000 - 2006 Mantis Group
Powered by Mantis Bugtracker