PDA

View Full Version : [Apple TV] (fixed) Black screen after installing something


yleibu
2010-03-19, 03:13
Hello

I just installed XBMC for Apple TV on aTV version 3.01
All went well, all the files are installed but unfortunately I have omitted to disable the aTV screen saver before clicking Relunch Finder in the newly added menu to the aTV
Since then I can longer control the aRV main screen (menu). Is there any solution to this problem, even via Terminal commands, which I am not very conversant with.
Thanks for any help.

PowerPC Cube
Mac OS 10.5.8
Apple TV 160 GB version 3.01
atvusb-creator-1.0.b13

davilla
2010-03-19, 04:34
Hello

I just installed XBMC for Apple TV on aTV version 3.01
All went well, all the files are installed but unfortunately I have omitted to disable the aTV screen saver before clicking Relunch Finder in the newly added menu to the aTV
Since then I can longer control the aRV main screen (menu). Is there any solution to this problem, even via Terminal commands, which I am not very conversant with.
Thanks for any help.

PowerPC Cube
Mac OS 10.5.8
Apple TV 160 GB version 3.01
atvusb-creator-1.0.b13

ssh in
sudo reboot

yleibu
2010-03-19, 04:53
ssh in
sudo reboot

Thanks for the hint.
I have typed the commands into Terminal, aTV rebooted but then it still gives me the black screnn while Apple Remote stays unresponsive. In other words, I cannot get to the menu screen.
Any other thing(s) / commands I should try?

Thanks again.

DV3B
2010-03-19, 05:18
Do you have multifinder set to boot directly into XBMC? If so try this;

ssh in
cd /System/Library/CoreServices/Finder.app/Contents/Plugins/XBMCLauncher.frappliance/Contents/Resources/
sudo ./setMultiFinderMode.sh OFF

yleibu
2010-03-19, 05:25
Do you have multifinder set to boot directly into XBMC? If so try this;

ssh in
cd /System/Library/CoreServices/Finder.app/Contents/Plugins/XBMCLauncher.frappliance/Contents/Resources/
sudo ./setMultiFinderMode.sh OFF

I do not think so, at least I have not done anything else than installing XBMC on AppleTV through atvusb-creator (XBMC only runs on aTV since my Mac is a PowerPC).
I shall try that comand nevertheless and report back.
Thanks.

yleibu
2010-03-19, 05:34
I do not think so, at least I have not done anything else than installing XBMC on AppleTV through atvusb-creator (XBMC only runs on aTV since my Mac is a PowerPC).
I shall try that comand nevertheless and report back.
Thanks.

No go: same result, that is black screen and unresponsive Apple Remote.
Should I reset AppleTV to its factory settings and lose all data? Or is ther anything elsst that I could try before this last resort ?
If not, how do I do that without UI access to the main menu?
Thanks for your help.

yleibu
2010-03-19, 05:39
No go: same result, that is black screen and unresponsive Apple Remote.
Should I reset AppleTV to its factory settings and lose all data? Or is ther anything elsst that I could try before this last resort ?
If not, how do I do that without UI access to the main menu?
Thanks for your help.

Just a couple of additional details: the AppleTV's light activity indicator went black and AppleTV does no longer appear in my iTunes devices list. On the other hand, its screen saver is still active on my HD TV.

davilla
2010-03-19, 05:47
Just a couple of additional details: the AppleTV's went black and AppleTV does no longer appear in my iTunes devices list. On the other hand, its screen saver is still active on my HD TV.

did you by chance install atvfiles ?

yleibu
2010-03-19, 05:55
did you by chance install atvfiles ?

Yes, I have.
Shouldn't I have?

davilla
2010-03-19, 06:56
Yes, I have.
Shouldn't I have?

yes, ssh in and remove it, then reboot.

yleibu
2010-03-19, 07:08
yes, ssh in and remove it, then reboot.

What is the command to remove them?

yleibu
2010-03-19, 07:28
What is the command to remove them?

I found the command. Here is a transcript of the Terminal session trying to remove the appletvfiles

MonCube-3:~ yleibu$ ssh frontrow@appletv.local
frontrow@appletv.local's password:
Last login: Fri Mar 19 01:22:06 2010
-bash-2.05b$ rm appletvfiles
rm: appletvfiles: No such file or directory
-bash-2.05b$


What is wrong with this command?

DV3B
2010-03-19, 08:00
Its because you haven't given the full path the the plugin

sudo mount -uw /
sudo rm -r /System/Library/CoreServices/Finder.app/Contents/Plugins/ATVFiles.frappliance
sudo reboot

yleibu
2010-03-19, 08:35
It worked!
Thanks a lot for all your help.
I appreciate it.

Sam.Nazarko
2010-03-21, 16:07
Hey no need to remove it, just install a compatible version:

wget http://ericiii.net/sa/appletv/ATVFiles-1.3.0b1.run
chmod +x AtvFiles-1.30b1.run
sudo ./ATVFiles-1.3.0b1.run