Accessibility

Tools for AIR and Ajax

AIR applications can be developed with any IDE or text editor using HTML, Javascript, and/or Flash. Then use the free Adobe AIR SDK to package the applications so they can be deployed on Adobe AIR.

Adobe AIR SDK

The free Adobe® AIR™ SDK provides the tools necessary to build and deploy Adobe AIR applications, including:

  • Framework for Adobe AIR APIs
  • Template for the Adobe AIR application install badge
  • Command-line Adobe AIR Debug Launcher (ADL)
  • Command-line Adobe AIR Developer Tool (ADT)

Adobe AIR extension for Dreamweaver

The Adobe AIR extension for Dreamweaver will allow you to package and preview AIR application files directly within Adobe Dreamweaver CS4 or Adobe Dreamweaver CS5, so you can leverage your existing web development skills to build rich Internet applications on the desktop.

If you do not have Dreamweaver, you can purchase it here through the Adobe Store.

Download

Download the Adobe AIR runtime at the following link:

Once the runtime has been installed, download the Adobe AIR extension for Dreamweaver at the following link:

The Adobe AIR extension for Dreamweaver is provided in the MXP format, and can be installed using the Adobe Extension Manager (which is installed with Dreamweaver). Important: Please use the Extension Manager to remove any previously installed version of this extension before installing.

Documentation

Read documentation regarding the Adobe AIR extension for Dreamweaver online via LiveDocs. You may comment directly in the LiveDocs system should you encounter issues, typos, or other problems with the documentation.

Feedback

For reporting bugs, problems, or general feedback and suggestions for the extension, use the Adobe AIR extension for Dreamweaver web forum. We also encourage you to post your general feedback and links to your projects.

System requirements

The minimum system requirements for the Adobe AIR extension for Dreamweaver are:

Windows

  • Microsoft® Windows® XP
  • Windows Vista®
  • Dreamweaver CS4

Macintosh

  • Mac OS X v10.4.x (Intel® or PowerPC®)
  • Dreamweaver CS4

Earlier versions of Dreamweaver are not supported with this extension.

Next steps