My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 1172: King's Field Ancient City Load Problem
1 person starred this issue and may be notified of changes. Back to list
Status:  WontFix
Owner:  ----
Closed:  Nov 2011


Sign in to add a comment
 
Reported by dunkelka...@gmail.com, Nov 5, 2011
1) Did the game ever work correctly (i.e. not have this problem) on the
Official PCSX2 build or an earlier version of PCSX2 playground?
(If so, please specify the latest pcsx2-playground or Official revision
that last worked.)

To my knowledge, no emulation of this game has worked without the glitch. In fact, from doing some research, the problem even seems to happen when the game is emulated on a PS3 console. Also please excuse my explanations if they are not technically accurate as I am not a programmer or anything like that.


2) What steps will reproduce the problem?

1. After entering the Silver Gate area using the Green Wand, proceed left through the first room to the lava blocking the path. (See image 00)
2. Take the stairs to the left and go through the door on the left.
3. Once you begin to descend those stairs which lead to the knight (image 01), another area seems to load which is visible from that room and at the same time, the previous area seems to unload.
4. When returning to the previous area if you open the opposite door or descend the first flight of stairs, that area does not load back and there is just an empty black space that you will fall through. (What it should look like is pictured in images 02 and 04, instead you see images 03 and 05)

The same issue takes place in another area, although it has the problem as soon as you enter the room.

5. After unfreezing the Forge area and then lowering the lava level with the Icon of Ice, you can proceed across the South Cliffs to the South area. (Image 06)
6. Go up the stairs and through to door with the sign labeled "Central Tower" and the next door immediately in front of you is missing in the same way. (Image 07)


3) What exactly happens when you experience this issue (listing any console errors or screen output you receive)?

There seem to be no problems with the game's operation in regards to crashing or anything, it just impedes progression in the game. I've tried changing just about every emulation and plugin setting I can find without any luck and it doesn't seem to make a difference if I run from an ISO or directly from the game disc. Here is the PCSX2 console info from the point that I loaded the game up to the glitch area just in case you need it, there is no change when going through the loading zones or anything:

Opening plugins...
	Opening GS
	Opening PAD
	Opening SPU2
	Opening CDVD
isoFile open ok: E:\Programs\Game Files\PCSX2 0.9.8\- Games\KingsField_AncientCity.ISO
	Image type  = DVD
	Fileparts   = 1
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (1691856 sectors)
	Opening USB
	Opening FW
	Opening DEV9
McdSlot 0: C:\Users\Gary\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Gary\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
	Bios Found: USA     v01.60(07/02/2002)  Console
	BIOS rom1 module not found, skipping...
	BIOS rom2 module not found, skipping...
	BIOS erom module not found, skipping...
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.18;1
(SYSTEM.CNF) Software version = 2.00
(SYSTEM.CNF) Disc region type = NTSC


4) What version of PCSX2 are you using? On what operating system? Plugins?

Here is the initial console info when I boot PCSX2 for my specs and stuff, I think this has all the info you would need:

PCSX2 0.9.8.r4600  - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
	Operating System =  Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 32-bit
	Physical RAM     =  3069 MB
	CPU name         =  Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
	Vendor/Model     =  GenuineIntel (stepping 0B)
	CPU speed        =  2.393 ghz (4 logical threads)
	x86PType         =  Standard OEM
	x86Flags         =  bfebfbff 0000e3bd
	x86EFlags        =  20100000

x86 Features Detected:
	MMX.. SSE.. SSE2.. SSE3.. SSSE3

Reserving memory for recompilers...

Loading plugins...
	Binding GS	: E:\Programs\Game Files\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll 
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce GT 220 (8.17.12.8026)
	Binding PAD	: E:\Programs\Game Files\PCSX2 0.9.8\Plugins\lilypad-r4600.dll 
	Binding SPU2	: E:\Programs\Game Files\PCSX2 0.9.8\Plugins\SPU2-X.dll 
	Binding CDVD	: E:\Programs\Game Files\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll 
	Binding USB	: E:\Programs\Game Files\PCSX2 0.9.8\Plugins\USBnull.dll 
	Binding FW	: E:\Programs\Game Files\PCSX2 0.9.8\Plugins\FWnull.dll 
	Binding DEV9	: E:\Programs\Game Files\PCSX2 0.9.8\Plugins\DEV9null.dll 
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 333ms)


5) Please provide any additional information below.

The only work around I could find info on is copying the save game to an actual PS2 memory card and getting past the section on a PS2 console. Another less important glitch I thought I'd mention randomly happens when saving or loading a game. It should appear as in image 08 but sometimes looks like image 09. This of course is not a huge issue functionally though, so no worries if it's not addressed.


6) Attachments.

Image 00
https://docs.google.com/open?id=0B_GXs3wTBaaLZDY5YzRiMjgtYTQ2NC00NmJkLTk0ZmEtYzNlNTkxN2VkNjg4

Image 01
https://docs.google.com/open?id=0B_GXs3wTBaaLMTYxNGM0MTItYmRmOS00ZmUxLTgwMGEtM2ZhNjIzYzE5MjEy

Image 02
https://docs.google.com/open?id=0B_GXs3wTBaaLMWViNjUzM2QtNzM0OS00YjM4LThkZmItMTVlZWJlZjY5NjI3

Image 03
https://docs.google.com/open?id=0B_GXs3wTBaaLNGRlNGFjYWUtZGRiZC00NzA3LTkzOWQtM2UwMmM5NzllMGE3

Image 04
https://docs.google.com/open?id=0B_GXs3wTBaaLNzlmMDJiYTYtY2VjNy00Yzg0LTg2ZWEtMzUyNzgzMWQxMGY3

Image 05
https://docs.google.com/open?id=0B_GXs3wTBaaLZjczZjdhMDUtMDYxNy00ZTM4LTg5MmQtMmY2ZGM5OTRjM2Nm

Image 06
https://docs.google.com/open?id=0B_GXs3wTBaaLYjY4MTJiODEtZDAyYS00N2I2LWFjZWEtNWY5YWJjYjE5YjYy

Image 07
https://docs.google.com/open?id=0B_GXs3wTBaaLYmMwYTQyYzktZmVhZi00MzE2LTk4ODUtZWE1MmVjNGM2NWE2

Image 08
https://docs.google.com/open?id=0B_GXs3wTBaaLNWQyMjg0NmEtY2RmYS00MzZiLWI5Y2QtY2NiZjY0MTY1ZmE3

Image 09
https://docs.google.com/open?id=0B_GXs3wTBaaLMjQyNTFiZDktZjdlNS00MzA2LTk0NjgtZGVlMmFhNDY4ZjRj
Nov 6, 2011
#1 ramapcsx2
Can you try this with changed EE round modes and maximum clamping please?
Nov 6, 2011
#2 dunkelka...@gmail.com
Thank you so much for the quick response.

I tried your suggestions. When I changed the EE round mode to either
positive or negative, it solved the first issue with the area that unloads
but doesn't load back, although it had some odd glitches including some
doors being off set and at least one teleport symbol not working, but those
aren't a big deal as changing the setting back fixes them.

The other area however that never loads in the first place doesn't seem
affected at all. Changing the clamping doesn't seem to make a difference in
either area and I tried a number of combinations but still can't get the
second area to load.

Thanks again for the help, let me know if you want me to try anything else.
Nov 7, 2011
#3 ramapcsx2
Well, I knew another Kings Field game had issues with FPU rouding and people often reuse their engines for their games..
You may be able to get the 2nd area to work by using the EE interpreter but it'll be *slow* :p
Nov 7, 2011
#4 dunkelka...@gmail.com
Yeah, I did actually try that also since you pointed towards EE settings
and it still didn't work. Do you think there's some combination of settings
that might do the trick?
Nov 11, 2011
#5 dunkelka...@gmail.com
Good news! I was able to find a solution to the loading issue. I decided to
try the same fix one more time and it worked. It doesn't seem to work every
time so I think that's why it didn't work the first time around but I
figured out what works best. Changing the EE round mode to negative any
time before climbing the stairs seems to make it load properly (positive
doesn't work in the second area). Sometimes it still doesn't load but if
you just go down and climb the stairs again it should work. This applies
for both problem areas and as soon as the area loads, you can turn EE round
mode back to Chop/Zero to avoid other glitches. Thanks again for your help
and suggestions!
Nov 12, 2011
#6 ramapcsx2
Those are the joys of emulation :p
I don't think we can reasonably automate this.
Status: WontFix
Sep 11, 2012
#7 viciousb...@gmail.com
I have the same problem on the PS3. But it used to work b4 a patch update. 
Mar 29, 2014
#8 magus.so...@gmail.com
A fairly brain-melting issue, to be sure.
Sign in to add a comment

Powered by Google Project Hosting