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GRASS ORIGIN AND GROWTH
GRASS (Geographic Resources Analysis Support System) has been under continuous development involving 

a number of federal US agencies, universities and private companies since its launch in 1982. US Army Construction 
Engineering Research Laboratory (USACERL) completed it as version 4.1 in 1992 and provided five updates and 
patches to this release through 1995.

Baylor University, the first ‘GRASS Research Group’ adds numerous programs for 4.2 vesion (1997) and takes 
control of the GRASS development. Baylor University developed versions up to 5.0 with several new modules and 
fixes.  The international GRASS Development Team at  ITirst  (Trento,  Italy)  has been releasing the later  versions: 
GRASS 5.0 stable – Sept 2002, GRASS 5.0.3 – Nov   2003, GRASS 5.3   – May 2004, GRASS 5.7 – June 2004, 
GRASS 6.0.0beta1 – Jan 2005.
UTILITY FOR GEOSCIENCES

Being a raster and vector GIS with 3D capabilities GRASS can handle all the different data formats, i.e.,  
satellite imagery, aerial photos, scanned raster, SRTM(Shuttle Radar Topography Mission), vector .dwg, dxf, .shp, e00, 
arc , GPS,  available for earth scientists. With georeferencing and projection support all the unprojected data as well as 
the data with different projections can be brought to the same projection for viewing, overlaying and further analysis. 

Different   thematic   maps   like   geology,   geomorphology,   landuse,   soils,   topography,   structure,   seismic, 
geophysical and geochemical data can be processed and generated.

GRASS data are stored in a directory referred to as DATABASE (also called “GISDBASE”). This directory 
must be created before working with GRASS. Within this DATABASE, the projects are organized by project areas 
stored in subdirectories called LOCATIONs.   
RASTER GRASS

Traditionally GRASS has been very strong in raster data processing and analysis. It has both supervised and 
unsupervised radiometric  image classification and supervised radio and geometric classification capabilities,   image 
fusion with Brovey transform, morphological analysis like slope and aspect, flowlines, tracing a flow through a DEM, 
watershed analysis and cost surfaces, image geocoding and volume visualisation (isosurfaces and profiles ) tools.

VECTOR GRASS
The   versions   later   to   5.7   have   improved   vector   processing   capabilities   especially   in   the   attribute   data 

management through a SQLbased DBMS and support to vector analysis. Digitization and topology building is on the 
fly with the closing of the digitization. Raster to vector conversion is automatic but may involve careful postconversion 
drawing clean up operation. 

Large number of vector data formats are supported and different formats can be freely imported into and also 
exported. All the popular formats like .dwg, .dxf, ESRI .shp, arc coverages, e00, SRTM, CSV ASCII text, GPS point, 
VMAP0 (National Geospatial Agency), Map Info tables are supported.

Point data can be imported with elevation /3D attributes and contours can be generated after extrapolation of 
the raster surface by inverse distance weighted, bilinear and regularized splines with tension methods.

GRASS supports the projection of  the files being imported on the fly either by creating new Location or 
importing into a Location with projection. It can override the projection of the file being imported if the user wishes so. 

METHODOLGY:
IMPORTING A RASTER IMAGE /MAP AND GEOREFERENCING

  The command  r.in.gdal attempts to preserve projection information when importing raster datasets  if the 
source format includes projection information, and if  the GDAL driver supports  it.   If  the projection of the source 
dataset does not match the projection of the current location r.in.gdal will report an error message 

  If one wishes to ignore the difference between the apparent coordinate system of the source data and the 
current location, one may choose the o flag to override the projection check. 

If   the  user  wishes   to   import   the   data  with   the   full   projection  definition,   it   is   possible   to  have   r.in.gdal 
automatically create a new Location based on the projection and extents of the file being read. This is accomplished by 
passing the name to be used for the new Location via the Location parameter and the raster will be imported with the 



indicated output name into the PERMANENT mapset.

STEPS FOR IMPORTING A RASTER IMAGE / MAP:
In the GIS Manager window in an XY coordinate location
1. File> Import > Raster > Multiple formats using GDAL>  The  r.in.gdal dialog box appears. 
2. Click the arrow below 'Raster file to be imported' to browse to the file to be imported. For browsing the hard 

disk partitions of windows one can go to the /mnt / folder. After selecting the appropriate file click open. 
3. Then give a name to the output file in the next line and leave the rest to defaults.
4. Select the check boxes  override projection

Extend location extents based on new data sets. 
5. Then click  Run  i.e.,  to execute every command click the  Run  tab and close the dialog box after the 

execution of the command indicated by green progress bar. 
6. After the successful import close the dialog box by clicking Close tab

A color   image  import  would result   in  three   layers  (files)  which  can be combined,   to  yield a  RGB color 
composite, using the function r.composite. Before running r.composite make sure the region is set to match the region 
of the raster map. This can be done by g.region command.
7 GIS> Region > manage region > g.region  dialog box  

click 'set region to match this raster map' and select the raster file and click OK.
Then click Run tab. Close the dialog box by clicking Close tab. The region is set to match the selected raster 

file/ map.
8. Raster > Manage map colors > create color image from RGB files> r.composite   dialog box. Select the three 

layers, give a name for the combined map and click Run.
Note: Gdal function supports several image formats. For import of other formats one can use the GIMP programme to 

convert the  images, to be imported into GRASS, into any of the supported desired formats. 

STEPS FOR STARTING DISPALYS AND DISPALYING THE RASTER
9. Display > Start displays > x0   or click x0 icon in 6.1 version.
10. Display the raster by clicking the  Add Raster  icon > click 'raster1' >  click 'Raster name'  tab > 
select the raster map to be displayed > click Display selected layers icon 

or   Display  > Raster maps > Display raster map > d.rast dialog box 
Select the raster map  and click Run.  After the display click Close to close the dialog box. 

GEOREFERENCING AN IMAGE : 1. BY PROVIDING GCPS(Continued from step 8 above)
     9. Exit GRASS by clicking close in the title bar menu (or  Alt+F4) or by typing EXIT at command prompt. 

Create   a   fresh   location   with   a   Projection(say   'll',   lat   long   coordinates),   instead   of   XY  coordinates,   and   give 
appropriate lat long values and resolution. The projection parameters should be the ones you want to assign for the 
image you are going to georeference (e.g. No datum and ellipsoid  'evrst56').
10. Exit GRASS60/ 61
11. Re enter GRASS. This time choose the first location you created to enter GRASS60 /61 where your imported 
image in GRASS format is stored. 
12.  Image > Develop images and groups > Create / edit image groups> i.group dialog
Select/create image group and image to be included and click Run, then close the dialog box.
13.  Image > Develop images and groups > Target imagery group> i.target dialog
Select the image group and image to be included and click Run. 
NB:if the image is imported in to a Location with projection, the same Location can be used as target Location by 
selecting the check box for “set current location as target; in such a case there is no need to give the target Location 
and Mapset parameters in the i.target dialog box.
14.   Image >   Rectify and georeference image group>Set GCPs from Raster map or key board entry > 
i.points dialog (Grass.run.sh) NB: Make sure a monitor is open before opening the command.
It prompts for use of mouse. Double Click on the image name you want to rectify in the monitor window. That 
image will be loaded. Use mouse to click the zoom menu on the bottom of the screen. Box menu is activated. Click 
on the Box menu and draw a box where ever you want to zoom into. And click the points where you want to create 
GCPs and type respective Eastings/ Northings or longitude/ latitude in degree decimal form (ex. 80.5 14.75 for lat 
long projected location) separated by spaces. You have the option to say 'no' to any point if a mistake is made in 



entering the values when it prompts for confirmation. After giving as many points as desired (minimum is 4) click 
Analyze menu button. It will show the RMS error. You have the option to delete the points which are erroneous. 
The points can be saved to a file by clicking on the file menu and giving a name. When done click Done. And click 
exit. 
15. Image >  Rectify and georeference image group>Affine and polynomial rectification > i.rectify db 

Fig. Osmania University image from 'Google earth georeferenced and digitised showing different 
departments
GEOREFERENCING AN IMAGE : 2. IMAGE TO REFERENCEDRASTER RECTIFICATION
16.   For image rectification with reference to a georeferenced raster the difference is in choosing the  plot raster 
option in the i.points dialog box.  Click to  the right side of the image in the monitor to plot the raster and choose 
the desired referencedraster available in the projected location by double clicking on the name.
17. Pick a point, first in the source image and then the same point in the target referencedraster. Use of zoom 
function for both the source and target raster maps is a must to achieve high accuracy.  The color of the accepted 
pair of points changes to green. Continue the process till enough points distributed widely over the whole of the 
area are picked. For image rectification the order of polynomial transformation should preferably be greater than for 
scanned rasters. And as the order of transformation increases the minimum number of control points required also 
increases. (number of points n= (p+1)(p+2)/2)) where p is the order of transformation required. Though according 
to the above calculation the third order transformation requires a minimum of 10 GCPs it is always recommended to 
define more control points than the bare minimum. Then analyse for RMS error as mentioned above.  An acceptable 
RMS error should be less than  half a pixel size  in terms of ground distance or true distance.   

Note: Georeferencing works even if the RGB files are removed and only the composite file (false color) is left in the 
image group. But regrouping is required.

POINTS created during georeferencing by default are stored in the respective group folder of a raster file. 
NB:Latitudes  longitudes can be obtained using GPS for well known land marks and points of intersection of roads, 



railways and streams and used as keyboard input while georeferencing. 

Fig. Georeferenced image of Hyderabad saved from 'Google earth' and vectorised showing roads and a few landmarks
IMPORT AND EXPORT

Import and export functions:
• Can retain projection of the source map.
• Can create new Location, having the same projection as that of the source map, automatically.
• Can override the projection of the map being imported in to a location without projection or having a  different 

projection.
Vector import supported formats:

• ESRI Shapefile,  UK.NTF,  SDTS,TIGER, S57,  MapInfo  File,  DGN,  VRT,  AVCBin,  REC, Memory,  CSV, 
GML, ODBC, OGDI, PostgreSQL, SRTM (Shuttle Radar Topographic Mission), VMap0

• Further available drivers such as IHO S57 (ENC),  depend on the local installation (OGR library)
• ASCII points file or GRASS ASCII file
• Old GRASS vector format
• ESRI e00 format       (requires avcimport program for versions later than5.7)
• Garmin GPS waypoints/Routes/Tracks
• MATLAB mapGen files
• AutoCAD  dwg/ dxf  (requires OpenDwgToolkit for versions later than5.7)

STEPS FOR IMPORTING VECTOR FILES:
1. File> Import > Vector map > Various formats using OGR (v.in.ogr dialog opens, which can import several 
formats like ESRI Shapefile,UK .NTF,SDTS,TIGER,S57, MapInfo File, DGN, VRT, AVCBin, REC, Memory, CSV, 
GML, ODBC, OGDI, PostgreSQL).

• for importing ESRI shape files the mapName.shp file should be given as input.

• for Mapinfo files the mapName.tab file shoud be given as input.



• for ESRI coverages the arc.adf / tic.adf  should be given as input.
2. For importing point data 

File> Import > Vector map > ASCII points file or GRASS ascii file (v.in.ascii dialog opens)
• The file should be stored as Text CSV file.

• No header row information should be there. 
• The number of the column having X, Y coordinates has to be given in respective input parameters
• 3D maps can be generated using Z value and the Z values can be in more than one column; then the input for 

that column is the number of columns having z values. For example geochemical data having values of several 
elements can have many columns of Z value data.

• Full path of the ASCII file has to be given.
3. For importing .dxf /.dwg files the v.in.dwg dialog can be invoked by typing  v.in.dwg at the command    prompt in 
the
 terminal. This can import both .dwg and .dxf files. At command prompt > v.in.dwg

'TRANSFORMATION' AND 'PROJECTION' OF VECTORS
Transforming  vector  map   either  digitised  from a  scanned   image or   imported  in   to  GRASS  is  performed by   the 

v.transform command which requires either the transform coordinates stored   in a simple text file or the X, Y shift  

values    in degree decimal form (not  in degree /minute/seconds).  Transformcoordinatesfile  is  a  text  file with the 

coordinates required for transformation, stored in four columns separated by spaces or tab as file delimiters . The first 

line of the file should be a comment, that is, it should start with '#' character. These coordinates can be copied to this 

file   from   the   (last   four   columns)   points   file     generated   during   georeferencing   of   the   image   using   the   i.points 

(Grass.run.sh), 'Set ground control points from raster map' command (GCPs). Or they can be generated by clicking on 

the points of interest in the vector map by using the d.where command. 

STEPS FOR TRANSFORMATION:

Display > show geographical position> invokes the d.where command.

vector> Rectify and georeference vector map> opens v.transform dialog

An  example of  transformation coordinate file for v.transform command:

#    transformation coordinates ; this line is a comment only
        542.0 247.5      76.0      14.8 
        446.5 247.6      76.2      14.8 
        540.7 443.4      76.0      14.2 
        445.6 443.5      76.2      14.2 

NB: If the i.points file is stored in a different path than the vector file give the full path to that file or move the points  

file to the same folder where the vector file resides.

PROJECTION CONVERSIONS

v.proj:   To project from one projection system to another.   Maps from other Locations/ Mapsets having a different 

projection other than the current Location/ Mapset can be reprojected to the current Location and Mapset. If both the 

Locations are in the same DATABASE folder it is sufficient to give the map name, Location name, Mapset name  and 

the DATABASE parameter can be left blank.

STEPS FOR CHANGING PROJECTION:

Vector >Develop map > Reproject vector from other location (for vector maps)

Raster >Develop map > Reproject raster from other location (for raster maps)

**NB: As with all transformations to raster, we have to define the Gird resolution for the new raster map with 



g.region , before applying the interpolation method; may end up with a raster map of only one or a few pixels, if the  
resolution is too coarse (high value) or the map generation may be inordinately delayed if the resolution is set too  
fine/ high (low value). g.region  res = 5  (5 meters if units are meters or in degree decimal for degrees at command 
prompt or in g.region dialog)

CONTOURING  AND 3D SURFACE INTERPOLATION
From point data:  A onetime creation of point *data file for any number of variables helps in quickly creating 
several raster surface & contour (variable distribution) maps. The point vector file depicts the location of sample sites 
and the values for different variables are available   as attributes in the .dbf (database table) file.   By selecting one 
column at a time from this info file  as ‘Z’ value Raster Surface maps   can be prepared  using ‘Regularised Spline 
Tension (RST) interpolation  from vector points’ function from Raster menu.  Vector contour maps are prepared from 
these raster surface maps     by selecting ‘Generate vector contour lines’ function from Raster menu.   The Min, Max 
and Contour Interval can be set for any particular contour map.

Since same Region (which depicts map  limits,  projection and grid  specifications)   is  set  for  all   the maps, 
element distribution maps can be overlaid one above the other for visual comparison.  

• The name of a database table is same as that of a vector map name. 

• The column names can be changed in the mapName.dbf file under dbf folder within a Mapset.
• The column names can be found by going to Database menu in the GIS manager window:
• Database>Database information>Describe table ( 'c' option that is 'print columns names only' gives only 

column names)   or   Database>Database information>List columns
• While giving the  column names with spaces  (when viewed in Edit  attribute form mode)  use underscore 

wherever there is a space in the column names in v.surf.rst dialog or GIS manager.  
STEPS FOR CREATION OF 3D SURFACE & CONTOURS:

2. Import ASCII point data from .csv file (File>Import>Vector>ASCII point file)
3. Set Region to the generated point Vector file : GIS>Region>Manage Region>g.region dialog box—>Set 

region to match this Vector Map
4. To view the Point Vector File:

'Add Vector' icon in the GIS Manager.  b)  Enter vector  file name by clicking on the ‘vector name’ tab.  c) 
Select the file name from the dialog box.  d)  Click on the ‘Display Selected Layers Icon’ on the GIS Manger

5. Creating Raster surface: ** set the resolution with g.region  res = 5  (5 meters if units are meters or in degree 
decimal for degrees at command prompt or in g.region dialog)
Raster>interpolate surfaces>Regularised spline tension interpolation from vector points or contours or 
from the terminal using v.surf.rst command.

Enter Vector Point file name, Name of column for using as Z values, and output raster file name for 
elevation (Z)     b.    View the Raster surface map

6. Creating Vector Contours from the Elevation Raster surface (raster>generate vector contour lines)
7. Use r.null to modify the raster to generate threshold maps after nullifying values below the total of Mean + 

Standard Deviation. To get the statistics for a raster use r.univar :
 Raster>Develop map > manage null values(r.null).  Give the range e.g.  5070   (minus 50 to 70)
 Raster> Reports and statistics> univariate  statistics > r.univar dialog opens
*See steps for import of point data, under import & export topic, for file format.
**NB: As with all transformations to raster, we have to define the Gird resolution for the new raster map with 
g.region , before applying the interpolation method
10. Create profiles with d.profile command.

Raster> Terrain analysis>Profile Analysis>d.profile dialog appears
Fig. Geochemical profiles generated from surface elevation map showing anamolies



HARDWARE AND OS REQUIREMENTS:
Operating Systems: GRASS can be installed on any of the OS viz., GNU/Linux, Sun Solaris, Mac OS, MSWindows 
with Cygwin, HPUX, DECAppha, AIX, BSD, iPAQ/Linux and other UNIX compliant platforms (32/ 64 bit). The 
authors  have  worked  on  PCQ Linux2005  (Fedora),  Mandrake10,  Debian   flavours  of  Linux all  of  which   are   free 
versions. It is also found that the MS Windows versions of GRASS are not as fast as theis GNULinux variants.

Hardware: The bare minimum is a 586 processor and 64 MB RAM, however for efficient processing especially for 
large raster files 1GB can vastly improve the performance. For geospatial data more RAM is generally more effective 
than a faster CPU. For 3D visualisation highend graphics card with open GL hardware acceleration will boost the 
speeds significantly.   The GRASS, complied on Linux system require about 100MB disk space, 90 MB on Windows 
and up to 180 on other Unix systems.

INTERNATIONAL SUPPORT: S/W can be down loaded from  http://grass.ibiblio.org
GRASSproject: http://grass.itc.it and its mirrors  grass5_AT_grass.itc.it
Newsletter online: http://grass.itc.it/newsletter/ 
CONCLUSION:   GRASS,   a   free   and   open   source   GIS   is   eminently   suitable   for   handling   many   geospatial   data 
formats/types and will drastically reduce the software costs for GIS and makes it affordable not only in public and 
private organisations but all educational institutions at graduate and undergraduate levels.  With  increasing availability 
of quality data both high resolution 3D raster and vector, hitherto restricted or prohibitively costly, over the Internet, 
that too free of cost, it is right time for all to utilise the same for learning GIS, processing and analysis.

http://grass.ibiblio.org/
http://grass.itc.it/newsletter/
http://grass.itc.it/
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