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1 Introduction
This document helps you understand and use Integrity Virtual Machines Manager.
The audience for this document includes system administrators and others responsible for
maintaining an Integrity VM host and its virtual machines. You should be familiar with the HP
Integrity Virtual Machines (Integrity VM) product and HP-UX system administration using
either HP SMH or HP SIM.
This chapter provides an overview of HP Integrity Virtual Machines Manager (VM Manager)
and the product that it manages, HP Integrity Virtual Machines. This chapter also lists the basic
management tasks you can perform using VM Manager.

HP Integrity Virtual Machines
HP Integrity Virtual Machines (Integrity VM) is a soft partitioning and virtualization technology
that enables you to create multiple software-controlled Itanium-based virtual machines within
a single HP Integrity server, Integrity blade, or nPartition. The Integrity server or nPartition acts
as a VM Host for the virtual machines (virtual machines are also called guests). The VM Host is
a platform manager. It manages hardware resources such as memory, CPU allocation, and I/O
devices, and shares them among multiple virtual machines. The VM Host runs a version of the
HP-UX operating system and can be managed using standard HP-UX management tools. HP
Integrity VM 4.0 and later runs on HP-UX v3 only. Version 3.5 runs on HP-UX v2 only.
The virtual machines share a single set of physical hardware resources, yet each virtual machine
is a complete environment in itself and runs its own instance of an operating system (called a
guest OS). As with a real machine, the virtual machine contains:
• At least one processor core, also referred to as a virtual CPU or vCPU
• Memory
• Disks
• Networking cards
• A keyboard
• A console
• Other components of a computer
All these elements are virtual, meaning that they are at least partially emulated in software rather
than fully implemented in hardware; however, to the guest OS they appear as if they are real,
physical components.
No guest OS can access memory allocated to another guest OS. One virtual machine is not affected
by software events on another virtual machine, such as faults or planned software downtimes.
Integrity VM optimizes the utilization of hardware resources, quickly allocating resources such
as processor cores, memory, or I/O bandwidth to the virtual machines as needed. Any software
that runs on supported versions of HP-UX can run in an Integrity VM virtual machine. No
recompiling, recertification, or changes are required for applications to run in a guest OS.
Applications run in the guest OS as they do on any operating system.
The operating systems supported on guests vary from version to version of HP Integrity Virtual
Machines. For information about supported VM guest operating systems, see the version of the
HP Integrity VirtualMachines Installation, Configuration, andAdministrationmanual that corresponds
to the version of HP Integrity Virtual Machines being used.

HP Integrity Virtual Machines Manager
HP Integrity Virtual Machines Manager (VM Manager, also called vmmgr) is the GUI that you
can use from your browser to manage Integrity VM resources. VM Manager allows you to create,
configure, and evaluate virtual machines, and to monitor and evaluate data and resources at the
level of the VM Host. You can view all of a VM Host's virtual machines and their assigned
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resources, and you can view all resources assigned to a specific virtual machine or virtual switch.
For example, VM Manager provides graphical views of virtual-to-physical network and storage
devices so that you can view I/O data, including resource utilization information. VM Manager
obtains information about Integrity VM resources through Web-Based Enterprise Management
(WBEM) providers installed on the VM Host and on virtual machines (guest OSes).

NOTE: Features available from VM Manager may depend on the version of Integrity VM on
the VM Host. New VM Manager features described in this document that depend on features
introduced with version 4.1 of Integrity VM are not available when managing a VM Host that
runs an earlier version of Integrity VM.
VM Manager version 4.1.1 supports all the HP Integrity Virtual Machines version 4.2 features
that are documented in this manual. VM Manager version 4.1.1 is compatible with HP Integrity
Virtual Machines version 4.2 but does not support new features provided by HP Integrity Virtual
Machines version 4.2.

VM Manager is available as a standalone product (the VMMGR bundle) that is installed on a VM
Host and accessed through the HP System Management Homepage ( HP SMH), or as a component
provided with HP Insight Dynamics - VSE for Integrity (the VSEMgmt bundle), the latter which
is installed with HP Systems Insight Manager (HP SIM) on a central management server (CMS).
As a component of HP Insight Dynamics -VSE for Integrity, VM Manager seamlessly-integrates
with other Insight Dynamics components.
You can access VM Manager from a browser, using either of two web-based software components
(depending on the bundle installed):
• HP System Management Homepage (HP SMH)

VM Manager is installed separately on any given VM Host to manage that Integrity VM
Host and its virtual machines. You access VM Manager from a browser that can connect
over the network to that VM Host. Figure 1-1 shows how VM Manager is configured and
used with HP SMH. This configuration is supported on HP-UX v3 and v2.
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Figure 1-1 VM Manager with HP SMH
Using VM Manager with HP SMH
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• HP Insight Dynamics - VSE for Integrity
VM Manager is installed as part of Insight Dynamics - VSE for Integrity that runs under
HP Systems Insight Manager software (HP SIM) on a server reserved for use as a central
management server (CMS). The CMS can run on HP-UX or Windows platforms. HP SIM
serves as the central point of administration for complete resource-lifecycle management
for multi-OS environments. You access VM Manager from a browser that can connect over
the network to the CMS. The CMS allows you to manage multiple Integrity VMs (VM Hosts
and each of their virtual machines) that are discovered by HP SIM. Figure 1-2 shows how
VM Manager is configured and used with Insight Dynamics and HP SIM.
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Figure 1-2 VM Manager with HP SIM and the Insight Dynamics - VSE for Integrity
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In this environment, you can use VM Manager in seamless integration with other Insight
Dynamics - VSE for Integrity components. These interlinking components enhance the
functionality and flexibility of your virtual server environment. For example:
— HP Insight Virtualization Manager software provides a framework for visualizing your

Virtual Server Environment. All of the systems and workloads that you are authorized
to view are displayed in a graphical view. The hierarchical relationships between systems
and their current utilization metrics can be seen in a single screen. Using Virtualization
Manager, you can manage a pool of multiple-OS, dynamically sizable virtual servers.
You use Virtualization Manager to access VM Manager for viewing and modifying VM
Host or virtual machine components. For more information, see “Accessing VM Manager
from Insight Dynamics - VSE for Integrity” (page 21).

— HP Insight Global Workload Manager software for Integrity (gWLM) is a
multiple-system, multiple-OS workload manager that serves as an intelligent policy
engine in Insight Dynamics - VSE for Integrity. It simplifies the deployment of
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automated workload management policies across multiple servers, and provides
centralized monitoring and reporting and improved server utilization to assist in meeting
your service level objectives. Using VM Manager with Insight Dynamics - VSE for
Integrity, you can create, view, and modify gWLM policies for virtual machines. For
more information, see “Using the Policy menu” (page 84).

— HP Insight Capacity Advisor software is capacity analysis and planning software that
allows you to optimize the workloads across Insight Dynamics - VSE for Integrity for
the highest utilization of server resources. From VM Manager, you can cause Capacity
Advisor to collect and display historical data for a VM Host or selected virtual machines.
Certain VM Manager views include utilization meters (bar graphs) that display current
utilization data for a resource; you can click the meter to view a screen that provides
more detailed historical data. (These meters are visible when using VM Manager with
HP SMH, but you cannot click them to obtain a Capacity Advisor report.) For more
information about using VM Manager to collect and view utilization data, see Chapter 7
(page 111). For more information about accessing Capacity Advisor through VM Manager,
see “Using the Tools menu” (page 76) and “Using the View menu” (page 82).

Other Insight Dynamics - VSE for Integrity components include:
— Application Discovery
— HP Instant Capacity Manager
— Partition Manager
— WBEM providers (which include the VM Provider and the Utilization Provider, as

described in “System and software requirements” (page 13) and other agents.
For more information about Insight Dynamics concepts and terminology, including a
complete list of the components of Insight Dynamics - VSE for Integrity, see the HP Insight
Dynamics 6.2 Getting Started Guide.

Information about HP SMH is available from the following HP SMH website:
http://www.hp.com/go/smh
Information about HP SIM is available from the following HP SIM website:
http://www.hp.com/go/hpsim

VM Manager tasks
Use VM Manager to create and manage Integrity VM virtual machines. To take full advantage
of VM Manager, you can perform the following tasks:
• Create, configure, and control virtual machines and their resources, such as virtual switches

(vswitches), virtual network devices, and virtual storage devices (Chapter 6 (page 87))
• Monitor VM Host and virtual machine operation (Chapter 4 (page 31))
• Modify virtual machine configurations (“Modifying virtual machines” (page 92))
• Migrate virtual machines from host to host (“Migrating virtual machines” (page 100))
• Collect and view utilization data for VM Host, virtual machines, and their resources

(Chapter 7 (page 111))
• Respond to status reports, error messages, and problems concerning virtual machines

(Appendix A (page 123))
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2 Installing VM Manager
This chapter discusses how to install VM Manager on your system or on the systems you will
manage, including setup and software requirements, licensing requirements, and how to set
WBEM security credentials.

System and software requirements
System requirements for the VM Host and virtual machines are described in the HP Integrity
Virtual Machines Installation, Configuration, and Administration manual. In addition, see the HP
Integrity Virtual Machines Release Notes, which are available on the product media. The most
up-to-date release notes are available at the following location (click on theHP InsightDynamics
- VSE for Integrity tab):
http://www.hp.com/go/insightdynamics/docs

NOTE: Operating system support for VM Host and guests varies from release to release of HP
Integrity Virtual Machines. For information about operating systems supported by a particular
release and about installing supported operating systems on virtual machines, see theHP Integrity
Virtual Machines Installation, Configuration, and Administration manual.

With use of VM Manager in the Insight Dynamics environment, any managed node must have
WBEM and the appropriate WBEM credentials to support the visualization and configuration
features of Virtualization Manager and the collection of utilization data by HP Insight Capacity
Advisor software. Without WBEM, only HP Insight Global Workload Manager software for
Integrity (gWLM) is functional. Managed nodes are systems that the user has instructed HP SIM
to manage. For Insight Dynamics, all virtual machines and their VM Host are managed nodes.
Systems become managed nodes through the HP SIM “discovery” mechanism. Nodes can be
discovered by HP SIM in various ways, including automated discovery or manual addition of
the node. For example, you can configure and initiate node discovery, and perform numerous
other setup tasks, by using the Insight managed system setup wizard. For more information, see
the Insight managed system setup wizard getting started guide, available at the following location:
http://www.hp.com/go/insightdynamics/docs
To use VM Manager and all its features, install the required WBEM provider components on the
VM Host and on the virtual machine guests.
In the Insight Dynamics environment, to install such components on guests, use the Insight
managed system setup wizard. The wizard allows you to choose whether to install the VM
Provider. The wizard also checks the selected virtual machines for the appropriate versions of
Utilization Provider software and installs the software as needed on supported platforms. (On
a VM Host, you must install the appropriate providers manually, using the VM Host command
line.) For more information, see the Insight managed system setup wizard getting started guide and
the HP Integrity Virtual Machines documentation available from the HP Technical Documentation
website (for the HP Integrity Virtual Machines documentation, click on theHP InsightDynamics
- VSE for Integrity tab):
http://www.hp.com/go/insightdynamics/docs
In the HP SMH environment, install on the virtual machine guests the required provider
components located in /opt/hpvm/guest-images on the VM Host. Subdirectories contain
the guest management software for each type of guest operating system, including both HP-UX
versions 11i v2 and v3, Windows, and Linux. Each subdirectory includes software provided by
HP Integrity VM that should be installed on the guest, including the latest VM Provider software.
For more information about installing software components on the VM Host and guests, see the
HP Integrity Virtual Machines Installation, Configuration, and Administration manual and the HP
Integrity Virtual Machines Release Notes.
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The WBEM provider components are the VM Provider and the Utilization Provider:
• The VM Provider provides VM Host and guest configuration data. This information is

delivered using WBEM. To use Integrity Virtual Machines Manager to view configuration
data, install the VM Provider (VMProvider bundle) that is provided with Integrity VM.
Install the VM Provider on the VM Host and on each virtual machine when you install the
HP Integrity Virtual Machines product. If you upgrade Integrity VM, be sure to keep the
VM Provider up to date, too. If the VM Provider version does not match the Integrity VM
version, the Integrity Virtual Machines Manager might not work as expected.
As for guests, the VM provider is required to view guest configuration data. The VM Provider
and Integrity VM versions need not match. A guest's VM Provider can be an earlier version
than that of the Integrity VM running on the VM Host. However, HP recommends upgrading
the guests to the latest version of VM Provider available, even if the latest available provider
version is greater than the version of the Integrity VM currently installed on the VM Host.
When the VM Host Integrity VM is upgraded, you are not required to upgrade the VM
Provider on each of the guests, but HP recommends upgrading the VM Providers on the
guests to at least match the version of the Integrity VM on the VM Host.
To install the VM Provider on the VM Host and guests, install the appropriate provider
software from the operating system media or the Integrity VM guest management software
kit.

• The Utilization Provider gathers utilization statistics for CPU, memory, disk, and LAN. This
information is delivered using WBEM and gathers data using a daemon
(/usr/sbin/utild). You must install the Utilization Provider on the VM Host and on
each virtual machine.

Installing VM Manager on HP SIM
On HP SIM, system requirements for installing VM Manager are the same as requirements for
installing Insight Dynamics - VSE for Integrity. You must have a license for at least one other
component of Insight Dynamics - VSE for Integrity, such as Virtualization Manager. You cannot
access the functionality in VM Manager unless you have a license for, and have installed Integrity
VM on, at least one system to be managed through your licensed Insight Dynamics - VSE for
Integrity components.
For information about system requirements and installation instructions, see the HP Insight
Dynamics 6.2 Integrity CMS Installation and Configuration Guide and the Insight managed system
setup wizard getting started guide. This and other similar documentation is available from the HP
Technical Documentation website:
http://www.hp.com/go/insightdynamics/docs

NOTE: Do not install the VMMGR bundle (the bundle containing the VM Manager HP SMH
plug-in) from the software depot onto the HP SIM CMS. For centralized Integrity VM management
capabilities, install the VSEMgmt bundle (containing the VM Manager for HP SIM) from the
software bundle.

Installing VM Manager on HP SMH
On HP SMH, VM Manager must be installed separately on a VM Host.
VM Manager 4.1.1 requires JDK 6.0 for installation. Ensure that you have installed JDK 6.0 before
installing VM Manager 4.1.1.
Download the VM Manager software depot from the following location:
http://h20293.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=VMMGR
This depot is also available with the HP-UX 11i v2 September 2006 and later releases.
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After downloading the depot, install the software. As a privileged user, execute the following
command, where path-to-depot-file is the full path specification to the depot file:
# swinstall -x mount_all_filesystems=false -s path-to-depot-file VMMGR

To determine the version of VM Manager currently installed, enter the following command:
#/usr/sbin/swlist VMMGR

NOTE: Beginning with the HP-UX 11i v3 March 2009 Operating Environment Update Release
(OEUR), you can optionally install VM Manager on HP SMH as part of the VSE-OE or DC-OE.

Licensing requirements
The licensing requirements for VM Manager on HP SIM and on HP SMH include the following:
• On HP SIM, VM Manager is included with Insight Dynamics - VSE for Integrity and is

installed when Insight Dynamics is installed. To make VM Manager operational, you must
have a valid license installed for at least one other component of Insight Dynamics - VSE
for Integrity (for example, Virtualization Manager) and one license installed for Integrity
VM on at least one host.
You cannot access the functionality in VM Manager unless you have a license for Integrity
VM and have Integrity VM installed on at least one system to be managed through your
licensed Insight Dynamics - VSE for Integrity components.

• On HP SMH, VM Manager is installed separately on a VM Host. You must have a license
for Integrity VM and have Integrity VM installed on that VM Host. A separate license for
VM Manager is not required.

For information about licensing, see the readme file in either the /opt/vse/src directory (HP
SIM) or the /opt/vmmgr/src directory (HP SMH).
You must purchase licenses for any software you run in a virtual machine, including the HP-UX
operating system and any HP or third-party layered software. You can purchase the licenses for
HP software under the HP Virtualization Licensing program. For more information, contact your
HP representative.

Setting security credentials
To display the full range of data about each virtual machine in VM Manager, you must have
WBEM-recognized credentials for each virtual machine. A user name and password are required
to collect resource utilization and other data, such as the status of the installed operating system.
This data is available only from a WBEM provider on the VM Host or virtual machine. The
WBEM providers are the tools used to gather data about the virtual machine and the VM Host.
The user interface uses this information to show various kinds of system status.
You can set credentials by specifying a default user name and password combination for any or
all virtual machines. You can also override the default user name or password on a case-by-case
basis.

NOTE:
• For a given virtual machine, if no user name or password is specified, the default is used.
• If a password is specified but a user name is not, the default user name is used with the

password override. This allows a system administrator to use the same user name but
different passwords for each virtual machine.

When running VM Manager with Insight Dynamics - VSE for Integrity, HP SIM is responsible
for managing the credentials needed for using WBEM providers on the VM Host and on virtual
machines. When running VM Manager under HP SMH, HP SMH manages credentials and access
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for the VM Host on which HP SMH is running; credentials for each virtual machine are managed
by VM Manager.
The method for setting WBEM credentials depends on whether you are using HP SIM or HP
SMH.

Setting WBEM credentials in HP SIM
Any virtual machines that are not managed nodes do not have any credentials available, and
VM Manager cannot contact them. These machines are displayed, but some of the information
that can be gathered from the managed nodes is not displayed for non-managed nodes.
You can set credentials in HP SIM for a global configuration across multiple systems by selecting
Options→Protocol Settings→Global Protocol Settings...; for a single managed node, set
credentials by selecting Options→Protocol Settings→System Protocol Settings.... VM
Manager requires that the proper WBEM credentials (a valid user name and password) be set
in those option pages. Without WBEM, the Virtualization Manager and HP Insight Capacity
Advisor software functionality will not be available; only HP Insight Global Workload Manager
software for Integrity (gWLM) is functional.
With HP SIM, you can set the credentials when you first launch HP SIM after installation by
using the HP SIM First Time Wizard. For information about setting credentials, see theHP Insight
Dynamics 6.2 Integrity CMS Installation and Configuration Guide.

Setting WBEM credentials in HP SMH
You must set WBEM credentials for virtual machines in HP SMH. This allows VM Manager to
collect utilization data and operating system information on the virtual machine. Stored credentials
are specific to the user logged in to HP SMH. Two users who are logged in with different user
names do not share credentials.
When you log into SMH without having already set the WBEM credentials and saving them in
the file system, the Set WBEM Credentials for Virtual Machines page is displayed. When you
create a new virtual machine, you must add credentials for that virtual machine by selecting
Modify→WBEM Credentials... from the VM Manager menu bar, which displays the same page.
Figure 2-1 shows an example of the Set WBEM Credentials for Virtual Machines page.
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Figure 2-1 HP SMH: Set WBEM Credentials page

On this page, you can set one user name and password combination for all virtual machines, or
you can set them individually for one or more virtual machines. If you set the credentials for
some but not all of the individual systems, VM Manager does not collect utilization data and
operating system information for the excluded systems.
You can also save the user name and password entries in obscured format in the file system.
This allows you to use the same setting each time you enter VM Manager through HP SMH. To
save these entries, select the Save user name and password settings in the file system check
box, and then click OK. This information is obfuscated before being stored.
If you do not want to provide this security information for the current session, click Cancel. VM
Manager continues without collecting this data. If you do not want to provide this additional
data for subsequent uses of VM Manager, and you do not want to be prompted for it on each
entry into VM Manager, make sure all entries on the page are blank, select the check box to save
the credentials to file, and click OK. Empty credentials are stored, and this prevents the WBEM
credentials page from being displayed on subsequent entries into VM Manager.

HP Confidential Setting security credentials 17



If you require the additional security provided by certificate validation, you can turn on SSL
certificate validation by checking the Require trusted certificates check box. If this box is
checked, you must store the valid certificates for the virtual machines in a keystore on the VM
Host to indicate that connections to those virtual machines are trusted; otherwise, some
information is not displayed by VM Manager. For example, if a certificate is missing, utilization
meters are labeled No Data. For more information about trusted certificates and how to store
them in a keystore on the VM Host, see “Trusted certificates” (page 19).
You can use the basic features of the HP SMH version of VM Manager without exposing user
credentials or configuration data on the local network. In this case, you see a subset of the potential
information that the VM Manager can display. To have all data displayed, the following steps
are required.

NOTE: Displaying all the information about the virtual machines' configuration exposes the
credentials of a connecting user.

1. Create a nonlogin, nonprivileged account on each virtual machine to which VM Manager
might connect and whose credentials can be intercepted on the network. Although these
credentials are restricted to nonlogin capabilities, they can also be used to gain access to
other data or actions available using WBEM and other nonlogin services, including those
from additional providers that are registered on the system.

2. Optional, for additional security: If local policy is to avoid exposure of any account credentials
on your network, or if you do not want to expose the virtual machine configuration data,
then configure an SSH or IPSec tunnel from the VM Host system to each virtual machine
for port 5989 (HP WBEM Services).

The following types of information require credentials for each virtual machine for which
information is to be gathered:
• Operating System: If the required credentials are not set for a virtual machine, VM Manager

cannot contact the machine. VM Manager displays the expected operating system (if the
operating system was set during configuration of the virtual machine, or if the guest operating
system on the virtual machine has been booted). If the credentials are set and the virtual
machine is running with the proper provider, VM Manager displays the operating system
and version number.

• Utilization: If the required credentials are not set for a virtual machine, the utilization meters
for virtual machine-specific items are dimmed. (Meters specific to a virtual machine are
located on such VM Manager pages as the VM Host Virtual Machines tab, the VM Properties
Network and VM Properties Storage tabs, and the VM Properties General tab. For more
information about these tabs, see Chapter 4 (page 31).) Meters for the VM Host and host
resources are still available if the VM Host's WBEM Utilization Provider is running.
The data is a 5-minute average that is calculated and updated on 5-minute boundaries.
When a utilization meter is dimmed, a label next to the meter indicates the probable cause.
These labels and status indicators are described in “Utilization meter status/error information”
(page 125).
Virtual LAN interface I/O utilization on the VM Properties Network tab: For a virtual
machine with invalid credentials, either the No Perm. or No Data label appears next to
the meter. The page still displays whatever information is available from the VM Host, such
as the status and the bus, device, and function numbers for a virtual LAN interface. For a
virtual machine with valid credentials, VM Manager displays I/O utilization data for each
virtual LAN interface and for VM aggregated LAN interfaces.
Virtual storage device I/O utilization on the VM Properties Storage tab: For a virtual
machine with invalid credentials, either the No Perm. or No Data label appears next to
the meter. The page still displays whatever information is available from the VM Host, such
as the virtual device type and the bus, device, and target numbers for the virtual storage
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device. For a virtual machine with valid credentials, VM Manager displays I/O utilization
data for each virtual storage device and for VM aggregated storage interfaces.

• Virtual LAN (VLAN) interface name and status on theNetwork tab: This status is displayed
for a virtual machine with valid credentials, but invalid credentials will return an unknown
LAN status and utilization. It might display whatever information is available, for example,
the bus, dev, or the fcn number for the VLAN interface.

To change the WBEM credentials settings for virtual machines, return to the Set WBEM
Credentials for Virtual Machines page by selecting Modify→WBEM Credentials.... You do
not need to select a virtual machine before setting credentials.

IMPORTANT: After you enter the data, save it by clicking OK. Otherwise, the data is cleared
when the session ends.

Trusted certificates
If you require the additional security provided by certificate validation you can turn on SSL
certificate validation by selecting the Require trusted certificates check box on the VM Manager
Set WBEM Credentials for Virtual Machines page. With this setting turned on, the client
Certificate Trust Store must include the server certificates from the virtual machines; otherwise,
VM Manager cannot obtain certain information from the virtual machines. If your environment
does not require the additional security provided by certificate validation, you can leave certificate
validation turned off.
To enable SSL certificate validation in VM Manager, you must export the server certificates from
the WBEM services providers on the virtual machines, and import those certificates into the
keystore on the VM Host where VM Manager is running. This keystore is shared between Partition
Manager and VM Manager. Certificates in this keystore are trusted by both Partition Manager
and VM Manager.
To get the certificate file from the WBEM services provider, follow these steps:
1. Locate the WBEM services provider certificate file (cert.pem) on the virtual machine to

which you want to connect. To find the correct file, open the WBEM services Provider
configuration file, which can be found in the following locations:
• For Windows:

%PEGASUS_HOME%\cimserver_current.conf

• For HP-UX:
$PEGASUS_HOME/cimserver_current.conf

(The default value for PEGASUS_HOME on HP-UX is /var/opt/wbem.)

The location of the server certificate file is configured by the sslCertificateFilePath
setting. If this value is not set in the configuration file, the default values are as follows:
• For Windows:

%PEGASUS_HOME%\server.pem

• For HP-UX:
/etc/opt/hp/sslshare/cert.pem

2. Copy the certificate file (cert.pem or server.pem) to the VM Host where VM Manager
is running.
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NOTE: Copy the certificate file to a temporary directory (not to the sslshare directory)
on the VM Host. Do not overwrite the existing cert.pem or server.pem file in the
sslshare directory on the VM Host.

3. To import the certificate file, enter the following command on the VM Host:
$ JAVA_HOME/bin/keytool -import -alias server_hostname \
-file cert.pem \ -keystore /etc/opt/hp/sslshare/parmgr.keystore

Discovering data when setting new WBEM credentials
When you set new WBEM credentials from the VM Manager Modify menu and click OK, the
page to which you return is updated using the new credentials. However, especially when VM
Manager must retrieve data from a large number of virtual machines, some of the data might
not yet be updated when the page displays in full (instead, the old data is still displayed). With
the exception of data displayed by utilization meters, the new data (such as the virtual machine
guest OS version) is not seen until the page refreshes again. The utilization meters update
immediately after VM Manager retrieves the utilization data; refreshing the page is not required
for updating that data.
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3 Accessing and Navigating VM Manager
You access VM Manager through a web browser. This chapter explains how to access VM Manager
from the HP SIM/Insight Dynamics - VSE for Integrity Virtualization Manager Visualization
tab and from HP SMH. This chapter also explains how to access VM Manager help. Information
about possible access failures and the messages that might be seen is included in Appendix A
(page 123).

Accessing VM Manager from Insight Dynamics - VSE for Integrity
To use all the VM Manager facilities (view all screens and perform all menu actions), you must
have VSE All Tools authorization . To access VM Manager from Insight Dynamics, follow these
steps:
1. From the HP SIM/Insight Dynamics Home page, select Tools→Virtualization Manager...,

as shown in Figure 3-1.

Figure 3-1 Insight Dynamics: accessing Virtualization Manager

This displays the Virtualization Manager Visualization tab, as shown in Figure 3-2.
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Figure 3-2 Virtualization Manager Visualization tab

2. The first time you start Virtualization Manager, the Visualization tab appears with the
default Physical and Virtual perspective, which shows all physical and virtual nodes in
graphical compartments. When you start Virtualization Manager any time after, the software
checks whether you had previously set a default view by modifying user preferences (modify
user preferences by selecting Configure→User Preferences... from the Virtualization
Manager menu bar). If you set a collection such as VM Hosts, Virtualization Manager displays
the collection for all VM Hosts and virtual machines.
The Perspective menu allows you to choose a view comprised solely of VM Hosts and
virtual machines (both HP Integrity VM and VMware ESX, if both products are present
among the resources). Select Virtual Machine from the drop-down menu, as shown in
Figure 3-3.
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Figure 3-3 Selecting Virtual Machine perspective

3. On the Virtualization Manager Visualization tab, select the VM Host or virtual machine
that you want to manage. For example, in the Integrity VM representation shown in Figure 3-4
(a closeup from the screen shown in Figure 3-3 (page 23)), you can select VM Host system
chili3 by clicking the monitor icon beneath the VM Host name. (If you hover your
cursor over the icon, a pop-up pane displays explanatory text.) Selecting a VM Host monitor
icon displays the VM Manager VM Host General tab.
Alternatively, you can select one of the virtual machines running on VM Host chili3 by
clicking the similar but smaller icon beneath a virtual machine name (such as the monitor
icon for chili3a in Figure 3-4). Selecting a virtual machine monitor icon, displays the VM
Properties General tab.
The basic VM Manager views are described in Chapter 4 (page 31).

Figure 3-4 Select VM Host
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Accessing VM Manager from HP SMH
To use all the VM Manager facilities (view all screens and perform all menu actions), you must
log in to HP SMH with Administrator privileges. To access VM Manager from HP SMH, follow
these steps:
1. On the SMH Home page, click Tools.

NOTE: SMH GUI sessions stop after the session timeout period elapses without any user
activity (by default, the session timeout period is 15 minutes). With HP SMH Version 2.2.7
December 2007 and later, you can prevent a session from timing out by selecting the Session
never expires check box in the upper right corner of the page. Even if the box is checked,
the SMH server might shut itself down to conserve system resources if there is a period of
inactivity from all users (by default, this timeout period is 30 minutes). All of the VM Manager
Version 4.1.1 views and dialogs periodically issue short keepalive messages to the server to
prevent SMH from shutting itself down during your session. For more information about
SMH session management, see the smhstartconfig(1) and hpsmh(1) manpages.

2. On the SMH Tools page, select Integrity Virtual Machine Manager from the Integrity
Virtual Machines Management menu box. In the SMH Tools page shown in Figure 3-5,
the Integrity Virtual Machines Management menu box appears in the lower right corner
of the page. (Its location varies, depending on the management tools that are available.) This
example shows the SMH list view. The SMH icon view displays icons instead of menu boxes.

Look for the Integrity Virtual Machines icon ( ). To switch from one type of view to
another, click one of the the associated icons in the SMH header (to the right of the
Management Processor information).
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NOTE: When you access VM Manager for the first time from HP SMH, you might encounter
an End User License Agreement (EULA). You must accept this agreement to continue using
the VM Manager product.

Figure 3-5 HP SMH: accessing VM Manager

If you have already saved WBEM credentials for each virtual machine, selecting Integrity Virtual
Machines Manager displays the VM Host General tab as shown in Figure 3-6.
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Figure 3-6 HP SMH: VM Host General tab

If you have not set and saved WBEM credentials for each virtual machine, the Set WBEM
Credentials page is displayed first (instead of the VM Host General tab). An example of the Set
WBEM Credentials page is shown in Figure 2-1. Enter the appropriate information and click
OK, or click Cancel to skip this step and advance to the VM Manager VM Host General tab. For
more information about setting WBEM credentials, see “Setting security credentials” (page 15).

Accessing VM Manager help
To access help information for any VM Manager page, click the question mark icon located
in the upper right corner of the VM Manager page.

Navigating VM Manager
VM Manager provides numerous navigation aids, as shown in Figure 3-7, which is an example
of a VM Manager view from within the Insight Dynamics environment.
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NOTE: The VM Manager navigation aids available in a particular view vary according to the
view. The view in Figure 3-7 shows most of the navigation aids that VM Manager provides.
Missing from this view are navigation buttons such as Previous and Next, visible in some of
the Create Virtual Machines wizard pages (discussed in “Creating virtual machines” (page 87)).
Certain VM Manager pages (such as the Start Virtual Machine page) include OK and Cancel
buttons, which complete or cancel an action, returning you to the VM Manager view from which
you initiated the action.

Figure 3-7 VM Manager navigation features

Virtualization Manager

Restore Size

Go back to

VM Host metallica.aa.bb.com 

General Virtual Machines

Tools Create

Last refresh: May 5, 2009 2:37:14 PM MDT

Modify Delete View

Virtual Switches Network Storage

Integrity Virtual Machines Manager: Manage Host ?

View Printer-friendly Refresh Data

metallica01
(metallica01.aa.bb.com)

HP-UX
B.11.31

100 %

No Data No Data No Data

No Data No Data No Data

No Data No Data No Data

95 % of 1GB

94 % of 1GB

18 KB/s

20 KB/s11 %

95 % of 1GB 19 KB/s4 %

HP-UX
B.11.23

HP-UX
B.11.23

HPUX

HPUX

HPUX

metallica02
(metallica02.aa.bb.com)

metallica03
(metallica03.aa.bb.com)

metallica04
(metallica04.aa.bb.com)

motley03
(motley03.aa.bb.com)

motley04
(motley04.aa.bb.com)

VM Name
(Hostname)

HW OS Operating
System

VM vCPU
Utilization

Memory
Utilization

Disk I/O Net

1

2

3

4

5

6

7

8

1 Click the Go back link to return to the previous view.

NOTE: Avoid using your browser's Back and Forward buttons in VM Manager. When
you use these buttons, VM Manager cannot identify that you have changed to a different
view. This can cause problems, including incorrect display of objects selected in the current
view. Instead, use the links and navigation buttons provided by VM Manager.

If you navigate from one VM Manager view to another (for example, from VM Host view
to VM Properties view), click the Go back link in the new view (and on any subsequent
tabs you navigate to in that same view) to return to the previous VM Manager view. For
example, if you navigate from the VM Host view to the VM Properties view or to the Vswitch
Properties view, clicking the Go back link returns you to the VM Host view. If you navigate
from the VM Properties view to the VM Host view or to the Vswitch Properties view, clicking
the Go back link returns you to the VM Properties view.
Using VM Manager from Insight Dynamics, if the VM Manager view was accessed directly
from Virtualization Manager, clicking the Go back link returns you to Virtualization
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Manager (as indicated in Figure 3-7); clicking the Go back link on any tab that you navigate
to in the same view also returns you to the Virtualization Manager. For more information
about returning to Virtualization Manager from VM Manager (or, if you are using HP SMH,
about returning to the HP SMH Homepage), see “Returning to Virtualization Manager or
the HP SMH Homepage” (page 28).

2 Click a tab to change to another view. All VM Manager tabs are described in Chapter 4
(page 31).

3 Click a menu in the menu bar beneath the tab title. This displays additional information
about the actions you can perform. The VM Manager menu bar is described in Chapter 5
(page 75).

4 Click the top of a column of a table (on or near the title of the column) to change which
column is driving the sort order of the table. Click the arrow in the selected column to toggle
between ascending and descending order. Not all columns can drive the sort order. Hover
your cursor over a column heading to determine whether the column is selectable for sorting;
the cursor (pointer) changes according to the current pointer scheme configured for your
operating system (for example, when you hover over a selectable column, your cursor might
change from an arrow to a hand).
In tables that are sortable, one column has a darker grey background in the column heading
and an ascending or descending arrow in the same area. The dark grey color indicates that
the column is driving the sort order for all rows of data in the table. The arrow indicates
whether the column has been sorted in ascending or descending order. Criteria for the order
may be numeric or alphabetical. In Figure 3-7, the column that drives the sorting order is
the VM Name column, and the column is sorted in ascending order.

5 Click a check box next to an object that you want to act on, then select the action from one
of the VM Manager menus. To perform an action on all the objects listed, select the box at
the top of the check box column (in the header row at the top of the table).

6 Using VM Manager with Insight Dynamics - VSE for Integrity, you can click a utilization
meter to view a snapshot of Capacity Advisor historical data; this feature is not provided
when using VM Manager from HP SMH. For information about using VM Manager to collect
and view utilization data, see Chapter 7 (page 111).

7 Click a link to an object (the object's name forms the link) to move to a view of that object.
For example, click the virtual machine name link shown in Figure 3-7 to access the Virtual
Machine Properties page for that virtual machine.

8 These icons indicate the status of the virtual machine hardware (HW) and its guest operating
system (OS). The icons in the HW column indicate whether the virtual machine is started
(up) or stopped (down). For example, the ) icon indicates a VM is up; the icon indicates
it is down. The same icons in the OS column indicate whether the operating system is running.
In this particular view (the VM Host Virtual Machines tab), if a virtual machine is migrating,
an icon indicates the direction of migration. In the last row of the table, the icon indicates
the virtual machine is migrating to another VM Host. For more information about migration
status icons, see “VM Host Virtual Machines tab” (page 36). The meanings of these and
other status icons are summarized in “Status indicators” (page 124). For more information
on how to migrate virtual machines, see “Migrating virtual machines” (page 100).

Returning to Virtualization Manager or the HP SMH Homepage
With Insight Dynamics, to access Virtualization Manager from a VM Manager view in which
the Go back link currently directs you to another VM Manager view, you can do one of the
following:
• From the Insight Dynamics menu bar (top menu bar), select Tools→Virtualization

Manager.... Alternatively, select the All VSE Resources link in the left-hand navigation
pane (System and Event Collections→Systems→Shared→Systems by Type→All VSE
Resources). To access the top menu bar or left-hand navigation pane, your VM Manager
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view must not be maximized (using the Maximize link in the top right corner). If your view
is maximized, return to the view that includes the top menu bar by clicking Restore Size
in the top right corner of the maximized VM Manager view.

• Continue using the Go back link until you return to the VM Manager view that you accessed
originally from the Virtualization Manager, at which point you can click the Go back to
Virtualization Manager link.

Using VM Manager from HP SMH, you can return to the HP SMH Homepage by clicking Home
from the HP SMH menu bar.

NOTE: Avoid using your browser's Back and Forward buttons in VM Manager. Instead, use
the links and navigation buttons provided by VM Manager, as described in this section and
“Navigating VM Manager” (page 26).
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4 Using VM Manager views and tabs
VM Manager provides three basic views, each with several tabs, as described in the following
sections.
You can print any of the VM Host or virtual machine tabs by clicking View Printer-friendly
beneath the VM Manager menu bar, on the left side of the page. This redisplays the tab in a
format suitable for printing. To print the tab, click Print. To switch back, click View Normal.
You can update the data on certain pages by clicking Refresh Data beneath the VM Manager
menu bar, on the right side of the page. In general, VM Manager tabbed views are refreshed
automatically every five minutes. An indicator on these visualization pages notifies you when
the data was last refreshed. VM Manager screens that display configuration data are updated
instantaneously when you use VM Manager to change the related configuration parameters.
However, when changes to the virtual machine I/O configuration are made using tools other
than VM Manager (such as adding or removing I/O devices by using the VM Host command
line), the updated configuration data is not shown until the screen is refreshed. Some dialog
screens, such as the Create Virtual Machine wizard Add Storage Device and the Modify→Add
Storage Device to Virtual Machine... screens, include a Refresh Data link that you can use to
manually refresh data.

NOTE: The figures in this chapter and in the remainder of the manual display views seen from
Insight Dynamics. Views in HP SMH might differ slightly. Differences are noted. In addition,
the examples display maximized window views to give more focus to the VM Manager window
(eliminating the Insight Dynamics system status pane available on the left of the page and the
HP SIM/Insight Dynamics header and menu bar on the top of the page). Select the maximized
view by clicking Maximize in the top right corner of the page. You can see the Maximize link in
Figure 3-3 (page 23). To return to the original view, click Restore Size in the top right corner
of the maximized page. The maximize feature is not provided by HP SMH but is not needed;
HP SMH provides a full-window VM Manager view.
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VM Host view
You can access the VM Manager Host view directly from Virtualization Manager or from other
VM Manager views that include a link to the VM Host, such as the VM Properties General tab.
Figure 4-1 shows a typical VM Host view in VM Manager. Tabs available from the VM Host
view are described in the text that follows. Subsequent sections describe each tab in more detail.

Figure 4-1 VM Host view
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1 The “VM Host General tab” (page 33) displays information about the VM Host system.
2 The “VM Host Virtual Machines tab” (page 36) displays information about the virtual

machines in the VM Host system.
3 The “VM Host Virtual Switches tab” (page 40) shows information about the virtual switches

on the VM Host.
4 The “VM Host Network tab” (page 42) shows all mappings from virtual network interface

cards in the virtual machines to the physical network interface cards in the VM Host system.
5 The “VM Host Storage tab” (page 49) shows all mappings from the virtual storage devices

in the virtual machines to the physical storage devices in the VM Host system.
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VM Host General tab
The VM Host General tab displays information about the state and configuration of the VM
Host system.

Quick reference

Figure 4-2 VM Host General tab
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1 Goes back to the previous view, in this case Virtualization Manager. If you accessed the VM
Host view from another VM Manager view (such as the VM Properties view), the link returns
you to that previous view. In HP SMH, when you first access this page from HP SMH, the
link is not provided. The link appears whenever you move from one VM Manager view to
another (such as from VM Properties view to VM Host view, in which case the Go back to
Integrity Virtual Machines Manager: Manage VM link appears on the VM Host view).

2 Displays this window in a format suitable for printing.
3 Updates the data displayed on this page. In general, VM Manager tabbed view screens are

refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change the
related configuration parameters. However, when changes to the virtual machine I/O
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configuration are made using tools other than VM Manager (such as adding or removing
I/O devices by using the VM Host command line), the updated configuration data is not
shown until the screen is refreshed.

4 Describes resources in the VM Host system.
5 Describes the status of virtual machines in the VM Host system and identifies external

managers. If virtual machines are managed by gWLM, the field provides a hyperlink that
enables you to access gWLM.

6 Summarizes resource utilization for the VM Host system.
For more information about using VM Manager to collect and view utilization data, see
Chapter 7 (page 111).

Screen details

VM Host Information

• Hostname: The hostname of the VM Host system (as well as the nPartition name and link
to Partition Manager for this nPartition, if the VM Host system is contained within an
nPartition).

• Resource inventory.
— Physical CPU Core Count: The number of processors.
— Physical CPU Core Speed: The speed of processors.
— Physical Memory: The amount of memory.
— Online Migration: Indicates whether the VM Host is enabled and licensed to support

online migration of virtual machines. The second column in the following table shows
what the status field displays, based on the state of the VM Host listed in the first column:

Table 4-1 Online migration status

Online migration statusVM Host state for online migration

Host disabledDisabled

Host licensedEnabled and licensed

Host not licensedEnabled and unlicensed

The licensing is included with a bundle that must be installed on the VM Host. For more
information about enabling and licensing the VM Host, see the HP Integrity Virtual
Machines Installation, Configuration, and Administration manual.

— MSE group: The name of the Integrity VM multiserver environment group, which is
a set of Integrity VM servers. This grouping is required when a set of Integrity VM
servers is also configured as a Serviceguard cluster. Virtual machines configured as
Serviceguard packages automatically fail over to another node in the Integrity VM MSE.

VM Information

• Number of defined VMs: The number of defined virtual machines.
• Number of active VMs: The number of virtual machines currently booted, and the number

of virtual machine packages running on the local VM Host (local) as well as the number that
are hosted remotely using HP Serviceguard.

• External Managers: Indicates if the virtual machine is being managed by gWLM or HP
Serviceguard. With Insight Dynamics - VSE for Integrity, if virtual machines are managed
by gWLM, the field provides a hyperlink to gWLM. Under HP SMH, if virtual machines are
being managed by gWLM, the field identifies the Central Management Server (CMS) on
which gWLM is running and provides a hyperlink to the HP SIM/Insight Dynamics login
screen (you cannot modify gWLM policies from HP SMH). In either case (using VM Manager
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with Insight Dynamics or HP SMH), if the virtual machines are not being managed by gWLM
or HP Serviceguard, this field displays (none).

VM Host Resource Utilization

Resource utilization meters display data retrieved by the WBEM Utilization Provider. The data
is a 5-minute average that is calculated and updated on 5-minute boundaries. If the utilization
cannot be displayed, the utilization meter is dimmed and a label indicates the probable cause.
For a description of meter labels, see “Utilization meter status/error information” (page 125).
Using VM Manager with Insight Dynamics - VSE for Integrity, you can click a meter to view a
snapshot of Capacity Advisor historical data; this feature is not provided when using VM Manager
from HP SMH.
• VM Host CPU Utilization: An aggregate showing how busy the VM Host is with respect

to the processes and virtual machines that are executing on it.
• Physical Memory currently in use: A started virtual machine requires the total amount

of memory defined for that virtual machine.
• Physical network I/O An aggregate of all network I/O that is occurring on the host as a

result of both host and guest access to network devices. Because this is an aggregate, one or
more network devices might be very busy, while others might be idle. For information about
specific devices, see the VM Host Network tab.
Physical disk I/O An aggregate of the storage I/O that is occurring on the host as a result
of both host and guest access to storage devices. Because this is an aggregate, one or more
storage devices might be very busy, while others might be idle. For more information about
each device, see the VM Host Storage tab.
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VM Host Virtual Machines tab
The VM Host Virtual Machines tab displays information about the state of virtual machines in
the VM Host system.

Quick reference

Figure 4-3 VM Host Virtual Machines tab
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1 Goes back to the previous view, in this case Virtualization Manager. If you accessed the VM
Host view from another VM Manager view (such as the VM Properties view), the link returns
you to that previous view. In HP SMH, when you first access this page from HP SMH, the
link is not provided. The link appears whenever you move from one VM Manager view to
another (such as from VM Properties view to VM Host view, in which case the Go back to
Integrity Virtual Machines Manager: Manage VM link appears on the VM Host view).

2 Displays this window in a format suitable for printing.
3 Updates the data displayed on this page. In general, VM Manager tabbed view screens are

refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change the
related configuration parameters.

4 Allows you to perform an action on the virtual machine. Select the box for a specific virtual
machine, then select an action from one of the menus available on the VM Manager menu
bar. To perform an action on all the virtual machines, select the box in the header row.

5 Displays information about the virtual machine by taking you to the VM Properties General
tab.

6 Utilization meters (bar graphs) display utilization data. This one provides memory utilization
data. Other meters display data about virtual machine vCPU utilization, disk I/O, network
I/O, and VM Host CPU utilization. (In Figure 4-3, the virtual machine information table is
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only partially visible; some utilization meters are not visible. To see all the utilization meters
in the full-width view, see Figure 4-4.)
If the data cannot be displayed, the meter is dimmed and a label indicates the probable
cause. For a description of meter labels, see “Utilization meter status/error information”
(page 125)
Using VM Manager with Insight Dynamics -VSE for Integrity, you can click a meter to view
a snapshot of Capacity Advisor historical data.

7 Indicates the hardware status of the virtual machine.
8 Indicates whether the OS is running. If the virtual machine is migrating, indicates the status

or direction of migration. (You can manage the virtual machine at the target host once the
migration process finishes.) For more information about migration and how to start the
migration of a virtual machine, see “Migrating virtual machines” (page 100).

Figure 4-4 shows an example of the full-width view of the virtual machine information table
displayed by the VM Host Virtual Machines tab. (To see the entire table, you might have to
scroll horizontally or maximize your window.)

Figure 4-4 Full-width view of virtual machine information table

Screen details
• VM Name (Hostname): Displays the virtual machine name and, in parentheses, a fully

qualified network name for the virtual machine (if available). If the virtual machine is
configured as a Serviceguard package, the package icon ( ) appears next to the virtual
machine name. (If the virtual machine Serviceguard package is being managed by another
VM Host, the HW field indicates so.) If errors occur during an attempt to migrate the virtual

machine, the Migration Alerts icon ( ) appears next to the virtual machine name; more
information about the errors is available from the VM Properties General tab.

• HW: Displays an icon that indicates the state (for example, up/down) of the virtual machine.
You can hover your cursor over the icon for a more detailed description.
If the virtual machine has successfully migrated to another VM Host, the state of the virtual
machine becomes Not Runnable, indicated with the following status icon: . This means
that the virtual machine cannot be modified or started. If you never intend to migrate the
virtual machine back to this VM Host, you can remove the virtual machine configuration
by using the VM Manager Delete→Virtual Machine... menu item.
If the virtual machine is an HP Serviceguard package managed by another VM Host, this
field also displays the following icon: . Flyover text shows the state of the hardware (On)
and the name of the VM Host currently managing the virtual machine.
For more information on the meanings of status icons, see “Status indicators” (page 124).
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• OS: Displays an icon that indicates whether the operating system is active on the virtual
machine. You can hover your cursor over the icon for a more detailed description. The
icon indicates the operating system is running. The icon indicates the operating system
is not running. If the virtual machine is currently migrating, an icon indicates the direction
of migration:

: Migrating to another VM Host. Flyover text indicates the virtual machine is migrating
and provides the name of the target VM Host.

: Migrating to this VM Host from another VM Host. Flyover text indicates the virtual
machine is migrating from another VM Host.
If the virtual machine is waiting in queue to migrate (when several virtual machines are
selected to migrate, only one migrates at a time; the rest wait in queue), an hourglass icon
( ) indicates so. To view changes in migration status, click Refresh Data.

NOTE: Although only one virtual machine migrates at a time, you might see indication
of two machines migrating simultaneously to another host. The first migration has actually
completed but VM Manager has not yet received notification from the VM Provider.

For more information on the meanings of status icons, see “Status indicators” (page 124)

• Operating System: Displays the operating system type and version information for the
virtual machine.

• VM vCPU Utilization: Displays how much of the virtual CPU assigned to the virtual machine
is currently being used.

NOTE: This and other utilization meters in this table display utilization data, if available.
The utilization information is a 5-minute average that is calculated and updated on 5-minute
boundaries. If the utilization cannot be displayed, the utilization meter is dimmed and a
label indicates the probable cause. For a description of meter labels, see “Utilization meter
status/error information” (page 125).
Using VM Manager with Insight Dynamics - VSE for Integrity, you can click a utilization
meter to view a snapshot of Capacity Advisor historical data; this feature is not provided
when using VM Manager from HP SMH. For an example utilization history screen and
information about collecting and viewing utilization data, see Chapter 7 (page 111).

• Memory Utilization: Displays how much of the memory assigned to the virtual machine is
currently being used.

• Disk I/O: Displays storage I/O throughput measured for this virtual machine.
• Network I/O: Displays network I/O throughput measured for this virtual machine
• vCPU Count: Displays how many virtual CPUs the virtual machine has.
• gWLM Policy: Displays the gWLM policy for the virtual machine. This field is displayed

only if the virtual machines are being managed by gWLM, in which case entitlements are
controlled by gWLM. When virtual machines are not being managed by gWLM, the column
displays the vCPU entitlement instead of the gWLM policy. In this case, you can use VM
Manager to modify the entitlements (for more information about modifying vCPU
entitlements, see “Modifying virtual machines” (page 92)). If a policy is defined for a virtual
machine, the name of the policy is shown; if a policy is not defined, then “(none)” is displayed.
When you use VM Manager with the Insight Dynamics - VSE for Integrity, if the virtual
machine is managed by gWLM, the gWLM policy name is a hyperlink to gWLM. When you
use VM Manager through HP SMH, if virtual machines are being managed by gWLM, the
gWLM policy name is text only (you cannot modify gWLM policies from HP SMH).
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• vCPU Entitlement: Displays the percentage of CPU power guaranteed to the virtual machine.
This field is not displayed if the virtual machines are being managed by gWLM.

• VM Host CPU Utilization: Displays how many of the VM Host's physical CPU resources
are being consumed by this virtual machine. This meter is not displayed if the virtual machine
is a Serviceguard package running on another VM Host.
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VM Host Virtual Switches tab
The VM Host Virtual Switches tab shows information about the virtual switches on the VM
Host system.

Quick reference

Figure 4-5 VM Host Virtual Switches tab
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1 Goes back to the previous view, in this case the Virtualization Manager. If you accessed the
VM Host view from another VM Manager view (such as the VM Properties view), the link
returns you to that previous view. In HP SMH, when you first access this page from HP
SMH, the link is not provided. The link appears whenever you move from one VM Manager
view to another (such as from VM Properties view to VM Host view, in which case the Go
back to Integrity Virtual Machines Manager: Manage VM link appears on the VM Host
view).

2 Displays this window in a format suitable for printing.
3 Updates the data displayed on this page. In general, VM Manager tabbed view screens are

refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change the
related configuration parameters. However, when changes to the virtual machine I/O
configuration are made using tools other than VM Manager (such as adding or removing
I/O devices by using the VM Host command line), the updated configuration data is not
shown until the screen is refreshed.

4 Allows you to perform an action on the virtual switches. Select the box for a specific virtual
switch, then an action from one of the menus available on the VM Manager menu bar. To
perform an action on all the virtual switches, select the box in the header row.

5 Displays information about the virtual switch by taking you to the Vswitch Properties
General tab.

6 Indicates whether the physical backing device supports Accelerated Virtual Input/Output
(AVIO).

Screen details
• Vswitch Name: lists the names of the virtual switches.
• Status : shows whether the virtual switch is up (operational) or down (inoperational).
• Type: shows whether the corresponding virtual switch is a shared or dedicated vswitch.
• Supports AVIO: shows whether the corresponding backing device supports Accelerated

Virtual Input/Output (AVIO). AVIO is supported on HP Integrity VM Version 3.5 or later
and requires installation of AVIO drivers on the VM Host. For proper operation of virtual
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storage or network devices configured to use AVIO, special AVIO software must be installed
on the associated VM guest. Currently, for AVIO support, HP Integrity VM requires that a
backing device exist. For more information about AVIO requirements, see the HP Integrity
VM documentation.

• Used by: shows the virtual machines that are using the virtual switch. Position your cursor
over the information icon to view a list of the virtual machines that are connected to the
virtual switch.
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VM Host Network tab
The VM Host Network tab shows the mapping from virtual network interface cards in the virtual
machines to the physical network interface cards in the VM Host system.

Quick reference

Figure 4-6 VM Host Network tab
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1 Goes back to the previous view, in this case Virtualization Manager. If you accessed the VM
Host view from another VM Manager view (such as the VM Properties view), the link returns
you to that previous view. In HP SMH, when you first access this page from HP SMH, the
link is not provided. The link appears whenever you move from one VM Manager view to
another (such as from VM Properties view to VM Host view, in which case the Go back to
Integrity Virtual Machines Manager: Manage VM link appears on the VM Host view).

2 Displays this window in a format suitable for printing.
3 Updates the data displayed on this page. In general, VM Manager tabbed view screens are

refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change the
related configuration parameters. However, when changes to the virtual machine I/O
configuration are made using tools other than VM Manager (such as adding or removing
I/O devices by using the VM Host command line), the updated configuration data is not
shown until the screen is refreshed.

4 Displays detailed information about the virtual machine by taking you to the VM Properties
General tab.

5 Clicking the Focus link limits the display to only those network devices associated with the
selected object (in this instance, the devices associated with virtual machine suffolk) and the
objects directly connected to it. All other devices are not displayed. To return to the original
view, click the Show All link visible beneath the VM Manager menu bar on the focused
page.

6 Displays the type of network interface such as emulated LAN (displayed here as “LAN”)
or Accelerated Virtual Input/Output LAN (displayed as “AVIO LAN,” as for the next network
device shown in the figure).

7 Indicates by color coding that matching components are related.
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8 The utilization meter (bar graph) displays network I/O throughput data, if available. The
data is a 5-minute average that is calculated and updated on 5-minute boundaries. If the
data cannot be displayed, the meter is dimmed (as in the meter in the next box below) and
a label indicates the probable cause. For a description of meter labels, see “Utilization meter
status/error information” (page 125).
Using VM Manager with Insight Dynamics -VSE for Integrity, you can click a meter to view
a snapshot of Capacity Advisor historical data for network I/O; this feature is not provided
when using VM Manager from HP SMH.
For more information about using VM Manager to collect and view utilization data, see
Chapter 7 (page 111).

9 Allows you to perform an action on the virtual machine or I/O device. Select the box, then
select an action from one of the menus available on the VM Manager menu bar.

Network devices
VM Manager displays icons to represent certain network devices. You can hover your cursor
over the icon to see text describing the representation. Table 4-2 describes these icons.

Table 4-2 Network device icons

DescriptionIcon

Physical or virtual network card

Virtual switch

Virtual LAN (VLAN)

A question mark within the device icon, such as , indicates that the type of device cannot
be determined. The device type cannot be determined, for example, when the device has been
removed from the VM Host but not from the virtual machine.

Screen details

Network tab column layout

Figure 4-7 depicts the column layout for the VM Host Network tab.
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Figure 4-7 Network tab column layout

The VM Host Network tab consists of three columns with the following titles. The contents of
each column are described in the subsections that follow.

Virtual Network Interfaces column contents

This column displays the virtual network interfaces in the virtual machines. The virtual network
interfaces are grouped by virtual machine. Each major box grouping in the column represents a
virtual machine.

Figure 4-8 Virtual Network Interfaces column

Referring to Figure 4-8, note the following:
• The icons next to the name of the virtual machine and next to the network interface devices

show the status of the system or interface. A question mark (?) means no information is
available.

• Clicking the name of the virtual machine (for example, suffolk) displays general
information about the virtual machine.

• Clicking the box near the virtual machine name allows you to perform operations on the
virtual machine by using one of the menus available from the VM Manager menu bar.
Clicking the box next to the device label allows you to perform operations on the device (for
example, removing the device).
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• The bar graphs indicate network throughput, if available.
• If the virtual machine is running and can be contacted by using WBEM, the network interfaces

are shown (for example, vs1); otherwise, a portion of the hardware path (bus, device, and
function) is shown.

• If the virtual network interface is defined to use Accelerated Virtual Input/Output (AVIO),
the label AVIO appears with the network interface designation, such as AVIO LAN or AVIO
lan0 (the latter for a specific guest network interface designation). If the virtual network
interface is not defined to use AVIO, the network interface designation does not include the
AVIO label.

• The Focus link limits the display to a specific virtual machine or interface and the objects
connected to it. All other devices are not displayed. If you use this link to focus on only a
specific virtual machine or interface, you can return to see all the virtual machines or network
interfaces by using the Show All link visible on the focus page.

Virtual Switches column contents

This column displays details about each virtual switch. Each major box grouping represents a
virtual switch.

Figure 4-9 Virtual Switches column

Referring to Figure 4-9, note the following:
• The icon next to the name of the virtual switch shows whether the virtual switch is

operational.
• Clicking the box near the virtual switch name allows you to perform operations on the

virtual switch by using one of the menus available from the VM Manager menu bar.
• Clicking the virtual switch name displays general information about the virtual switch.
• The icon and label below the virtual switch name indicates whether the corresponding

virtual switch is shared or dedicated.
• If the physical network interface that backs the virtual switch can support AVIO, the label

Supports AVIO appears next to the Focus link. The Focus link shows only that specific
virtual switch and anything connected to it. If use this link to focus on a specific virtual
switch, you can return to displaying all the virtual switches by using the Show All link
visible on the focus page.

A virtual LAN (VLAN) is depicted as shown in Figure 4-10:
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Figure 4-10 Virtual LAN

If a virtual switch has VLANs configured on it, each VLAN appears as a separate box within the
virtual switch box. The virtual NICs from the virtual machines are connected to the appropriate
VLAN box by a color-coded line. The switch port used by the virtual NIC is listed in its box. The
VLAN boxes list the switch ports that are using that VLAN ID.
For ports on the switch that are not associated with a VLAN, the virtual switch contains a box
labeled No VLAN. Virtual NICs can be connected to the No VLAN box.

Physical Network Interfaces column contents

This column displays the physical network interface devices in each virtual machine on the VM
Host. These can be either an APA or a single device.
Each box in the Physical Network Interfaces column represents one of the following:
• A physical network interface card in the host

Figure 4-11 Physical network interface card

• An APA. When multiple physical network interface devices are aggregated using the Auto
Port Aggregation (APA) software package, they are displayed as network devices inside an
APA box.

Figure 4-12 APA

The icon next to the hardware path of the physical interface device shows whether the device is
operational.
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The label next to the hardware path shows the description for the physical interface device.
The bar graph indicates network throughput, if available.
If the physical interface can support AVIO, the label Supports AVIO appears next to the Focus
link. The Focus link limits the display to the selected physical interface and anything connected
to it. If you use this link to focus on a specific physical interface, you can return to displaying all
the physical interfaces by using the Show All link visible on the focus page.

Colors

The connections are color coded to help you identify interconnected elements.

NOTE: The actual colors shown do not imply any specific meaning. The colors are provided
to help you understand the connections from virtual to physical devices.

Focus links

Clicking one of these links simplifies the display by showing only the item that was selected and
the elements that are directly attached to it.
• Focusing on a virtual machine shows the network interfaces on the virtual machine, the

virtual switches that they are connected to, and the physical network interface devices
connected to the virtual switches.

• Focusing on a LAN in a virtual machine shows only the devices and virtual machines
connected to the LAN.

• Focusing on a virtual network shows all of the virtual switches and all of the network
interface devices connected to it.

• Focusing on a virtual switch shows only the devices and virtual machines connected to the
vswitch.

• Focusing on a physical network interface device shows the virtual switches connected to
the physical interface device and all the virtual network interfaces connected to them.

• Focusing on an APA shows the shared virtual switches connected to it, and all the virtual
network interfaces connected to them.

• In a focused view, the presence of additional devices or connections are shown either as an
ellipsis, or as a solid line becoming a dotted line.

• To view all the virtual network interfaces again, click the Show All link.

Dotted lines

The vertical dotted line indicates the boundary between the virtual and physical devices.
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Bar graphs

The bar graphs are utilization meters that indicate the current IO throughput of a device or
interface device. When using VM Manager with Insight Dynamics - VSE for Integrity, some bar
graphs are selectable and bring up a view of the historical data related to the graph.

Status icons

These indicate whether an item is operational. Position the cursor over the icon to view a textual
description. For more information about status icons, see “Status indicators” (page 124).
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VM Host Storage tab
The VM Host Storage tab shows the mappings from the virtual storage devices in the virtual
machines to the physical storage devices in the VM Host system.

Quick reference

Figure 4-13 VM Host Storage tab
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1 Goes back to the previous view, in this case Virtualization Manager. If you accessed the
VM Host view from another VM Manager view (such as the VM Properties view), the
link returns you to that previous view. In HP SMH, when you first access this page from
HP SMH, the link is not provided. The link appears whenever you move from one VM
Manager view to another (such as from VM Properties view to VM Host view, in which
case the Go back to Integrity Virtual Machines Manager: Manage VM link appears on
the VM Host view).

2 With the Show physical host bus adapters check box selected (as in this example), the
view includes the complete storage bus structure, host bus adapters, and multipath storage
configurations. This view may take longer to render and can be more challenging for
discerning the associations between virtual machines and devices, especially when many
multipath storage devices exist on the VM Host. By default (the check box being
unselected), the view is simpler, showing only the specific storage devices that are being
used as backing devices. For a multipath device, the simple view shows only the device
special file (DSF) path, as specified when the virtual storage device was created. In contrast,
the complex view displays all DSF versions of the same device, including (on an HP-UX
11i v3 VM Host) the persistent DSF.
When you navigate to another VM Manager view and return to this view again, the Show
physical host bus adapters check box retains its state. In other words, if the box is
checked when you navigate away from the VM Host Storage tab, it remains checked
when you navigate back (you continue to see the complex view on return). If the box is
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unchecked, it remains unchecked when you return (you continue to see the simple view).
The check box state on the VM Host Storage tab does not affect the state of the same check
box on the VM Properties Storage tab. For example, selecting the check box on the VM
Host Storage tab does not automatically affect the check box and view of the VM
Properties Storage tab.

3 Displays this window in a format suitable for printing.
4 Updates the data displayed on this page. In general, VM Manager tabbed view screens

are refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change
the related configuration parameters. However, when changes to the virtual machine I/O
configuration are made using tools other than VM Manager (such as adding or removing
I/O devices by using the VM Host command line), the updated configuration data is not
shown until the screen is refreshed.

5 Allows you to perform an action on the virtual machine or I/O device. Select the box, then
select an action from one of the menus available on the VM Manager menu bar.

6 Clicking the Focus link limits the display to only those storage devices associated with
the selected object (in this instance, the devices associated with virtual machine vse02v1)
and the objects directly connected to it. All other devices are not displayed. To return to
the original view, click the Show All link visible beneath the VM Manager menu bar on
the focused page.
The Show physical host bus adapters check box is disabled (dimmed) in the focussed
view; you cannot change the Show physical host bus adapters state until you return
to the original (unfocussed) view. The simplicity or complexity of the focussed view with
respect to host bus adapters and so forth is determined by the check box selection at the
time that you selected the focus link.

7 Displays detailed information about the virtual machine by taking you to the VM
Properties General tab.

8 Displays the type of storage device interface and device, such as emulated SCSI Disk
(labeled SCSI Disk, as in this instance) or Accelerated Virtual Input/Output disk (labeled
AVIO Disk).

9 The meter (bar graph) displays storage I/O throughput data, if available. The data is a
5-minute average that is calculated and updated on 5-minute boundaries. If the data cannot
be displayed, the meter is dimmed (as in the meter underneath this one) and a label
indicates the probable cause. For a description of meter labels, see “Utilization meter
status/error information” (page 125).
Using VM Manager with Insight Dynamics - VSE for Integrity, you can click a meter to
view a snapshot of Capacity Advisor historical data for storage I/O; this feature is not
provided when using VM Manager from HP SMH.
For more information about using VM Manager to collect and view utilization data, see
Chapter 7 (page 111).

10 The green horizontal line indicates by color coding that matching components are related.
This particular line links the virtual storage component to its corresponding physical
storage component. The green vertical line to the right of the screen also indicates by color
coding that matching components are related. This line links two representations of the
storage device, one with the agile address and the other with the legacy address. The line
indicates that they are two different representations of the same physical device. Multiple
representations are displayed only if the Show physical host bus adapters check box
is selected.
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Storage devices
Various types of devices are supported on virtual machines. VM Manager represents each type
of device with an icon. You can hover your cursor over the icon to see text describing the
representation. Table 4-3 describes these icons.

Table 4-3 Network device icons

DescriptionIcon

Disk

DVD

Tape

Burner

Changer

File

Directory (folder)

Storage adapter

A question mark within the device icon, such as , indicates that the type of device cannot
be determined. The device type cannot be determined, for example, when the device has been
removed from the VM Host but not from the virtual machine.

Virtual device type:

• The virtual device type and subset of the hardware path are shown with each virtual device.
This also indicates how the device is being used in the virtual machine.

Backing device:

The storage that backs a virtual device does not necessarily need to be the same type as the virtual
device itself; for example, a file can be the backing storage for virtual disks or virtual DVDs. A
file can be selected as a backing device for one of two purposes:
• The file is intended to represent the capacity of a virtual storage device. This storage space

is treated like a disk drive and can be used the way a disk drive is used (for example, by a
storage manager, or a raw device).

• The file is intended to represent a DVD or CD. In these cases, the file is an .ISO image of the
actual media.

A directory can be a backing device for a virtual DVD. A directory backing device is equivalent
to a physical DVD drive that is empty (the DVD was ejected or has not been inserted). The list
of files in the backing directory are ISO files, each representing a physical DVD that can be
inserted and used as the backing device.
If you eject a file-backed virtual DVD, the storage device is then backed by the directory in which
the ISO file was located. If you insert (select) an ISO file for a directory-backed DVD, the DVD
becomes a file-backed virtual DVD. For information about loading and ejecting a virtual DVD
by command from the virtual machine virtual console, see the HP Integrity Virtual Machines
Installation, Configuration, and Administration manual.
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NOTE: If you use VM Manager to manage a VM Host running Integrity VM Version 3.5 or
earlier, VM Manager does not fully support virtual device special files located in /hpap
(introduced in HP StorageWorks Secure Path software Version 3.0F SP2) as backing devices for
virtual storage. If a virtual storage device using an /hpap device special file already exists on a
virtual machine managed by VM Manager, VM Manager displays it on the VM Host Storage
and VM Properties Storage tabs as an unknown device (using the question mark icon, ). VM
Manager displays the correct device special file name (for example, /hpap/rdsk/hpap1) but
the box representing this device is not connected to the boxes that represent the physical storage
devices associated with that virtual device special file. In general, VM Manager correctly displays
only those device special files located in /dev.

Screen details

Storage tab column layout

Figure 4-14 depicts the column layout for the VM Host Storage tab.

Figure 4-14 Storage tab column layout

The VM Host Storage tab consists of three columns with the following titles. The contents of
each column are described in the subsections that follow.

Virtual Storage column contents

As shown in Figure 4-15, this column displays the virtual storage devices in the virtual machines.
The virtual storage devices are grouped by virtual machine. Each major box grouping in the
column represents a virtual machine.
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Figure 4-15 Virtual Storage column

Referring to Figure 4-15, note the following:
• The icon next to the name of the virtual machine shows operational status of the virtual

machine. A question mark (?) means no information is available.
• Clicking the name of the virtual machine (for example, vse02v4) displays general information

about the virtual machine.
• Clicking the box next to the virtual machine allows you to perform operations on the virtual

machine by using one of the menus available from the VM Manager menu bar. Clicking the
box near the device name allows you to perform operations on that device (such as removing
the device).

• The meters (bar graphs) indicate I/O throughput, if available.
• If the virtual storage device is defined to use Accelerated Virtual Input/Output (AVIO), the

label AVIO identifies the device interface type; for example, AVIO Disk. If the virtual storage
device is defined to use emulated SCSI, the label SCSI identifies the device interface type;
for example, SCSI Disk.

• The Focus link limits the display to a specific virtual machine or device and anything
connected to it. All other objects are not displayed. If you use this link to focus on only a
specific virtual machine or device, you can return to see all the virtual machines or devices
by using the Show All link visible on the focus page.

Logical Storage column contents

This column displays information about logical storage devices, including the files and logical
volumes that reside on physical storage devices. Each box represents a logical storage device, as
in Figure 4-16.

Figure 4-16 Logical storage device
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Referring to Figure 4-16, note the following:
• The Focus link limits the display to only that specific storage device and the objects connected

to it. All other devices are not displayed. If you use this link to focus on a specific storage
device, you can return to displaying all the storage devices by using the Show All link visible
on the focus page.

Physical Storage column contents

This column displays the physical storage media, such as disk, DVD, DVD writers, tape devices
and tape changers, as well as their corresponding physical storage devices through which the
media is accessed. Each box in the column represents a physical storage device or interface card
in the host. Two examples follow: Figure 4-17 shows what might be seen on an HP Integrity VM
Version 3.5 VM Host, while Figure 4-18 shows what might be seen on an HP Integrity VM Version
4.0 or later VM Host. The former lists the device special file (legacy addressing) for the storage
device, as defined in HP-UX 11i v2 and all earlier versions of HP-UX. The latter lists in addition
the device's new persistent device special file (agile addressing), available with HP-UX 11i v3.
The orange line in this second example links the two representations of the storage device.

Figure 4-17 Physical storage detail from HP Integrity VM Version 3.5 VM Host

The following items describe physical storage details in Figure 4-17:
• The first line at the top includes the hardware path for the adapter (also referred to as the

host bus adapter or HBA).
• The line below the hardware path (here, beginning with SCSI) describes the adapter.
• The first line in the gray box describes the storage device.
• The next line in the gray box (/dev/rdsk/c5t8d0) displays the device file path (device

special file) for the storage device, using the legacy addressing scheme.
• The bar graph is an I/O utilization meter that registers throughput. In this example, the

meter is grayed out, indicating that the data is not available.
• Clicking a Focus link limits the display to the selected device and those objects connected

to it. All other devices are not shown. If you use this link to focus on a specific adapter or
device, you can return to the original view displaying all the storage interface cards and
devices by using the Show All link visible on the focus page.
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Figure 4-18 Physical storage detail from HP Integrity VM Version 4.0 or later VM Host

The following items describe physical storage details in Figure 4-18:
• The box on the top is the storage device representation with the persistent device special

file (agile addressing). The first line describes the storage device (HP 300 GST3300007LC).
The next line below that (/dev/rdsk/disk3) displays the persistent device special file
(DSF) path for the storage device. The path is persistent with respect to changes in the access
path or host bus adapter, and can use multiple paths through a single device file name. This
enables VM Manager to display a single DSF for each device instead of displaying a separate
DSF for each path to a device with multiple paths (as done when devices are displayed using
the legacy addressing scheme).

• The second, larger box shows the adapter information, where the first line displays the
hardware address (0/1/1/0), and the next line describes the adapter (SCSI Ultra320).
The gray box within this larger box is the storage device representation of the HP 300
GST3300007LC, but with the legacy DSF path (/dev/rdsk/c2t1d0).
The orange line on the right of the two boxes links the two representations of the storage
device (one with the agile address and the other with the legacy address), indicating that
they are two different representations of the same physical device.

• The utilization meter (bar graph) is an I/O utilization meter that registers throughput. In
this example, the meter is grayed out, indicating that the data is not available.

• Clicking a Focus link displays information about the specific physical storage adapter or
device and anything connected to it. If you use this link to focus on a specific adapter or
device, you can return to the original view displaying all the storage interface cards and
devices by using the Show All link visible on the focus page.
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Colors

The connections are color coded to help identify interconnected elements.

NOTE: The actual colors shown do not imply any specific meaning. The colors are provided
to help you understand the connections from virtual to physical devices.

Focus links

Clicking a Focus link simplifies the display by showing only the item that was clicked and the
elements that are directly attached to it:
• Focusing on a virtual machine shows the virtual storage interfaces in the virtual machine

and all the logical storage devices, physical interface cards, and devices that back them.
• Focusing on a virtual storage interface is like focusing on a virtual machine, except that only

the selected virtual storage interface and its connections are shown; all others are hidden.
• Focusing on a logical storage device shows all of the virtual storage devices and all of the

physical storage interface cards and devices connected to it.
• Focusing on a physical storage interface card shows only the physical devices attached to

the card, the logical storage devices connected to the physical device, and the virtual storage
devices connected to those logical storage devices.

• Focusing on a physical storage device shows only the logical and virtual devices using that
physical storage. This might reduce the number of devices shown, depending on how many
virtual devices and virtual machines are connected to the physical storage device.

• In a focused view, the presence of additional devices or connections is shown by either an
ellipsis, or a solid line becoming a dotted line.

• To view all the storage devices again, use the Show All link.

Dotted lines

The black vertical dotted line indicates the boundary between the virtual and physical devices.
A colored vertical dotted line indicates devices are present but not associated with the indicated
virtual machine. For example, a three-dotted vertical line inside a box indicates that other storage
devices are attached to the host bus adapter but are not used by the virtual machine (in other
words, other virtual machines are using those devices).

Bar graphs

The bar graphs are utilization meters that indicate the current I/O throughput of a device or
interface card. When running the Integrity VM Manager with Insight Dynamics - VSE for
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Integrity, some bar graphs are selectable and display a view of the historical data related to the
graph.

Status icons

These indicate whether an item is operational. You can hover the cursor over the icon to view a
textual description. For more information about status icons, see “Status indicators” (page 124).
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Virtual Machines (VM) Properties view
You can access the VM Properties view directly from the Virtualization Manager or from any
other VM Manager views that include a link to a virtual machine, such as the VM Host General
tab, the VM Host Virtual Machines tab, or any Network or Storage tab. You can also access the
VM Properties view by selecting View→ Virtual Machine Properties... (a virtual machine must
be selected in the current view). Figure 4-19 shows a portion of a typical VM Properties view.
Tabs available from the view are described in the text that follows. Subsequent sections describe
each tab in more detail.

Figure 4-19 VM Properties View
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1 The “VM Properties General tab” (page 59) displays information about the general state
of the virtual machine.

2 The “VM Properties Network tab” (page 65) displays information about the network devices
for the virtual machine.

3 The “VM Properties Storage tab” (page 67) displays information about the storage devices
for the virtual machine.
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VM Properties General tab
The VM Properties General tab shows the state and configuration details of a specific virtual
machine.

Quick reference

Figure 4-20 VM Properties General tab
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1 Goes back to the previous view, in this case the VM Manager VM Host view. When you
access the VM Properties view from another VM Manager view (such as the VM Host view),
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the link returns you to that previous view. If you had accessed the VM view directly from
Virtualization Manager, the link returns you to Virtualization Manager. In HP SMH, when
you first access this page from HP SMH, the link is not provided. The link is visible whenever
you move from one VM Manager view to another (such as from VM Host view to VM
Properties view, in which case the Go back to Integrity Virtual Machines Manager: Manage
Host link is visible on the VM Properties view).

2 Displays this window in a format suitable for printing.
3 Updates the data displayed on this page. In general, VM Manager tabbed view screens are

refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change the
related configuration parameters.

4 Lists virtual machine identification, status, and general configuration details. To update
status information, click Refresh Data. If supported by the version of Integrity VM running
on the VM Host, the Graceful Stop Timeout is displayed, as in this screen example. The
timeout value is set by using the hpvmmodify command at the VM Host command line.
This section of the screen includes configuration and status information about online
migration. If the virtual machine has migrated to another VM Host, the Virtual Hardware
Status field displays the icon indicating the virtual machine is Not Runnable ( ), and VM
Manager displays additional fields that indicate the agent or activity that caused the Not
Runnable status and the reason for the status change. If the virtual machine is currently
migrating or waiting to migrate, an icon in the OS Status field indicates the status or direction
of the migration. (You can manage the virtual machine at the target host once the migration
process finishes.) If the virtual machine is migrating to another VM Host, VM Manager
displays an Online Migration Phases section following this section that reports the status of
each phase of the migration. For more information about virtual machine migration and
how to start migration of a virtual machine, see “Migrating virtual machines” (page 100).
If an error occurs during the attempt to migrate a virtual machine, VM Manager displays
an Alerts section that reports the error details.

5 Lists information about virtual CPU. If supported by the version of Integrity VM running
on the VM Host, the minimum and maximum number of virtual CPUs and a cap for the
entitlement is displayed, as in this screen example.

6 Lists information about virtual machine memory. If the guest operating system supports
dynamic memory, the information about dynamic memory parameters is displayed.

7 Lists information about external management tools or software: gWLM or HP Serviceguard.
8 Lists utilization information for the virtual machine. Using VM Manager with Insight

Dynamics - VSE for Integrity, you can click a meter to view a snapshot of Capacity Advisor
historical data for virtual CPUs, memory, disk I/O, or network I/O; this feature is not provided
when using VM Manager from HP SMH.

9 Lists authorization information.

Screen details

VM Configuration Information

• VM Name: The virtual machine name. If the virtual machine is configured as a Serviceguard
package, the package icon ( ) appears next to the virtual machine name. (If the VM is being
managed by another VM Host, the HW field indicates so.)

• VM Network Identity: The host name of the operating system (OS) running on the virtual
machine. The host name is discovered by communicating with the virtual machine, or if the
virtual machine is not active, the host name stored in the virtual machine configuration is
used. The virtual machine must have booted an OS at least once for a host name to be stored
in the virtual machine configuration. If the host name is not known, a question mark (?) is
displayed.
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• VM Host(s): The host name of the VM Host on which this virtual machine is configured.
This is a hyperlink to the VM Host view. If the VM Host is an nPartition, the label “(contained
in nPartition)” is displayed and “nPartition” is a hyperlink to Partition Manager for that
nPartition.
If the virtual machine is managed by HP Serviceguard and is hosted on multiple VM Hosts,
all of the VM Hosts are listed here.

• VM Description: The description of the virtual machine, if the description is available.
• Virtual Hardware Status: This indicates the status of the virtual hardware of a virtual

machine. For a description of the status, position the cursor over the icon.
If the virtual machine has migrated to another VM Host, the hardware status of the virtual
machine is indicated as Not Runnable ( Not Runnable). The VM Configuration Information
section includes two additional lines of information explaining the cause of the Not Runnable
status, as described below.
If the virtual machine is an HP Serviceguard package that is managed by another VM Host,
this field also displays a status icon ( ) that indicates so. Flyover text shows the status of
the hardware (On) and the name of the VM Host currently managing the virtual machine
(Serviceguard guest package).

• Operating System: Indicates the last OS type to be booted on this virtual machine. If the
virtual machine has never been booted, this field contains the value that was supplied when
the virtual machine was created.

• OS Status: Indicates the OS status for a virtual machine, such as Up, Down, Initializing
(indicating that the virtual machine has just been started and is being initialized — the OS
is not yet active), or In EFI (indicating that the virtual machine is in the firmware interface
and an OS has not yet been booted). If the virtual machine is migrating an icon indicates the
direction of migration ( indicates migration to another host; indicates migration from
another host). If the virtual machine is waiting to migrate (when multiple virtual machines
are selected to migrate, only one is migrated at a time), an hourglass icon ( ) indicates so;
to view changes in migration status, click Refresh Data. For a description of the status,
position the cursor over the icon.

• Boot Attribute: Indicates the hardware startup attribute for a virtual machine, which
determines its startup behavior (that is, whether the virtual machine is started automatically
when the virtual machine boots or whether it must be manually started). To use VM Manager
to modify this attribute, click Modify→ Virtual Machine Hardware Auto Start.

• Graceful Stop Timeout: If supported by the version of Integrity VM running on the VM
Host, this specifies the amount of time HP Integrity VM waits for I/O activity to complete
before stopping a virtual machine. The timeout value is set at the VM Host command line
by using the hpvmmodify command.

• Online Migration Enabled: Indicates whether the virtual machine is enabled for online
migration or whether the VM Host is not licensed to support online migration. The VM Host
administrator can enable a virtual machine by using the hpvmmodify command at the VM
Host. The following table shows in the third column what the status field displays, based
on the state of the VM Host and virtual machine listed in the first and second column,
respectively:

Table 4-4 Online migration status

Online migration statusVirtual machine stateVM Host state

Host disabledEnabled or disabledDisabled

Host not licensedEnabled or disabledUnlicensed
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Table 4-4 Online migration status (continued)

Online migration statusVirtual machine stateVM Host state

VM enabledEnabledEnabled and licensed

VM disabledDisabledEnabled and licensed

• Not Runnable Set By: Displayed when the virtual machine has migrated to another VM
Host, indicates the activity or agent that caused the virtual machine hardware status to be
Not Runnable. For example, Migrate indicates the Not Runnable state was initiated by
migration (hpvmmigrate); Admin indicates the VM was marked Not Runnable by the
hpvmmodify command.

• Not Runnable Reason: Displayed when the virtual machine has migrated to another VM
Host, indicates the reason the virtual machine hardware status is Not Runnable. For example,
the guest has migrated to another VM Host.

Online Migration Phases

The VM Properties General tab displays the Online Migration Phases section when online
migration is in progress. An example is shown in Figure 4-21.

NOTE: If you access the VM Properties General tab immediately after initiating a migration,
the Online Migration Phases section might not be displayed. To view this data, click Refresh
Data.

Figure 4-21 Online migration phases

Each of the following fields display the phase's percentage of completion:
• Init Phase: The initialization phase when the source and target VM Hosts establish

connections, perform various checks, starts the target guest, and so forth.
• Copy Phase: Tracks writes to guest memory and copies all of guest memory from the source

to the target VM Host.
• I/O Quiesce Phase: Completes outstanding I/O and queues new I/O requests for the target

guest.
• Frozen Phase: Stops the virtual CPUs and copies modified memory and guest state to the

target guest.

Alerts

The VM Properties General tab displays the Alerts section only when an error occurs during
an attempt to migrate one or more virtual machines to another VM Host. An example is shown
in Figure 4-22.
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Figure 4-22 Migration alerts

• Error: Displays errors pertaining to migration of virtual machines.

You can clear the alerts information by clicking the trash button ( ) on the right. This also

clears the Migration Alerts icon ( ) next to the virtual machine name on the VM Host
Virtual Machines tab.
For more information about migration and how to start the migration of a virtual machine,
see “Migrating virtual machines” (page 100).

VM vCPU Information

• vCPU Count: The number of virtual CPUs in the virtual machine. To use VM Manager to
modify the vCPU count, click Modify→ Virtual Machine vCPU Count.

• Minimum number of vCPUs: If supported by the version of Integrity VM running on the
VM Host, specifies the minimum number of virtual CPUs to be allotted for the virtual
machine. To use VM Manager to modify the minimum count, click Modify→ Virtual Machine
vCPU Count.

• Maximum number of vCPUs: If supported by the version of Integrity VM running on the
VM Host, specifies the maximum number of virtual CPUs to be allotted for the virtual
machine. To use VM Manager to modify the maximum count, click Modify→ Virtual Machine
vCPU Count.

• vCPU Entitlement: Indicates the entitlement associated with each virtual CPU in the virtual
machine. To use VM Manager to modify the vCPU entitlement, click Modify→ Virtual
Machine vCPU Entitlement.

• vCPU Entitlement Cap: If supported by the version of Integrity VM running on the VM
Host, specifies the maximum amount of processing power (expressed either as a percentage
of physical processor power or as a specific processor speed) to be allotted for the virtual
machine. To use VM Manager to modify the cap, click Modify→ Virtual Machine vCPU
Entitlement.

VM Memory Information

To use VM Manager to modify the following parameters, click Modify→ Virtual Machine vCPU
Entitlement.
• Current Dynamic Memory Size: Indicates the current actual memory size for the virtual

machine.
• Current Dynamic Memory Target: The target value to which Integrity VM is trying to set

the memory size for the virtual machine (the Dynamic Memory Size field on the Modify→
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Virtual Machine Memory page). These two values can be different if for some reason Integrity
VM cannot change the memory size to the specified value.

• Memory: The amount of memory configured for the virtual machine, which is the amount
of memory required to start VM (and is modifiable as such on the Modify→ Virtual Machine
Memory page).
If dynamic memory was enabled, the configuration table displays the following fields instead:
— Memory Required to Start VM: The amount of memory needed for the virtual machine

to boot.
— Initial Target for Memory Size After Boot: The value to which Integrity VM tries to

change the virtual machine memory immediately after it boots.
— Minimum Memory Size: The lowest value to which the virtual machine can attempt

to dynamically decrease its memory while the OS is running.
— Maximum Memory Size: The highest value to which the virtual machine can attempt

to dynamically increase its memory while the OS is running.
— VM is Allowed to Control Memory Size: Indicates whether the Allow dynamic control

of memory size from the virtual machine is in effect. This control allows applications
running VM (for example, gWLM) to dynamically change the memory on the virtual
machine.

External Manager Information

• gWLM Policy: If the VM Host is being managed by gWLM and a policy has been assigned
to the virtual machine, the External Manager gWLM field displays the name of the gWLM
policy. If the VM Host is not managed by gWLM or if a policy has not been assigned to the
virtual machine, the gWLM field displays(none). With Insight Dynamics-VSE for Integrity,
if the virtual machine is managed by gWLM, the gWLM policy name is a hyperlink to gWLM.
Under HP SMH, if virtual machines are being managed by gWLM, the gWLM policy name
is text only (you cannot modify gWLM policies from HP SMH). In either case (using VM
Manager with Insight Dynamics or HP SMH), if the virtual machine is not being managed
by gWLM, this field displays (none).

• Serviceguard Package: If the virtual machine is being managed by HP Serviceguard, the
virtual machine package name is listed here. If the virtual machine is not being managed
by HP Serviceguard, this field displays (none).

VM Utilization Information

• VM Utilization Information: Displays resource utilization statistics for a virtual machine.
The utilization information is a 5-minute average that is calculated and updated on 5-minute
boundaries. If the utilization cannot be displayed, the utilization meter (bar graph) is dimmed
and a label indicates the probable cause. For a description of meter labels, see “Utilization
meter status/error information” (page 125). When VM Manager runs with Insight Dynamics
- VSE for Integrity, the utilization meters link to HP Insight Capacity Advisor software,
which records and displays utilization data. Click a meter to view the virtual machine
utilization history for virtual CPUs, memory, disk I/O, or network I/O; this feature is not
provided when using VM Manager from HP SMH. For an example utilization history screen
and more information about collecting and viewing utilization data, see Chapter 7 (page 111).

VM Authorization Information

• Authorized Administrators, Authorized Administrative Groups, Authorized Operators,
Authorized Operator Groups: These fields indicate which users and groups have
administrator or operator authority.
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VM Properties Network tab
The VM Properties Network tab shows the network devices for a specific virtual machine.

Quick reference

Figure 4-23 VM Properties Network tab

?

?

?

Integrity Virtual Machines Manager: Manage VM

Refresh DataView Printer- friendly Last refresh: May 22, 2009 9:56:31 AM MDT

General Network Storage

Tools Create Modify Delete View Policy

Properties for VM rex05 on VM Host rex01.xx.xx.com

Integrity Virtual Machines Manager: Manage HostGo back to

Restore Size

Virtual Network Interfaces Physical Network InterfacesVirtual Switches

AVIO LAN
bus 0, dev 0, fcn 0
      focus (aviosing port 1)

LAN
bus 0, dev 2, fcn 0
      focus (aviosing port 2)

   0/0/6/1/0 1000Base-T LAN
              lan3

focus (Supports AVIO)

   0/0/12/1/0 10/100Base-TX LAN
              lan1

focus

    no avio
            Shared VSwitch
focus

    aviosing
            Shared VSwitch
focus (Supports AVIO)

AVIO LAN
bus 0, dev 4, fcn 0
      focus (aviosing port 3)

0 MB/s

0 MB/sNo Perm.

No Perm.

No Perm.

No Perm.
rex05

?

1

2

3

4

6

5

7

8

1 Goes back to the previous view, in this case the VM Manager VM Host view. When you
access the VM Properties view from another VM Manager view (such as the VM Host view),
the link returns you to that previous view. If you had accessed the VM Properties view
directly from Virtualization Manager, the link returns you to Virtualization Manager. In HP
SMH, when you first access this page from HP SMH, the link is not provided. The link
appears whenever you move from one VM Manager view to another (such as from VM Host
view to VM Properties view, in which case the Go back to Integrity Virtual Machines
Manager: Manage Host link appears on the VM Properties view).

2 Displays this window in a format suitable for printing.
3 Updates the data displayed on this page. In general, VM Manager tabbed view screens are

refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change the
related configuration parameters. However, when changes to the virtual machine I/O
configuration are made using tools other than VM Manager (such as adding or removing
I/O devices by using the VM Host command line), the updated configuration data is not
shown until the screen is refreshed.

4 Displays the type of network interface such as emulated LAN (displayed as “LAN” ) or
Accelerated Virtual Input/Output LAN (displayed as “AVIO LAN,” as in this instance).

5 Allows you to perform an action on the I/O device. Select the box, then select an action from
the appropriate menu available on the VM Manager menu bar.

6 Clicking the Focus link limits the display to only those network devices associated with the
selected object (in this instance, the device associated with port 1) and the objects directly
connected to it. All other devices are not displayed. To return to the original view, click the
Show All link visible beneath the VM Manager menu bar on the focused page.

7 The meter (bar graph) displays network I/O throughput data, if available. The data is a
5-minute average that is calculated and updated on 5-minute boundaries. If the data cannot
be displayed, the meter is dimmed as in this example, and a label indicates the probable
cause. For a description of meter labels, see “Utilization meter status/error information”
(page 125).
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Using VM Manager with Insight Dynamics -VSE for Integrity, you can click a meter to view
a snapshot of Capacity Advisor historical data for network I/O; this feature is not provided
when using VM Manager from HP SMH.
For more information about using VM Manager to collect and view utilization data, see
Chapter 7 (page 111).

8 Indicates by color coding that matching components are related.

Screen details
For more information about using and interpreting the items displayed in the Network tab, see
“Screen details” (page 43).
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VM Properties Storage tab
The VM Properties Storage tab shows state and configuration information for a specific virtual
machine.

Quick reference

Figure 4-24 VM Properties Storage tab
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1 Goes back to the previous view, in this case the VM Host view. If you accessed the VM
Properties view from Virtualization Manager, the link returns you to Virtualization
Manager. In HP SMH, when you first access this page from HP SMH, the link is not
provided. The link appears whenever you move from one VM Manager view to another
(such as from VM Host view to VM Properties view, in which case the Go back to Integrity
Virtual Machines Manager: Manage Host link appears on the VM Properties view).

2 With the Show physical host bus adapters check box selected (as in this example), the
view includes the complete storage bus structure, host bus adapters, and multipath storage
configurations. This view may take longer to render and can be more challenging for
discerning the associations between virtual machines and devices, especially when many
multipath storage devices exist on the VM Host. By default (the check box being
unselected), the view is simpler, showing only the specific storage devices that are being
used as backing devices. For a multipath device, the simple view shows only the device
special file (DSF) path, as specified when the virtual storage device was created. In contrast,
the complex view displays all DSF versions of the same device, including (on an HP-UX
11i v3 VM Host) the persistent DSF.
When you navigate to another VM Manager view and return to this view again, the host
bus adapters check box retains its state. In other words, if the box is checked when you
navigate away from the VM Properties Storage tab, it remains checked when you navigate
back (you continue to see the complex view on return). If the box is unchecked, it remains
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unchecked when you return (you continue to see the simple view). The check box state
on the VM Properties Storage tab does not affect the state of the same check box on the
VM Host Storage tab. For example, selecting the check box on the VM Properties Storage
tab does not automatically affect the check box and view of the VM Host Storage tab.

3 Displays this window in a format suitable for printing.
4 Updates the data displayed on this page. In general, VM Manager tabbed view screens

are refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change
the related configuration parameters. However, when changes to the virtual machine I/O
configuration are made using tools other than VM Manager (such as adding or removing
I/O devices by using the VM Host command line), the updated configuration data is not
shown until the screen is refreshed.

5 The meter (bar graph) displays storage I/O throughput data, if available. The data is a
5-minute average that is calculated and updated on 5-minute boundaries. If the data cannot
be displayed, the meter is dimmed (as in the meter below this one) and a label indicates
the probable cause. For a description of meter labels, see “Utilization meter status/error
information” (page 125).
Using VM Manager with Insight Dynamics - VSE for Integrity, you can click a meter to
view a snapshot of Capacity Advisor historical data for storage I/O; this feature is not
provided when using VM Manager from HP SMH.
For more information about using VM Manager to collect and view utilization data, see
Chapter 7 (page 111).

6 Displays the type of storage device interface and device, such as emulated SCSI DVD
(labeled SCSI DVD) or Accelerated Virtual Input/Output disk (labeled AVIO Disk).

7 Allows you to perform an action on the I/O device. Select the box, then select an action
from the appropriate menu available on the VM Manager menu bar.

8 Clicking the Focus link limits the display to only those storage devices associated with
the selected object (in this instance, the devices associated with the indicated AVIO disk)
and the objects directly connected to it. All other devices are not displayed. To return to
the original view, click the Show All link visible beneath the VM Manager menu bar on
the focused page.
The Show physical host bus adapters check box is disabled (dimmed) in the focussed
view; you cannot change the Show physical host bus adapters state until you return
to the original (unfocussed) view. The simplicity or complexity of the focussed view with
respect to host bus adapters and so forth is determined by the check box selection at the
time that you selected the focus link.

9 Indicates by color coding that matching components are related.
10 This color-coded line links the multiple representations of the storage device, one with its

agile address (/dev/rdisk/disk24) and two with legacy addresses
(/dev/rdisk/c18t0d3 and /dev/rdisk/c17t0d3). The line indicates that they are
different representations of the same physical device. Multiple representations are
displayed only if the Show physical host bus adapters check box is selected.

Screen details
For more information about using and interpreting the items displayed in the Storage tab, see
“Screen details” (page 52).
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Virtual Switch (Vswitch) Properties view
You can access the Vswitch Properties view from any VM Manager views that include a link to
a virtual switch, such as the VM Host Virtual Switches tab, the VM Host Network tab, or the
VM Properties Network tab. You can also access the Vswitch Properties view by selecting View→
Virtual Switch Properties... (a virtual switch must be selected in the current view).
Figure 4-25 shows a typical Vswitch Properties view. Tabs available from the view are described
in the text that follows. Subsequent sections describe each tab in more detail.

Figure 4-25 Vswitch Properties view

1 The “Vswitch Properties General tab” (page 70) displays information about the general
state of the virtual switch.

2 The “Vswitch Properties Network tab” (page 72) displays network details about the virtual
switch.
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Vswitch Properties General tab
The Vswitch Properties General tab shows the status, configuration properties, and port
assignments of a virtual switch.

Quick reference

Figure 4-26 Vswitch Properties General tab

1 Goes back to the previous view, in this case the VM Manager VM Host view. When you
access the Vswitch Properties view from another VM Manager view (such as the VM Host
view), the link returns you to that previous VM Manager view.

2 Displays this window in a format suitable for printing.
3 Displays virtual switch configuration information.
4 Updates the data displayed on this page. In general, VM Manager tabbed view screens are

refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change the
related configuration parameters. However, when changes to the virtual machine I/O
configuration are made using tools other than VM Manager (such as adding or removing
I/O devices by using the VM Host command line), the updated configuration data is not
shown until the screen is refreshed.
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Screen details

Table 4-5 Data displayed by the Vswitch Properties General tab

DescriptionData

Name of the virtual switchVswitch Name

The status of the virtual switch:
• Up (operational)
• Down (inoperational)
• Link down (the physical network interface used by the vswitch is not running)

Status

The type of virtual switch:
• shared vswitch: can be used by more than one virtual machine that includes a virtual network

device (virtual NIC) backed by the switch
• dedicated vswitch: can be used by only one started virtual machine at a time

Type

The LAN interface on the host through which the network traffic flowsBacking LAN

Indicates whether the backing LAN interface supports Accelerated Virtual Input/Output.
AVIO is supported on HP Integrity VM Version 3.5 or later. For each virtual machine containing
an AVIO device, the VM Host OS and the guest OS must support AVIO. For more information
about AVIO requirements, see “Creating virtual switches” (page 105) in this manual. In addition,
see the HP Integrity Virtual Machines Installation, Configuration, and Administration manual.

Supports AVIO

The set of active virtual machines that are configured to use this vswitch, are currently started,
and therefore, are using the vswitch

Actively used by

The set of inactive virtual machines with at least one virtual network interface card in the virtual
machine configured to use the vswitch as a backing device

Configured, but
not actively used
by

If the VM Host is running HP Integrity Virtual Machines Version 2.0 or greater, a table of the
VLAN (virtual LAN) port assignments, if any. (A VLAN defines the logical connectivity defined
by a LAN.) This table lists the following information:

Vswitch Port
Assignments

DescriptionData

Port IDs for the vswitchPort

If a VLAN ID has been specified for this port, it
is displayed here; otherwise, this column
displays (none)

VLAN ID

List of virtual machines that are assigned to this
vswitch port

Assigned to
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Vswitch Properties Network tab
The Vswitch Properties Network tab shows information about the network devices for a specific
virtual switch.

Quick reference

Figure 4-27 Vswitch Properties Network tab
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1 Goes back to the previous view, in this case the VM Properties view. When you access the
Vswitch Properties view from another VM Manager view (such as the VM Properties view),
the link returns you to that previous VM Manager view.

2 Displays this window in a format suitable for printing.
3 Updates the data displayed on this page. In general, VM Manager tabbed view screens are

refreshed automatically at regular intervals, and VM Manager screens that display
configuration data are updated instantaneously when you use VM Manager to change the
related configuration parameters. However, when changes to the virtual machine I/O
configuration are made using tools other than VM Manager (such as adding or removing
I/O devices by using the VM Host command line), the updated configuration data is not
shown until the screen is refreshed.

4 Displays information about the virtual machine.
5 Allows you to perform an action on the virtual machine or I/O device. Select the box, then

select an action from one of the menus available on the VM Manager menu bar.
6 Clicking the Focus link limits the display to only those network devices associated with the

selected object (in this instance, the devices associated with the indicated LAN) and the
objects directly connected to it. All other devices are not displayed. To return to the original
view, click the Show All link visible beneath the VM Manager menu bar on the focused
page.

7 Color coding indicates that matching components are related.
8 The meter (bar graph) displays network I/O throughput data, if available. The throughput

data is a 5-minute average that is calculated and updated on 5-minute boundaries. If the
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data cannot be displayed, the meter is dimmed and a label indicates the probable cause. For
a description of meter labels, see “Utilization meter status/error information” (page 125).
Using VM Manager with Insight Dynamics -VSE for Integrity, you can click a meter to view
a snapshot of Capacity Advisor historical data for network I/O; this feature is not provided
when using VM Manager from HP SMH.
For more information about using VM Manager to collect and view utilization data, see
Chapter 7 (page 111).

Screen details
For detailed information about the what is displayed in the Vswitch Properties Network tab,
see the description of the VM Host Network tab, “Screen details” (page 43).
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5 Using VM Manager menus
VM Manager views provide a menu bar beneath the tabs row, as shown in Figure 5-1. The menus
enable you to perform a variety of actions. Not all actions (menu options) are available from
every screen view. Actions are enabled or disabled based on the state of the system, the view
you are in, and the objects in that view that are currently selected. Actions that are disabled are
dimmed and unselectable. To display text that explains how to enable a disabled action, place
the cursor over the visible but dimmed, menu item.

Figure 5-1 VM Manager menus

The menus are described in each of the following sections:
• “Using the Tools menu” (page 76)
• “Using the Create menu” (page 78)
• “Using the Modify menu” (page 79)
• “Using the Delete menu” (page 81)
• “Using the View menu” (page 82)
• “Using the Policy menu” (page 84)
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Using the Tools menu
The VM Manager Tools menu allows you to perform actions on a selected virtual machine or
virtual switch, and to collect and view HP Insight Capacity Advisor software data. The options
that might be available when you select the Tools menu are shown in Figure 5-2. In this example,
the Start Virtual Switch... and Stop Virtual Switch... options are disabled. These options are
enabled when you are in the Vswitch Properties view or a view with one or more virtual switches
selected, such as the VM Host Virtual Switches tab. The virtual machine operations (start, stop,
restart, migrate) are enabled when you are in a VM Properties view or in a view that allows
selection of virtual machines, such as the VM Host Virtual Machines tab. From tabs that list and
allow selection of multiple virtual machines or multiple virtual switches, you can perform an
action on multiple selected machines or switches.

NOTE: The Tools→Collect Capacity Advisor Data... and Tools→Capacity Advisor Data
Historical report... items are displayed only when you use VM Manager with Insight Dynamics
- VSE for Integrity; they are not displayed when using VM Manager through HP SMH.

Figure 5-2 VM Manager Tools menu

Table 5-1 describes the Tools menu options and where to obtain more information in this manual.
More detailed information is provided by the VM Manager help.

Table 5-1 VM Manager Tools menu options

More InformationAction SummaryMenu Selection

“Starting virtual machines” (page 94)Starts the virtual hardware for a
virtual machine, taking it from an Off
state (powered off) to an On state
(powered on).

Tools→Start Virtual Machine...

“Stopping virtual machines” (page 96)Stops a virtual machine, taking it
from an On state (powered on) to an
Off state (powered off).

Tools→Stop Virtual Machine...
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Table 5-1 VM Manager Tools menu options (continued)

More InformationAction SummaryMenu Selection

“Restarting virtual machines”
(page 98)

Restarts an already started virtual
machine, taking it first to an Off state
(powered off) and then to an On state
(powered on). Starts a stopped virtual
machine.

Tools→Restart Virtual Machine...

“Starting, stopping, and deleting
virtual switches” (page 108)

Starts a virtual switch, taking it from
a Down state (powered off) to an Up
state (powered on).

Tools→Start Virtual Switch...

“Starting, stopping, and deleting
virtual switches” (page 108)

Stops a virtual switch, taking it from
an Up state (powered on) to a Down
state (powered off).

Tools→Stop Virtual Switch...

“Migrating virtual machines”
(page 100)

Starts the Migrate Virtual Machine
wizard, which guides you through a
two-step procedure for migrating a
virtual machine to another VM Host.

Tools→Migrate Virtual Machine...

“Collecting and viewing utilization
data” (page 111)
HP Insight Capacity Advisor 6.2 User
Guide

Causes Capacity Advisor to collect
utilization data from specified targets.
This menu item is displayed only
when you use VM Manager with
Insight Dynamics; it is not displayed
when using VM Manager through HP
SMH.

Tools→Collect Capacity Advisor
Data...

“Collecting and viewing utilization
data” (page 111)
HP Insight Capacity Advisor 6.2 User
Guide

Creates a historical report from the
target workloads, systems, complexes
or scenarios of your choosing. This
menu item is displayed only when
you use VM Manager with Insight
Dynamics; it is not displayed when
using VM Manager through HP SMH.
Before creating a report, you must
have collected data of interest (you
can use the Tools→Collect Capacity
Advisor Data... menu item to collect
data).

Tools→Capacity Advisor Data
Historical Report...
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Using the Create menu
The Create menu allows you to create a virtual machine or virtual switch. Figure 5-3 shows the
choices when you select the Create menu.

Figure 5-3 VM Manager Create menu

Table 5-2 describes the Create menu options and where to obtain more information in this
manual. More detailed information is provided by the VM Manager help.

Table 5-2 VM Manager Create menu options

More InformationAction SummaryMenu Selection

“Creating virtual machines” (page 87)Starts the Create Virtual Machine
wizard, which guides you through
the procedure of creating a virtual
machine. Each step presents a dialog
that asks you to specify required
information.

Create→Virtual Machine...

“Creating virtual switches” (page 105)Creates a new virtual network switch
(vswitch) on the host. The vswitch is
used by the virtual machines to
connect to the network: one or more
virtual machines connect to the
vswitch, and the vswitch is connected
to a host's physical network device.

Create→Virtual Switch...
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Using the Modify menu
The VM Manager Modify menu allows you to perform actions on a selected virtual machine.
The options displayed when you select the Modify menu using VM Manager from Insight
Dynamics are shown in Figure 5-4. The options are available only when you are in a VM Properties
view or in a view in which you have selected a virtual machine, such as on the VM Host Virtual
Machines tab. You can only modify one virtual machine at a time.
If the virtual machine being modified is an HP Serviceguard package, you must make the same
modifications to the virtual machine on the other VM Hosts in the cluster.

NOTE: When you use VM Manager from HP SMH, this menu includes an additional option
that allows you to modify WBEM credentials. This option can be available from any VM Manager
view.

Figure 5-4 VM Manager Modify menu

Table 5-3 describes the Modify menu options. More information about the various modification
options is provided in “Modifying virtual machines” (page 92). More detailed information is
provided by the VM Manager help and theHP Integrity VirtualMachines Installation, Configuration,
and Administration manual.

Table 5-3 VM Manager Modify menu options

Action SummaryMenu Selection

Modifies the processor entitlement of a selected virtual
machine.

Modify→Virtual Machine vCPU Entitlement...

Modifies the amount of virtual memory (entitlement) to
allocate to the virtual machine. Allows you to set dynamic
memory parameters if dynamic memory is supported on
the virtual machine's OS. The changes take effect when
the virtual machine is restarted.

Modify→Virtual Machine Memory...

Modifies the number of virtual CPUs allotted to a virtual
machine that has been configured for symmetric
multiprocessing. The changed value takes effect when
the virtual machine is restarted.

Modify→Virtual Machine CPU Count...

Modifies the VLAN assignments of virtual switch ports
connected to the virtual machine.

Modify→Virtual Machine VLAN Settings...
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Table 5-3 VM Manager Modify menu options (continued)

Action SummaryMenu Selection

Modifies the startup attribute (autoboot) of a selected
virtual machine. You can allow the virtual machine to be
started automatically when the VM Host is started, or
you can set the attribute so that you can start the virtual
machine manually.

Modify→Virtual Machine Hardware Auto Start...

Adds a virtual storage device to a virtual machine, where
the virtual storage device is backed by physical storage
and connected to a virtual storage adapter on the VM
Host.

Modify→Add Storage Device to Virtual Machine...

Adds a network device to a virtual machine, where the
network device is associated with a virtual switch. Allows
you to create a new virtual switch.

Modify→Add Network Device to Virtual Machine...

Sets and changes WBEM credentials for virtual machines.
For information, see “Setting WBEM credentials in HP
SMH” (page 16). This menu option is available only when
using VM Manager with HP SMH.

Modify→WBEM Credentials...

HP Confidential80 Using VM Manager menus



Using the Delete menu
The Delete menu allows you to delete one or more virtual machines, virtual switches, or virtual
machine I/O devices. Figure 5-5 shows the choices that might be available when you select the
Delete menu. The choices are enabled according to the view and tab. In Figure 5-5, the Virtual
Machine... option is enabled and the Virtual Switch... and I/O Device... options are disabled.
The Virtual Machine... option is enabled at the VM Properties view or any VM Host or Vswitch
Properties tab where you have selected one or more virtual machines (such as the VM Host
Virtual Machines tab, as shown in Figure 5-5). The Virtual Switch... option is enabled at the
Vswitch Properties view or any VM Host or VM Properties tab where one or more virtual switches
are selected. The I/O Device... option is enabled at any Network or Storage tab where one or
more I/O devices are selected.
From tabs that list and allow selection of multiple virtual machines, virtual switches, or I/O
devices, you can simultaneously delete all selected objects.

Figure 5-5 VM Manager Delete menu

Table 5-4 describes the Delete menu options and where to obtain more information in this manual.
More detailed information is provided by the VM Manager help.

Table 5-4 VM Manager Delete menu options

More InformationAction SummaryMenu Selection

“Deleting virtual machines” (page 99)Deletes all configuration files for the
virtual machine and frees resources
assigned to the virtual machine.

Delete→Virtual Machine...

“Starting, stopping, and deleting
virtual switches” (page 108)

Removes all configuration
information for a virtual switch.

Delete→Virtual Switch...

“Deleting network or storage Devices”
(page 108)

Removes all configuration
information for an I/O device.

Delete→I/O Device...
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Using the View menu
The View menu allows you to display a variety of information. Figure 5-6 shows the choices that
might be available when you select the View menu.

NOTE: The Capacity Advisor Data item is displayed only when you use VM Manager with
Insight Dynamics - VSE for Integrity; it is not displayed when using VM Manager through HP
SMH. The accessibility of the other menu items depends on the current view and selections. For
example, to access the virtual machine log from the VM Host Virtual Machines tab, a virtual
machine must be selected, as shown in Figure 5-6.

Figure 5-6 VM Manager View menu

Table 5-5 describes the View menu options. More detailed information is provided by the VM
Manager help.

Table 5-5 VM Manager View menu options

Action SummaryMenu Selection

Displays the VM Properties General tab. For more
information about this view, see “Virtual Machines (VM)
Properties view” (page 58).

View→Virtual Machine Properties...

Displays the Vswitch Properties General tab. For more
information about this view, see “Virtual Switch
(Vswitch) Properties view” (page 69).

View→Virtual Switch Properties...

Displays the version numbers of VM Manager, Integrity
VM, and the providers on the VM Host and each virtual
machine. For more information, see “Viewing VM
Manager, Integrity VM, and WBEM Provider versions”
(page 119).

View→VM Manager Version Information...

Displays the events logged by Integrity VM pertaining to
the VM Host and all its guests. To use this feature with
VM Manager running under HP SMH, you must be
logged into HP SMH with either Operator or
Administrator privileges. For more information, see
“Viewing Integrity VM Host and VM logs” (page 119).

View→Integrity VM log for VM Host...
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Table 5-5 VM Manager View menu options (continued)

Action SummaryMenu Selection

Displays the events logged by Integrity VM pertaining to
a virtual machine. To use this feature with VM Manager
running under HP SMH, you must be logged into HP
SMH with either Operator or Administrator privileges.For
more information, see “Viewing Integrity VM Host and
VM logs” (page 119).

View→Integrity VM log for VM...

Only available when using VM Manager with Insight
Dynamics, displays data collected from systems licensed
for the Capacity Advisor. You can view data collected for
the VM Host or for one or more virtual machines. For
more information, see the HP Insight Capacity Advisor 6.2
User Guide.

View→Capacity Advisor Data...
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Using the Policy menu
The Policy menu allows you to perform a variety of tasks pertaining to the gWLM policy. Using
VM Manager with Insight Dynamics - VSE for Integrity, VM Manager can be integrated with
gWLM. When gWLM is managing specific virtual machines, the virtual machines have assigned
policies and are placed in a shared resource domain (SRD). If any virtual machines are managed
on a VM Host, then only that set of virtual machines can be started on that VM Host; no other
virtual machines can be started on that VM Host without first using gWLM to add them to the
SRD.

NOTE: The Policy menu is not available when using VM Manager with HP SMH.

Figure 5-7 shows the options that might be available in the VM Manager Policy menu. If no
policy is established, the Change Associated gWLM Policy... and Remove Associated gWLM
Policy... options are disabled.

Figure 5-7 VM Manager Policy menu

Table 5-6 describes the Policy menu options. For more information about gWLM policies, see
the HP Insight Global Workload Manager 6.2 User Guide. More detailed information is provided by
the VM Manager help.

Table 5-6 VM Manager Policy menu options

Action SummaryMenu Selection

Associates a gWLM policy with a virtual machine and
adds it to an SRD. This menu option is available when
you are in VM Properties view or in another view in
which one or more virtual machines are selected. Use this
option to start using gWLM for scheduling virtual
machine resources.

Policy→Apply gWLM Policy...

Changes the policy of a virtual machine that is already
managed by gWLM. This menu option is available when
you are in VM Properties view or in another view in
which one or more virtual machines are selected.

Policy→Change Associated gWLM Policy...

Displays a page that lists all the gWLM policies that are
currently defined and allows you to create, edit, or delete
them.

Policy→Edit gWLM Policies...
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Table 5-6 VM Manager Policy menu options (continued)

Action SummaryMenu Selection

Removes the policy association from the virtual machine,
effectively removing the virtual machine from the SRD.
The selected virtual machine must be powered off before
it can be removed from the SRD. This menu option is
available when you are in VM Properties view or in
another view in which one or more virtual machines are
selected.

Policy→Remove Associated gWLM Policy...

Creates a new gWLM policy. You do not need to select a
virtual machine to create a gWLM policy. The new policy
can subsequently be applied to a new virtual machine.

Policy→Create gWLM Policy...
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6Working with virtual machines
This chapter describes tasks you can perform to create and manage virtual machines and their
resources.

Planning virtual machines
To achieve your goals using virtual machines, plan the configuration of each virtual machine by
assessing its requirements for resources on the HP Integrity system on which it will run. For
information about how to assess your system's resources as well as the virtual machines you
will run on the system, and how to map your virtual machine requirements to the system's
resources, see the HP Integrity Virtual Machines Installation, Configuration, and Administration
manual, located on the HP Technical Documentation website (click on theHP Insight Dynamics
- VSE for Integrity tab):
http://www.hp.com/go/insightdynamics/docs
For information about AVIO performance tuning, see the latest Integrity VM white papers
available from this website.

Creating virtual machines
To create a virtual machine, VM Manager uses the Create Virtual Machine wizard to guide you
through the process. Each step presents a dialog that allows you to specify the required
information. At any time you can get help, return to previous steps, or exit the wizard. By creating
a new virtual machine, you assign attributes and resources to it. This creates an association among
the virtual devices known to the virtual machine and the physical devices managed by the VM
Host.
Where possible, reasonable default values are provided for each dialog. However, the default
values are not necessarily optimal. You must determine what values are optimal based on the
unique requirements of your machine (such as the applications you plan to run and the
performance you expect).
To access the Create Virtual Machine wizard, select Create→Virtual Machine... from the VM
Manager menu bar. The Create Virtual Machine wizard leads you through several screens in the
following order. For more information about any screen, see the corresponding VM Manager
help topic.
1. Specify VM Identity

Specify the virtual machine name, an optional description, the intended guest operating
system, and the virtual machine hardware startup value (autoboot).

2. Specify Processor Entitlements
The processor entitlement sets the guaranteed amount of processing power for each virtual
CPU in a virtual machine. The processor entitlement is the default entitlement (10%), a
percentage of physical processor power, or a specific, fixed processor speed. If supported
by the version of Integrity VM running on the VM Host, you can specify an entitlement cap
and the minimum and maximum number of vCPUs to be allotted to the virtual machine.
An entitlement cap is the maximum amount of computing power allotted to a virtual machine
for each vCPU.

3. Specify Memory
Specify the amount of memory for the virtual machine. If the VM Host has Integrity VM 3.0
or later installed and the OS type you chose in step 1 supports dynamic memory (for example,
specifying HP-UX as the intended guest OS, with Integrity VM 3.0 or later installed on the
VM Host), the memory screen allows you to set dynamic memory parameters.
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NOTE: An up-to-date version of the WBEM Utilization Provider (UP) must be installed
on the virtual machine to enable HP Insight Capacity Advisor software and the memory
utilization meters in VM Manager and Integrity VM to reflect the dynamic change in memory.
For information about verifying and installing software on virtual machines, see “System
and software requirements” (page 13) and the HP Integrity Virtual Machines documentation.

4. Specify Network Devices
To add a virtual network device, click Add Network Device... on the first network device
screen. This brings up the Add Network Device screen. First, select the type of virtual
network interface card. The default is an emulated LAN device. You can select Accelerated
Virtual Input/Output (AVIO) device type if AVIO is supported by the version of Integrity
VM (Version 3.5 or later) on the VM Host and by the intended guest OS. For Windows and
Linux guests, support for AVIO virtual network devices requires that compatible Windows
and Linux drivers be installed on the guest and additional patches be installed on the Integrity
VM Version 3.5 or later. The OpenVMS guest OS supports only the AVIO interface.
For HP-UX, HP recommends that you install the latest AVIO components for both the VM
Host and the guest; however, updating both guest and host components at the same time
is not mandatory. Updating both components ensures that you always receive the latest bug
fixes for a complete solution. Always check the following software depot website for the
latest version of AVIO software (search for “HPVM AVIO”):
http://software.hp.com
The guest AVIO drivers are included in the VMGuestSW bundle available from the software
depot website. Search for the bundle and make sure you install the latest version.
For more information, see the HP Integrity Virtual Machines documentation.
After you select the virtual network interface type, select the virtual switch from the list
provided or create a virtual switch. To provide network access for the virtual machine, a
virtual switch is necessary.

NOTE: VM Manager does not automatically update its display of I/O while the Create
Virtual Machine wizard is being used. If the network or storage I/O configuration on the
VM Host changes while the Create Virtual Machine wizard is in use, update the configuration
changes displayed by the wizard by clicking the Refresh Data link.

5. Each virtual storage device is backed by physical storage in the VM Host system. A physical
storage device can be a disk device, a logical volume, a DVD or CD, a DVD writer (burner),
a tape device, a tape changer, an existing file (a file or directory being used as the backing
storage device for a virtual storage device of an already-existing virtual machine on the VM
Host), or a new file that VM Manager allows you to create as a backing storage device for
a virtual disk (Virtual FileDisk). When you add a DVD writer, tape device, or changer, they
are added as attached devices.You can add attached devices only if they are using an
emulated SCSI adapter. You cannot use VM Manager to add an attached AVIO device; to
add such a device to a virtual machine, use the hpvmdevmgmt command at the Integrity
Virtual Machines host.To add a virtual storage device, click Add Storage Device... on the
first storage device screen. This brings up the Add Storage Device screen. First, select the
type of virtual storage adapter. The default is an emulated SCSI adapter. You can select
Accelerated Virtual Input/Output (AVIO) adapter type if AVIO is supported by the version
of Integrity VM (Version 3.5 or later) on the VM Host and by the intended guest OS (HP-UX
11i v3 only).
If the VM Host is running HP-UX 11i v3, the Add Storage Device screen gives you the
choice of listing storage devices by their agile address (the default) or by their legacy address.
HP recommends using agile device addressing when configuring storage devices. This
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provides benefits especially for multipath devices. With legacy addressing, the screen lists
one entry for each path to a storage device that has multiple paths. With agile addressing,
the screen lists only one entry for each multipath storage device. To change the addressing
scheme for viewing, select the appropriate addressing scheme. If the VM Host runs an earlier
version of HP-UX, you are not given a choice: the table lists devices by the legacy addressing
scheme only. For more information about agile addressing, see the VM Host Storage tab
help topic.
For more information on AVIO devices and on agile addressing, see the HP Integrity Virtual
Machines documentation.
After you select the virtual storage adapter type, select the physical backing device from the
list of devices provided in the device selection table (such as disk, DVD, tape, LVM volume,
files).
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NOTE: The list can include file and directory backing devices that have not been associated
with a particular virtual machine, or that were associated with virtual machines that have
been removed or from which the associated virtual devices have been removed. You can
make these devices available to VM Manager by adding them to the Integrity VM device
database. One advantage is that this allows you to populate the Integrity VM device database
with entries for OS installation DVD images that might be used when creating and
provisioning several virtual machines. When you use VM Manager to add a virtual DVD
to a virtual machine, the image file shows up in the list of storage backing devices to choose
from, saving you from having to type the name of the image file or to browse for it.
At the VM Host command line, add a file as a guest device (gdev) to the device management
database by specifying the hpvmdevmgmt command with the USAGE attribute value as either
USAGE=DISK or USAGE=DVD. As a result, the VM Manager screen includes the file in the
list of backing devices you can choose from. The file is listed as a backing device for either
a virtual disk or a virtual DVD, depending on the value of the USAGE attribute. For example,
if you add file/images/myos.iso to the device management database, specifying attribute
USAGE=DVD, then /images/myos.iso will appear in the VM Manager list of backing
devices as a possible backing device for a virtual DVD. If you add a file to the database
without specifying the USAGE attribute, the file is not included in the list of possible backing
devices.
If you add a directory to the database, it is included in the list as a possible backing device
for a virtual DVD. Do not specify the USAGE attribute for a directory; the attribute is not
needed for a directory.
To ensure that a device database entry is preserved in the VM Host device management
database for future selection, even when the associated virtual device is removed from the
virtual machine, or even when all virtual machines using the entry as a backing device are
deleted from the VM Host, you can enter the hpvmdevmgmt command with the PRESERVE
attribute specified as PRESERVE=YES.
When you use the hpvmdevmgmt command to create a file as a backing device for a disk,
specify the size (-S) and -A attributes to ensure that the file is included in the list of possible
backing devices. Specifying these two attributes automatically sets USAGE=DISK and
PRESERVE=YES.
When you use VM Manager to create a file as a backing device for a disk, the PRESERVE
attribute is set as PRESERVE=YES.

NOTE: If you use VM Manager to manage a VM Host running Integrity VM Version 3.5
or earlier, VM Manager does not fully support virtual device special files located in /hpap
(introduced in HP StorageWorks Secure Path software Version 3.0F SP2) as backing devices
for virtual storage. When you use VM Manager to add a storage device on a virtual machine,
VM Manager does not display device files in /hpap as possible backing devices to choose
from.
To add a virtual storage device that uses a virtual device special file in /hpap to a new
virtual machine on a VM Host running Integrity VM Version 3.5 or earlier, use the Integrity
VM hpvmcreate command. For more information about these commands, see the HP
Integrity Virtual Machines Installation, Configuration, and Administration manual.

6. Summary
Review the identity and resources specified for the new virtual machine and preview the
command that will be used to create it. This summary step allows you to review all
information before the new virtual machine is created.
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At this step, you can still cancel (exit the Create Virtual Machine wizard) or return to modify
previous steps in the wizard. When you click Finish, the wizard executes the hpvmcreate
commands displayed in the Command Preview area:
• If the Create VM even if resources are insufficient, missing or unavailable check

box is not selected, the wizard executes the first of two commands (hpvmcreate -s)
to check for resource availability and other issues without actually creating the virtual
machine. This command reports any errors or warnings at the top of the page. If
warnings or errors are detected, the virtual machine will not be created. Upon analyzing
any reported warnings, you can choose to create the virtual machine anyway by selecting
the check box and clicking Finish again.
If no serious problems are detected by the first command, the wizard then executes the
second command (hpvmcreate -F), which creates the virtual machine.

• If the Create VM even if resources are insufficient, missing or unavailable check
box is selected, the wizard does not check for resource warnings. It simply runs the
hpvmcreate -F to create the virtual machine even if potential resource issues exist
(but not if a fatal error is detected). For example, if this check box is selected, you can
create a virtual machine that uses a physical disk that some other running virtual
machine is already using. As another example, you can create a virtual machine for
which you incorrectly specified a storage device file. You can correct these kinds of
problems after the virtual machine is created and before it is started. For information
about problem solving, see “Troubleshooting virtual machine problems” (page 126).

7. Specify VLAN IDs
If the VM Host supports vswitch VLANs (virtual LANs), and virtual NICs (vNICs) are
specified for the new virtual machine, then you can assign VLAN IDs to the newly created
virtual machine. You can assign a VLAN ID to the vswitch port connected to each virtual
NIC in the virtual machine. By default, VLANs are not specified (VLAN ID is “none”). When
you click OK on this page, any modifications to the VLAN IDs are updated, after which the
Create Virtual Machine wizard Next Steps page is displayed.

8. Next Steps
After creating the new virtual machine, VM Manager presents you with the next steps you
can take to manage and use the new virtual machine. The steps presented depend on the
environment in which you created the virtual machine. For example, when virtual machine
scheduling on a VM Host is managed by HP Insight Global Workload Manager software
for Integrity (gWLM), the Next Steps page advises you to associate the virtual machine
with a gWLM policy and add the virtual machine to a Shared Resource Domain (SRD). You
cannot start the virtual machine until you complete that action.
If the new virtual machine includes AVIO devices (AVIO support is provided on HP Integrity
VM Version 3.5 or later), you are advised to make sure the appropriate OS that supports
AVIO is installed on the VM Host and the virtual machine. If the intended OS on the virtual
machine does not support AVIO, you are warned of this. In addition, HP strongly
recommends that AVIO components (such as drivers and libraries) on the virtual machine
and VM Host be updated to the latest release of the OS. If the virtual machine OS is Windows
or Linux, install additional AVIO-compatible drivers on the VM Host and virtual machine;
the Windows and Linux AVIO drivers include instructions for installing the drivers on
virtual machines. For more information about AVIO requirements, see the HP Integrity
Virtual Machines Installation, Configuration, and Administration manual.
Other steps you can take include starting the virtual hardware for the virtual machine,
accessing the virtual machine console, adding additional software (provider components)
needed to support management of the virtual machine, getting information about the virtual
machine, and tuning the performance of the virtual machine.
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NOTE: Any devices added using the Create Virtual Machine wizard are not functional on
the virtual machine until the new virtual machine is started. Certain devices are not seen in
a VM Manager Storage tab until the virtual machine is started.

You can configure the virtual machine's Extensible Firmware Interface (EFI) to boot the
guest OS automatically when the virtual machine is started (powered on). Configure EFI
when the virtual machine has been started and before booting the OS. You can interact with
EFI through the virtual Management Processor (vMP) for the virtual machine. The vMP
provides access to the console for the virtual machine. To interact with vMP, use the
hpvmconsole command. For more information, see the HP Integrity Virtual Machines
Installation, Configuration, and Administration manual.
If you are using VM Manager from HP SMH, click OK to finish. VM Manager displays the
page from which you initiated the Create Virtual Machine wizard.
If you are using VM Manager from Insight Dynamics, click Apply gWLM Policy. To skip
this step and add the new virtual machine to the SRD later, click Apply Later (you must
click either button). When you click Apply Later, VM Manager displays the page from which
you initiated the Create Virtual Machine wizard. When you are ready to add the virtual
machine to the SRD, select the virtual machine from the appropriate screen (for example,
from the VM Host Virtual Machines tab) and then select Policy →Apply gWLM Policy ...
from the VM Manager menu bar. For more information, see the VM Manager Policy Menu
help topic.

NOTE: After creating a virtual machine using VM Manager, if you return immediately to
Virtualization Manager, the machine might not yet appear in Virtualization Manager. This
means HP SIM/Insight Dynamics has not yet completed identifying the new virtual machine.
However, it appears when the identification process completes (usually within a minute or
two).

Modifying virtual machines
To modify a virtual machine, select one of the following items from the VM Manager Modify
menu. For more information about any item, see the corresponding VM Manager help topic.

NOTE: You cannot modify a virtual machine that is currently migrating online. You must wait
until migration completes. You cannot modify a virtual machine that has migrated to another
VM Host (the target): the virtual machine (on the source VM Host) is in the Not Runnable state.

• Virtual Machine vCPU Entitlement to modify the processor entitlement of a selected virtual
machine. If supported by the version of Integrity VM running on the VM Host, you can
modify the entitlement cap. An entitlement cap is the maximum amount of computing power
allotted to a virtual machine for each vCPU.
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NOTE: If the virtual machine is being managed by gWLM, you cannot modify the vCPU
entitlement. When you access the Virtual Machine vCPU Entitlement page, the following
error message is displayed, where virtual-machine-name is the name of the virtual
machine:
The processor entitlement for VM virtual-machine-name cannot be
modified because it is being managed by gWLM. To adjust the processor
entitlement for this VM, use gWLM to change the policy associated
with this VM.

To create or modify the gWLM policy for this virtual machine, use the Policy menu (available
when using VM Manager with Insight Dynamics - VSE for Integrity).

• Virtual Machine Memory to modify the amount of memory for a selected virtual machine.
If the VM Host has Integrity VM 3.0 or later installed and the OS type for the VM supports
dynamic memory, the dynamic memory parameters are shown, and you can modify them.
Changes to memory take effect when the virtual machine is restarted.

NOTE: An up-to-date version of the WBEM Utilization Provider (UP) must be installed
on the virtual machine to enable HP Insight Capacity Advisor software and the memory
utilization meters in VM Manager and Integrity VM to reflect the dynamic change in memory.
For information about verifying and installing software on virtual machines, see “System
and software requirements” (page 13) and the HP Integrity Virtual Machines documentation.

• Virtual Machine vCPU Count to modify the number of virtual CPUs for a selected virtual
machine. If supported by the version of Integrity VM running on the VM Host, you can
modify the minimum and maximum number of vCPUs to be allotted to the virtual machine.
Changes take effect when the virtual machine is restarted.

• Virtual Machine VLAN Settings to modify the VLAN associated with the virtual machine.
• Virtual Machine Hardware Auto Start to specify whether the virtual machine should start

automatically when Integrity VM is started or whether the virtual machine will be started
manually.

• WBEM Credentials to set and change WBEM credentials for virtual machines.
• Add Storage Devices to Virtual Machine to add storage devices for virtual machines.
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NOTE: The list of possible backing devices for the storage device you want to add can
include file and directory backing devices that have not been associated with a particular
virtual machine, or that were associated with virtual machines that have been removed or
from which the associated virtual devices have been removed.
You can create a file as a backing storage device for a virtual disk. You can add DVD burners,
tape devices, and changers if they are emulated SCSI adapters; they are added as attached
devices. You cannot use VM Manager to add an attached AVIO device; to add such a device
to a virtual machine, use the hpvmdevmgmt command at the Integrity Virtual Machines
host. For more information, see the Modify→Add Storage Device to Virtual Machine...
help topic.

NOTE: If you use VM Manager to manage a VM Host running Integrity VM Version 3.5
or earlier, VM Manager does not fully support virtual device special files located in /hpap
(introduced in HP StorageWorks Secure Path software Version 3.0F SP2) as backing devices
for virtual storage. When you use VM Manager to add a storage device on a virtual machine,
VM Manager does not display device files in /hpap as possible backing devices to choose
from. If a virtual storage device using an /hpap device special file already exists on a virtual
machine managed by VM Manager, VM Manager displays it on the VM Host Storage and
VM Properties Storage tabs as an unknown device (using the question mark icon, ). VM
Manager displays the correct device special file name (for example, /hpap/rdsk/hpap1)
but the box representing this device is not connected to the boxes that represent the physical
storage devices associated with that virtual device special file. In general, VM Manager
correctly displays only those device special files located in /dev.
To add a virtual storage device that uses a virtual device special file in /hpap to an existing
virtual machine on a VM Host running Integrity VM Version 3.5 or earlier, use the Integrity
VM hpvmmodify command. For more information about these commands, see the HP
Integrity Virtual Machines Installation, Configuration, and Administration manual.

• Add Network Device to Virtual Machine to add network devices and vswitches for virtual
machines.

NOTE: Any network or storage devices that you add are not functional on the virtual machine
until the virtual machine is started or restarted. When you add an I/O device to a started virtual
machine, it might not appear on the Network or Storage tab until the virtual machine is stopped
or restarted. If you add an I/O device to a stopped virtual machine, the tab displays the device
immediately.

NOTE: If the virtual machine being modified is an HP Serviceguard package, you must make
the same modifications to the virtual machine on the other VM Hosts in the cluster.

Starting virtual machines
Starting a virtual machine starts the virtual hardware for the virtual machine. The virtual machine
enters an On state (powered on).
The Start and Restart functions are similar except the Start function does not stop and restart a
virtual machine that is already started (it leaves the started machine as is), while the Restart
function does. Use Restart instead of Start when you have several virtual machines that you want
newly started, some which are already started and some currently stopped. The Restart function
takes care of all the virtual machines (in contrast, the Start function does not restart the already
started machines). If you do not want the already started machines stopped and restarted (you
just want the stopped machines started), use the Start function instead. For information about
restarting virtual machines, see “Restarting virtual machines” (page 98).
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NOTE: You cannot start a virtual machine that is currently migrating online. You must wait
until migration completes. If the selected virtual machine has migrated to another VM Host (the
target), the virtual machine (on the source VM Host) is in the Not Runnable state: you cannot
start a virtual machine in this state.

To start one or more selected virtual machines, perform the following steps.
1. From the VM Host General tab, select the VM Host Virtual Machines tab (or any tab that

allows you to select one or more virtual machines).
2. Select one or more virtual machines to start by clicking the appropriate check boxes.

Alternatively, you can access the VM Properties view, in which case no selection is necessary;
the virtual machine being viewed is implicitly selected.

3. Select Tools→Start Virtual Machine... from the VM Manager menu bar. A page similar to
that shown in Figure 6-1 is displayed.

Figure 6-1 Start Virtual Machine page

4. In the example shown in Figure 6-1, two virtual machines will be started. A note near the
bottom of the screen indicates that two of the selected virtual machines are already started.
The Command Preview area shows the commands that Integrity VM will perform to start
the virtual machine.
Click OK to start the virtual machine.

When a virtual machine is started, it is in the On state (powered on). You can then perform the
functions you want.
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NOTE: Depending on the settings in the virtual machine's Extensible Firmware Interface (EFI),
starting a virtual machine might not boot the operating system. For more information, see
“Creating virtual machines” (page 87).

Once a virtual machine is started, the resources assigned to the virtual machine are allocated for
its use. The VM Host ensures that the resources required by the virtual machine are available in
the current VM Host system environment. If the virtual machine cannot be started, VM Manager
displays messages indicating which resources cannot currently be provided.
For information about possible reasons that a virtual machine might not start, see
“Troubleshooting virtual machine problems” (page 126).

Stopping virtual machines
To stop one or more virtual machines, perform the following steps. This action allows you to
stop the virtual hardware for a virtual machine. When stopped, a virtual machine enters an Off
state (powered off) and the virtual machine is halted. Once a virtual machine is stopped, the
resources assigned to it no longer are allocated and are now available for use by other virtual
machines.

NOTE: If the OS is running on a virtual machine that you want stopped, HP recommends that
you shut down the OS before stopping the virtual machine. This ensures that all applications
are shut down cleanly.
You cannot stop a virtual machine that is currently migrating online. You must wait until
migration completes. If the selected virtual machine has migrated to another VM Host (the target),
the virtual machine (on the source VM Host) is in the Not Runnable state: attempts to stop the
virtual machine will fail.

1. From the VM Host view, select the VM Host Virtual Machines tab (or any tab that allows
you to select one or more virtual machines).

2. Select one or more virtual machines to stop by clicking the appropriate check boxes.
Alternatively, you can access the VM Properties view, in which case no selection is necessary;
the virtual machine being viewed is implicitly selected.

3. Select Tools→Stop Virtual Machine... from the VM Manager menu bar. This displays a
page similar to that shown in Figure 6-2.
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Figure 6-2 Stop Virtual Machine page

4. In the screen example shown in Figure 6-2, two of the selected virtual machines are going
to be stopped (bitsy00 and bitsy01), while two are already stopped (vm001 and vms). The
screen reports that the OS is running on one of the virtual machines and advises you to shut
down the OS on that machine before stopping it.
The How to Stop options allow you to control how a virtual machine is stopped:
• Graceful. This is the default. With a graceful stop, the virtual machine notifies the guest

OS of an impending shutdown. This advance notice gives the OS an opportunity to
perform cleanup operations before its virtual machine is powered off. A graceful stop
typically takes 30 to 60 seconds, but can take as long as 5 minutes because Integrity VM
waits for the OS to complete its cleanup operations.

• Forced. A forced stop is the equivalent of a power failure and gives no warning to the
guest OS. Because the guest OS receives no advance notice of the power off operation,
the OS has no opportunity to perform a crash dump or perform any system cleanup
tasks.

If you want to set a forced stop for the machines, click the Forced option; otherwise, skip to
the next step.

5. The Command Preview area shows the commands that Integrity VM will perform to stop
the virtual machines.
Click OK to perform the action.
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Restarting virtual machines
When you choose to restart one or more virtual machines, VM Manager stops a virtual machine
that is already started, and then restarts it; if a machine is stopped, VM Manager starts it. Once
a virtual machine starts, the resources assigned to the virtual machine are allocated for its use.
The Restart and Start functions are similar except the Restart function first stops a virtual machine
that is already started, while the Start function does not (it leaves the started virtual machine as
is). Use Restart instead of Start when you have several virtual machines that you want newly
started, some which are already started and some currently stopped. The Restart function takes
care of all the virtual machines (in contrast, the Start function does not restart the already started
machines). However, if you do not want the already started machines stopped (you just want
the stopped machines started), use the Start function instead. For information about the start
function, see “Starting virtual machines” (page 94).

NOTE: If the OS is running on a virtual machine that you want stopped, HP recommends that
you shut down the OS before stopping the virtual machine. This ensures that all applications
are shut down cleanly.
You cannot start a virtual machine that is currently migrating online. You must wait until
migration completes. If the selected virtual machine has migrated to another VM Host (the target),
the virtual machine (on the source VM Host) is in the Not Runnable state: you cannot start a
virtual machine in this state.

To restart one or more virtual machines, perform the following steps:
1. From the VM Host General tab, select the VM Host Virtual Machines tab (or any tab that

allows you to select one or more virtual machines).
2. Select the virtual machines to restart by clicking the appropriate check boxes.

Alternatively, you can access the VM Properties view, in which case no selection is necessary;
the virtual machine being viewed is implicitly selected.

3. Select Tools→Restart Virtual Machine... from the VM Manager menu bar. This displays
a page similar to that shown in Figure 6-3.
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Figure 6-3 Restart Virtual Machine page

4. In the screen example shown in Figure 6-3, two virtual machines will be stopped (gracefully)
and restarted. A message indicates that these machines have an active operating system that
should be shut down prior to stopping the virtual machine. The How to Stop options allow
you to control whether the virtual machines are stopped gracefully (the default) or forcefully.
For a description of each stop option, see “Stopping virtual machines” (page 96).
If you want to set a forced stop for the machines, click the Forced option; otherwise, skip to
the next step. If all machines are already stopped, skip to the next step (the How to Stop
options are irrelevant).
As noted, if the OS is running on a virtual machine that is already started, shut down the
OS before initiating the restart in the next step.

5. The Command Preview area shows the commands that Integrity VM will perform to restart
the virtual machines.
Click OK to perform the action.

For information about possible reasons that a virtual machine might not start, see
“Troubleshooting virtual machine problems” (page 126).

Deleting virtual machines
To delete a virtual machine, select Delete→Virtual Machine... from the VM Manager menu bar.
The Virtual Machine... menu option is enabled in the VM Properties view or when one or more
virtual machines are selected in any of the tabs that list virtual machines, such as in the VM Host
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Virtual Machines tab. From tabs that list and allow selection of multiple virtual machines, you
can simultaneously delete multiple virtual machines that are selected.

NOTE: Before deleting a virtual machine, you must first stop the virtual machine (put it in the
Off state). For instructions, see the section “Stopping virtual machines” (page 96).

Deleting a virtual machine removes the configuration definition for a virtual machine and frees
any resources assigned to the virtual machine, making the resources available to be assigned to
other virtual machines. Deleting a virtual machine does not delete files and data residing on the
virtual storage or backing storage that was assigned to the virtual machine.
By default, vswitch VLAN port assignments are removed when the virtual machine is deleted.
If any of the ports are connected to other virtual machines that are not being removed, those port
assignments are not removed. Clearing the Remove VLAN Assignment check box causes vswitch
VLAN port assignments to remain after the virtual machine is deleted.

NOTE: You cannot delete a virtual machine that is currently migrating online. You must wait
until migration completes.

NOTE: Using VM Manager with Insight Dynamics - VSE for Integrity, if you create a virtual
machine and then delete it before the new virtual machine has been identified by HP SIM, the
virtual machine might appear in Virtualization Manager as though it had not been deleted. The
appearance of the virtual machine in Virtualization Manager depends on when the deletion
occurred during the HP SIM identification process. In addition, if you decide to delete the virtual
machine soon after creating it, wait a few minutes before doing so. If the deleted virtual machine
does appear in Virtualization Manager, delete it from the HP SIM All System view. (From the
HP SIM Systems and Event Collections list in the navigation area on the left, select All
Systems.) For more information, see theHP Insight VirtualizationManager 6.2 Software with Logical
Server Management User Guide.
This is not an issue when using VM Manager from HP SMH.

Migrating virtual machines

Overview
This topic presents an overview of virtual machine migration and of the Migrate Virtual Machine
wizard that allows you to set up and initiate migration of virtual machines from your VM
Manager's VM Host (the migration source) to another VM Host (the migration target).
The wizard allows you to perform either online or offline migration:
• Online migration migrates a virtual machine that is running, moving the guest OS and

applications without disrupting service. All guest I/O connections to network and storage
devices remain active throughout the migration, and the guest OS and its applications
continue operating without requiring a reboot or application restart.

• Offline migration migrates the configuration of a virtual machine that is not running.
Some of the most common reasons for migrating virtual machines online include the need to:
• Vacate the source VM Host system for maintenance purposes without disrupting services
• Perform a rolling upgrade of a VM Host, moving its running guests to another VM Host,

upgrading the VM Host, then moving the guests back
• Populate a new VM Host with one or more virtual machines already configured and tested

on the source
• Move virtual machines to take advantage of a particular resource or feature on the target

VM Host, without losing application availability
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• Balance VM Host workloads
• Optimize physical resource utilization
Online migration of virtual machines enables a higher level of workload-to-resource alignment,
flexibility, and agility.
Reasons for migrating a virtual machine offline include the need to:
• Move a stopped virtual machine's configuration information
• Save VM Host resources while migrating virtual machines (for example, memory and CPUs

are not consumed during offline migration)
• Copy local storage, logical volumes, or file-backed storage to the target VM Host (such

storage cannot be migrated online)
• Migrate a virtual machine between VM Hosts that might have different processor types,

making online migration impossible
The Migrate Virtual Machine wizard is started by selecting Tools→Migrate Virtual Machine...
from the VM Manager menu bar. The menu item is enabled from the VM Properties view, from
which you can migrate the one viewed virtual machine, or from a tab on which one or more
virtual machines are selected, such as the VM Host Virtual Machines tab, from which you can
migrate multiple virtual machines at the same time. For more information about starting the
wizard, see “Starting the Migrate Virtual Machine wizard” (page 103).
The Migrate Virtual Machine wizard guides you through a two-step procedure. The screen for
the first step prompts you to specify the target VM Host. The screen for the second step allows
you to preview the HP Integrity Virtual Machine commands that will be invoked to initiate the
migration and allows you to initiate the migration.
Using the Migrate Virtual Machine wizard, you can migrate virtual machines from the VM Host
you are currently using with VM Manager to another VM Host; you cannot use the wizard to
migrate virtual machines from another VM Host to the current VM Manager VM Host.
While a virtual machine is being migrated to another VM Host, you cannot stop, start, restart,
modify, or delete that virtual machine. You can continue using VM Manager for other purposes.

NOTE: If the virtual machine is configured as a Serviceguard package, the wizard allows you
to migrate the virtual machine online or offline. However, you cannot migrate a virtual machine
that is configured as a Serviceguard cluster node.
When migrating a virtual machine that is configured as a Serviceguard package, Serviceguard
protection is suspended temporarily during the migration.
Capacity Advisor cannot collect utilization information for a virtual machine that is being
migrated.
For more information about Serviceguard and Capacity Advisor requirements and
recommendations pertaining to virtual machine migration, see “Planning requirements and
recommendations” (page 101).

Planning requirements and recommendations
Successful migration of a virtual machine requires that the source and target hosts be configured
appropriately. If they are configured properly before migration of a virtual machine, the migration
task completes more quickly. Configuration requirements for online migration are more elaborate
than for offline migration.
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Some of the basic migration requirements include the following; for complete details, see the HP
Integrity Virtual Machines Installation, Configuration, and Administration manual:
• For online migration, the source and target hosts must be running HP Integrity VM Version

4.1 or later.
• The source and target hosts must conform to the operating system requirements, and both

must be able to provide the allocated resources to the virtual machine being migrated.
• The target host must be accessible from the source host.
• Resources used by the virtual machine must be configured symmetrically on both the source

and target host.
• You can migrate guests that use both the virtual I/O (VIO) and the accelerated virtual I/O

(AVIO) drivers for storage and network. Only whole disk SAN storage and ejected file-backed
DVDs can be migrated while the virtual machine is online. File and logical volume backing
storage are not supported for online migration of virtual machines.

• Online migration requires that both the source and target VM Host be licensed and enabled
for such migration. The licensing is included with a bundle that must be installed on each
VM Host; for more information, see theHP Integrity VirtualMachines Installation, Configuration,
and Administration manual.

• Online virtual machine migration requires that the virtual machine be enabled for online
migration (the VM Host administrator can enable a virtual machine by using thehpvmmodify
-x online_migration=enabled command).

Serviceguard requirements and recommendations
For online migration of a virtual machine configured as a Serviceguard package, package switching
for the migrating virtual machine guest package is disabled before migration begins and then
re-enabled immediately after the migration finishes. Therefore, the virtual machine software is
not protected by Serviceguard during the migration process. If a failure occurs during migration,
you must manually re-enable package failover after the migration completes and restart the
virtual machine by running it on one of the Serviceguard cluster nodes.
If temporary loss of failover protection is not tolerable, disable online migration for the virtual
machine. For example, to disable the virtual machine named sgnode, run the hpvmmodify
command on the VM Host as follows:
hpvmmodify -P sgnode -x online_migration=disabled

Do not attempt online migration of a virtual machine configured as a Serviceguard cluster node.
If a Serviceguard node is migrated while online, it might lose connection to other cluster members
and be automatically removed from the cluster. Disable online migration for all virtual machines
configured as Serviceguard cluster nodes.

NOTE: VM Manager detects whether a virtual machine is configured as a Serviceguard package;
the VM Host Virtual Machines and VM Properties General tab tabs display the package icon
( ) next to the virtual machine name.

For more information about managing virtual machines with Serviceguard support, see the HP
Integrity Virtual Machines Installation, Configuration, and Administration manual.

Capacity Advisor requirements and recommendations
If Capacity Advisor is used on the virtual machine, collect utilization information before you
migrate the virtual machine. The Capacity Advisor cannot continue to collect utilization
information for the virtual machine during the migration.
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Migration status and error notification
The migration status of a virtual machine — including the direction of migration, percentage
completion per phase (for online migration only), and error messages — is displayed on the VM
Properties General tab. The VM Host Virtual Machines tab also indicates migration status (use
this tab to monitor the migration of multiple virtual machines). For more information, see “VM
Properties General tab” (page 59) and “VM Host Virtual Machines tab” (page 36).
If errors occur during an attempt to migrate a virtual machine online, the VM Host Virtual

Machines tab (for the source VM Host) displays the Migration Error icon ( ) next to the name
of the affected virtual machine. Information about the migration-related errors is on the VM
Properties General tab. For more information about status icons, see “Status indicators”
(page 124).
Various conditions can cause an online migration to abort: insufficient resources on the target
host, busy source or target hosts, a slow private network connection, an excessively busy guest
(virtual machine operating system and applications), and so on. When a migration aborts, the
guest continues to run, unaffected, on the source VM Host. Therefore, these are not serious errors.
You can attempt the online migration again when the blocking conditions improve.
After a virtual machine successfully migrates to another VM Host, it is placed in the Not Runnable
state on the source VM Host. A virtual machine in this state cannot be modified or started. If you
never intend to migrate the virtual machine back to the source VM Host, you can remove the
virtual machine configuration by using the VM Manager Delete→Virtual Machine... menu item.
The state of the virtual machine is displayed by the HW column on the VM Host Virtual Machines
tab. The Not Runnable state is indicated by the following status icon: . The VM Properties
General tab also displays the state of the virtual machine (in the Virtual Hardware Status field).

Adjusting online migration phase timeout values
To protect the guest's workload, the online migration software limits the amount of time spent
in each phase of the migration. If necessary, the VM Host administrator can carefully adjust
migration time outs for each phase by using the hpvmmodify -x command, as documented in
the HP Integrity Virtual Machines Installation, Configuration, and Administration manual.

Starting the Migrate Virtual Machine wizard
To migrate one or more virtual machines, follow these steps:
1. If you want to migrate a single virtual machine, access any VM Properties view, and skip

to the next step.
If you want to migrate several virtual machines, access the VM Host Virtual Machines tab
or any tab that allows you to select multiple virtual machines. Then select the virtual machines
to migrate by clicking the appropriate check boxes.

2. To start the Migrate Virtual Machine wizard, select Tools→Migrate Virtual Machine... from
the VM Manager menu bar. This displays the first of two Migrate Virtual Machine wizard
screens, the Step 1 screen as shown in Figure 6-4.
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NOTE: The Tools→Migrate Virtual Machine... option is enabled from any VM Properties
view or from any tab on which one or more virtual machines are selected.

Figure 6-4 Migrate Virtual Machine: Step 1 of 2

3. Specify the target VM Host name, alias, or IP address. The target must be a valid VM Host
and must be accessible by the source VM Host. If you intend to migrate a virtual machine
online, this VM Host must be licensed and enabled for online migration.

4. If you want the virtual machine configuration removed from your source VM Host after the
migration completes, select the check box provided for that purpose. Make this selection if
you never intend to migrate the virtual machine back to this host. If you might migrate the
virtual machine back to this host sometime, or if you might want to create a virtual machine
on this host that is based on the configuration of the virtual machine that you migrated to
another host, do not check the box.

5. To continue to the Step 2 screen of the Migrate Virtual Machine wizard, click Next. To cancel
and return to the VM Manager screen from which you initiated the wizard, click Cancel.
Figure 6-5 shows an example of the Step 2 screen.
This screen lists the commands that VM Manager will issue to start the migration. The first
command will migrate a running virtual machine, so it is listed as an online migration. The
second command will migrate a virtual machine that is not running and so is listed as an
offline migration. If any virtual machines cannot be migrated, the screen lists the virtual
machine names and the reasons why they cannot be migrated. Reasons that a virtual machine
cannot be migrated include:
• It is already migrating
• Online migration only — It is not enabled for online migration
• It is in a Not Runnable state
• Online migration only — The source or target VM Host is not licensed and enabled for

online migration
• Serviceguard packages only — The package is already running on the target VM Host

HP Confidential104 Working with virtual machines



NOTE: If the source or target VM Host is not enabled and licensed for online migration,
or the virtual machine is not enabled for online migration, you can migrate the virtual
machine offline. Stop the virtual machine and then retry migrating it.

Figure 6-5 Migrate Virtual Machine: Step 2 of 2

6. Inspect the commands. If they suit your needs and you want to go ahead with the migration,
click Finish. If you want to tailor the commands to be used for migrating the selected virtual
machines, you can enter the desired commands manually on the VM Host. If you want to
start over — perhaps to specify a different target host or to change your selection regarding
whether to remove the virtual machine configuration after it is migrated to the other host
— click Previous to return to the Step 1 screen of the wizard.
If you do not want to perform the migration, click Cancel. When you click Cancel or Finish,
VM Manager returns you to the screen from which you initiated the Migrate Virtual Machine
wizard.
While a virtual machine is being migrated to another VM Host, you cannot stop, start, restart,
modify, or delete that virtual machine. You can continue using VM Manager for other
purposes. While the current migration is in progress, if you start the Migrate Virtual Machine
wizard again to migrate another virtual machine, VM Manager queues the newly-selected
migration until after the current migration completes.
To determine the status of the migration, use the VM Host Virtual Machines tab (especially
if multiple virtual machines are being migrated) or the VM Properties General tab.

Creating virtual switches
To provide network access for virtual machines, you must create virtual network switches
(vswitches) for them. This section describes how to create a new vswitch on the VM Host. The
vswitch is used by a virtual machine to connect to the network: one or more virtual machines
connect to the vswitch and the vswitch is connected to a VM Host's physical network device.
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To create a vswitch, select Create→Virtual Switch from the VM Manager menu. This displays
a page similar to that shown in Figure 6-6.

Figure 6-6 Create Virtual Switch page

The table on the screen shown in Figure 6-6 displays the following information:
• LAN interface: Shows the physical LAN interface to which a vswitch can be attached. The

“(none)” entry indicates that the vswitch is local, meaning that it not connected to a LAN
interface. Communication over such a vswitch does not go out on the physical network and
is useful only for communicating between virtual machines.

• Used by: Shows all of the vswitches already configured to use the corresponding LAN
interface. A LAN interface can be used by only one vswitch at a time. You can configure
multiple vswitches that use the same LAN card, but only one of these switches can be active
at one time. In the row for creating a local vswitch [“(none)” entry], the Used by column
lists all existing local vswitches. All local vswitches can be active simultaneously. A new
local vswitch can be started regardless of the number of existing active local vswitches.
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• Hardware path: Shows the hardware path associated with the LAN interface.
• Supports AVIO: Shows whether the physical backing device supports Accelerated Virtual

Input/Output (AVIO). For each virtual machine containing an AVIO device, the VM Host
OS and the guest OS must support AVIO. In addition, HP strongly recommends that AVIO
components (such as drivers and libraries) on the virtual machine and VM Host be updated
to the latest release of the OS. If the virtual machine OS is Windows or Linux, install
additional AVIO-compatible drivers on the VM Host and virtual machine.
For HP-UX, HP recommends that you install the latest AVIO components for both the VM
Host and the guest; however, updating both guest and host components at the same time
is not mandatory. Updating both components ensures that you always receive the latest bug
fixes for a complete solution. Always check the following software depot website for the
latest version of AVIO software (search for “HPVM AVIO”):
http://software.hp.com
Guest AVIO drivers are included in the VMGuestSW bundle available from the software
depot website. Make sure you install the latest version of that bundle.
With HP Integrity VM, AVIO requires a vswitch that has a physical network device as the
backing device (local vswitches such as localnet are not supported). In addition, the physical
NIC that backs the virtual switch must have an AVIO-compatible driver.
For more information about AVIO requirements, see the HP Integrity Virtual Machines
documentation.

Create the virtual switch by performing the following steps:
1. (Required) Enter a virtual switch name.

• The name must be 8 characters or fewer.
• The allowable characters are A-Z, a-z, 0-9, dash (-), underscore (_), and period (.).
• The name cannot begin with a dash and cannot remain blank.

2. Specify the virtual switch type (whether it is to be dedicated or shareable). The default is
shareable.

NOTE: The terms "shareable" and "dedicated" refer to how the switch is assigned to the
virtual machines.
• A dedicated vswitch can be used by only one started virtual machine at a time and is

dedicated to providing network throughput to that virtual machine. More than one
virtual machine can have the same dedicated switch as a resource, but only one is
allowed to start.

• A shareable vswitch can be used at any given time by all the associated virtual machines
that contain the virtual network device (NIC) backed by a shareable vswitch.

NOTE: All virtual machines with virtual NICs backed by a shareable vswitch are not
required to be running. If you have a stopped virtual machine that uses the shareable
vswitch, you can always start the virtual machine (unless other problems prevent it
from starting).

3. (Required) From the table, select the VM Host's physical network device that will be the
physical backing of the vswitch.
Choices include the following:
• Any physical network cards (adapters) configured on the VM Host
• Any APA (Automatic Port Aggregation) configured on the VM Host

The display shows the APA name in one column and the individual devices or cards
in the next column; however, the letters "APA" do not appear in either column. In
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HP-UX, any LAN port with port number 900 or greater is an APA (for example, lan900
or lan901).

• None
This creates a local vswitch. When no physical network device on the VM Host is chosen,
the vswitch is a local vswitch. A local vswitch has no connection with any physical
network device on the VM Host. Virtual machine virtual network interface cards (vNICs)
can communicate only with other virtual machines on the same VM Host that are
connected to the same local vswitch.

4. Specify whether or not to start the vswitch after it is created. The default is to start the
vswitch.

Clicking OK does the following:
• Creates the new vswitch, using the hpvmnet command.
• If you chose to make the vswitch dedicated, configures the vswitch as a dedicated vswitch,

using the hpvmdevmgmt command.
• If you chose to have the switch started, starts the vswitch, using the hpvmnet command.
A preview of these commands is shown in the Command Preview area. After you click OK, any
errors that occur with the execution of these commands is displayed on a separate error page
that lists each command and whether the command succeeded, failed, or was not attempted.
Clicking OK on the error page returns you to the Create Vswitch page.

Starting, stopping, and deleting virtual switches
To start or stop a virtual switch, select Tools→Start Virtual Switch... or Tools→Stop Virtual
Switch... from the VM Manager menu bar. To delete a virtual switch, select Delete→Virtual
Switch.... Access these menu options from a view that allows you to select one or more virtual
switches, such as the VM Host Virtual Switches tab. In this way, you can act on several multiple
switches simultaneously, if selected. (You can also access the menu options from the Vswitch
Properties view, in which case the action is performed on a single virtual switch: the one being
viewed.)
To start a vswitch, select Tools→Start Virtual Switch.... Once a vswitch is started, the virtual
machines that are connected to it can use it for network connectivity. Before you start a vswitch,
it must be stopped.
To stop a vswitch, select Tools→Stop Virtual Switch.... The selected vswitch must currently be
started. Once a vswitch is stopped, the virtual machines connected to it can no longer use it for
network connectivity.
To remove all configuration information for a vswitch, select Delete→Virtual Switch.... Before
you remove a vswitch, you must first stop it.

NOTE: For information about creating and managing vswitches, see the HP Integrity Virtual
Machines Installation, Configuration, and Administration manual.

Deleting network or storage Devices
To delete a network or storage device from a virtual machine, select one or more I/O devices
from a Network or Storage tab, and then select Delete→I/O Device... from the VM Manager
menu bar. You can select I/O devices from any of the following tabs: VM Host Storage, VM
Properties Storage, VM Host Network, VM Properties Network, Vswitch Properties Network.
Selecting Delete→I/O Device... displays a page that allows you to remove the selected I/O devices.
When you delete a device from a virtual machine, it is disassociated from that virtual machine,
allowing the device to be used by another virtual machine on the VM Host. Deleted devices
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remain active on a virtual machine that is running; the devices are removed once you restart the
virtual machine.
Storage devices that you can delete include virtual disks and DVDs as well as attached tapes,
burners, and changers. Deleting a storage device does not affect data on that device (files or data
are not removed from the device).

NOTE: You cannot remove a device that is currently being used by the guest OS or if I/O is
outstanding.
If a virtual machine is running the Windows operating system, VM Manager indicates that it
will not remove the virtual machine's devices. The operating system must be shut down first.
If a virtual machine is running HP-UX, devices selected for removal might not be removed until
you restart the virtual machine. To confirm that the device has been removed from the virtual
machine, view the appropriate Network or Storage tab.

NOTE: If the virtual machine is powered on, preliminary actions might be required to remove
an AVIO storage device. If the virtual machine is powered off, no preliminary actions are required
to remove the AVIO storage device (or any other selected storage device). To remove an AVIO
storage device from a virtual machine that is powered on, note the following:
• If the virtual machine is powered on and running at EFI, to remove the device, first stop the

virtual machine. To stop the virtual machine, use the VM Manager Tools→Stop Virtual
Machine... menu option. Once the virtual machine has stopped, delete the device using the
Delete→I/O Device... menu option.

• If the virtual machine is powered on and running HP-UX 11i v3, you must remove all
instances of the device from the guest OS. To do so, follow these steps:
1. Obtain the device's hardware target path (tgtpath class) or lun path (lunpath class),

using the ioscan command at the guest in either of the following ways:
ioscan -kfNC tgtpath

or
ioscan -kfNC lunpath

2. Remove the device by using the rmsf command at the guest, specifying the obtained
hardware path:
rmsf -H tgtpath

or
rmsf -H lunpath

Once the device has been completely removed from the guest OS, then you can delete
the storage device by using the VM Manager Delete→I/O Device... menu option.

NOTE: HP Integrity VM maintains a device database that includes entries for all devices and
their associations. If deleting a device causes removal of the last association of that device with
any other virtual machine on the VM Host, HP Integrity VM removes that device from its device
database unless it is marked for preservation. To preserve an entry, use the Integrity VM
hpvmdevmgmt command, specifying PRESERVE=YES; or, when creating a file as a backing
device, specify the -S) and -A attributes with that command.
When you use VM Manager to create a file as a backing device for a disk, the PRESERVE attribute
is set as PRESERVE=YES.
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7 Collecting and viewing utilization data
Certain VM Manager views include utilization meters (bar graphs) that display current utilization
data for a resource. For example, the VM Host Virtual Machines tab includes several utilization
meters for each virtual machine listed, as shown in Figure 7-1. Using VM Manager with Insight
Dynamics -VSE for Integrity, you can click a meter to view a more detailed historical data report
provided by HP Insight Capacity Advisor software. These meters are visible when using VM
Manager with HP SMH, but you cannot click them to obtain a Capacity Advisor report.

Figure 7-1 Utilization meters displayed by the VM Host Virtual Machines tab

Using VM Manager with Insight Dynamics, you can cause Capacity Advisor to collect and display
historical utilization data for a VM Host or selected virtual machines.

Enabling collection of utilization data
Utilization meters display utilization data retrieved by the WBEM Utilization Provider. WBEM
providers are included with Insight Dynamics - VSE for Integrity and must be installed on the
VM Host and each virtual machine. For more information, see “System and software
requirements” (page 13).
Using VM Manager through HP SMH, viewing utilization meter data specific to virtual machines
requires certain WBEM credentials to be set. If such credentials are not set, the meters are dimmed.
For more information, see “Setting WBEM credentials in HP SMH” (page 16). Meters for the
VM Host and host resources are still available if the VM Host's WBEM Utilization Provider is
running.
Using VM Manager with Insight Dynamics, you can enable collection of utilization data from
systems licensed for HP Insight Capacity Advisor software. Select the Tools→Collect Capacity
Advisor Data menu item from the VM Manager menu bar. This menu item is not available when
using VM Manager through HP SMH.
Data is collected by WBEM Utilization Provider software on the licensed systems and stored on
the Central Management Server. Data collection is done on individual systems. Results from
stdout and stderr are saved to the HP SIM/Insight Dynamics Tasks Results log. Capacity
Advisor uses the collected data to calculate the utilization of CPU and memory on targeted
systems. You can collect data for:
• All systems licensed to use Capacity Advisor
• Specific selected systems licensed to use Capacity Advisor
To view the collected data, use the View→Capacity Advisor Data... menu item, as described in
“Viewing utilization data” (page 112).
For information on Capacity Advisor, including prerequisites for using Capacity Advisor features,
see the HP Insight Capacity Advisor 6.2 User Guide.
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Viewing utilization data
VM Manager provides the following options for viewing utilization data. These assume the
prerequisites discussed in “Enabling collection of utilization data” (page 111) have been met.
• Utilization meters provided by VM Manager tabs. Table 7-1 lists the meters provided by

VM Manager tabs. Utilization meters display current utilization data for the associated
resource. The utilization information is a 5-minute average that is calculated and updated
on 5-minute boundaries. If the utilization cannot be displayed, the utilization meter is
dimmed. A label next to the meter indicates the probable cause. For information about these
labels, see “Utilization meter status/error information” (page 125).
CPU and memory utilization are expressed as a percentage. Network and storage meters
display I/O data in terms of throughput (for example, megabytes per second). Storage meters
are labeled as “Disk I/O” but provide utilization data for any supported devices (DVDs and
tape devices as well as disks). If a network or storage I/O meter is in a device box on a
Network or Storage tab, the data is specific to the device, whether it is a virtual device in
a virtual machine or a physical device on the VM Host; if the meter is in a virtual machine
box, the data is an aggregate, registering the total throughput for all virtual devices on the
virtual machine.
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Table 7-1 Utilization meters available on VM Manager tabs

Utilization MetricsVM Manager Tab

Storage I/O
(throughput)

Network I/O
(throughput)

Memory (%)CPU (%)

VM Host onlyVM Host onlyVM Host onlyVM Host onlyVM Host
General

Per VM onlyPer VM onlyPer VM onlyVM Host CPU
utilization per VM
VM vCPU utilization

VM Host Virtual
Machines

VM Host (Physical
Network Interfaces
column)
VM (Virtual Network
Interfaces column)

VM Host
Network

VM Host (Physical
Storage column)
VM (Virtual Storage
column)

VM Host
Storage

VM onlyVM onlyVM onlyVM CPU utilization
VM Host CPU
utilization per VM

VM Properties
General

VM Host (Physical
Network Interfaces
column)
VM (Virtual Network
Interfaces column)

VM Properties
Network

VM Host (Physical
Storage column)
VM (Virtual Storage
column)

VM Properties
Storage

VM Host (Physical
Network Interfaces
column)
VM (Virtual Network
Interfaces column)

Vswitch
Properties
Network
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NOTE: Data reported by certain VM Manager CPU utilization meters might vary from the
data collected by Capacity Advisor as displayed in the Profile Viewer and historical utilization
reports. The data from VM Manager meters is reliable for most purposes. For capacity
planning, refer to the data collected by the Capacity Advisor Profile Viewer and historical
utilization reports. For more information about how Capacity Advisor data might vary from
VM Manager data, see “Data Handling for Virtual Machines” in Chapter 3 of the HP Insight
Capacity Advisor 6.2 User Guide.
Another source of discrepancy is the difference in the way Capacity Advisor and VM Manager
present CPU data. Capacity Advisor Profile Viewer and historical utilization reports present
CPU data in absolute terms (specifying the number of physical cores used) while VM Manager
presents CPU data in terms of percentages (specifying the percentage of available CPU
resources being used). For example, the VM Manager “VM Host CPU Utilization” meter
displayed on the VM Host Virtual Machines and VM Properties General tabs displays the
percentage of the total VM Host physical CPU capacity used by the virtual machine in
question. Capacity Advisor tabulates similar data but presents it in different terms. For
example, on a VM Host that has 16 physical cores, if a VM has 4 vCPUs each currently using
50% of a physical core, CapAd would report that the VM is consuming 2 VM Host cores.
The VM Manager “VM Host CPU utilization” meter would report that the VM is consuming
12.5% of the VM Host's CPU capacity.

• Using VM Manager with Insight Dynamics:
— You can click a utilization meter to view a more detailed historical data report provided

by HP Insight Capacity Advisor software.
— You can use the VM Manager View→Capacity Advisor Data... menu item to view a

snapshot of recent utilization data collected by HP Insight Capacity Advisor software.
First, you must enable collection of data by using the Tools→Collect Capacity Advisor
Data menu item, as described in “Enabling collection of utilization data” (page 111). (If
you use the VM Manager View→Capacity Advisor Data... menu item without having
enabled data collection, no data is displayed; however, the screen includes a link to the
Collect Capacity Advisor Data facility so that you can begin collecting data to view.)
Figure 7-2 (page 115) shows the upper half of the screen showing data collected for a
VM Host, while Figure 7-3 (page 116) shows the lower half of the screen.
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Figure 7-2 View Capacity Advisor data screen: upper half
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Figure 7-3 View Capacity Advisor data screen: lower half

The data collection view is provided by the Capacity Advisor Profile Viewer. The Profile
Viewer displays historical utilization data along with additional information you provide.
The Profile Viewer also enables you to examine different time intervals and different
categories of data. In the Capacity Advisor graphs, you can view utilization data for
both CPUs and memory. You can also view network and disk bandwidth utilization
(throughput) for whole OS profiles. For more information about the Capacity Advisor
Profile Viewer, see theHP Insight Capacity Advisor 6.2 User Guide or the Capacity Advisor
Profile Viewer Screen help topic.
When you click the View→Capacity Advisor Data... menu item without any virtual
machines selected on the current tab, the screen shows utilization data pertaining to
the VM Host.
The data provided by the View→Capacity Advisor Data... menu item is similar to
what is provided by clicking on a utilization meter. However, clicking on a meter presets
certain parameters, such as what type of utilization metric to display and for which
system (VM Host or a particular virtual machine, for example). Nevertheless, you can
change parameters once the screen comes up.

— You can use the Tools→Capacity Advisor Historic Report menu item to create a
comprehensive report that collects and analyzes data over specified time periods from
specified sources, as described in “Creating a historical utilization data report” (page 117).
The report can be browsed and saved.
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Creating a historical utilization data report
To use HP Insight Capacity Advisor software to create a historical utilization report that includes
data for the target workloads, systems, complexes, or scenarios you specify, select the
Tools→Capacity Advisor Historic Report menu item from the VM Manager menu bar. This
menu item is available only when you use VM Manager with Insight Dynamics; it is not available
when using VM Manager through HP SMH. Before creating a report, you must have collected
data on the systems of interest (see “Enabling collection of utilization data” (page 111)).
HP Insight Capacity Advisor software reports provide information about utilization and allocation
data that have been collected and analyzed. This facility gives you the flexibility of analyzing
and showing data collected over specified time periods. A wizard allows you to set a variety of
parameters to determine the time periods and systems for data collection and analysis. The report
can be browsed (the screen is presented in a new browser window) and saved. In contrast, the
View→Capacity Advisor Data... menu item gives a snapshot of utilization that's more limited
to the current, most recent time period.
Capacity Advisor collects data for the following resources or targets: systems, workloads,
complexes, and scenarios. For these targets, Capacity Advisor provides utilization information
in the following reports:
• System Utilization Report
• Workload Utilization Report
• Complex Utilization Report
• Scenario Utilization Report
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8 Viewing logs and version information
Viewing Integrity VM Host and VM logs

You can view the events logged by Integrity VM pertaining to the VM Host and all guests by
selecting View→Integrity VM log for VM Host... from the VM Manager menu bar. This gives a
display similar to that created by the hpvmstatus -e command (used at the Integrity VM CLI),
except VM Manager limits the display to the most recent 1000 log lines. The VM Host event log
records all changes to configurations of the VM Host and to virtual machines on the VM Host,
including information about commands issued and error messages.
You can view the events logged by Integrity VM pertaining to a selected virtual machine by
selecting View→Integrity VM log for VM... from the VM Manager menu bar (if you are in a VM
Host or Vswitch Properties view, a virtual machine must be selected). This gives the same display
that the hpvmstatus -e -P vm-name command would give when used at the Integrity VM
CLI (where vm-name is the name of the virtual machine). The event log records all changes to
configurations of the virtual machine and information about commands issued and error messages.

NOTE: With VM Manager running under HP SMH, to view the Integrity VM logs using either
of these View menu items, you must be logged into HP SMH with either Operator or
Administrator privileges. For more information, see the HP SMH documentation, available from
the following website (click the Support and Documents link):
http://www.hp.com/go/smh

Some reasons that you might want to view either log include the following:
• To confirm a change that you made to a running virtual machine. This is especially useful

when the VM Manager does not immediately display the changed data, such as modification
of memory or the number of virtual CPUs for a running virtual machine. In such
circumstances, VM Manager does not display the new data until the virtual machine is shut
down or restarted.

• To review an error message that resulted from an Integrity VM command run by VM
Manager, or to view the actual command line that was run. VM Manager displays, or allows
you to view this information, at the time of the action. This view allows you to review the
information at a later time without having to access a log manually from the VM Host.

• To view commands, logged information, and error messages obtained directly from the
Integrity VM CLI and that might not have been recorded by VM Manager.

• To view other information logged on the VM Host, such as the status of the virtual machine
subsystem startup sequence (this information includes whether the virtual machine starts
automatically when the Integrity VM Host starts or remains in the Off state until manually
started).

Viewing VM Manager, Integrity VM, and WBEM Provider versions
You can view the version numbers of VM Manager, Integrity VM, and WBEM providers by
selecting View→VM Manager Version Information from the VM Manager menu bar. The
resulting screen reports the current versions of Integrity VM, of VM Manager, and of the providers
on both the VM Host and each virtual machine.
Figure 8-1 shows an example of a screen. If “No Permission” is displayed where a virtual machine's
WBEM provider version should be, the WBEM credentials (user name and password) have not
been set for that virtual machine. For more information on setting WBEM credentials, see “Setting
security credentials” (page 15).
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Figure 8-1 VM Manager Version Information screen
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9 Support and other resources
Contacting HP

HP encourages your comments concerning this document. We are truly committed to providing
documentation that meets your needs.
Your comments and suggestions regarding product features will help us develop future versions
of the Virtual Server Environment Management Software. Use the following email address to
send feedback directly to the Insight Dynamics development team:vse@hpuxweb.fc.hp.com.

NOTE: HP cannot provide product support through this email address. To obtain product
support, contact your HP Support Representative, your HP Services Representative, or your
authorized HP reseller. For more information about support services, see the support website
at:
http://www.hp.com/go/support

For other ways to contact HP, see the Contact HP website at:
http://welcome.hp.com/country/us/en/contact_us.html

New and changed information in this edition
This document reflects the features provided by VM Manager Version A.4.1.1 (4.1.1). New and
changed information in this document includes the following:
• Support for OpenVMS as a guest OS

VM Manager supports guest systems having OpenVMS as operating system.

Related information
You can download the latest version of this document from the following website (click on the
HP Insight Dynamics - VSE for Integrity tab):
http://www.hp.com/go/insightdynamics/docs
The following related documents can be downloaded from the same site:
• HP Insight Dynamics 6.2 Getting Started Guide
• HP Integrity Virtual Machines Manager 4.1.1 Software: User Guide
• HP Integrity Virtual Machines Manager 4.1.1 Software: Release Notes
• HP Integrity Virtual Machines Installation, Configuration, and Administration
• HP Integrity Virtual Machines Release Notes
The latest versions of manuals and white papers for the HP Insight Dynamics and related products
can be downloaded from the site mentioned previously.
For more information about the Insight Dynamics and related products and solutions, visit the
following HP websites:
• Insight Dynamics - VSE for Integrity: http://www.hp.com/go/insightdynamics/integrity
• Insight Dynamics for ProLiant: http://www.hp.com/go/insightdynamics

Typographic conventions
This document uses the following typographic conventions.
Book Title Title of a book or other document.
Linked Title Title that is a hyperlink to a book or other document.
http://www.hp.com A website address that is a hyperlink to the site.
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Command Command name or qualified command phrase.
user input Commands and other text that you type.
computer output Text displayed by the computer.
Enter The name of a keyboard key. Note that Return and Enter both refer

to the same key. A sequence such as Ctrl+A indicates that you must
hold down the key labeled Ctrl while pressing the A key.

variable The name of an environment variable, for example PATH or errno.
value A value that you may replace in a command or function, or

information in a display that represents several possible values.
find(1) HP-UX manpage. In this example, “find” is the manpage name and

“1” is the manpage section.
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A Error messages, status indicators, and troubleshooting
This appendix discusses error messages and troubleshooting related to VM Manager problems,
and describes the status indicators that appear on some VM Manager screens and the error and
status labels that might appear with utilization meters (bar graphs) displayed on certain VM
Manager screens.

Error messages
Error messages visible in VM Manager are returned primarily from the Integrity VM commands
themselves. This section describes how to review such error messages as logged by Integrity VM
and includes information about error messages that might be seen when attempting to access
VM Manager. Other errors or problems are discussed in “Troubleshooting virtual machine
problems” (page 126).

Reviewing error messages
To review an error message that resulted from an Integrity VM command run by VM Manager
in the past (and so is not currently viewable), you can select View→Integrity VM log for VM
Host... or View→Integrity VM log for VM.... The former menu item displays events logged by
Integrity VM that pertain to the VM Host and all its guests. The latter menu item displays events
logged by Integrity VM that pertain to a specific virtual machine. For more information, see
“Viewing Integrity VM Host and VM logs” (page 119).
For more information about error messages related to Integrity VM, see the HP Integrity Virtual
Machines Installation, Configuration, and Administration manual.

Errors accessing VM Manager
Under certain circumstances, errors can occur when attempting to enter Integrity VM Manager
from HP Insight Virtualization Manager software (Insight Dynamics -VSE for Integrity) or from
the HP System Management Homepage. In those cases, a page titled “Access failure” is displayed
with the name of the VM Host system and the reason for the failure to enter Integrity VM Manager.
The following list describes the access failure messages that you might receive:
• Incorrect permissions. An error occurred communicating with WBEM:

CIM_ERR_ACCESS_DENIED CIM_ERR_ACCESS_DENIED: PGS05203.
The following is an example of the error message displayed for a user, hpsmh:
The user 'hpsmh' is not authorized to run 'EnumerateInstances' in
the namespace 'root/cimv2/hpvm'.
CIM_ERR_ACCESS_DENIED (part of the error message mentioned earlier) indicates that a
CIM user is not authorized to access the namespace.
This error occurs when a user with specific credentials uses a WBEM connection to access
the VM WBEM services listening at ports 5988 and 5989 without sufficient permissions. For
a WBEM user to access the WBEM services, the user must be provided with sufficient
permissions.
This issue does not occur if the CIM configuration parameter enableNamespaceAuthorization
is set to FALSE. If the value is set to FALSE, irrespective of whether the users are SIM or
SMH users, they can access WBEM services.
To resolve the issue, first examine the value of the configuration parameter,
enableNamespaceAuthorization.
To examine the configuration parameter settings, run the following command:
cimconfig -lp

This command lists all the configuration parameters. Verify whether the
enableNamespaceAuthorization parameter is set to TRUE. If it is set to TRUE, follow these steps:

HP Confidential Error messages 123



1. To access WBEM Providers from HP SIM, run the following command:
# cimauth -a -u <SIMUSER> -n root/cimv2/hpvm -R -W

# cimconfig -s enableNamespaceAuthorization=true -p

where, SIMUSER is the username created for SIM access.
2. To access WBEM Providers from HP SMH, run the following command:

# cimauth -a -u <SMHUSER> -n root/cimv2/hpvm -R -W

# cimconfig -s enableNamespaceAuthorization=true -p

where, SMHUSER is the username created for SMH access.

• The user is not authorized to monitor the VM host in HP SIM/Insight
Dynamics. Authority to monitor the VM host is required when using
Integrity Virtual Machines Manager for accessing the VM host or for
accessing any hosted VM within the Insight Dynamics environment.

To use VM Manager, an HP SIM/Insight Dynamics user must have at least Monitor Tools
authorization for the virtual machine host system. If a user has authority to manage an
individual virtual machine but is not authorized within HP SIM/Insight Dynamics to monitor
the VM Host system that contains it, the error message appears when the user selects the
VM Manager icon in the virtual machine's system box displayed by the Virtualization
Manager Visualization tab. To return to Virtualization Manager, select All VSE Resources
in the left-hand navigation pane of HP SIM/Insight Dynamics (System and Event
Collections→Systems→Shared→Systems by Type→All VSE Resources).

• The VM host is not known to HP SIM/Insight Dynamics. The VM host
must be known to use Integrity Virtual Machines Manager for the VM
host or for any VM hosted by it.

It is possible that a virtual machine might be discovered by HP SIM while the containing
VM Host has not yet been discovered. To use VM Manager, both the virtual machine and
the containing VM Host must be discovered by HP SIM. This error message appears when
you select a virtual machine link in the virtual machine system box displayed in Virtualization
Manager before HP SIM has discovered the virtual machine's VM Host. To return to
Virtualization Manager, select the All VSE Resources link in the left-hand navigation bar
of HP SIM (System and Event Collections→Systems→Shared→Systems by Type→All
VSE Resources).

• The user is not authorized to use Integrity Virtual Machines Manager
on this VM host.

With HP SMH, VM Manager is configured by default to permit read-only access to HP SMH
users with User-level privileges, and read-write access to HP SMH users with Operator-level
and Administrator-level privileges. However, it is possible to reconfigure these permissions
to deny all VM Manager access to User-level and Operator-level users. In this case, these
users can log into HP SMH, but they are denied access to VM Manager. To return to the
SMH Homepage, select Home in the top navigation link.
With Insight Dynamics - VSE for Integrity, users need VSE All Tools authorization to view
all VM Manager screens and perform all VM Manager menu actions.

If other messages are displayed on an Access failure page, contact your HP Technical Support
Representative for further assistance.

Status indicators
In several actions and views, the status of a component is represented by an icon next to the
component name or label. For example, the icon next to the name of a virtual machine shows
whether the virtual machine is up or down. A question mark (?) means no information is available.
Table A-1 explains the meaning of each status icon.
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Table A-1 Status icons

Possible meanings in more detailIndicationIcon

The virtual machine is started or starting; devices are powered on
and active; the operating system is up or in the last part of the boot
sequence; no fault was detected.

On/Up/Normal

The virtual machine has stopped or is stopping; the devices are
powered off, or powered on but inactive; the operating system is
down, shutting down, or in the first part of the boot sequence. For a
virtual machine that has migrated to another VM Host (the target),
this icon indicates the virtual machine is no longer runnable on the
source VM Host, meaning that you cannot start or modify it. After
the migration has finished, you can delete the virtual machine from
the source VM Host.

Off/Down/Disabled

The virtual machine is configured as a Serviceguard package; flyover
text indicates the virtual machine is a Serviceguard package.

Serviceguard package

The virtual machine is a Serviceguard package that is running on
another VM Host; flyover text indicates hardware status (On) and
the name of the VM Host.

Managed by another
VM Host

The VM Manager cannot read information about virtual machines or
devices, or cannot obtain this information from the remote WBEM
services provider. This does not necessarily indicate an error
condition. For example, some information (such as memory
configuration) cannot be obtained if the virtual machine is powered
off or has not completed a restart.

Unknown

A critical problem with the virtual machine or device configuration
has been detected.

Critical

The virtual machine is experiencing major performance problems.Major

The virtual machine is currently migrating from this VM Host (source)
to another VM Host (target).

Migrating to another
VM Host

The virtual machine is currently migrating from another VM Host
(source) to this VM Host (target).

Migrating from
another VM Host

The virtual machine is in queue, waiting to migrate. When multiple
virtual machines are selected to migrate, only one is migrated at a
time.

Waiting for migration

An error was detected during the latest attempt to migrate one or
more virtual machines to another host.

Migration error An
error was detected
during the latest
attempt to migrate
one or more virtual
machines to another
host.

Utilization meter status/error information
When a utilization meter visible on one of the VM Manager tabs is dimmed (rather than displaying
a utilization value), a label indicates the probable cause. The following list describes the labels
or status indicators:
• No Comm. indicates that VM Manager is unable to communicate with the WBEM provider

running on a virtual machine. Hover the cursor over the meter to display an exception error
message identifying the problem.
A common reason for the No Comm. label to be displayed is a problem with trusted
certificates. For example, if trusted certificates are required (the Require trusted certificates
check box was selected on the Set WBEM Credentials for Virtual Machines page) but the
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keystore on the host does not trust the certificate from the virtual machine, then the certificate
is not in the keystore, has expired, did not match the virtual machine name, or is otherwise
invalid. For information about trusted certificates, see “Trusted certificates” (page 19).
If the WBEM provider is unresponsive, you might need to restart it.

• No Data indicates one of the following:
— Data is being collected, but it can take up to 10 minutes to display utilization data.
— The virtual machine is not started, not booted, or cannot be contacted by the system on

which VM Manager is running.
— The VM Host has no WBEM credentials for collecting the data from the virtual machine.

Normally, this is only seen for invalid or missing WBEM credentials for a Windows
VM guest. See the discussion of the No Perm label.For more information about WBEM
credentials, see “Setting security credentials” (page 15).

For more information about problems displaying data (data is out of date, incomplete, or
missing), see “Troubleshooting virtual machine problems” (page 126).

• No Perm. indicates that the VM Host lacks or has invalid WBEM credentials for collecting
the data from the virtual machine.

• Timed Out indicates that VM Manager attempted to retrieve utilization data but received
no response from the WBEM provider on the virtual machine because of one of the following
situations:
— The WBEM provider for the data is not running, is not installed, or is disabled on the

virtual machine.
— Network problems are preventing a timely response.

For more information about collecting and viewing utilization data, see Chapter 7 (page 111).

Troubleshooting virtual machine problems
This section discusses problems that might occur when using VM Manager to create, start, or
modify a virtual machine or to display virtual machine data. Also included are ways for resolving
these problems.
• Utilization data for OpenVMS guests is not displayed

The utilization data for OpenVMS guests may not be visible after the first installation of the
OpenVMS operating system or after rebooting the OpenVMS guests. This is because, by
default, the TCP/IP and WBEM Provider services do not start automatically after rebooting
the OpenVMS guest machine.
The TCP/IP, the WBEM Services, and the Utilization Provider products are not installed by
default on an OpenVMS guest. Ensure that the TCP/IP, the WBEM services, and the Utilization
Provider products are installed, configured, and started on the guest. After rebooting the
guest, verify if the TCP/IP and WBEM services have been started. If not, restart TCP/IP
and/or WBEM services manually or add the command in the startup script so that they start
automatically when the OpenVMS guest reboots. For more information, see the OpenVMS
documentation on setting up TCP/IP and WBEM Provider services.

• Failure creating a virtual machine
When using the Create Virtual Machines wizard, a number of warning or error conditions
can prevent the virtual machine from being created. However, if the Create VM even if
resources are insufficient, missing or unavailable check box is selected on the Create
Virtual Machines wizard Summary page, you can still have VM Manager create the virtual
machine. You will have to correct the conditions prior to starting the virtual machine.
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• Failure starting a virtual machine
The most likely cause for a virtual machine failing to start is missing, insufficient, or
unavailable resources. Make sure the required resources are made available. For example:
— Not enough memory on the VM Host is available for the virtual machine

Make sure that enough memory is available on the VM Host to provide the memory
you allocated for the new virtual machine (in addition to providing for the existing
virtual machines).

— You specified a device that is already in use by another virtual machine
You might have specified a network or storage device that is already in use by another
virtual machine. You need to return to the appropriate Create Wizard page to select a
device that is not in use. To determine what devices are already in use, examine the VM
Host Network or VM Host Storage tab.

— A file specified as a backing device does not exist
You might have incorrectly specified the name or path of a file to be used as a backing
storage device, or you specified a file that does not exist.

— The virtual machine is currently migrating online or has migrated to another VM Host
(and is in a Not Runnable state).

• Failure to modify the virtual machine vCPU entitlement
If you attempt to modify (by selecting Modify→Virtual Machine vCPU Entitlement) the
vCPU entitlement of a virtual machine that is being managed by gWLM, the following error
message is displayed, where virtual-machine-name is the name of the virtual machine:
The processor entitlement for VM virtual-machine-name cannot be
modified because it is being managed by gWLM. To adjust the processor
entitlement for this VM, use gWLM to change the policy associated
with this VM.

To create or modify the gWLM policy for this virtual machine, use the Policy menu (available
when using VM Manager with the Insight Dynamics - VSE for Integrity).

• Information is out of date, incomplete, or missing
In general, VM Manager tabbed view screens are refreshed automatically every five minutes.
An indicator on these visualization pages notifies you when the data was last refreshed. VM
Manager screens that display configuration data are updated instantaneously when you
use VM Manager to change the related configuration parameters.

NOTE: When changes to virtual machine I/O configuration are made using tools other
than VM Manager (such as adding or removing I/O devices by using the VM Host command
line), the updated configuration data is not shown until the screen is refreshed. You can
manually refresh a tabbed view screen and certain dialog screens (such as those for adding
storage or network devices) by clicking on the Refresh Data link.

If information about certain virtual machines is missing from a VM Manager screen (for
example, specifics about a port interface), the screen might need refreshing, the virtual
machines might not yet be started or, if they are started, the VM Provider or certain WBEM
components might not be running on those virtual machines or on the VM Host. WBEM
components are required on any virtual machine for which you want data. If the VM Provider
is not running on the VM Host, no data will be available on any VM Manager tabs; all tabs
will display a “No data available” message. To verify that the VM Provider is running, enter
the following command on the virtual machine or VM Host
cimprovider -ls

The response “HPVMProviderModule OK” indicates the VM Provider is running. Any other
response indicates it is not running. For system and software requirements regarding the
VM Provider, see “System and software requirements” (page 13). For installation instructions
and information about providers that must be installed and running on virtual machines,
see the HP Integrity Virtual Machines Installation, Configuration, and Administration manual.
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• Device special file displayed as unknown device ( )
If you use VM Manager to manage a VM Host running Integrity VM Version 3.5 or earlier,
VM Manager does not fully support virtual device special files located in /hpap (introduced
in HP StorageWorks Secure Path software Version 3.0F SP2) as backing devices for virtual
storage. If a virtual storage device using an /hpap device special file already exists on a
virtual machine managed by VM Manager, VM Manager displays it on the VM Host Storage
and VM Properties Storage tabs as an unknown device (using the question mark icon, ).
VM Manager displays the correct device special file name (for example,/hpap/rdsk/hpap1)
but the box representing this device is not connected to the boxes that represent the physical
storage devices associated with that virtual device special file. In general, VM Manager
correctly displays only those device special files located in /dev.

• Deleted virtual machine still appears in Virtualization Manager
Using VM Manager with Insight Dynamics-VSE for Integrity, if you create a virtual machine
and then delete it before the new virtual machine has been identified by HP SIM, the virtual
machine might appear in Virtualization Manager as though it had not been deleted. The
appearance of the virtual machine in Virtualization Manager depends on when the deletion
occurred during the HP SIM identification process. This is not an issue when using VM
Manager from HP SMH. In addition, if you decide to delete the virtual machine soon after
creating it, wait a few minutes before doing so. If the deleted virtual machine does appear
in Virtualization Manager, delete it from the HP SIM All System view. (From the HP SIM
Systems and Event Collections list in the navigation area on the left, select All Systems.)
For more information, see theHP Insight VirtualizationManager 6.2 Software with Logical Server
Management User Guide.

• Created virtual machine does not appear immediately in Virtualization Manager
After creating a virtual machine using VM Manager, if you return immediately to
Virtualization Manager, the machine might not yet appear in Virtualization Manager. This
means HP SIM has not yet completed identifying the new virtual machine. However, it
appears when the identification process completes (usually within a minute or two).
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Glossary
The following terms are commonly used to discuss VM Manager and its integrated
components:

Accelerated
Virtual
Input/Output

See AVIO.

agent A program that regularly gathers information or performs some other service without the user's
immediate presence. Insight Dynamics relies on agents on managed systems to provide in-depth
hardware and software information.

agile addressing Supported on Integrity VM running HP-UX 11i v3, a storage device addressing model that
addresses a logical unit (referred to as LUN, this is the logical device that refers to the physical
storage device) by using the same device special file (DSF) regardless of the location of the
LUN. The addressing model uses a worldwide device identifier (WWID) to uniquely identify
LUNs. The WWID is a device attribute that is independent of the device’s location in a SAN or
in an adapter/controller access path. With a multipath device, the WWID allows one persistent
DSF and one LUN hardware path to represent the device, regardless of the number of legacy
hardware paths. Therefore, an agile device address remains the same (is persistent) when
changes are made to the access path. Likewise, if additional paths are offered to a given LUN
(by adding a new SCSI controller or new SCSI target paths), the DSF is unaffected: no new DSFs
need be provided. This model enables VM Manager to display one DSF for each multipath
device instead of displaying a separate DSF for each path to the device (as done when using
the legacy addressing scheme).
See also legacy addressing.

APA Automatic Port Aggregation. A combination of LAN ports that can be accessed through a single
interface name. An APA creates link aggregates (often called trunks) that provide a logical
grouping of two or more physical ports into a single “fat pipe.” This port arrangement provides
more data bandwidth and higher reliability than would otherwise be available.

AVIO Accelerated Virtual Input/Output. An I/O protocol that improves virtual I/O performance for
network and storage devices used within the Integrity VM environment. The protocol also
enables support for a greater number of virtual I/O devices per guest. For each virtual machine
containing an AVIO device, the VM Host OS and the guest OS must support AVIO.

backing device Backing store. The physical device (such as a network adapter, a disk, or a file) on the VMHost
that is allocated to guests.

cluster Two or more systems configured together to host workloads. Users are unaware that more than
one system is hosting the workload.

core The actual data-processing engine within a processor. A single processor might have multiple
cores, and a core might support multiple execution threads. A virtual processor core in a virtual
machine is also called a virtual CPU or vCPU.
See also processor.

dedicatedvswitch A vswitch that is dedicated to use by a certain virtual machine. This type of vswitch cannot be
shared by multiple virtual machines running at the same time.

EFI Extensible Firmware Interface. The system firmware user interface that allows boot-related
configuration changes and operations on Itanium-based systems. For example, EFI provides
ways to specify boot options and list boot devices.

entitlement The amount of a system resource (for example, processor resources) that is guaranteed to a
virtual machine. The actual allocation of resources to the virtual machine can be greater or less
than its entitlement, depending on the virtual machine's demand for processor resources and
the overall system processor load.

entitlement cap The maximum amount of computing power allotted to a virtual machine for each vCPU.
guest The virtual machine running the guest OS and guest applications.
guest OS Guest operating system.
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host TheVMHost, which is the controlling operating system that allows multiple virtual machines
(VMs) to be booted on a single server or nPartition.

1.

2. A system or partition that is running an instance of an operating system.

Integrity VM HP Integrity Virtual Machines. The HP product that allows you to install and run multiple
systems (virtual machines) on the same physical host system.

legacy addressing The storage device addressing model that uses the device special file (DSF) path as defined in
HP-UX 11i v2 and earlier versions. In contrast to the agile addressing model introduced with
HP-UX 11i v3, the legacy device special file (DSF) is bound to a specific hardware path to a
storage device. For this reason, a device with multiple paths is represented by several legacy
DSFs. If the physical storage device is reconnected to a host through a different host bus adapter
(HBA) or a different target port, the address represented by the DSF is affected, requiring
reconfiguration of applications, volume managers, or file systems. Likewise, if additional paths
are offered to a given LUN (through the addition of a new SCSI controller or new SCSI target
paths), an equal number of additional DSFs are required to address them.
See also agile addressing.

localnet A vswitch created by default when Integrity VM is installed on a VM Host. The local network
created by this vswitch can be used for communications among guests but not for communication
between the VM Host and any guest or between any external system and a VM guest.

managed node A system running under HP SIM/Insight Dynamics. Systems become managed nodes through
the HP SIM discovery mechanism.

managed system See managed node.
MSE group Multiserver Environment group. A set of Integrity VM servers can be grouped into an Integrity

VM MSE group, as required when a set of Integrity VM servers is also configured as a
Serviceguard cluster.

NIC Network interface card. Also called LAN card, LAN adapter, or PPA.
nPartition A partition in a cell-based server that consists of one or more cells, and one or more I/O chassis.

Each nPartition operates independently of other nPartitions and either runs a single instance
of an operating system or is further divided into virtual partitions.
nPartitions can be used as compartments managed by HP Insight Global Workload Manager
software for Integrity (gWLM) as long as several requirements are met. Refer to the gWLM
online help for a description of nPartition requirements.

processor Also referred to as the central processor unit (CPU), a processor is the hardware component in
a computer that processes instructions and plugs into a processor socket. A processor can
contain more than one core.
See also core.

Serviceguard HP Serviceguard. A product that allows you to create high-availability clusters of HP 9000 or
HP Integrity servers. By installing Serviceguard on an HP Integrity VM Host system,
Serviceguard can manage Integrity VMvirtualmachines as Serviceguard packages. A Serviceguard
package groups application services (individual HP-UX processes) together and maintains
them on multiple nodes in the cluster, making them available for failover. When the VM Host
system fails, the guests automatically fail over to another node in the Integrity VM multiserver
environment (MSEgroup). By installing Serviceguard on HP Integrity guests, each guest becomes
a Serviceguard cluster node. When a virtual machine fails, the guest applications can fail over
to another guest configured as a Serviceguard node or to another server or partition.

shared vswitch A vswitch that can be used by more than one active virtual machine.
Utilization
Provider

The WBEM services provider for real-time utilization data from managed systems.

vCPU Virtual CPU. A single-core virtual processor in a virtual machine.
See also core, processor.

virtual CPU See vCPU.
virtual machine A software entity provided by HP Integrity Virtual Machines. This technology allows a single

server or nPartition to act as a VM Host for multiple individual virtual machines, each running
its own instance of an operating system (referred to as a guest OS). Virtual machines are managed
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systems under Insight Dynamics. Other providers of virtual machines include VMware ESX,
VMware ESXi, or Microsoft Hyper-V.

virtual machine
console

The user-mode application that provides console emulation for virtual machines. Each instance
of the virtual machine console is one console session for its associated virtual machine.

virtual network A LAN that is shared by the virtual machines running on the same VM Host or in the same
Serviceguard cluster.

virtual switch See vswitch.
VLAN Virtual LAN. Defines logical connectivity instead of the physical connectivity defined by a

LAN. A VLAN provides a way to partition a LAN logically such that the broadcast domain for
a VLAN is limited to the nodes and switches that are members of the VLAN.

VM See virtual machine.
VMHost A server running software such as HP Integrity Virtual Machines, VMware ESX, VMware ESXi,

or Microsoft Hyper-V, that provides multiple virtual machines, each running its own instance
of an operating system.

VM Provider The WBEM services provider for Integrity VM host and guest configuration data. The VM
Provider allows Integrity VM Manager to have visibility to VM Host and guest resources. For
VM Manager VM Host views, the provider gives information about the VM Host and its guests.
For VM Manager virtual machine views, the provider gives information about a particular virtual
machine and the identity of its host.

vswitch Virtual switch. Refers to both a dynamically loadable kernel module (DLKM) and a user-mode
component implementing a virtual network switch. The virtualized network interface cards
(NICs) for guest machines are attached to the virtual switches. By associating the vswitch with
a physical working LAN on the VM Host, you provide the guest with the capability of
communicating outside the localnet.

WBEM Web-Based Enterprise Management. A set of web-based information services standards
developed by the Distributed Management Task Force, Inc. A WBEM provider offers access to
a resource. WBEM clients send requests to providers to get information about, and access to,
the registered resources.

HP Confidential 131



HP Confidential132



Index

A
Accelerated Virtual Input/Output (see AVIO)
agile device addressing

Add Storage screen, 88
APA, 107
Automatic Port Aggregation (see APA)
AVIO

performance tuning, 87
support indication, Create Vswitch screen, 107
support information, 91

AVIO backing device
support indication, VM Host view, 40
support indication, Vswitch Properties view, 71

AVIO network
adding, 88
support indication, VM Host view, 42
support indication, VM Properties view, 65

AVIO storage
adding, 88
support indication, VM Host view, 50
support indication, VM Properties view, 68

B
backing device

AVIO support indication, 40, 71, 107
selecting for network, 88
selecting for storage, 89
selecting for vswitch, 107

C
Capacity Advisor

and VM Manager, 11
collecting data for, 77, 111
displaying collected data, 83, 112, 114
historical report, 77, 117
requirements, 13

core, 7
(see also vCPU)

CPU core resources
VM Host view, 33
VM Properties view, 59

Create Virtual Machine wizard, 87
credentials, WBEM, 15

E
entitlement (see vCPU entitlement)
error messages, 123
event logs

viewing, 119
virtual machine, displaying using View menu, 83
VM Host, displaying using View menu, 82

external managers
VM Host view, 34
VM Properties view, 64

F
focus link

VM Host Network tab, 42
VM Host Storage tab, 50
VM Properties Network tab, 65
VM Properties Storage tab, 68
Vswitch Properties Network tab, 72

G
Global Workload Manager (see gWLM)
Go back link, 27
graceful stop timeout

displaying, 59
guest OS

specifying for new VM, 87
starting automatically, 91

gWLM
and VM Manager, 11
policy tasks, 84

gWLM policy
VM Host view, 34, 38
VM Host view (VM Manager), 34
VM Properties view, 60
VM Properties view (VM Manager), 64

H
help

accessing, 26
historical utilization data report

creating, 117
HP Insight Dynamics - VSE for Integrity

accessing VM Manager from, 21
and VM Manager, 9

HP SIM
accessing VM Manager from, 21
and VM Manager, 9
documentation, 121
installing VM Manager on, 14
licensing, 15

HP SMH
accessing from VM Manager, 28
accessing VM Manager from, 24
and VM Manager, 8
documentation, 11
installing VM Manager on, 14
licensing, 15

I
I/O device

adding (network) to new virtual machine, 88
adding (storage) to new virtual machine, 88
adding to existing virtual machine, 93, 94
deleting, 81, 108

Insight Capacity Advisor software (seeCapacity Advisor)
Insight Dynamics
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documentation, 121
Insight Global Workload Manager (see gWLM)
Integrity VM

event logs, 119
overview, 7
viewing version of, 82, 119

L
legacy device addressing

Add Storage screen, 88
licensing, 15
logs (see event logs)

M
Maximize link, 31
memory

displaying, 60
modifying, 93
specifying, 87
utilization, 112
VM Host view, 33
VM Properties view, 59

Migrate Virtual Machine wizard
overview, 100
step 1 screen, 104
step 2 screen, 105

migration
overview, 100
phase timeouts, 103
planning and recommendations, 101
previewing and invoking commands, 105
specifying VM Host, 104
starting, 103
status and error notification, 103
status and errors, 103
support and status, 37, 38, 60, 61
VM Host support status, 34

MSE group
displaying, 34

Multiserver Environment group (see MSE group)

N
network device

adding to existing virtual machine, 94
adding to new virtual machine, 88
deleting, 81, 108
VM Host view, 42
VM Properties view, 65
Vswitch Properties view, 72

P
printer-friendly view, 31
providers

enabling use of, 15
utilization meter status and error information, 125
viewing version of, 82, 119

R
Refresh Data link, 31

Restore Size link, 31

S
security certificates, 19
Serviceguard, 61, 125

MSE group, 34
VM Host View, 37
VM Host view (VM Manager), 35
VM Properties view (VM Manager), 64

Serviceguard packages
and modifying VMs, 94

Serviceguard support
VM Host view , 34
VM Properties view , 60

Shared Resource Domain (see SRD)
Show All link

VM Host Network tab, 42
VM Host Storage tab, 50
VM Properties Network tab, 65
VM Properties Storage tab, 68
Vswitch Properties Network tab, 72

SRD
adding new VMs to, 92
VM Manager Policy menu actions, 84

SSL certificates, 18, 19
startup attribute (see virtual machine startup attribute)
storage device

adding to existing virtual machine, 93
adding to new virtual machine, 88
deleting, 81, 108
VM Host view, 49
VM Properties view, 67

support and feedback, 121
system requirements, 13

T
trusted certificates

enabling, 18, 19

U
utilization data

collecting and viewing, 111
creating a report, 117
viewing, 112

utilization meter
and WBEM credentials, 18
error, 18
errors and status, 125
general discussion, 111
table of available meters, 112
viewing, 112
virtual machine, 36, 60
virtual machine network I/O, 65
virtual machine storage I/O, 68
VM Host, 34
VM Host network I/O, 43
VM Host storage I/O, 50
VM Properties view, 64
vswitch network I/O, 72
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V
vCPU, 7

displaying count and entitlement, 60
modifying allotment, 79
modifying processor entitlement for, 92, 93
specifying processor entitlement for, 87

vCPU count
displaying, 59
specifying, 87, 93

vCPU entitlement
displaying, 59
specifying, 87, 92

View normal link, 31
View Printer-friendly link, 31
virtual CPU (see vCPU)
virtual LAN (see VLAN)
virtual machine, 7

(see also VM Properties)
creating, 78, 87
deleting, 81, 99
Integrity VM event logs, 83
migrating, 77, 100
migration status, 37, 38, 60, 61
modifying, 92
network utilization meters, 65
planning, 87
properties of, 58, 82
restarting, 77, 98
starting, 76, 94
stopping, 76, 96
storage utilization meters, 68
utilization meters, 36, 60
viewing properties of, 58, 82
VM Host view, 36

virtual machine authorization information
displaying, 59

virtual machine console, 91
virtual machine entitlement (see vCPU entitlement)
virtual machine graceful stop timeout

specifying (VM Manager), 61
virtual machine identity

displaying, 59
specifying, 87

virtual machine OS (see guest OS)
virtual machine startup attribute

displaying, 59
modifying, 93
specifying, 87

Virtual Server Environment (see VSE)
virtual switch (see vswitch)
Virtualization Manager

accessing from Insight Dynamics, 21
accessing from VM Manager, 28
accessing VM Manager from, 23
and VM Manager, 10
requirements, 13

VLAN
displaying port assignments, 71
ID, 71

modifying ID, 93
modifying settings of, 79
removing port assignments, 100
specifying ID, 91

VM Host
General tab, 33
Integrity VM event logs, 82
Network tab, 42
network utilization meters, 43
Storage tab, 49
storage utilization meters, 50
utilization meters, 34
view, 32
Virtual Machines tab, 36
Virtual Switches tab, 40

VM Manager
accessing, 21
Create menu, 78
Delete menu, 81
focus link

VM Host Network tab, 42
VM Host Storage tab, 50
VM Properties Network tab, 65
VM Properties Storage tab, 68
Vswitch Properties Network tab, 72

Go back link, 27
help, 26
installing, 13
Maximize link, 31
menus, 75
Modify menu, 79
navigating, 26
new features, 121
Policy menu, 84
Refresh Data link, 31
Restore Size link, 31
setting up, 13
Show All link

VM Host Network tab, 42
VM Host Storage tab, 50
VM Properties Network tab, 65
VM Properties Storage tab, 68
Vswitch Properties Network tab, 72

system requirements, 13
table sorting, 28
tasks, 11
Tools menu, 76
View menu, 82
View normal link, 31
View Printer-friendly link, 31
viewing version of, 15, 82, 119
views and tabs, 31

VM Properties
General tab, 59
Network tab, 65
Storage tab, 67
view, 58

vswitch
creating, 78, 105
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deleting, 81, 108
network utilization meters, 72
properties of, 69, 82
starting, 77, 108
stopping, 77, 108
viewing properties of, 69, 82
VM Host view, 40

Vswitch Properties
General tab, 70
Network tab, 72
view, 69

W
WBEM

setting credentials in HP SIM, 16
setting credentials in HP SMH, 16

WBEM credentials
modifying, 93

WBEM providers
enabling use of, 15
utilization meter status and error information, 125
viewing version of, 82, 119

wizard
migrating virtual machines, 100
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