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Georeferencing Images Using Input Geometry

Data from many sensors now come with detailed acquisition (platform geometry) information that allows
model-based geometric rectification and map registration. This tutorial provides basic information about
georeferenced images in ENVI® Classic and model-based geometric correction using image input
geometry within ENVI Classic. It discusses required data characteristics and covers step-by-step
procedures for successful registration. It assumes that you are already familiar with general image-
registration and resampling concepts.

Files Used in this Tutorial

Tutorial data files are available from the Exelis VIS website.

File Description
cup99hy true.img True-color composite, Cuprite, NV, 1999 HyMap Data
cup9%hy true.hdr ENVI header for above
cup9%hy geo_glt Geometry Lookup File
cup9%hy geo glt.hdr ENVI header for above
cup9%hy geo_igm Input Geometry File
cup9%hy_geo_igm.hdr ENVI header for above
copyright.txt Description of data copyright

1999 HyMap data of Cuprite, Nevada, used for the tutorial are copyright 1999 Analytical Imaging and
Geophysics (AIG) and HyVista Corporation (All Rights Reserved), and may not be redistributed without
explicit permission from AIG (info@aigllc.com).

Background

ENVI Classic provides full support for georeferenced images in numerous predefined map projections
including UTM and State Plane. In addition, ENVI Classic’s user-configurable map projections allow
construction of custom map projections utilizing many different projection types, ellipsoids, and datums
to suit most map requirements.

ENVI Classic map projection parameters are stored in an ASCII text file map proj.txt. The
information in this file is used in the ENVI header files associated with each image and allows simple
association of a “magic pixel” location with known map projection coordinates. Selected ENVI Classic
functions can then use this information to work with the image in georeferenced data space.

Modern sensors collect ephemeris data along with their image data to allow precision georeferencing to
map coordinates. ENVI Classic provides a paradigm for storing sensor geometry information and
automatically correcting image data to specified map projections/coordinates. The input geometry (IGM)
file contains the x and y map coordinates for a specified map projection for each pixel in the uncorrected
input image. The geometry lookup (GLT) file contains the sample and line that each pixel in the output
image came from in the input image. If the GLT value is positive, there was an exact pixel match. If the
GLT value is negative, there was no exact match and the nearest neighboring pixel is used.
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Three ENVI Classic routines available via the ENVI Classic main menu bar are provided to do the
georeferencing:

o Map > Georeference from Input Geometry > Build GLT builds a GLT file from input
geometry information.

o Map > Georeference from Input Geometry > Georeference from GLT performs
geocorrection utilizing the Geometry Lookup images.

o Map > Georeference from Input Geometry > Georeference from IGM performs
geocorrection utilizing the input geometry and creates the GLT file.

Users must have the IGM or GLT file as a minimum to conduct this form of geocorrection. Image
geometry data files are available for delivery as products from several sensors, including AVIRIS,
MASTER, and HyMap. HyMap is a state-of-the-art aircraft-mounted commercial hyperspectral sensor
developed by Integrated Spectronics, Sydney, Australia, and operated by HyVista Corporation.

HyMap provides unprecedented spatial, spectral, and radiometric excellence. The system is a
whiskbroom scanner utilizing diffraction gratings and four 32-element detector arrays (1 Si, 3 liquid-
nitrogen-cooled InSb). Data consists of 126 spectral channels covering the 0.44 - 2.5 mm range with
approximately 15nm spectral resolution and 1000:1 SNR over a 512-pixel swath. Spatial resolution is 3-
10 m (approximately 8 meters for the Cuprite data used here). Because the instrument uses a gyro-
stabilized platform, the initial image geometry (prior to this correction) is quite good and corrections are
minor.

While geocorrected images produced using the above methods are visually pleasing and map-correct,
they do have several practical drawbacks. First, they have null values around their edges that must be
masked in processing. Second, they are often inflated in size by replicated pixels as indicated in the
GLT files. These two disadvantages lead to our suggestion to acquire and process the hyperspectral
imagery in its raw spatial format, then apply the geocorrection to the derived final products. It is not
recommend that you geocorrect the entire reflectance data cube.

The following sections provide examples of the model-based geocorrection built into ENVI Classic.
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Opening and Exploring Uncorrected HyMap
Hyperspectral Data

This portion of the tutorial will familiarize you with uncorrected image geometry and characteristics.
1. From the ENVI Classic main menu bar, select File > Open Image File.

2. Select cup99hy true.img and click Open. The Available Bands List appears on your screen
and the image is loaded into the display. This is a true-color image extracted from the HyMap
reflectance data.

3. Examine the characteristics of the uncorrected HyMap data by displaying the Cursor
Location/Value dialog. Double-click in the Image window. A dialog box displays the location of
the cursor in the Image, Scroll, or Zoom windows. The dialog also displays the screen value and
the actual data value of the pixel underneath the crosshair cursor.

4. Move the cursor throughout the image. Examine the pixel locations and data values, and
geometric relations between pixels (rotation, road curvature, etc.).

5. From the Cursor Location/Value dialog menu bar, select File > Cancel to dismiss the dialog.

& #1 (R:Band 16,G:Band 8,8:Band 2):cu... [= |[B][X]
File Owverlay Enhance Tools Window
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Opening and Exploring HyMap Input Geometry
Data (IGM)

1.
2.
3.

From the ENVI Classic main menu bar, select File > Open Image File.
Select cup99hy geo igm, and click Open. The Available Bands List appears.

From the Available Bands List dialog, select the IGM Input X Map band. It will be displayed in
the Selected Band field.

Click Display #1 and select New Display.
Click the Load Band button to load the image into the new display.

Examine the characteristics of the uncorrected HyMap data using the Cursor Location/V alue
feature. Move the cursor throughout the image, and examine the pixel locations and data values
(map coordinates).

Load the IGM Input Y Map band into a new display and explore the image using the Cursor
Location/Value feature.
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Geocorrecting an Image Using an IGM File

1.

From the ENVI Classic main menu bar, select Map > Georeference from Input Geometry >
Georeference from IGM. The Input Data File dialog appears.

Click the Open drop-down button and select New File.

3. Select the cup99hy.eff file and click Open to return to the Input Data File dialog.

S

10.
11.
12.

Select the cup99hy.eff file and click the Spectral Subset button. The File Spectral Subset
dialog appears.

Select Band 109 and click OK to return to the Input Data File dialog.
From the Input Data File dialog, click OK. The Input X Geometry Band dialog appears.
Select the IGM Input X Map band and click OK. The Input Y Geometry Band dialog appears.

Select the IGM Input Y Map band and click OK. The Geometry Projection Information dialog
appears.

For both the input an output projections, select UTM, the North America 1927 datum, Zone 13,
and click OK. This produces an image with the same map projection as the input geometry. The
Build Geometry Lookup File Parameters dialog appears.

Type or choose an output filename for the GLT file.
In the Georeference Background Value field, type -9999.

Type or choose an output filename for the georeferenced image and click OK.

Displaying and Evaluating Correction Results

1.
2.

From the Available Bands List, load the Georef band into a new display.

Examine the characteristics of the data using the Cursor Location/Value feature. Move the cursor
throughout the image, and examine the image geometry, pixel locations, map coordinates, and
data values.

Close the IGM displays when finished examining results.
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Examining Geometry Lookup (GLT) Files

1
2
3.
4

From the ENVI Classic main menu bar, select File > Open Image File.
Select cup99hy geo glt, and click Open. The Available Bands List appears.
Load the GLT Sample Look-up band into a new display group.

Examine the characteristics of the data using the Cursor Location/Value feature. Move the cursor
throughout the image, and examine the pixel locations and data values (input pixel locations). Pay
particular attention to the negative values, which indicate use of nearest neighbor pixels.

Load the GLT Line Look-up band into a new display group, and explore the image using the
Cursor Location/Value feature.
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Geocorrecting an Image Using a GLT File

1. From the ENVI Classic main menu bar, select Map > Georeference from Input Geometry >
Georeference from GLT. The Input Geometry Lookup File dialog appears.

2. Select the cup99hy geo glt file and click OK. The Input Data File dialog appears.

3. Select the cup99hy.eff file and click the Spectral Subset button. The File Spectral Subset
dialog appears.

4. Select Band 109 and click OK to return to the Input Data File dialog.

5. From the Input Data File dialog, click OK. The Georeference from GLT Parameters dialog
appears.

6. Inthe Background Value field, type -9999.

7. Type or choose an output filename for the georeferenced image, then click OK.

Displaying and Evaluating Correction Results
1. From the Available Bands List, load the Georef band into a new display group.

2. Examine the characteristics of the data using the Cursor Location/Value feature. Move the cursor
throughout the image, and examine the image geometry, pixel locations, map coordinates, and
data values.
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3. Close the GLT displays when finished examining results.

& #5 Georef (Band 109:cup99hy.eff):georef... |:”E”E|
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Using Build GLT with a Map Projection

1.

From the ENVI Classic main menu bar, select Map > Georeference from Input Geometry >
Build GLT. The Input X Geometry Band dialog appears.

Select the IGM Input X Map file and click OK. The Input Y Geometry Band dialog appears.

Select the IGM Input Y Map file and click OK. The Geometry Projection Information dialog
appears.

At the bottom of the Geometry Projection Information dialog, select State Plane (NAD 27) as the
Output Projection.

Click the Set Zone button, select Nevada West (2703) as the output zone, and click OK.

Click OK in the Geometry Projection Information dialog. The Build Geometry Lookup File
Parameters dialog appears.

Type or choose an output filename for the GLT file and click OK to create the GLT.

Using the steps listed under "Geocorrecting an Image Using a GLT File" on page 8, geocorrect
Band 109 of the cup99hy.eff data and compare the resulting image to the UTM-corrected
image.

Close all display groups by selecting Window > Close All Display Windows from the ENVI
Classic main menu bar.
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Overlaying Map Grids

1. Inthe Available Bands List dialog, load one of the georeferenced images produced above.

2. From the Display group menu bar, select Overlay > Grid Lines. The Grid Line Parameters
dialog appears. A virtual border will be added to the image to allow display of map grid labels
exterior to the image.

3. Change the Map Grid Spacing to 1000 and the Geographic Grid Spacing to 1 minute, and click
Apply.

4. Examine the characteristics of the data using the Cursor Location/Value feature. Compare the
grids to the pixel coordinates.

& #1 Grid Line Parameters EI@|E|
File Options Help

Pisel Grid| O 41|

Map Giid[On 41
Grid Spacing |1 0o Ltz

Geugraphicarid|'3'ﬂ ﬂ DMS < DD

Spacing |0 il |0.00

Apply | YWindow ¥ Image W Scroll W Zoom
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Saving the Image

ENVI Classic gives you several options for saving and outputting your image maps. You can save your
work in ENVI Classic’s image file format, or in several popular graphics formats (including Postscript)
for printing or importing into other software packages.

1. From the Display group menu bar, select File > Save Image As > Image File. The Output
Display to Image File dialog appears.

2. Ensure the Output File Type drop-down menu reads ENVI Classic.
3. Select the Memory radio button and click OK to output the image.

4. Load the RGB image into another display and examine the results of the grid annotation as a
raster image.

Direct Printing

ENVI Classic also allows direct printing to devices supported by your operating system. Select File >
Print and follow your standard printing procedures. For example, in Microsoft Windows, you would
select the printer name from the pulldown menu, change the properties as desired, and click on OK to
print the image. Once you have selected all of the parameters and clicked OK, a dialog appears to allow
you to set additional basic ENVI Classic printing parameters similar to those used for postscript output.
Set these as desired and click OK to begin printing.

Ending the ENVI Classic Session

You can quit your ENVI Classic session by selecting File > Exit from the ENVI Classic main menu bar.

Copyright Notice:
ENVI Classic is a registered trademark of Exelis Inc.

QUAC and FLAASH are registered trademarks of Spectral Sciences, Inc.
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