UPDATES & TITLE UPDATES Support Start Here Technical Support

    • Level   2
    Reposting to the new forums so I am able to help 
    eastmanblues Computer [co] Posted: Wed, Aug 19 2009 9:37 AM
     

     UPDATES & TITLE UPDATES Support Start Here


    I encourage you to post here is you are having a troubles applying or downloading an update.

    Generally it is best practice to sign in to LIVE and apply the update that GFWL guide prompts you to when signing in. Sometimes to troubleshoot you may need to download the update manually. If an update fails to download it is most likely a connectivity issue I have provided update links below. But it is best to try these things first.

    • Ensure that all the required Games for Windows LIVE ports are open.

    TCP 80
    UDP 88
    UDP 3074
    TCP 3074
    UDP 53
    TCP 53
    TCP 443

    • Try circumventing the router.

    Other programs are also known to conflict such as Antivirus, Firewall software, Xfire/Hamachi. Sometimes if disabling the software does not work it may need to be uninstalled for troubleshooting purposes. If you have pin pointed the issue to be with the Anti Virus/Firewall software it is recommended that you contact the support of your provider.

     It seems like my update is taking for ever or will not update

    • Games for Windows Live will not update.

    The update bar sits there & does nothing. This could be two issues. If you are connectible then the blue bar should gradually get to 100%. After it gets there depending on your PC's specifications, it could take a couple minutes before the update closes the game.

    If you are on Vista it will give a UAC (user access control) prompt that you will have to allow in order to get the update to continue. This prompt does not always show on top of all open windows, like it is supposed to. I have run into this before & had to Alt+Tab to be able to see the prompt. You can disable UAC inside the user profile settings. This will now close the game & an update module will popup. It will automatically install the update.

    (InGlocksWeTrust)

    • I am stuck in a update loop

    Sometimes the update will not take if the update cannot find the specified path of the game installation folder. This happens when the game install path is not specified in the update sometimes this happens with Digital Distrubtion such as Steam, Impulse. This may also happen if you choose a custom install pointing to a different drive or directory.

    You can find the install logs for title/client updates here

    Windows Xp

    %userprofile%\Local Settings\Application Data\Microsoft\GFWLive\Logs\

    Vista & 7

    %localappdata%\microsoft\GFWLive\Logs

    If the patch install runs but fails to find the specified path or does not install you may want to force the install by pointing to the game path. For example you will need to find the approprate setup.exe file.

    Click >Start> Run >Type

    c:\<example directory>\setup.exe" /f  "<path to game folder>"

    Note the /f is a switch that tells the install that you are going to specify the path of the game install folder. Leave the quotes "<path to game folder>" as they handle wildcards in the directory structure.

    Another thing you can do is extract the update files in to the Game Install Folder and run setup from with in the directory (If you are still having trouble installing the game patch at this point it would be upto you to contact the game developer for further assistance.)

     You may also try this - Launch the Setup.exe or Titleupdate.msi - Launch the game you are trying to patch just long enough for the installer to find the game and quickly close it by means of Task Manager or Right Click on Task Bar and selecting Close.

    Here is a bunch of Links to manually update LIVE titles. I have either uploaded the patches myself and or have tested them when I created this thread. Now with updates since they can be ongoing may be out of date. I will attempt to keep this page up to date and current as much as possible.

    • This is great but the update I require is not listed here! - Well I have complied this list out of common update issues I have encountered here on the forums. If you do not see an update that you require please post and I will do my best to update this page to add it for you and others.
    • I need to update my purchase from Games on Demand - Be very sure your game needs an update. Game on Demand titles ussually have the latest Digital Distrubution Patches already in place

    HAPPY UPDATING

    Battlestations Pacific

    Digital Distribution Patch 1.02 (Steam or D2D)

    http://dlh.net/getfile.php?78:ec21b68a749c381d:b4cbf66d0ef4290f:/Battlestations_pacific/battlestations_pacific_ddpatch102.zip

    Batman Arkham Asylum

    http://eidos.http.internapcdn.net/eidos_vitalstream_com/batman/Batman_TU_v1.1_EFIGS.exe 

    Batman AA 1.1 Digital Distrubtion http://www.direct2drive.com/patches/

    Bioshock 2

    http://download.xbox.com:80/content/5454085c/tu10000083_10000183.cab

    http://download.xbox.com/content/5454085c/tu10000083_10000483.cab  Latest *

    BulletStorm

    -

    Dead Rising 2

    http://download.xbox.com/content/4343080e/tu10000084_10000284.cab

    FABLE III

    http://download.xbox.com/content/4d53090a/tu10000083_10000283.cab?n=6C149862C50B6A0F

    Fallout 3
    Please note that Fallout 3 has different regional patches. Make sure you are applying the patch for the correct version of your game. If the wrong patch is applied it can cause LIVE to act abnormally or not at all. Certain regional copies of Fallout 3 do not support the latest patches.

    http://fallout.bethsoft.com/eng/downloads/updates.html

    GEARS OF WAR

    This fixes Modified Executable Error

    http://support.microsoft.com/kb/967644

    http://download.microsoft.com/download/5/1/A/51A3F34C-E65D-47D1-9E28-02E3356FEC3F/GearsPC_TU3_Microsoft.exe

    www.fileplanet.com/.../Gears-of-War-PC-Patch-3 

    www.shacknews.com/.../gears-of-war-patch-3

    Note:
    There is a know issue with Asus Auto Updater that prevents the Gears of War update from applying. If you are unable to install the update please check if Asus Auto Updater is running and disable or uninstall then re-apply the update.

    *Games on Demand Version of Gears of War does not require a patch to be apllied as it is packaged with it.

    Grand Theft Auto IV & Episodes from Liberty Cities

    http://support.rockstargames.com/entries/479479-gta-iv-title-update-installation-issues

     

    Halo 2 For Windows VISTA

    http://www.microsoft.com/games/halo2/

    http://download.microsoft.com/download/b/0/e/b0ec1acf-8623-4520-9764-75baaffc0718/Update.exe

    Operation Flashpoint RED RIVER

    http://download.xbox.com/content/434d083e/tu10000081_10000381.cab

    Section 8 

    http://download.xbox.com/content/535007e3/tu10000084_10000284.cab

    Section 8 Patch V1.1 (Retail) http://www.fileplanet.com/files/200000/208551.shtml

     

    Section 8 Patch v1.1 Fixes the "No disc inserted" Error [Digital Distribution] http://www.direct2drive.com/patches/

    Shadowrun

    http://www.microsoft.com/downloads/details.aspx?familyid=C975179C-DFBB-4A99-B0D5-7ABF45D00C71&displaylang=en

    Tinker

    http://www.fileplanet.com/212808/210000/fileinfo/Tinker-Update-1.1

    The Club

    http://download.xbox.com/content/534507f6/tu10000082_00000000.cab

    007 Quantum of Solace

    http://download.xbox.com/content/41560829/415608291000008110000182.cab

    http://www.bigdownload.com/games/quantum-of-solace/pc/quantum-of-solace-v11-patch/

    (Does NOT work with Steam Version)^

    http://www.fileplanet.com/198687/190000/fileinfo/Quantum-Of-Solace-007-Patch-v1.1

    (Steam Patch - For Users Having issues with update)^

    Red Faction Guerrilla

    http://www.fileplanet.com/files/200000/208549.shtml (Works with Retail Copies not test on Digital Distrubution)

    Universe at War Earth Assault

    http://help.sega.com/index.php?_m=downloads&_a=viewdownload&downloaditemid=3&nav=0,1

     


    Games for Windows LIVE Marketplace Client & Redistributable


    http://go.microsoft.com/?linkid=9640147 Current Build
    Windows Xp Hotfix

    http://download.microsoft.com/download/8/B/2/8B2DC324-ACE3-4EF4-A4F4-56A055989C3B/WindowsXP-KB938759-x86-ENU.exe

    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Am I missing anything I am sure I am please let me know and I will add it if it checks out.

     

    Are you still having trouble?

    Phone Support
    Finally, if none of the above steps have helped you resolve your issue, and you are sure the issues is with LIVE and not covered on the forums, you can use the following steps to contact LIVE support via phone in North America only:

    Please dial 1-877-274-4349 from 9 am EST (6 am PST) to 1 am EST (10 pm PST).  Our technical support agents there will be more than happy to assist you.

     

     

    Top 10 Contributor
    Posts 2,375

     

    I encourage you to post here is you are having a troubles applying or downloading an update.

     

    If you are having Trouble  Please provide the following information when posting

    Game:

    Error:

    Windows Version: Press Start > Run >type WINVER > press OK - provide version and build number, if displayed.

    Windows System Type? (Bit version) 32bit  or 64bit

    AntiVirus & Firewall Software:

    Did the patch download through LIVE?:

    Where was the game purschases and in what format? For example: new retail boxed title from gamestop, Direct2Drive, Best Buy, Steam, Ebay (used), etc.

     

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.

     

    • Level   3

    Eastman... Epic has revamped their site, and could care less about updating the page for GOW, and now have buried the forums in a god awful place. Further proof of how they feel about this game is the PC update link from the Gears of War site no longer works. Fileshack, and Fileplanet have links to them since the developer could care less. Starting to rethink my pre-order for number 3 now.

     

    www.fileplanet.com/.../Gears-of-War-PC-Patch-3

     

    www.shacknews.com/.../gears-of-war-patch-3

    • Level   2

    support.microsoft.com/.../967644

    This will still work for the gears of war patch

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.

     

    • Level   3

    Nice that is better. Can you edit the post then? Not sure if you could say they are more trustworthy then a microsoft download.

    • Level   1

    Game: Dead Rising

    Error: DEBUG: Error 2911

    The symptom: Infinite update loop.  Log into Windows Live, it sees I need an update, I get the update from Live, exit out, get the installation box after, and when I reload the game once again it asks for an update.

    Windows version: 6.1, build 6700.

    Windows 7: 64-bit system.

    Tested with no AntiVirus and Firewall Software activated.

    The patch seems to have downloaded through LIVE, but can not be sure.

    Purchased from Steam.

    Even after going through your suggestions for working with the infinite loop issue, the problem still persists.  This included downloading the update manually, pointing it to the game directory in the methods you described, etc.  And naturally, I have reinstalled the game as well.  My brother installed the game and updated without any issues on his Windows XP system, so I am left suspecting my OS may be the issue.

    While looking through the logs for the TitleUpdate, I even see a good result at the bottom:

    === Logging stopped: 6/14/2011  21:44:09 ===

    MSI (c) (68:10) [21:44:09:813]: Product: Dead Rising 2 -- Installation completed successfully.

    MSI (c) (68:10) [21:44:09:814]: Windows Installer installed the product. Product Name: Dead Rising 2. Product Version: 1.0.0001.130. Product Language: 1024. Manufacturer: Capcom. Installation success or error status: 0.

    HOWEVER, this seems to be the issue with the installation:

    DEBUG: Error 2911:  Could not remove the folder C:\Config.Msi\.

    The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2911. The arguments are: C:\Config.Msi\, ,

    Action ended 21:44:06: InstallFinalize. Return value 1.

    Action ended 21:44:06: INSTALL. Return value 1.

    That ends the Action portion of the log.  I assume this caused the installation to crash out, so I believe this may be the issue.  Let me know if you require more information to look into this.

    • Level   2

    Your Version of the game is it from STEAM, D2D ? What Version of Game is it? Can you provide the full the path of the game ? 

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.

     

    • Level   1

    My version is from Steam.  It's the one that was on sale last weekend, and (as far as I know), only one listed.  No expansions, no DLCs, just the base purchase.

    The path to the game folder is the default for Steam: C:\Program Files\Steam\steamapps\common\dead rising 2

    Here is the unusual part though, while the guts of the game are in that folder, it also put some other Dead Rising stuff in: C:\Program Files (x86)\steam\steamapps\common\dead rising 2

    That "x86" path contains data, frontends, a couple movies, and a couple other stuff.  Only about 20 MB in size though.  I tried running the installer pathed to both paths, neither produced results.  Not entirely sure why the x86 folder exists, but was produced as-is, and I did nothing to alter it.

    • Level   2

    it sounds like the installer is confused because you should only have Steam in the Program Files (X86) Folder for 64 bit. Are you running Multiple Operating systems?

    Have you tried any the manual steps above ?

    Please post the entire title update log for me to look

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.

     

    • Level   1

    This is now working, but what I did may surprise you...

    Per the log, yes, GFWL is indeed putting the patch files in the Program Files (X86) path (I'll spare you posting the log entries to prove this.  I actually work in a different field of IT, so trust me on this one).  The patch contents amounts to 20 MB on my hard drive (it's interesting really, a mere 20 MB for a 6 GB game is causing so much turmoil).  So I backed up both the patch files, and the game files (remember folks, number one priority is being able to revert your change!)  I then pasted the patch files into my Program Files directory, overwriting what they want.  Then I pasted the 6 GB game files into the Program Files (X86) path, not overwriting at any attempt.  Effectively, I was hoping my game would be fully updated in both directories, so depending on where GFWL was checking for the updated version, one of them is guaranteed to work (I hate GFWL, so I assumed it could check in one directory, but update in the other.  Effectively a worst-case scenario.)  When I ran the game from the Program Files (X86) path, sure enough it doesn't require an update, and I can go into co-op and everything (so far as I see.  If I experience further problems, I will let you know.)  If you want more information on what I'm doing, to assist you with formulating documentation, let me know and I will clarify and contribute any way I can.

    Now, all that aside, GFWL is a thoroughly painful service, I don't understand why I should be locked out of a game just because of a simple update.  Please improve QA, I beg you.  I don't have the option to purchase games (like Dead Rising 2) without GFWL, and knowing it could cause me many hours of grief (which I'm sorry, it has) is painful.  Furthermore, the amount of searching I had to do in order to find this topic is astounding (that's partially on me actually, this is the site where I should go to look for help after all).  It should be more obvious how to contact support.

    With all that said, I applaud you for your help.  I have tried and understand why the manual steps you posted would work (and I'm sure others have used them and got their games to work).  Most impressive to me though is your response time.  I am just one customer, and as small as your posts are, you replied twice in one day, and the very next day.  GFWL may make me want to cry, but knowing there is support out there ready and willing to help may restore my faith in supported games.  Thank you for your assistance, and I hope I won't need to ask for your help again :)

    • Level   1

    i was updating, but dosen`t red my games and i don`t know ow fixed this mistake

    • Level   1

    I'm stuck in an update loop for DiRT 3,

    I'm not sure what the error is but it basically updates the game through Live when I start it up, and then when it's done it restarts and asks me to update once more. It's a retail version of DiRT 3, and I'm pretty sure none of my antivirus software is blocking it.

    • Level   2

    Domzino, After you download the update do you exit the Game?

    If so does the update complete?

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.

     

    • Level   2

    Added Operation Flashpoint Red River

    Editing this post is proving to be problematic

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.

     

    • Level   1

    I am stuck at updating Lost Planet 2. After I create the account, It prompt me to update the GfWL, however, the erro message soon appear " Cannot Update, please make sure you are conneting to the Internet. error 0x80070005"

    What Can I do for that?

    • Level   4

    Sure, you could try that, at least that will let you rule out an outdated installation, or currupt one.

     

    But here are a couple other things to try:

    1. Click Start
    2. Run
    3. Type services.msc
    4. Scroll down some to the Windows Live ID Assistant
    5. Double click on it to start the service
    6. Set the service to automatic
      1. or set it to automatic delayed if automatic doesn't work out right (sometimes a conflict can occur)

    OR

    You could create a separate User Account with full Administrator rights, not best idea, but it will probably work.

    OR

    Start Internet Explorer
    On the Tools menu, click Internet Options
    Click the Advanced tab
    Under Security, clear the Check for Server certificate revocation check box.
    Click OK
    unset your windows password
    Click Start, click Control Panel and go to User Accounts.
    b. If you have multiple accounts on the same computer, choose your user account.
    c. Click Remove the password. (You will be asked to enter your current password if you wish to remove your password. Please enter your current password. If you don’t have a password, please create one first to create a cache for Net Services then remove it afterwards).
    d. Click on the Remove Password button.
    e. Open Windows Live Messenger and verify if you can now sign in.

    Windows 7:
    a. Click Start, type user account in the Search programs and files box; press ENTER.
    b. Click on the "Manage User Account" link to access all Windows accounts on your computer. Log-in as an administrator user if prompted.
    c. Double-click on the user name (Windows profile) to remove their password protection
    d. Click on "Remove the password" link
    e. Windows 7 will display the Remove a password screen; for security reasons, Windows asks you to supply the current password (at least for administrator accounts), and click on the Remove Password button. After a few seconds, Windows 7 brings you back to that particular user's profile, confirming that the password has been successfully removed.
    f. Open Windows Live Messenger and verify if you can now sign in.

    9. If you sign in successfully, you can now set a password for your Windows Profile by following these steps:
    a. Click Start and choose Control Panel
    b. Click User Accounts link
    c. In Make changes to your user account window, click Create a password for your account link
    d. After you enter your password, click Create password button to confirm your new password

    - taken from the Games for Windows LIVE Facebook Pages . . .

    Download and install the Windows LIVE ID Sign-In Assistant if you don't have it for some reason.

    And lastly:

    Wedge The Jedi

    If you don't know me I'm an MS employee and I've worked on the GFWL project since it started (they don't have my icon on my profile yet):

    That message generally means that the Windows Live Sign-in Assistant is not running on your machine. Even if it is installed and set to 'auto start', it doesn't mean that something is blocking it from starting up when it tries.

    Open up a command window run as Administrator (go to All Programs->Accessories and right click to select 'Run As Administrator' on 'Command Prompt'). The run the following commands:

    net stop wlidsvc

    net start wlidsvc

    That should stop the service and then restart it manually. If it gives you an error with the stop command (like, 'service is not currently running') then for some reason it is not auto starting on your machine. If the start command fails then that would be the problem :) See if there is more information on why the service couldn't start or you can also look in your system's event log to see why it wouldn't start.

    The only other thing that I can think of is if you don't have the .Net 3.5 software installed on your machine. When you download the GFWL Software from this page, the downloader should make sure that you have the needed software already installed. If you haven't tried that yet give it a whirl.

    http://www.gamesforwindows.com/en-US/Download/

    I hope one of these helps you out.