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editing projects in DaVinci Resolve. 
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The Edit Page User Interface
The Edit page has evolved into a source-record style NLE that contains nearly every editorial 
tool you need for creative editing through finishing. The Edit page is divided into three main 
regions: the browsers found at the left, the Viewers at the top, and the Timeline at the bottom, 
all of which work together to let you import, edit, and trim timelines with a flexible variety of 
tools and methods.

The Edit Page in its entirety

The Interface Toolbar
At the very top of the Edit page is a toolbar with buttons that let you show and hide different 
parts of the user interface. These buttons are as follows, from left to right:

The Interface toolbar

 � Media Pool/Effects Library/Edit Index height button: Lets you set the area used by the 
Media Pool, Effects Library, and/or Edit Index to take up the full height of your display 
(you can display two at a time), giving you more area for browsing at the expense of a 
narrower timeline. At half height, the Media Pool/Effects Library/Edit Index are restricted 
to the top of the UI (you can only show one at a time), and the timeline takes up the full 
width of your display.

 � Effects Library: Opens or hides the repository of all transitions, generators, OpenFX, 
and audio filters available to use in the Edit page.

 � Edit Index: Opens or hides the list of all edit events in enabled tracks of the Timeline.

 � Metadata: Hides or shows the Metadata Editor.

 � Inspector: Shows or hides the Inspector, which shows you the transform and 
compositing effects of selected clips, or the editable options of selected effects such 
as transitions or generators.
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The Media Pool
In addition to containing all of the media used in a project, starting in version 12 the Media Pool 
also contains all timelines that have been either imported or created within that project. The Bin 
list at the left shows the same hierarchical list of bins used for organizing your media, which you 
can use to organize your timelines. 

By default, the Media Pool consists of a single bin, named “Master,” but you can add more bins 
as necessary to organize timelines and clips by right-clicking anywhere in the empty area of the 
Media Pool and choosing Add Bin. You can rename any custom bin by double-clicking on its 
name and typing a new one, or by right-clicking a bin’s name and choosing Rename Bin. The 
bin view can be hidden or shown via the button at the upper left-hand corner of the Edit 
page toolbar.

The Media Pool in Thumbnail mode, shown in half-height mode

The browser area to the right shows the contents of the currently selected folder. Every timeline 
you create, and every AAF, XML, or EDL file you import, appears here. You can create or import 
as many timelines as you need within a single project.

As in the Media page, the Media Pool can be displayed in either Icon or List view. In List view, 
you can sort the contents by any one of a subset of the total metadata that’s available in the 
Metadata Editor of the Media page. Of particular interest to editors are columns for Name, Reel 
Name, different timecode streams, Description, Comments, Keyword, Shot, Scene, Take, Angle, 
Circled, Start KeyKode, Flags, Usage, Resolution, and Frames Per Second.
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Searching for Content in the Media Pool
An optional Search field can be opened at the top of the Library that lets you quickly find 
plug-ins by name or partial name. 

To search for an OpenFX filter by name:

1 Click the magnifying glass button at the upper right-hand corner of the OpenFX panel.

2 Choose the particular column of information you want to search (or # to search all 
columns) using the Filter by pop-up menu.

3 Type your search string into the Search field that appears. A few letters should be 
enough to isolate only those plug-ins that have that character string within their name. 
To show all clips again, click the cancel button at the right of the search field.

For more information on using the Media Pool, see Chapter 8, “Adding and Organizing Media.”

More About Timelines
DaVinci Resolve projects contain one or more edited timelines (sometimes called a sequence in 
other applications) which are also organized in the Media Pool, and displayed in the Timeline 
editor (referred to as “the Timeline”). Timelines contain clips, the source media of which is kept 
in the Media Pool, and which also appear as edit events in the Edit Index that can be shown at 
the right of the Timeline.

Timelines, Grades, and Versions
Within any given timeline, grades are associated with the timecode of the source clip they’re 
applied to. That means that as you alter the timeline, each clip’s grade moves along with it, 
making it extremely easy to move back and forth between editing and grading as your needs 
require. By default, each timeline in a project has independent sets of grades using Local 
versions; this is true even if your timelines are duplicates. That means each clip within every 
timeline has a completely independent grade.

However, if you switch the clips in one or more timelines to use Remote versions, a clip’s grades 
are shared by every instance of that clip in all timelines with clips that also use Remote versions. 
If you import a new timeline that rearranges clips into a different order and switch it to using 
Remote versions, then grades will automatically follow the clips, so that the clips within each 
new timeline inherits the grades applied to those same clips in other timelines.

You can switch a timeline between using Local and Remote grades at any time. For more 
information on using Local versus Remote versions, see “Using Versions to Manage Grades” in 
Chapter 28, “The Gallery and Grade Management.” You can also copy grades from one timeline 
to another using the ColorTrace feature. For more information about ColorTrace, see Chapter 
32, “Copying Grades Between Timelines Using ColorTrace.”

Taking Advantage of the Media Pool’s Usage Column

In List view, the Usage column does not automatically update to show how many times 
a particular clip has been used. However, you can manually update this metadata by 
right-clicking within the Media Pool and choosing Update Usage Data from the 
contextual menu that appears. Afterwards, each clip will display how many times it’s 
been used in this column. Clips that have not been used yet display an x.
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Enabling the Use of a Master Timeline
Previous versions of Resolve had a Master Timeline, which consisted of one long timeline 
containing every clip in the Media Pool, arranged by default in ascending order by timecode. 
While the Master Timeline was useful for a variety of tasks, architectural improvements have 
rendered it unnecessary, and by default the Master Timeline does not appear in new projects 
created by DaVinci Resolve version 10 or later.

However, if you want a Master Timeline in order to have a single timeline that always contains 
all clips currently in the Media Pool, there’s a way you can create one. You need to do it 
immediately upon creating a new project, before adding any media to the Media Pool. Once 
you’ve added one or more clips to the Media Pool, the option you need to do so will 
be disabled.

To create a new Master Timeline:

1 Create a new project, open the General Options panel of the Project Settings, and turn 
on the “Automatically match master timeline with media pool” checkbox. If you also 
want all clips to use Remote versions as you grade by default as in previous versions of 
Resolve, you can turn off the “Store grade with local version by default.”

Turning on the option to use a Master Timeline

2 Click Apply, and close the Project Settings window.

3 Open the Edit page, and choose File > New Timeline (Command-N).

4 When the New Timeline Properties window appears, turn the Empty Timeline checkbox 
off, and click Create New Timeline.

Now, in addition to the new timeline, a Master Timeline appears in the Timeline list.

 

Creating a Master Timeline

TIP: If you want to make sure that you always have a Master Timeline when you create 
new projects, you can alter the Project Setting preset for your user account to reflect 
these settings, or you can create a new Project Setting preset with these settings that 
you can easily switch to.
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The Master Timeline consists of one long sequence of every clip in the Media Pool, arranged in 
ascending order by timecode. Each clip in the Master Timeline appears at its full duration, 
regardless of the duration of corresponding clips in an EDL-, AAF-, or XML-imported timeline. 
Whenever you add more clips to the Media Pool, they’re automatically added to the 
Master Timeline.

Opening Timelines in the Media Pool
Timelines can be organized like any other clip in the Media Pool. To open or switch among 
timelines, use the following procedures.

To switch timelines, do one of the following:

 � In the Edit page Media Pool, double-click a timeline.

 � In the Edit page Timeline Viewer, choose a timeline from the Timelines pop-up menu at 
the top of the viewer.

 � In the Color page, choose a timeline from the Timelines pop-up menu at the top of 
the viewer.

To switch timelines using the DaVinci control panel:

1 Press MODES, above the fourth trackball on the Center panel.

2 Press the SWITCH SESSION soft key repeatedly to switch among all available timelines 
in the Project Browser.

3 Press MODES again when you’re finished.

The Master Timeline is useful for organizing media for which no editing has yet been 
done, such as when grading digital dailies. The Master Timeline is also useful for 
identifying a range of similar clips, based on their similar ranges of timecode. For 
example, you could find all the talking head shots from a particular section of tape 
clustered together in the Master Timeline.
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Effects Library Browsing
The Effects Library contains a folder with the different Video Transitions, Title Effects, 
Generators, and Filters that are available for editing in the Timeline. 

The Effects Library

The Toolbox
The Toolbox contains all Transitions, Titles, and Generators that ship along with 
DaVinci Resolve.

 � Transitions: You can drag any video transition to any edit point in the Timeline that has 
overlapping clip handles to add it to your edit; you have the option to drag the transition 
so that it ends on, is centered on, or starts on the edit point. You can also use various 
contextual menus and keyboard shortcuts which are described later in this chapter.

 � Titles and Generators: Titles and Generators can be edited into the Timeline like 
any other clip. Once edited into the Timeline, you can open that clip into the viewer 
to access its controls in the Inspector, for customization. You can choose a standard 
duration for generators to appear with in the Editing panel of the Project Settings.
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OpenFX
DaVinci Resolve supports the use of third-party OpenFX transitions and generators in the Edit 
page. Once you install these effects on your workstation, they appear in this panel of the 
Effects Library, organized by type and group depending on the metadata within each effect. 
These transitions and generators can be used in the same way as other transitions and 
generators in Resolve.

AudioFX
On OS X and Windows, DaVinci Resolve supports the use of third-party VST audio plug-ins. On 
OS X, Resolve supports Audio Unit (AU) audio plug-ins. Once you install these effects on your 
workstation, they appear in this panel of the Effects Library. Audio plug-ins let you apply effects 
to audio clips or entire tracks worth of audio, to add creative qualities such as echo or reverb, or 
to take care of mastering issues using noise reduction, compression, or EQ.

Effects Library Favorites
You can click on the far right of any transition, title, or generator flag that effect with a star as a 
favorite effect. When you do so, choosing Favorites from the Effects Library option menu filters 
out all clips that are not favorites, letting you see only effects you most commonly use. To 
“de-favorite” any effect, click its star to turn it off.

At left, the transition is not a favorite, at right, the  
gold star indicates a flagged favorite effect
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Edit Index
Clicking the Edit Index button opens the Edit Index. By default, this shows an EDL-style list view 
of all the edit events in the current timeline. Whichever timeline is selected in the Timeline list 
displays its events here. However, the contents of the Edit Index can be filtered using 
commands found in the Option pop-up, described later in this section. 

Each clip and transition is shown as an individual event, each of which contains multiple 
columns of information. If you re-edit a timeline, your changes are also reflected in this list.

Edit Index List shown open

Navigating The Timeline Using the Edit Index
Whenever you move the Timeline playhead to intersect a clip, the Edit Index updates to show 
only the clips on the video track the intersecting clip is on, and that clip’s event is highlighted in 
the Edit Index. This makes it easy to see the correspondence between a clip in the Timeline 
and its event, which is helpful when troubleshooting problems. There are also commands 
available in the Option menu to display only clips on enabled tracks, only video clips, and only 
audio clips.
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Edit Index Columns 
Each event populates several columns of information. These columns can be rearranged by 
dragging them to the left or right, depending on what information is most important to you.

The available columns of information are:

 � #: The event number (which corresponds to the clip number shown in the Thumbnail 
timeline of the Color page).

 � Reel: The reel name of the corresponding clip.

 � V: Video event.

 � C: The event type (C for cut, D for dissolve or transition).

 � Dur: A number showing the duration of a transition in frames. 

 � Source In/Source Out: The Source In and Source Out timecode indicating the range of 
timecode referenced by that clip; corresponds to the timecode locations of each clip’s 
In and Out point relative to the source media it comes from.

 � Record In/Record Out: Record In and Record Out timecode indicating that clip’s 
position in the Timeline.

 � Name: The name of the clip.

 � Comments: Whatever comments were present in the EDL that was imported. For 
example, clip names exported from the original NLE to be used as reel names in RED 
workflows using EDL import.

 � Source Start/ Source End: The very first and last frame of media available in the Source 
Media for that clip.

 � Source Duration: The duration, in timecode, of the total source media available in 
that clip.

 � Codec: The codec of the corresponding clip.

 � Source FPS: The frame rate of the corresponding clip.

 � Resolution: The frame size of the corresponding clip.

 � Color: The color of flags or markers applied to that clip.

 � Notes: Notes entered inside of markers applied to clips or the Timeline.

The columns in the Edit Index can be customized to prioritize the information that’s 
important to you.

Methods of customizing metadata columns in the Edit Index:

 � To show or hide columns: Right-click at the top of any column in the Edit Index and 
select an item in the contextual menu list to check or uncheck a particular column. 
Unchecked columns cannot be seen.

 � To rearrange column order: Drag any column header to the left or right to rearrange 
the column order.

 � To resize any column: Drag the border between any two columns to the right or left to 
narrow or widen that column.

You can also customize column layouts in the Edit Index. Once you’ve customized a column 
layout that works for your particular purpose, you can save it for future recall. 
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Methods of saving and using custom column layout:

 � To create a column layout: Show, hide, resize, and rearrange the columns you need 
for a particular task, then right-click any column header in the Media Pool and choose 
Create Column Layout. Enter a name in the Create Column Layout dialog, and click OK.

 � To recall a column layout: Right-click any column header in the Media Pool and choose 
the name of the column layout you want to use. All custom column layouts are at the 
top of the list.

 � To delete a column layout: Right-click any column header in the Media Pool and 
choose the name of the column layout you want to delete from the Delete Column 
Layout submenu.

Filtering the Edit Index
You can use options found in the Edit Index’s option menu to filter specific things that you want 
to check out, whether to go through all of the marked clips to see if there are any notes you 
need to address, or to isolate all offline clips, or to go through edits to see if there’s anything 
you need to fix. You can filter the Edit Index in the following ways:

 � Show All: Shows all entries in the list. Choose this option after using any of the other 
options to go back to seeing the entire timeline.

 � Show Active Track Items Only: Filters out all clips that appear on tracks above or below 
tracks identified with a Destination Control. For example, if you have three video tracks 
and the Destination Control is on track V2, then all clips on tracks V1 and V3 will be 
hidden from the Edit Index.

 � Show Video Track Items Only: Filters out all audio clips so only video clips appear 
in the list.

 � Show Audio Track Items Only: Filters out all video clips so only audio clips appear 
in the list.

 � Show Flags: Isolates all clips with flags in the list.

 � Show Markers: Isolates all clips with markers in the list.

 � Show Through Edits Only: Filters only clips that have through edits, or cuts where 
continuous timecode appears from the outgoing to the incoming half of the edit, that 
you may or may not want to remove, depending on why they’re there.

 � Show Offline Clips Only: Isolates all offline clips in the Timeline, so you can quickly 
navigate to each one and troubleshoot the issue.

Exporting the Edit Index
If you’ve filtered a series of edits in the Edit Index that you’d like to share with someone else, 
this is easy to do. For example, you might filter the Edit Index to show a list of all the offline clips 
in the current timeline, and then export a list as either a .csv or .txt file to give to your assistant 
editor so they can chase down the necessary media. Both types of files are widely compatible 
with spreadsheet and database software in the event you want to import the data into another 
application.

To export the Edit Index:

1 Right-click the currently open timeline in the Media Pool, and choose Timelines > 
Export > Edit Index… from the contextual menu.

2 Use the Export Edit Index window to choose a location to save the exported file, and 
choose a format from the pop-up menu at the bottom. You can export either a Comma 
Separated Values (.csv) file, or a Tab Delimited Values (.txt) file.

3 Click Save.
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Source and Timeline Viewers
The Edit page presents a traditional source/record style editing experience. The Source Viewer 
lets you view individual clips from the Media Pool to prepare them for editing. Meanwhile, the 
Timeline Viewer shows the frame at the position of the playhead in the Timeline. You can select 
either viewer by clicking, and the name of the viewer that currently has focus appears in orange.

Source and Timeline Viewers

Both viewers share the following onscreen controls:

 � Zoom pop-up menu: Choosing Fit fits the currently visible frame to the available size of 
the viewer. Choosing a percentage zooms the visible frame to that size. You can also 
use the scroll wheel functionality of your mouse, trackpad, or tablet to zoom in and out 
of the viewer.

 � Duration field: At the top left-hand side of the Source Viewer, this displays the 
total duration of the clip, or the duration from the In to the Out point, if these have 
been placed. In the Timeline tab, this displays the total duration of the currently 
selected timeline.

 � GPU Status Display: Every viewer in Resolve exposes a a GPU status indicator and a 
frame-per-second (FPS) meter, which appears in the viewer’s title bar, which shows you 
your workstation’s performance whenever playback is initiated. Since DaVinci Resolve 
uses one or more GPUs (graphics processing units) to handle all image processing and 
effects, the GPU status display shows you how much processing power is being used 
by whichever clip is playing.

 � Clip Name: The clip name is displayed at the center of the Source Viewer title bar. 
The Timeline Viewer displays the timeline name and is also a pop-up menu that lets 
you switch among other timelines in the current project. The clip/timeline name is 
highlighted orange when either the Source or Timeline Viewer has focus.

 � Source/Timeline Timecode/Frame/Keykode Display: At the top right-hand side of 
the Source Viewer, this field shows the timecode of the current frame at the position 
of the playhead in the Source Viewer’s jog bar, and can be switched between 
source timecode, source frame, and keykode by right-clicking and choosing from the 
contextual menu. In the Timeline Viewer, this field shows the record timecode of the 

NOTE: The Color Viewer Lookup Table options in the Look Up Tables of the Project 
Settings only affect the GUI Viewer in the Color page. They do not affect the viewers 
in the Edit page.
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current frame at the position of the playhead in the Timeline, and can be switched 
between source and record timecode, source and record frames, and keykode by right-
clicking and choosing from the contextual menu. 

 � Option menu: The Option menu for each viewer contains the following commands:

 � Gang Viewers: With Gang Viewers enabled, the movement of the Source and 
Timeline Viewer playheads is locked together, so that they move in unison. This is 
useful when you’re matching the timing of part of a clip in the Source Viewer to match 
an event in the Timeline.

 � Show All Video Frames: When available processing power is insufficient to play the 
clip or clips at the position of the playhead due to the grade, transforms, or effects 
that are applied at that moment in the Timeline, you have the ability to choose exactly 
how performance in Resolve degrades. When off, Resolve prioritizes audio playback 
at the expense of dropping video frames when processing power is tight, resulting in 
a more conventional playback experience. When on, audio quality is compromised 
while every frame of video plays in slower-than-real time to maintain playback.

 � Source Viewer Mode pop-up (Source Viewer only): This pop-up menu lets you set the 
Source Viewer to display different views of the clips you’re working on, depending on 
what you need to do.

 � Offline Reference Movie button: If you’ve assigned an offline reference movie to 
the currently selected timeline, clicking the Offline Mode button lets you display the 
offline movie so you can compare it with the currently open timeline. In this mode, 
Source and Timeline playback are synched; an Offset field replaces the duration 
field, letting you re-sync the offline reference movie, if necessary.

 � Video button: Shows the video of the currently open clip in the Source Viewer.

 � Audio button: Shows the audio waveforms corresponding to all channels of the 
currently open clip in the Source Viewer. The top of this audio-only view shows the 
waveform for the entire duration of the clip, while the main region of the viewer shows 
a zoomed in section of the audio waveform. The level of zoom displayed is controlled 
by the zoom pop-up at the upper left-hand corner of the Source Viewer.

 � Multicam: Shows you the multi-angle Multicam Viewer that you can use to 
switch among different angles of video and audio while multicam editing a 
clip in the Timeline. For more information on multicam editing, see Chapter 16, 
“Multicam Editing.”

 � Transform Mode pop-up (Timeline Viewer Only): This functions as both a toggle switch 
and a pop-up menu. Clicking the button control to the left enables or disables onscreen 
controls that you can use to transform the clip right in the viewer. Clicking the pop-up 
control to the right lets you switch between two modes of transforms:

 � Transform: Exposes controls for Pan (X) and Tilt (Y), Scale X and Y, and Rotation.

 � Crop: Exposes controls to crop from the top, bottom, left, and right.

 � Jog control: Clicking the Jog control and dragging left and right lets you move slowly 
through a clip or the Timeline a frame at a time.

 � Transport controls: These controls include, from left to right, Jump to First Frame, Play 
Reverse, Stop, Play Forward, Jump to Last Frame.

 � Loop Playback: Enables or disables looped playback. Looping is also controllable via 
the Playback > Loop/Unloop command (Command-/). When enabled, each playback 
command loops back to the beginning when the end of that command’s range is 
reached. In and Out points in the Source or Timeline Viewers do not trigger looping. 
For example, when enabled, the Play command will play through the entire clip or 
timeline, and then loop back to the beginning when the end is reached and start 
playing automatically. The Play Around command, on the other hand, will start at the 
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beginning of pre-roll, play through the post-roll, and then immediately loop back around 
to the beginning of pre-roll, continuing playback in this manner until you stop it.

 � Match Frame: In the Source Viewer, Match Frame attempts to move the playhead in 
the Timeline to match the current frame of the clip in the Source Viewer. In the Record 
Viewer, Match Frame opens the Media Pool clip corresponding to the clip at the current 
position of the playhead into the Source Viewer, setting In and Out points and the 
playhead position to match those of the clip in the Timeline.

 � In/Out buttons: Places In and Out points with which to define a range of the clip, or of 
the Timeline, in preparation for making different kinds of edits.

 � Jog bar: In the Source Viewer, drag within the jog bar to reposition the Source 
playhead, scrubbing through the clip. In the Timeline tab, drag to reposition the 
playhead throughout the entire program.

Simultaneous Audio Waveform Display in the Source Viewer
When the Source Viewer is set to Source, two options in the Option Menu let you see a 
superimposed audio waveform running along the bottom of the viewer, over the video of the 
currently selected clip.

 � Show Current Frame Audio Waveform: Shows a zoomed-in section of audio that scrolls 
as you play the clip. Useful for seeing dialog and music cues as you play through a clip.

 � Show Full Clip Audio Waveform: Shows the audio waveform for the entire source media 
of that clip. The section of audio from the In to Out points you’ve set in the Source 
Viewer are highlighted. Useful for using the audio waveform to navigate throughout that 
clip using the waveform as a reference.

The Source Viewer with “Show Current Frame Audio Waveform” enabled
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Cinema Viewer Mode
You can also put either the Source or Timeline Viewers into Cinema Viewer mode by choosing 
Workspace > Viewer Mode > Cinema Viewer (Command-F), causing whichever viewer is 
currently selected to fill the entire screen, which is good for doing a test viewing of your edit 
without the distractions of the Resolve Edit Page UI. This command toggles Cinema Viewer 
mode on and off.

Viewer Indicators
Certain frames trigger visible indicators in either the Source or Timeline Viewers. For example, 
if the playhead is at the very first or last frame of media available to a particular clip, indicators 
appear in the lower-left or right corner of the frame to let you know there’s no more media in 
that direction.

The first and last frame clip indicators

If the playhead in the Timeline is on the first frame of black immediately after the last video clip 
in the Timeline, an end of sequence indicator appears in the Timeline Viewer to let you know 
that you’re viewing the last frame of the current sequence of clips, even though the playhead is 
actually on a frame of black. This makes it easy to see what you’re doing while you’re first 
assembling clips together.

The end-of-sequence indicator

Other Viewer Options
There are additional overlays and options you can use to customize how the viewer appears, 
available in the View menu.
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 � Safe Area: Choosing View > Safe Area > On lets you turn on Safe Area overlays 
showing you Title Safe, Action Safe, among other available overlays. If you want to 
choose the aspect ratio with which these overlays are represented, you can do so from 
the View > Select Aspect Ratio submenu.

 � Use Gray Background: Choosing View > Use Gray Background in Viewers sets the 
empty area of the viewer (if there is any) to a lighter gray, making it easier to see which 
parts of the viewer are black because of blanking, and which parts are simply empty 
because of the way the image is zoomed or panned.

Timeline Viewer Edit Overlays
Dragging a clip from the Media Pool or Source Viewer onto the Timeline Viewer also exposes 
edit overlays that let you choose what kind of edit you want to make by choosing which overlay 
to drop the clip onto.

The overlay that appears when you drag a clip onto the  
Timeline Viewer lets you choose from a variety of edits

This overlay exposes every type of edit that’s available in DaVinci Resolve, including the Insert, 
Overwrite, Replace, Fit to Fill, Place On Top, Ripple Overwrite, and Append at End edits, all of 
which are also available from the Edit menu. It’s a useful method of making three-point edits if 
you like drag and drop editing, but it also provides a nice reminder of what types of edits are 
available, given all the different options that are available.

By default, the larger empty area to the left of these overlays defaults to the highlighted 
Overwrite overlay, while all the smaller buttons let you perform each of the other edit types that 
are available. 

However, the “Timeline overlay retains the last performed action” checkbox in the Editing panel 
of the Project Settings can be turned on if you want Resolve to always remember the last edit 
type you used, and highlight it on this Overlay whenever you drag another clip over the 
Timeline Viewer to let you know that the last edit you performed is the new default edit if you 
drop clips to the left of the overlay. For example, with this option enabled, if you perform a Place 
On Top edit, then the next time you drop a clip into the empty area to the left of the overlays, 
the result will be another Place On Top edit. This option is off by default.
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Metadata Editor
Both the Media and Edit pages have a Metadata Editor. In the Edit page, the Metadata Editor 
opens in the same place as the Inspector, to the right of the Source and Timeline Viewers. 
When you select a clip in the Media Pool or Timeline, its metadata is displayed within the 
Metadata Editor, and the title bar indicates whether you’re evaluating a clip in the Timeline or 
Media Pool. If you select multiple clips, only the last clip’s information appears. The Metadata 
Editor’s header contains uneditable information about the selected clip, including the file name, 
directory, duration, frame rate, resolution, and codec.

Because there are so very many metadata fields available, two pop-up menus at the top let you 
change which set of metadata is displayed in the Metadata Editor.

 � Metadata Presets (to the left): If you’ve used the Metadata panel of the Project Settings 
to create your own custom sets of metadata, you can use this pop-up to choose which 
one to expose. Surprisingly enough, this is set to “Default” by default.

 � Metadata Groups (to the right): This pop-up menu lets you switch among the various 
groups of metadata that are available, grouped for specific tasks or workflows.

For more information on creating custom metadata presets, see the “Metadata” section of 
Chapter 3, “Project Settings and Preferences.”

The heart of the Metadata Editor is a series of editable fields underneath the header that let you 
review and edit the different metadata criteria that are available. For more information on 
editing clip metadata, see Chapter 9, “Working With Media.”

 

Clip Metadata Editor showing the Clip Details  
panel for a clip in the Timeline
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Inspector
The Inspector can be opened to let you customize compositing, transform, and cropping 
parameters for clips, as well as clip-specific retime and scaling options. Furthermore, the 
Inspector lets you edit the parameters of transitions, titles, and generators used in the Timeline, 
in order to customize their effect.

The Inspector, opened and showing a clip’s parameters

When the Inspector is open, the Source and Timeline viewers move to the left, to sit alongside the 
Inspector showing the selected clip’s parameters. However, if your computer display’s resolution 
is not high enough, opening the Inspector may result in the Source Viewer being hidden.

Methods of showing parameters in the Inspector:

 � To open a video or audio clip’s transform settings when the Inspector is closed: Select 
that clip, and then click the Inspector button at the far right of the Edit page toolbar.

 � If the Inspector is already open: You need only select a clip or effect to reveal its 
controls in the Inspector. 

 � If the Inspector is closed: Double-clicking any Transition will automatically open it. 

The Inspector shows different buttons at the top that let you switch among different pages of 
parameters. For example, when you select a clip with both audio and video components, the 
Inspector shows Video and Audio buttons at the top that let you switch among each set of 
controls. If you select a Generator effect, the Inspector only shows the controls corresponding 
to that generator.

Timeline
The Timeline shows whichever timeline you’ve double-clicked in the Timelines browser. It’s 
where you either edit programs together from scratch, or import sequences from other 
applications. For imported programs, the Timeline provides a visual representation of the edited 
program that’s helpful for verifying that the project was imported correctly, checking the media 
corresponding to each clip in the program, and performing whatever editorial tasks are 
necessary to prepare a project for grading (such as replacing or adding clips, superimposing 
composites, and modifying composite modes or transitions).
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An edited timeline

 � Timeline Ruler: The Timeline Ruler shows the program’s timecode, and the playhead 
indicates the current frame of the current clip. Whichever clip intersects the playhead is 
the one that you’ll be working on in the Color page. Dragging within the Timeline Ruler 
moves the playhead. When you add markers to the timeline, these markers appear 
within the Timeline Ruler, as well.

 � Playhead: The playhead automatically syncs with the Timeline Viewer’s jog bar 
playhead, the playheads in the Mini-Timeline and Thumbnail timeline of the Color 
page, and the playhead on the Deliver page. Furthermore, the Edit Index event that 
corresponds to the clip intersecting the playhead is automatically highlighted.

 � Timecode field: Shows the current timecode value corresponding to the position of 
the playhead.

 � Video Tracks: DaVinci Resolve supports multiple video tracks. At the left of each track 
is a header area that contains a number of controls.

 � Track Header: The Track Header contains different controls for selecting, locking/
unlocking, and enabling/disabling tracks. Each track header also lists how many clips 
appear on that track. The Track Header contains the following five controls, from 
left to right:

Track Header area showing the controls  
for each track that are located within
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 � Destination control and Track Number: These controls are highlighted orange when 
that track is selected for editing, dark gray when that track is not selected, and flat gray 
if that track is disabled for editing. The Destination buttons dictate into which tracks 
audio and video media in the Source Viewer will be placed when an edit is executed. 
Ordinarily, there is one video destination control (V1) and one audio destination control 
(A1). If you add additional tracks, you can see that each destination control is numbered 
according to its track position. The bottom track is “V1,” and subsequently numbered 
tracks appear higher in the Timeline. Click any track’s number to select that track for 
different editing functions; the selected track is highlighted black.

 � Track Name: Each track has a name that defaults to the type of track and the track 
number, such as Video 1, Audio 1. However, you can click any track’s name and edit it to 
be whatever you like. For example, you can rename each audio track with the type of 
audio you’re editing onto it, such as Production, Ambience, SFX, or Music. These track 
names are also used to identify each track’s channel in the Track Mixer, up at the top 
of each channel strip. Double-clicking the channel strip name toggles between your 
custom track name and the number of each audio track in the Timeline. You can also 
choose whether or not to show track names in the Mixer by choosing View > Use Track 
Names in Audio Mixer.

 � Enable Track button: A slash indicates when a track is disabled. This control lets you 
turn tracks on and off. Clips on tracks that are turned off aren’t visible in the viewer, 
don’t show up in the Color page, and aren’t available for rendering or output.

 � Lock Track button: Light gray when turned on, dark gray when turned off. When a track 
is locked, clips can’t be replaced, moved, or otherwise edited, although clips on locked 
tracks can be graded.

 � Auto Selection button: On by default. Light gray when that track is selected, dark gray 
when that track is not selected. Turning this control on enables clips on that track to be 
included in compatible operations that depend on the position of the playhead, or on 
Timeline In and Out points.

 � Audio channel type indicator: Audio tracks also show which channel configuration that 
track uses, listing the number of channels for stereo, mono, 5.1, and adaptive

 � Number of clips: The number of clips on that particular track of the Timeline is listed.

 � Vertical and horizontal scroll bars: If your project is longer than the current width of the 
Timeline, or the number of video tracks is taller than the current height of the Timeline, 
these scroll bars let you drag to navigate around your program.

 � Individual Timeline track resizing: Any track in the Timeline can be individually resized 
by dragging its top divider in the Track Header area.

Resizing an individual timeline track by dragging  
its top border in the Track Header
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 � Show Edit Index button: Opens and closes the Edit Index, which shows a text list of all 
edits in the Timeline, with columns for edit number, reel, cut type, duration, source and 
record In and Out points, clip name, and comments. These columns can be rearranged, 
depending on what information is most important to you. There are also commands 
available in the Option menu to display only clips on enabled tracks, only video clips, 
and only audio clips.

Show Playhead Shadow
Ordinarily, the playhead is shown in the Timeline as a single line that indicates the beginning of 
the frame that you’re viewing in the Timeline Viewer. However, you can choose View > Show 
Playhead Shadow to display an orange-ish background surrounding the playhead.

(Left) The playhead’s default look, (Right) The playhead showing the optional Playhead Shadow

This shadow can make it easier to see the playhead’s position, and it can also serve as a 
measuring tool for projects where you have an interest in visualizing a specific offset, in frames, 
both before and after the current position of the playhead. This offset can be adjusted by 
changing the Pre- and Post-Playhead Shadow Length parameters in the Editing panel of the 
Project Settings, which let you specify the number of frames to shadow both before and after 
the playhead. The default length of the Playhead Shadow is 5 frames.

TIP: You can set the “Pre-playhead shadow length” to 0, and the “Post-playhead 
shadow length” to 1 if you want to display a “Media Composer-style” playhead that 
shows the duration of the current frame.
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Toolbar
Eleven buttons starting from the left, running along the top of the Timeline, let you choose 
different tools for performing various editing functions.

Buttons in the Toolbar 

 � Normal Edit Mode: The default mode in which you can move and resize clips in the 
Timeline, roll edits, and do other basic editing tasks.

 � Trim Edit Mode: In this mode, the Trim tool lets you make slip, slide, ripple and roll edits 
by dragging different parts of clips in the Timeline, or by making specific selections 
and using the “nudge” keyboard shortcuts of comma and period to move the selection 
left or right.

 � Razor Edit Mode: Lets you add cuts to the Timeline by clicking.

 � Insert Edit: Performs an insert edit to the Timeline with whatever clip is in the 
Source Viewer.

 � Overwrite Edit: Performs an overwrite edit to the Timeline with whatever clip is in the 
Source Viewer.

 � Replace Edit: Performs a replace edit to the Timeline with whatever clip is in the 
Source Viewer.

 � Snapping: Enables or disables clip snapping. When turned on, clip In and Out points, 
markers, and the playhead all snap to one another for reference while you’re editing.

 � Link Audio/Video: Enables or disables Audio/Video linking. When turned on, clicking a 
video clip in the Timeline automatically selects the corresponding audio clip if they’re 
linked together. When turned off, clicking a video clip won’t select its audio. Clip linking 
can be toggled while you work by pressing the Option key while clicking to make 
selections in the Timeline.

 � Flag Clip/Flags pop-up menu: Flags identify clips, and indicate all clips that correspond 
to the same item of media in the Media Pool. Clips can have multiple flags. Clicking 
the Flag button automatically adds a flag to whichever clip is currently selected in the 
Timeline. A pop-up menu to the right lets you choose differently colored flags, and 
clear all flags from the currently selected clip.

 � Add Marker/Marker pop-up menu: Markers identify specific frames of individual 
clips. Clicking the Add Marker button adds a marker of the currently displayed color 
to the clip at the position of the playhead in the Timeline. A pop-up menu to the right 
lets you choose differently colored markers, and clear all markers from the currently 
selected clip.

 � Customize Timeline pop-up menu: Three controls at the top let you customize the look 
of the clips on the tracks (filmstrip, thumbnail, or minimized), whether or not to display 
audio waveforms, whether or not to display flags and markers, and the adjustable 
height of the all video and all audio tracks, adjustable independently.
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Selecting the Timeline View options

 � Zoom slider: Lets you zoom into or out of the clips in the Timeline. Use the scroll wheel 
of your mouse to horizontally zoom into and out of the Timeline. Scrolling up zooms 
in, while scrolling down zooms out. You can also use Command-Plus to zoom in, and 
Command-Minus to zoom out, and Shift-Z to fit every clip in your program into the 
available width of the Timeline.

 � Show Audio Meters/Audio Mixer button and pop-up: Opens and closes the Edit page 
audio meters or Audio Mixer, which you can switch between. The Audio Mixer also 
contains the audio mute button. If you have a display with 2560x1440 resolution you can 
see all 16 audio meters, but on lower resolution displays only 8 audio meters appear. 

These functions are described in greater detail in the following sections of this chapter.

Navigating the Edit Page Using the 
Keyboard
The following keyboard shortcuts can be used to give focus to different parts of the Edit page 
in order to select bins, clips, the Source and Timeline Viewers, the Timeline, the Effects Library, 
Edit Index, and Inspector.

Key Function

Q Toggle between Source and Timeline Viewers

Command-1 Source Viewer

Command-2 Timeline Viewer

Command-3 Timeline

Command-4 Bin List

Command-5 Media Pool

Command-6 Effects Library

Command-7 Edit Index

Command-8 n/a

Command-9 Inspector
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Dual Monitor Layout
The Edit page has a dual monitor layout that provides maximum space for the Timeline and 
Viewers on the primary monitor, and an enlarged Media Pool, simultaneously displayed 
Timelines browser, Edit Index, Effects Library, and Metadata editor on the secondary monitor.

To enter dual screen mode:

 � Choose Workspace > Layout > Dual Screen > On. 

The Edit page in dual-screen mode

To switch which UI elements appear on which monitors:

 � Choose Workspace > Layout > Primary Display > Display 1 or Display 2, which reverses 
the contents of both monitors in dual screen mode.
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Customizing the Edit page
The default layout is quite efficient for a number of tasks on most displays. You can always 
return to the default layout by choosing Workspace > Layout > Reset UI Layout. However, the 
Edit page can be customized to create more room for specific areas of the interface to 
accommodate different tasks.

To resize any area of the Edit page:

 � Drag the vertical or horizontal border between any two panels to enlarge one and 
shrink the other.

To expand the width of the Timeline:

 � Click the Media Pool/Effects Library/Edit Index height button to reduce the area used 
by the Media Pool, Effects Library, and/or Edit Index to shrink to half height. At this size, 
the Media Pool/Effects Library/Edit Index are restricted to the top of the UI (you can 
only show one at a time), and the Timeline takes up the full width of your display.

 � Hiding the Edit Index and the Effects Library causes the Timeline to expand to the full 
width of your screen.

To enable a full-screen timeline in Dual Screen mode:

 � Choose Workspace > Layout > Dual Screen > Full Screen Timeline, which causes the 
Timeline to fully occupy the primary display, while the Browser, Viewers, Audio Mixer, 
Edit Index, and Effects Library appear on the secondary display.

To customize the columns in the Edit Index:

 � To show or hide columns in the Edit Index: Right-click any column header, and choose 
the column you want to show or hide from the contextual menu. Checked columns are 
shown, unchecked columns are hidden.

To resize any column of the Edit Index: 

 � Move your pointer over the divider between any two columns and drag when the 
horizontal resize cursor appears.

To sort the Edit list by any column: 

 � Click the Option button at the top right to display all active tracks, just the video, or just 
the audio tracks.

To show and hide the Audio Meters:

 � Click the Audio Panel button at the right of the toolbar.

To switch between the Audio Meters and the Audio Mixer:

 � Click the Audio pop-up menu control (to the right of the Audio button) and choose 
Audio Mixer.

Undo and Redo in the Edit Page
The Edit page has its own multiple-undo stack, which is separate from the multiple-undo stacks 
of each clip in the Color page. The Edit page undo commands have been separated to make it 
easy and reliable to undo edits and other changes you make in the Timeline without disturbing 
your work in the Color page. 

To undo and redo:

 � Press Command-Z to Undo, and Shift-Command-Z to Redo.


